Jump to content
PopTheTop

Fancier Invoice & Packingslip v1.0

Recommended Posts

I'm seeing the same thing that others are:

 

If you update the status, the customer is sent an email, but it's not a nice HTML email, it's a generic plain email with EMAIL_TEXT_SUBJECT as the subject.

Share this post


Link to post
Share on other sites

Firstly kudos to the developer for a marvelous contribution.

 

A couple of people have reported that the Send Extra Order Emails are not arriving to their email address set up in the store configuration after enabling 'Send HTML or Text Invoices to Customers' in 'Email Options', I'm having the same problem but managed to track down the missing emails in my 'catch all' box on my mail server.

 

Here is what my mail server is reporting:

 

Mail failure - malformed recipient address

 

A message that you sent contained one or more recipient addresses that were

incorrectly constructed:

 

  "Matt McKenzie" <Sales Department <sales@compusys.co.nz>>: "@" or "." expected after "Sales"

 

This address has been ignored. There were no other addresses in your

message, and so no attempt at delivery was possible.

 

Looking at the code responsible:

 

if (SEND_EXTRA_ORDER_EMAILS_TO != '') {

  $ei_message->send(STORE_OWNER, SEND_EXTRA_ORDER_EMAILS_TO, $order->customer['name'], $order->customer['email_address'], EMAIL_TEXT_SUBJECT);

 

My 'Send Extra Order Emails to' setting follows OSC recommended format of

Sales Department <sales@compusys.co.nz> but the above code seems to messing it up, I suspect this is what is happening to the other people who reported it.

 

If I switch off 'Send HTML or Text Invoices to Customers', the email goes through without any trouble.

 

It would appear 'STORE_OWNER' in the code is unnecessary as the name is already specified in the 'Send Extra Order Emails to' setting, although i'm unsure why the code inserts an extra set of <> around the Name and Email address as you can see from the mail server information above.

 

I'm also unsure of why most people have no problems, possibly due to the format of their 'Send Extra Order Emails to' setting.

Share this post


Link to post
Share on other sites

sorry, forgot to add my solution.

 

In your 'Send Extra Order Emails to' setting, just enter your email address and nothing else, no name, no <> around the email address.

 

The email_invoice module will use the 'Store Owner' and 'Send Extra Order Emails to' configuration settings to formulate the 'To:' field in your outgoing email.

Share this post


Link to post
Share on other sites
If I install the box_invoice.php I get this error as an email sent to the client and I still don;t get an order email.

 

Warning: main(includes/modules/email_invoice/templates/box_invoice.php): failed to open stream: No such file or directory in /hsphere/local/group-1/home/ksaun/tonerjunction.com/catalog/includes/modules/email_invoice/email_invoice.php on line 39

Warning: main(includes/modules/email_invoice/templates/box_invoice.php): failed to open stream: No such file or directory in /hsphere/local/group-1/home/ksaun/tonerjunction.com/catalog/includes/modules/email_invoice/email_invoice.php on line 39

Warning: main(): Failed opening 'includes/modules/email_invoice/templates/box_invoice.php' for inclusion (include_path='.:/usr/local/lib/php') in /hsphere/local/group-1/home/ksaun/tonerjunction.com/catalog/includes/modules/email_invoice/email_invoice.php on line 39

 

 

 

Make sure that you have box_invoice.php in your catalog/includes/modules/email_invoice/templates folder and it is called box_invoice.php AND it is called box_invoice.php in your admin config.

 

As far as not getting your e-mails, I have no idea. The codes is in there and it works so that must be your store and possibly other modifications you have installed that may be conflicting.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Scooter,  I have a question and or problem with this mod & the email invoice mod that you added the box_invoice template. I have a more simpler layout but with more data for record keeping.

 

I can see the need for a better invoiceing & packing slip which I use, but one thing that knowbody has addressed is there is no way to manualy send an invoice from the orders page.

 

I may be wrong but the only chance for the customer to get an emailed invoice is on cheheckout. Most of us have the Order editor tool so if a customer wants to change an order they cannot get a final detailed invoice emailed to them.

 

Is there any way to add the following in the admin order page ?

 

1. Button to " Send Invoice" to the customers email address.

2. Button to " Send PDF Invoice" to the customers email address.

Thanks

 

Jimmy

 

 

I agree. I came across that issue after I edited an existing order by adding another item to it and changed the shipping amount. I needed to send an updated invoice and could not. I have a lot on my plate right now and as stated before, I am not really working on this anymore until I get caught up. If someone else can do it, that would be great.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Make sure that you have box_invoice.php in your catalog/includes/modules/email_invoice/templates folder and  it is called box_invoice.php AND it is called box_invoice.php in your admin config.

 

As far as not getting your e-mails, I have no idea. The codes is in there and it works so that must be your store and possibly other modifications you have installed that may be conflicting.

 

Like I said before in my previous post, if I uninstall the contrib everything works fine, all emails are sent and recieved, but when the contrib is installed I get these issues.

 

can you atleast direct me to the file in your contrib that takes over the sending of the emails?


My Favorite Quote from a movie.

 

Question: How do you know women sooo well?

 

Answer: I think of a man, then take away reason and accountability.

Share this post


Link to post
Share on other sites
Hello,

 

I've installed the Fancier Invoice & Packingslip v5.5. Everything seems to work acceptable, except when my customer receives an email with order status change:

Detailed Invoice: .......osCommerce/account_history_info.php?order_id=53 is not clickable, just a simple text.

 

Another problem is when a customer bought from my store, I receive an Extra Order Email not in my Inbox but in Trash of my Mailbox. That is strange!

 

Does anybody else have similar problems?

Thanks for your response. Irina.

 

 

1) Yes, that is not this contribution causing that. That is a known issue with the stock osC HTML e-mails.

 

Someone has already created a new contribution a few months back in the contributions area that will turn that into a link. Just go there and do some searches to find it.

 

2) maybe everyone should look in there SPAM folders or Trash folders. That is most likely caused by your SPAM filtering settings, software or whatever, not this contribution.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
catalog/admin/invoice.php

=====

Find:

=====

<table border="0" width="100%" cellspacing="0" cellpadding="2">
? ? ? ? ?<tr class="dataTableHeadingRow">
? ? ? ? ? <td class="dataTableHeadingContent" colspan="2"><?php echo TABLE_HEADING_PRODUCTS; ?></td>
? ? ? ? ? <td class="dataTableHeadingContent"><?php echo TABLE_HEADING_PRODUCTS_MODEL; ?></td>
? ? ? ? ? <td class="dataTableHeadingContent" align="right"><?php echo TABLE_HEADING_TAX; ?></td>
? ? ? ? ? <td class="dataTableHeadingContent" align="right"><?php echo TABLE_HEADING_PRICE_EXCLUDING_TAX; ?></td>
? ? ? ? ? <td class="dataTableHeadingContent" align="right"><?php echo TABLE_HEADING_PRICE_INCLUDING_TAX; ?></td>
? ? ? ? ? <td class="dataTableHeadingContent" align="right"><?php echo TABLE_HEADING_TOTAL_EXCLUDING_TAX; ?></td>
? ? ? ? ? <td class="dataTableHeadingContent" align="right"><?php echo TABLE_HEADING_TOTAL_INCLUDING_TAX; ?></td>
? ? ? ? ?</tr>
<?php
? for ($i = 0, $n = sizeof($order->products); $i < $n; $i++) {
? ?echo ' ? ? ? ? ?<tr class="dataTableRow">' . "\n" .
? ? ? ? ' ? ? ? ? ? <td class="dataTableContent" valign="top" align="right">' . $order->products[$i]['qty'] . ' x</td>' . "\n" .
? ? ? ? ' ? ? ? ? ? <td class="dataTableContent" valign="top">' . $order->products[$i]['name'];

? ? ?if (isset($order->products[$i]['attributes']) && (($k = sizeof($order->products[$i]['attributes'])) > 0)) {
? ? ? ?for ($j = 0; $j < $k; $j++) {
? ? ? ? ?echo '<br><nobr><small> <i> - ' . $order->products[$i]['attributes'][$j]['option'] . ': ' . $order->products[$i]['attributes'][$j]['value'];
? ? ? ? ?if ($order->products[$i]['attributes'][$j]['price'] != '0') echo ' (' . $order->products[$i]['attributes'][$j]['prefix'] . $currencies->format($order->products[$i]['attributes'][$j]['price'] * $order->products[$i]['qty'], true, $order->info['currency'], $order->info['currency_value']) . ')';
? ? ? ? ?echo '</i></small></nobr>';
? ? ? ?}
? ? ?}

? ? ?echo ' ? ? ? ? ? </td>' . "\n" .
? ? ? ? ? ' ? ? ? ? ? <td class="dataTableContent" valign="top">' . $order->products[$i]['model'] . '</td>' . "\n";
? ? ?echo ' ? ? ? ? ? <td class="dataTableContent" align="right" valign="top">' . tep_display_tax_value($order->products[$i]['tax']) . '%</td>' . "\n" .
? ? ? ? ? ' ? ? ? ? ? <td class="dataTableContent" align="right" valign="top"><b>' . $currencies->format($order->products[$i]['final_price'], true, $order->info['currency'], $order->info['currency_value']) . '</b></td>' . "\n" .
? ? ? ? ? ' ? ? ? ? ? <td class="dataTableContent" align="right" valign="top"><b>' . $currencies->format(tep_add_tax($order->products[$i]['final_price'], $order->products[$i]['tax']), true, $order->info['currency'], $order->info['currency_value']) . '</b></td>' . "\n" .
? ? ? ? ? ' ? ? ? ? ? <td class="dataTableContent" align="right" valign="top"><b>' . $currencies->format($order->products[$i]['final_price'] * $order->products[$i]['qty'], true, $order->info['currency'], $order->info['currency_value']) . '</b></td>' . "\n" .
? ? ? ? ? ' ? ? ? ? ? <td class="dataTableContent" align="right" valign="top"><b>' . $currencies->format(tep_add_tax($order->products[$i]['final_price'], $order->products[$i]['tax']) * $order->products[$i]['qty'], true, $order->info['currency'], $order->info['currency_value']) . '</b></td>' . "\n";
? ? ?echo ' ? ? ? ? ?</tr>' . "\n";
? }
?>
? ? ? ?	<tr>
? ? ? ? ?<td align="right" colspan="8">
? ? ?<table border="0" cellspacing="0" cellpadding="2">
<?php
?for ($i = 0, $n = sizeof($order->totals); $i < $n; $i++) {
? ?echo ' ? ? ? ?	<tr>' . "\n" .
? ? ? ? ' ? ? ? ? ?<td align="right" class="smallText">' . $order->totals[$i]['title'] . '</td>' . "\n" .
? ? ? ? ' ? ? ? ? ?<td align="right" class="smallText">' . $order->totals[$i]['text'] . '</td>' . "\n" .
? ? ? ? ' ? ? ? ?	</tr>' . "\n";
?}
?>
? ? ? ?</table>
? ?</td>
? ? ?	</tr>
? ? ?</table>

 

=========

Replace with:

=========

 

<table border="0" width="99%" cellspacing="0" cellpadding="2">
? ? ? ? ? ? ? ? ?<tr bgcolor="#CCCCCC">
? ? ? ? ? ? ? ? ? ?<td colspan="2" class="dataTableHeadingContent"> <font color="#000000"><?php echo TABLE_HEADING_PRODUCTS; ?></font></td>
? ? ? ? ? ? ? ? ? ?<td WIDTH="80" class="dataTableHeadingContent"><font color="#000000"><?php echo TABLE_HEADING_PRODUCTS_MODEL; ?></font></span></td>
? ? ? ? ? ? ? ? ? ?<td WIDTH="80" align="right" class="dataTableHeadingContent"><font color="#000000"><?php echo TABLE_HEADING_UNIT_PRICE; ?></font></td>
? ? ? ? ? ? ? ? ? ?<TD WIDTH="80" ALIGN="right" CLASS="dataTableHeadingContent"><font color="#000000"><?php echo TABLE_HEADING_TOTAL; ?></font> </TD>
? ? ? ? ? ? ? ? ?</tr>
? ? ? ? ? ? ? ? ?<?php
? ?for ($i = 0, $n = sizeof($order->products); $i < $n; $i++) {
?echo ' ? ? ?<tr class="dataTableRow">' . "\n" .
? ? ? ' ? ? ? ?<td class="dataTableContent" valign="top" align="right">' . $order->products[$i]['qty'] . ' x</td>' . "\n" .
? ? ? ' ? ? ? ?<td class="dataTableContent" valign="top">' . $order->products[$i]['name'];

? ? ?if (isset($order->products[$i]['attributes']) && (($k = sizeof($order->products[$i]['attributes'])) > 0)) {
? ? ? ?for ($j = 0; $j < $k; $j++) {
? ? ? ? ?echo '<br><nobr><small> <i> - ' . $order->products[$i]['attributes'][$j]['option'] . ': ' . $order->products[$i]['attributes'][$j]['value'];
? ? ? ? ?if ($order->products[$i]['attributes'][$j]['price'] != '0') echo ' (' . $order->products[$i]['attributes'][$j]['prefix'] . $currencies->format($order->products[$i]['attributes'][$j]['price'] * $order->products[$i]['qty'], true, $order->info['currency'], $order->info['currency_value']) . ')';
? ? ? ? ?echo '</i></small></nobr>';
? ? ? ?}
? ? ?}

? ? ?echo ' ? ? ? ? ?</td>' . "\n" .
? ? ? ? ? ' ? ? ? ? ?<td WIDTH="80" class="dataTableContent" valign="top">' . $order->products[$i]['model'] . '</td>' . "\n";
? ? ?echo ' ? ? ? ? ?<td WIDTH="80" class="dataTableContent" align="right" valign="top">' . $currencies->format($order->products[$i]['final_price'], true, $order->info['currency'], $order->info['currency_value']) . '</td>' . "\n" .
? ? ? ? ? ' ? ? ? ? ?<td WIDTH="80" class="dataTableContent" align="right" valign="top"><b>' . $currencies->format($order->products[$i]['final_price'] * $order->products[$i]['qty'], true, $order->info['currency'], $order->info['currency_value']) . ' </b></td>' . "\n";
? ? ?echo ' ? ? ? ?	</tr>' . "\n";
? ?}
?>
? ? ? ? ? ? ? ? ?<tr>
? ? ? ? ? ? ? ? ? ?<td align="right" colspan="5">
? ? ? ? ? ? ? ? ? ? ?<table border="0" cellspacing="0" cellpadding="2">
? ? ? ? ? ? ? ? ? ? ? ?<?php
?for ($i = 0, $n = sizeof($order->totals); $i < $n; $i++) {
? ?echo ' ? ? ? ?	<tr>' . "\n" .
? ? ? ? ' ? ? ? ? ?<td align="right" class="smallText">' . $order->totals[$i]['title'] . '</td>' . "\n" .
? ? ? ? ' ? ? ? ? ?<td align="right" class="smallText">' . $order->totals[$i]['text'] . '</td>' . "\n" .
? ? ? ? ' ? ? ? ?	</tr>' . "\n";
?}
?>
? ? ? ? ? ? ? ? ? ?</table></td>
? ? ? ? ? ? ? ? ?</tr>
? ? ? ? ? ? ? ?</table>

 

Hope this is of some help.

 

 

 

People...

 

The above changes has to be done in invoice.php AND ALL your invoice templates, and in account_history_info.php

 

Anywhere you need this changed. Just doing it to one file will not affect the other files.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
MrRim,

 

Made the changes you suggested but it still looks the same as before :blink:

 

Any other ideas? :huh:

 

 

The above changes has to be done in invoice.php AND ALL your invoice templates, and in account_history_info.php

 

Anywhere you need this changed. Just doing it to one file will not affect the other files.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Hopefully someone can direct me here...I've searched all over and have seen this type of error posted. However, the person usually responds later with "nevermind I fixed it"....um, how? is never answered!

 

I installed this contribution and with some hacking around was able to get most of it working - and it looks great. However, when an email is sent to the customer this is what the content looks like:

I've tried to look around in the files mentioned as well as configure.php but I am beyond my capabilities here. Any help would be appreciated. (and since these questions are usually obvious to everyone but the person with the problem, I apologize now!)

 

 

That is telling you that it can not find that file or folder. Make sure you have that folder in the correct location.

 

The correct location is:

catalog/includes/modules/email_invoice/templates

 

NOT This:

catalog/admin/includes/modules/email_invoice/templates


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
I'm seeing the same thing that others are:

 

If you update the status, the customer is sent an email, but it's not a nice HTML email, it's a generic plain email with EMAIL_TEXT_SUBJECT as the subject.

 

 

That is because you did not define "EMAIL_TEXT_SUBJECT" in your language files.

 

If you have the Edit Orders MOD, add it in catalog\admin\includes\languages\english\edit_orders.php

define('EMAIL_TEXT_SUBJECT', 'Order Update');

 

Make sure it is also in:

catalog\admin\includes\languages\english\orders.php

define('EMAIL_TEXT_SUBJECT', 'Order Update');

 

You should also find it in:

catalog\includes\languages\english\checkout_process.php

define('EMAIL_TEXT_SUBJECT', STORE_NAME . ' Order');

Edited by PopTheTop

L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

For those who are not getting their e-mails, you must set the Send Extra Order Emails to setting in Admin / Config / My Store to JUST your e-mail address. Not your name and e-mail address.

 

 

WRONG:

Sales <sales@xxxxxxxxx.com>

 

 

CORRECT:

sales@xxxxxxxxx.com


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Like I said before in my previous post, if I uninstall the contrib everything works fine, all emails are sent and recieved, but when the contrib is installed I get these issues.

 

can you atleast direct me to the file in your contrib that takes over the sending of the emails?

 

 

If you are not getting your extra order e-mails, you must set the Send Extra Order Emails to setting in Admin / Config / My Store to JUST your e-mail address. Not your name and e-mail address.

 

 

WRONG:

Sales <sales@xxxxxxxxx.com>

 

 

CORRECT:

sales@xxxxxxxxx.com


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
That is telling you that it can not find that file or folder. Make sure you have that folder in the correct location.

 

The correct location is:

catalog/includes/modules/email_invoice/templates

 

NOT This:

catalog/admin/includes/modules/email_invoice/templates

Hi Scooter...first off thanks for responding, I appreciate any help that can point me in the right direction.

 

I have looked at the location and it appears to be fine:

store/includes/modules/email_invoice/templates

Not sure if the fact that my store is called 'store' and not 'catalog' is having an impact - I've tried to find all instances of that and fixed them, but maybe I missed something. (and yes, I now see the error of my ways in calling it that, but it's done!)

 

Any other suggestions? Let me know if a file would help. Again, thanks!

Share this post


Link to post
Share on other sites
If you are not getting your extra order e-mails, you must set the Send Extra Order Emails to setting in Admin / Config / My Store to JUST your e-mail address. Not your name and e-mail address.

WRONG:

Sales <sales@xxxxxxxxx.com>

CORRECT:

sales@xxxxxxxxx.com

 

Already did that, but still nothing :blink:

 

I even changed the "Email From" the same way

 

and

 

I changed "E-Mail Transport Method" from send mail to smtp, with still no result.

 

It has to be something in the code that sends the emails, it doesn;t make sence that the customer gets their emails just fine but I don't recieve anything :blush:


My Favorite Quote from a movie.

 

Question: How do you know women sooo well?

 

Answer: I think of a man, then take away reason and accountability.

Share this post


Link to post
Share on other sites

:blush: Okay, my only excuse is that I had been on the computer all day - must have been seeing things.

 

(this is beyond stupidity, prepare yourself!) - my templates folder had a capital 'T'

 

Fixed that and it works great, and looks great. I apologize for taking up your time with this!

Share this post


Link to post
Share on other sites
If you are not getting your extra order e-mails, you must set the Send Extra Order Emails to setting in Admin / Config / My Store to JUST your e-mail address. Not your name and e-mail address.

WRONG:

Sales <sales@xxxxxxxxx.com>

CORRECT:

sales@xxxxxxxxx.com

 

OK did a liitle more testing and changing and here is what I found...

 

I am still not getting the email that is supposed to be sent to me as a store owner, but I have 2 emails in the "Send Extra Order Emails to" field.

 

if I remove one of them, the one that still remains gets the email, if I put the one I removed back in like this:

 

orders@company1.com, orders@company2.com

Neither of them get an email.

 

So looks like there are 2 issues.... the first is why am I not getting the store owner emails? :huh:

 

And second, what to do to have 2 different emails in the "Send Extra Order Emails to" field and have them both get an email?

 

Any Ideas? :blink:


My Favorite Quote from a movie.

 

Question: How do you know women sooo well?

 

Answer: I think of a man, then take away reason and accountability.

Share this post


Link to post
Share on other sites
If you are not getting your extra order e-mails, you must set the Send Extra Order Emails to setting in Admin / Config / My Store to JUST your e-mail address. Not your name and e-mail address.

WRONG:

Sales <sales@xxxxxxxxx.com>

CORRECT:

sales@xxxxxxxxx.com

 

OK did a liitle more testing and changing and here is what I found...

 

I am still not getting the email that is supposed to be sent to me as a store owner, but I have 2 emails in the "Send Extra Order Emails to" field.

 

if I remove one of them, the one that still remains gets the email, if I put the one I removed back in like this:

 

orders@company1.com, orders@company2.com

Neither of them get an email.

 

So looks like there are 2 issues.... the first is why am I not getting the store owner emails? :huh:

 

And second, what to do to have 2 different emails in the "Send Extra Order Emails to" field and have them both get an email?

 

Any Ideas? :blink:


My Favorite Quote from a movie.

 

Question: How do you know women sooo well?

 

Answer: I think of a man, then take away reason and accountability.

Share this post


Link to post
Share on other sites
Detailed Invoice is not clickable, just a simple text.

 

Thanks for your response. Irina.

 

 

In the HTML e-mails, the links are not clickable, just a simple text How do I make them a clickable link?

 

Answer:

You need to install the Email HTML Order Link contribution. You can download it from http://www.oscommerce.com/community/contributions,2253


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Not sure if the fact that my store is called 'store' and not 'catalog' is having an impact

 

 

Well of course it will. If you have those files in the folder I told you to put them in then no, it will not work for you. in your case, you put them in...

 

store/includes/modules/email_invoice/templates


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
OK did a liitle more testing and changing and here is what I found...

 

I am still not getting the email that is supposed to be sent to me as a store owner, but I have 2 emails in the "Send Extra Order Emails to" field.

 

if I remove one of them, the one that still remains gets the email, if I put the one I removed back in like this:

 

orders@company1.com, orders@company2.com

Neither of them get an email.

 

So looks like there are 2 issues.... the first is why am I not getting the store owner emails? :huh:

 

And second, what to do to have 2 different emails in the "Send Extra Order Emails to" field and have them both get an email?

 

Any Ideas? :blink:

 

 

It appears that multiple e-mail address can not be used here with this contribution.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

I am creating a new update - Version 5.6

 

This new update will have the new box_invoice.php with it and a new installation file.

 

The new installation file now has a built-in FAQ to answer most of the problems posted here and how to fix them.

 

It should be uploaded soon...


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
People...

 

The above changes has to be done in invoice.php AND ALL your invoice templates, and in account_history_info.php

 

Anywhere you need this changed. Just doing it to one file will not affect the other files.

For anyone still working on this, here is what I did and so far the admin invoice, account history view, and the html invoice all work with the two columns removed. Per instructions previously from Mr. Rim I believe it was, on what part of the file to replace and what to replace it with, I did that in the following files:

 

store/admin/invoice.php

store/includes/modules/email_invoice/templates/html_invoice.php

 

I did not make ANY changes to the files below for this to work:

store/account_history_info.php

store/admin/includes/languages/english/email_invoice.php

store/admin/includes/languages/english/invoice.php

store/includes/modules/email_invoice/email_invoice.php

store/includes/modules/email_invoice/templates/invoice.php

 

Hope this helps...

Share this post


Link to post
Share on other sites

Fancier Invoice & Packingslip v5.6

Full Release...

 

Updates:

- Added a new HTML invoice template (box_invoice.php)

- Removed the stylesheet files and included the CSS code in the invoices themselves

- Updated the installation file

- Added a FAQ section to the installation file

 

 

Download from:

http://www.oscommerce.com/community/contributions,2861


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
For anyone still working on this, here is what I did and so far the admin invoice, account history view, and the html invoice all work with the two columns removed. Per instructions previously from Mr. Rim I believe it was, on what part of the file to replace and what to replace it with, I did that in the following files:

 

store/admin/invoice.php

store/includes/modules/email_invoice/templates/html_invoice.php

 

I did not make ANY changes to the files below for this to work:

store/account_history_info.php

store/admin/includes/languages/english/email_invoice.php

store/admin/includes/languages/english/invoice.php

store/includes/modules/email_invoice/email_invoice.php

store/includes/modules/email_invoice/templates/invoice.php

 

Hope this helps...

Note: I installed the box_invoice.php template and apparently it also does NOT need to be modified. Thx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×