Jump to content
Sign in to follow this  
uhzoomzip

Authorize.net setup toubles

Recommended Posts

I have been trying to get the authorize.net module to work but it only halfway works. I have no clue as to why and despite all my searces have found little that is helping me. There was a very recent post that gave me a clue but still it's not working. Does anybody have step by step directions on how to set it up on both the authorize.net side and the oscommerce side. That would be a great contribution for the documentation site.

 

Anyway this is where I am:

 

I have installed the osCommerce module and everything seems correct. I created the transaction key and plugged it in and I've tried the card transactions in both test mode and in production mode. I use a real card number in both modes and I get the same error either way. It says that the transaction was approved but that there was an error while trying to contact the site. I called authorize.net and they said it was a timeout errorand that the system is not communicating with the site.

 

Ok so here is where I'm basically lost. It was suggested in another post that it is necessary to fill in the authorize.net information such as Receipt Page and Response / Receipt URLs which I put https://www.getdoors.com . Now I am not really sure if that's all I need to put in there but it doesn't seem like that is correct as it is still giving me the same time out message.

 

So what happens is that even though the authorize.net site approves the transaction osCommerce never completes it so there is no record of an order and the customer never actually finishes the transaction through the osCommerce site.

 

If someone could please help me fix whatever the problem is I would be ever so grateful. If nothing else please let me know if I'm doing something wrong as far as my posts because I really have no clue why previous posts have not been answered.

 

Simon

Share this post


Link to post
Share on other sites
I have been trying to get the authorize.net module to work but it only halfway works. I have no clue as to why and despite all my searces have found little that is helping me. There was a very recent post that gave me a clue but still it's not working. Does anybody have step by step directions on how to set it up on both the authorize.net side and the oscommerce side. That would be a great contribution for the documentation site.

 

Anyway this is where I am:

 

I have installed the osCommerce module and everything seems correct. I created the transaction key and plugged it in and I've tried the card transactions in both test mode and in production mode. I use a real card number in both modes and I get the same error either way. It says that the transaction was approved but that there was an error while trying to contact the site. I called authorize.net and they said it was a timeout errorand that the system is not communicating with the site.

 

Ok so here is where I'm basically lost. It was suggested in another post that it is necessary to fill in the authorize.net information such as Receipt Page and Response / Receipt URLs which I put https://www.getdoors.com . Now I am not really sure if that's all I need to put in there but it doesn't seem like that is correct as it is still giving me the same time out message.

 

So what happens is that even though the authorize.net site approves the transaction osCommerce never completes it so there is no record of an order and the customer never actually finishes the transaction through the osCommerce site.

 

If someone could please help me fix whatever the problem is I would be ever so grateful. If nothing else please let me know if I'm doing something wrong as far as my posts because I really have no clue why previous posts have not been answered.

 

Simon

 

That response/receipt URL looks like it should work.

Edited by baddog

Share this post


Link to post
Share on other sites
That response/receipt URL looks like it should work.  Are you forcing cookie use?  If so, don't.

 

 

Ok I guess I should just stay in this thread. Sorry. Been waiting all weekend for someone to help. I greatly appreciate your help.

 

Cookies are not forced. I saw someone else with the same problem on the general boards. But he hadn't received any help either. Please let me know if you need any more info as I would be glad to contribute anything I can to get this working.

Share this post


Link to post
Share on other sites
Ok I guess I should just stay in this thread. Sorry. Been waiting all weekend for someone to help. I greatly appreciate your help.

 

Cookies are not forced. I saw someone else with the same problem on the general boards. But he hadn't received any help either. Please let me know if you need any more info as I would be glad to contribute anything I can to get this working.

 

On the receipt url are there other places I need to insert that? Also it has options for link get and post as methods. Not sure which I should use. I tried the get and post method but not link. It seems like it should work with the get or post method. Is this incorrect thinking?

 

I also put the same https://www.getdoors.com in Response/Receipt URLs

 

Not sure if that should or should not be there. I'm sure if there was some oscommerce documentation I could muddle through this myself but I am just missing the solution. I know it must be out there but I'm just not getting it.

 

I would be willing to pay for help if someone can help me get it working

 

Simon

Share this post


Link to post
Share on other sites
any more luck with this?

 

 

I installed the latest contribution for authorize.net and found the path to curl (depends on provider) . Still is somewhat buggy but I have got it working. Let me know if you need guidance. I have a ssl so it seems as if that may have been part of the problem. Dunno. It's working alright now though. Now to get Paypal mod working right. :)

 

Simon

Share this post


Link to post
Share on other sites
yes, in order to use authorizenet ssl is required

Where is the setting for the SSL, and what contrib did you install that fixed the problem?

 

thanks,

shawn


If it was easy, anyone could do it!

Share this post


Link to post
Share on other sites
the receipt/return url at authorize.net

https:// or http://youroscommerce.com/checkout_process.php

 

in osc go to admin->configuration->sessions->force cookie use= false

 

I have ssl certificate

i WANT force cookie use= true (i dont want SID in my url)

 

but when i submit my checkout form to a.net, because i have forced cookies and i have no SID in my url, i will loose the session.

is there anyway to connect correctly to a.net without keeping the SID in the url?


Expresionario.com | Pura Sub-cultura!

Share this post


Link to post
Share on other sites
I installed the latest contribution for authorize.net and found the path to curl (depends on provider) . Still is somewhat buggy but I have got it working. Let me know if you need guidance. I have a ssl so it seems as if that may have been part of the problem. Dunno. It's working alright now though. Now to get Paypal mod working right. :)

 

Simon

 

:'(

Now, it seems that I am kind of late in the game, but is there any post here in the forum giving some outline/step by step how to setup both the Authorize.net module (on the OS Commerce side), and how to adminster or setup the account on Authorize.net to make all this happen?

 

My site is www.fiftyniftytips.com

I have the account setup with Authorize.

The store is working like a charm, the check out is working like a charm, no errors what so ever, the buyers get the receipt from the Os commerce order with a successful message, BUT THERE IS NO MONEY GOING TO THE AUTHORIZE :) It looks like I am going to pull my hairs off... Authorize guys say that they do not support OS Commerce, and on OS Commerce forum , it seems like people who succeeded in making this thing work, do not visit this forum any more :))

 

Can anybody list the steps for the setups (Authorize.net side)?

 

:o

Also, I have been unsuccessful to find anything to download or to install on that Authorize module contribution. How do you guys find something to install? Any help?

 

Thanks

Edited by karimlo

Share this post


Link to post
Share on other sites
:'(

Now, it seems that I am kind of late in the game, but is there any post here in the forum giving some outline/step by step how to setup both the Authorize.net module (on the OS Commerce side), and how to adminster or setup the account on Authorize.net to make all this happen?

 

My site is www.fiftyniftytips.com

I have the account setup with Authorize.

The store is working like a charm, the check out is working like a charm, no errors what so ever, the buyers get the receipt from the Os commerce order with a successful message, BUT THERE IS NO MONEY GOING TO THE AUTHORIZE :) It looks like I am going to pull my hairs off... Authorize guys say that they do not support OS Commerce, and on OS Commerce forum , it seems like people who succeeded in making this thing work, do not visit this forum any more :))

 

Can anybody list the steps for the setups (Authorize.net side)?

 

:o

Also, I have been unsuccessful to find anything to download or to install on that Authorize module contribution. How do you guys find something to install? Any help?

 

Thanks

 

I'm looking for the same thing. Except in my case no one is getting the osCommerce email receipts (I'm working on that) , when checking out (I'm pretending to be the customer) I can see when it is contacting Authorize.net, but then I get kicked back to the index page of my site. Authorize.net shows no transactions (I'm currently in test mode). So I don't think osCommerce is talking properly to Authorize.net, but I have the login in and transaction key both entered. I don't see what else I can do.

Share this post


Link to post
Share on other sites
I'm looking for the same thing. Except in my case no one is getting the osCommerce email receipts (I'm working on that) , when checking out (I'm pretending to be the customer) I can see when it is contacting Authorize.net, but then I get kicked back to the index page of my site. Authorize.net shows no transactions (I'm currently in test mode). So I don't think osCommerce is talking properly to Authorize.net, but I have the login in and transaction key both entered. I don't see what else I can do.

 

I figured that I had never updated to AIM module. ANd after couple of hours, I just succeeded in installing the authorize_aim.php module.

 

Now my problem remains the same. Moreover, when I checkout, I see two Creadit card blocks. One with the CCV option and one without. I went and uninstalled the old authorizenet payment module that was installed, but I still see two blocks.

 

I just ran a transaction. I got a successful message, but I haven't checked Authorize account yet.. :) I want to keep some drama...

 

As to your problem, I have not had bad luck to get any error message yet, since it is my third OS commerce website... The others though are just fake, they do not process any transactions, the Client want to have a catalogue only... On this one, the client wants to keep it real, so I am stuck :)

 

A big thanks to Anthony for his update and participation... I like that...

 

This is a big answer for a lot of questions posted here... In order to make the Authorize account and Os Commerce work, there are certain requirements that you have to meet in order to be able to use the update Module:

 

1. You must have a valid account with Authorize Net

 

2. Your site must establish an https connection to Authorize Net

 

3. cURL must be compiled in PHP (check with your web hosts)

 

4. None of the above are optional!

 

This module has been tested online and offline on different Apache based servers, using an AuthorizeNet Developer Test Account.

 

It has not been tested on Windows servers.

 

Good luck. :thumbsup:

Share this post


Link to post
Share on other sites

YEAAAAHHHHHHHHHHHHHHH I see the transaction and the money in the Authorize account.... My client is going to be happy.... Dam, they got money from my credit card, though :'(

 

So... Guys,

 

My advice for guys who want to spend some money to make this work,

- Get a webhosting with either ipowerweb.com or startlogic.com Make sure you ask for an account with SSL,

(If you don't and want to upgrade later on, they will transfer you on another server and you will pay extra for moving the files etc... No good...)

- These two hosts have a vdeck panel where you can install the OS Commerce automatically.

 

- Open an account with Authorize, obviously... :)

- Test authorize account and make sure everytning is working fine before you test your Os Commerce.

- Get a transaction key from your Authorze pannel

- Come back and install the AIM module on your OS commerce admin/ payment section (You will need to visit the following link to download the AIM module)

http://www.calltheseguys.com/os/AuthorizeNet_AIM_1_2.zip

 

and try it, the worst that can happen to you is having your credit card charged :)

Share this post


Link to post
Share on other sites
YEAAAAHHHHHHHHHHHHHHH I see the transaction and the money in the Authorize account.... My client is going to be happy.... Dam, they got money from my credit card, though :'(

 

So... Guys,

 

My advice for guys who want to spend some money to make this work,

- Get a webhosting with either ipowerweb.com or startlogic.com Make sure you ask for an account with SSL,

(If you don't and want to upgrade later on, they will transfer you on another server and you will pay extra for moving the files etc... No good...)

- These two hosts have a vdeck panel where you can install the OS Commerce automatically.

 

- Open an account with Authorize, obviously... :)

- Test authorize account and make sure everytning is working fine before you test your Os Commerce.

- Get a transaction key from your Authorze pannel

- Come back and install the AIM module on your OS commerce admin/ payment section (You will need to visit the following link to download the AIM module)

http://www.calltheseguys.com/os/AuthorizeNet_AIM_1_2.zip

 

and try it, the worst that can happen to you is having your credit card charged :)

 

I did all that and am getting the message (as a customer):

(TESTMODE) This transaction cannot be accepted. - Your credit card could not be authorized for this reason. Please correct any information and try again or contact us for further assistance.

 

The funny thing is that I'm in LIVE mode, not TEST mode. Yet the message indicates I'm in TEST mode.Hmmmm.

Share this post


Link to post
Share on other sites
I did all that and am getting the message (as a customer):

(TESTMODE) This transaction cannot be accepted. - Your credit card could not be authorized for this reason. Please correct any information and try again or contact us for further assistance.

 

The funny thing is that I'm in LIVE mode, not TEST mode. Yet the message indicates I'm in TEST mode.Hmmmm.

OK, the problem was a typo in the transaction key. I am no longer getting an error. It looks like all is working. My only concern is whether Authorize.net is actually verifying the CVV2 number. I don't know how to tell.

Share this post


Link to post
Share on other sites

I’m new to this thread, but having a similar problem. When customers check out on my site, they get this message on the Payment page:

 

“Payment Method

This is currently the only payment method available to use on this order.”

 

But there is no payment method listed below the message. The customer cannot move past this point in the check out process.

 

I’m using a merchant account from Authorize.net. I have an SSL certificate from GoDaddy installed, I have my Authorize.net Transaction Key entered into OSCommerce. My Authorize.net and OSCommerce site are in production mode. The only payment option that I have enabled is Authorize.net.

 

My sessions look like this:

Session Directory: /tmp

Force Cookie Use: False

Check SSL Session ID: True

Check User Agent: True

Check IP Address: True

Prevent Spider Sessions: False

Recreate Session: False

 

My Authorize.net Module Looks like this:

Enable Authorize.net Module

True

Login Username

The one I use to log in to Authorize.net

Transaction Key

I copy-pasted it from Authorize.net, so there aren't any typos.

Transaction Mode

Production

Transaction Method

Credit Card

Customer Notifications

True

Payment Zone

None

Set Order Status

Order Received

Sort order of display

1

 

 

What am I missing? I didn’t install the AIM module as instructed by Karim because my version of OSCommerce already has Authorize.net set up as a payment module. I don’t see why I need to install another one.

 

Please help!

 

Kevin

Edited by Teagish

Share this post


Link to post
Share on other sites

I've just installed authorize.net AIM and a test order went through and was approved perfectly. I receive the email from authorize.net, I received the email from osc stating the order had been placed (extra order email). So I am very happy about that.

 

Now, my question is this. When the card is authorized and charged and returns an approved, is this supposed to be updating my order from pending payment to payment received? It is not currently doing that.

 

I was hoping it would work like the google checkout module where each bit of the transaction is shown in the order in admin ie: authorized, approved, denied and so on.

 

Did I just miss something in the installation?

 

Thank you in advance for your help.

Share this post


Link to post
Share on other sites

I figured out what was wrong. My payment module called "Credit Cards," even though it was disabled, had a priority of "0." For some reason this was causing problems with Authorize.net's payment module. I fixed it by deleting the little priority number for every single one of my payment modules except for my two active modules: Authorize.net and Google Checkout. Now my site: http://www.TeagueProducts.com is ready for business!

Share this post


Link to post
Share on other sites
- Open an account with Authorize, obviously... :)

- Test authorize account and make sure everytning is working fine before you test your Os Commerce.

- Get a transaction key from your Authorze pannel

- Come back and install the AIM module on your OS commerce admin/ payment section (You will need to visit the following link to download the AIM module)

http://www.calltheseguys.com/os/AuthorizeNet_AIM_1_2.zip

 

Hi,

 

Thanks for the details! May I ask what do you exactly mean by "Test authorize account and make sure everytning is working fine"?

 

Thanks!

Share this post


Link to post
Share on other sites
Hi,

 

Thanks for the details! May I ask what do you exactly mean by "Test authorize account and make sure everytning is working fine"?

 

Thanks!

 

Armored, I belive what Karimlo is referring to is using the Virtual Terminal in Tools on https://test.authorize.net to verify that you're getting a successful transaction.

 

 

 

By the way, I'm new to using osCommerce and Authorize.net. I had a demo account created with Authorize.net which I was hoping would work with testing osCommerce on a test server. I'm wondering if the built-in Authorize.net payment module is considered SIM or AIM and if it will work properly for testing if I have a server that isn't available outside our network. I noticed that according to the Authorize.net documentation that I've read, SSL is not required. Is that true for use with osCommerce? When I try to make a test purchase I get "The following errors have occurred.

(13) The merchant login ID or password is invalid or the account is inactive."

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×