Jump to content
Chemo

[Contribution] Ultimate SEO URLs - by Chemo

Recommended Posts

I've got such a headache from reading through the thread and checking various versions to figure out which one to use. It sounds like yours is the most current, stable, complete package and the one we should be using.

 

Just to be clear, are you referring to the download marked:

 

2.1d ORIGINAL updated

Uploaded by FWR Media

on 23 Feb 2008

 

If so are there any issues with it that need to be addressed or is it golden just the way it is?

 

I hope I'm not being a pain. It just looks like a long and complicated install and I'd hate to put all that effort into the wrong version :)

That is the one.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
That is the one.

 

Thank you!

 

I actually crossed my fingers and installed it already so I am very happy to get verification that it was the right one :)

 

I was also very pleased to see that it was actually a very quick and simple install. Not sure why I thought it would be difficult.

Share this post


Link to post
Share on other sites

Hi All

 

Wonder if someone can help me out here.

 

 

 

Have installed ultimate SEO every thing working fine osCommerce 2.2-MS2 My problem is that when I click on the text link for a product I get this:

 

http://www.discountsuperstore-uk.com/-p-.html

 

and this takes me to a page Product not found!

 

 

When I click on the image for the same product i get this:

 

http://www.discountsuperstore-uk.com/samsu...lip-p-7813.html

 

and this takes me to the product page

 

This problem only affect the home page and any subsequent Categories pages Maybe if someone wants to check it out http://www.discountsuperstore-uk.com Any help would be much appreciated

 

Thanks in advance

 

Liam

Share this post


Link to post
Share on other sites

Hi,

 

Just installed Ultimate SEO URLs version 2.1.d on my test shop which is running locally. When I try to access the home page, I get

 

Server error!

 

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

 

If you think this is a server error, please contact the webmaster.

Error 500

 

If I remove the extra (new!) stuff from the .htaccess file I get the home page, but clicking on a category gives me a

 

Object not found!

 

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

 

If you think this is a server error, please contact the webmaster.

Error 404

 

(obviously because the page redirection isn't working because I removed it!)

 

SO should this work when run locally?

 

If so, what directory should I have in my .htaccess file - I currently have /catalog/ as my store is in http://localhost/catalog/

 

Many thanks,

 

Lucy

Share this post


Link to post
Share on other sites

Lucy, it sounds like you haven't got the mod_rewrite Apache module installed.

 

Find where your Apache is installed and locate the 'conf\httpd.conf' file. Open it and search for this line:

 

LoadModule rewrite_module modules/mod_rewrite.so

If you see a '#' in front of it this means it is currently disabled, so remove the '#' and save the file. Restart Apache and try your catalogue again.

Share this post


Link to post
Share on other sites
Lucy, it sounds like you haven't got the mod_rewrite Apache module installed.

 

Find where your Apache is installed and locate the 'conf\httpd.conf' file. Open it and search for this line:

 

LoadModule rewrite_module modules/mod_rewrite.so

If you see a '#' in front of it this means it is currently disabled, so remove the '#' and save the file. Restart Apache and try your catalogue again.

 

Hooray!!!!! That seems to have been the problem!

 

I can now play around with the settings, and then transfer it to the live store.

 

Thank you SO much for such speedy help Kanie! :-)

 

Lucy

Share this post


Link to post
Share on other sites
Lucy, it sounds like you haven't got the mod_rewrite Apache module installed.

 

Find where your Apache is installed and locate the 'conf\httpd.conf' file. Open it and search for this line:

 

LoadModule rewrite_module modules/mod_rewrite.so

If you see a '#' in front of it this means it is currently disabled, so remove the '#' and save the file. Restart Apache and try your catalogue again.

 

Hooray!!!!! That seems to have been the problem!

 

I can now play around with the settings, and then transfer it to the live store.

 

Thank you SO much for such speedy help Kanie! :-)

 

Lucy

Share this post


Link to post
Share on other sites

Sorry for the stupid newb question..

 

How do we even begin to install this???

 

Where do we upload it to on the server before install?

 

Into the includes/ like the rest of the contributions.

 

maybe a README file with instructions would come in handy in the package for people that recently download it?

 

Looks like a great Contribution :) Keep up the good work.

 

I have everything downloaded locally and ready to upload to the server.

 

Just waiting on where to upload it now :)

Share this post


Link to post
Share on other sites
Sorry for the stupid newb question..

 

How do we even begin to install this???

 

Where do we upload it to on the server before install?

 

Into the includes/ like the rest of the contributions.

 

maybe a README file with instructions would come in handy in the package for people that recently download it?

 

Looks like a great Contribution :) Keep up the good work.

 

I have everything downloaded locally and ready to upload to the server.

 

Just waiting on where to upload it now :)

Ultimate SEO URLS v21d_UPDATED by FWR is what you should have and the one that you install. It has a file called install.html. Very easy to install, just follow the instructions.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Everything works great except that the store name isn't showing before product titles in search results; Is it because of this?:

 

2. In index.php, product_info.php and product_reviews_info.php replace this code:

 

<title><?php echo TITLE; ?></title>

 

with

 

<?php include(DIR_WS_INCLUDES . 'easy_meta_tags.php'); ?>

 

 

source: readme_install-1-5.txt

Share this post


Link to post
Share on other sites
Everything works great except that the store name isn't showing before product titles in search results; Is it because of this?:

 

2. In index.php, product_info.php and product_reviews_info.php replace this code:

 

<title><?php echo TITLE; ?></title>

 

with

 

<?php include(DIR_WS_INCLUDES . 'easy_meta_tags.php'); ?>

 

 

source: readme_install-1-5.txt

 

Looks like you've posted in the wrong support thread .. this is for SEO URLs

Share this post


Link to post
Share on other sites

Hi,

 

I installed the contri and get an error from the seo.class.php

 

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home1/public_html/includes/classes/seo.class.php on line 626

 

I also do not see in my admin control panel under Configuration => SEO URLs

 

 

Please help

 

Thnx

Edited by MAD King

Share this post


Link to post
Share on other sites

Hello all,

 

I just installed 'Ultimate_SEO_URLSv21d_UPDATED-07-NOV-2008' onto my clean fresh installed osC MS2 2.2 and I have some problems getting it working in the right order. After reading the last 20 pages in this thread I haven't found a solution for my problem.

 

My .htaccess file (located in /catalog/)

 

#Options +FollowSymLinks
RewriteEngine On 
RewriteBase /catalog/

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

 

What does it do (wrong)?

 

The URL which is constructed by the contrib is like: http://localhost/xampp/catalog/swat-close-...05286cec225e43d which looks kinda good. Althought, the page is directed to an 404-error.

 

Error 404
localhost
11/10/08 15:34:48
Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6

 

If I remove the ?osCid= part manually the same things happens. Same goes for clicking a categorie from the list.

 

I am using the default settings mentioned in the installtion html file added in the contrib downloaded file.

Share this post


Link to post
Share on other sites
Hello all,

 

I just installed 'Ultimate_SEO_URLSv21d_UPDATED-07-NOV-2008' onto my clean fresh installed osC MS2 2.2 and I have some problems getting it working in the right order. After reading the last 20 pages in this thread I haven't found a solution for my problem.

 

My .htaccess file (located in /catalog/)

 

#Options +FollowSymLinks
RewriteEngine On 
RewriteBase /catalog/

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

 

What does it do (wrong)?

 

The URL which is constructed by the contrib is like: http://localhost/xampp/catalog/swat-close-...05286cec225e43d which looks kinda good. Althought, the page is directed to an 404-error.

 

Error 404
localhost
11/10/08 15:34:48
Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6

 

If I remove the ?osCid= part manually the same things happens. Same goes for clicking a categorie from the list.

 

I am using the default settings mentioned in the installtion html file added in the contrib downloaded file.

 

#Options +FollowSymLinks

 

Is commented out, it must not be.

 

Options +FollowSymLinks

 

If you commented it out because of server errors then your server does not have the relevant permissions set to allow Rewrite Rules.

Share this post


Link to post
Share on other sites
Same errors with uncommented Options +FollowSymLinks

 

Then your test server is set up incorrectly as this is not an issue with the contribution.

 

Is allow overide set to all in apache.conf.

 

Basically if your settings are correct then no 404 message.

Share this post


Link to post
Share on other sites

#
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories). 
#
# First, we configure the "default" to be a very restrictive set of 
# features.  
#
<Directory />
Options FollowSymLinks
AllowOverride All
Order deny,allow
Deny from all
</Directory>

 

	#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
AllowOverride All

#
# Controls who can get stuff from this server.
#
Order allow,deny
Allow from all

 

#
# "C:/xampp/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "C:/xampp/cgi-bin">
AllowOverride All
Options None
Order allow,deny
Allow from all
</Directory>

 

As you can see, all three lines which containt AllowOverride are set to all in apache/http.conf

 

I also tried to test it with (un)commenting the following line in http.conf

LoadModule autoindex_module modules/mod_autoindex.so # don't load because of mod_autoindex_color.so
LoadModule autoindex_color_module modules/mod_autoindex_color.so

 

Uncommenting both makes my Apache unable to start, having both commeted also prevents my Apache from starting.

Edited by Toyz

Share this post


Link to post
Share on other sites
#
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories). 
#
# First, we configure the "default" to be a very restrictive set of 
# features.  
#
<Directory />
Options FollowSymLinks
AllowOverride All
Order deny,allow
Deny from all
</Directory>

 

	#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
AllowOverride All

#
# Controls who can get stuff from this server.
#
Order allow,deny
Allow from all

 

#
# "C:/xampp/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "C:/xampp/cgi-bin">
AllowOverride All
Options None
Order allow,deny
Allow from all
</Directory>

 

As you can see, all three lines which containt AllowOverride are set to all in apache/http.conf

 

I also tried to test it with (un)commenting the following line in http.conf

LoadModule autoindex_module modules/mod_autoindex.so # don't load because of mod_autoindex_color.so
LoadModule autoindex_color_module modules/mod_autoindex_color.so

 

Uncommenting both makes my Apache unable to start, having both commeted also prevents my Apache from starting.

 

Well I don't know then .. it is something to do with your settings which you will have to sort out because the contribution has no issues.

 

Is http://localhost/xampp/catalog/ a correct path? normally localhost would be in a directory like www or public_html.

 

I don't use xamp as I prefer to set up my local server manually with the latest packages .. my localhost for example resides at .. C:\Program Files\Apache Group\Apache2\htdocs\.

 

Good luck with it but please don't fill up this thread with personal localhost issues as it is not an issue with the contribution itself.

 

Perhaps you could start a thread in general like "xamp issues".

Share this post


Link to post
Share on other sites
The localhost is the folder htdocs in c:\xampp and I never had problems with it before.

I think you need something like

 

RewriteBase /directorynameabovecatalog/catalog/


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
I think you need something like

 

RewriteBase /directorynameabovecatalog/catalog/

 

That does the trick... it works now =P

Share this post


Link to post
Share on other sites

I had to do the same thing under wamp.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

I have same problem with local installed of oscommerce with Ultimate SEO contribution.

 

Online works great.

Offline, the main page, index works ok, but every link not working. (404 error)

 

htacces file looks like this:

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

 

 

I put :RewriteBase /Applications/MAMP/htdocs this is the location of the catalog, without succes.

I have MAMP, using Macintosh.

 

 

Any sugestions?

Edited by edmond1815

Share this post


Link to post
Share on other sites

Excuse a maybe stupid question, but how do you know if SEO is working on your site?

 

Is the URL that shows telling if its working or not?

 

Can someone look at My Site and tell me if it is working

 

Thank you


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×