Jump to content
Chemo

[Contribution] Ultimate SEO URLs - by Chemo

Recommended Posts

Hi, I just installed Ultimate Seo Urls Version 2.5 by faaliyet . Great Contribution. No bumps whatsoever. I have to say this is the smoothest install I have done ever.

 

I tried to get rid of the .htaccess file and put the rewrite rules in the virutal host directive in httpd.conf, I am not familar with mod_rewrite, so I just copied the contents of .htaccess file and pasted into the virtual host directive, like

<VirtualHost>

ServerName....

DocumentRoot...

RewriteEngine On

......

........

</VirtualHost>

 

I removed the RewriteBase line as it caused apache configuration error. Now I am getting bad requests error when I tried to click on the products page and other SEO enabled pages..

 

so: is it possible to include the contents of .htaccess file in virtual host directive in httpd.conf? if yes, what will be the correct way?

 

help or pointers will be greatly appreciated..thanks a bunch...

Share this post


Link to post
Share on other sites
Hi, I just installed Ultimate Seo Urls Version 2.5 by faaliyet . Great Contribution. No bumps whatsoever. I have to say this is the smoothest install I have done ever.

 

I tried to get rid of the .htaccess file and put the rewrite rules in the virutal host directive in httpd.conf, I am not familar with mod_rewrite, so I just copied the contents of .htaccess file and pasted into the virtual host directive, like

<VirtualHost>

ServerName....

DocumentRoot...

RewriteEngine On

......

........

</VirtualHost>

 

I removed the RewriteBase line as it caused apache configuration error. Now I am getting bad requests error when I tried to click on the products page and other SEO enabled pages..

 

so: is it possible to include the contents of .htaccess file in virtual host directive in httpd.conf? if yes, what will be the correct way?

 

help or pointers will be greatly appreciated..thanks a bunch...

 

Looks like I encountered a problem after all. I installed Ultimate Seo Urls Version 2.5, everything seems to be fine for the english version of my site, however, when I switch to my chinese language site, choosing manufacturers from the manufacturers drop-down menu box in the left column caused problem. I am getting this :

==================================================

Forbidden

You don't have permission to access /oscommerce/catalog/±±¾©´ïÌØ¿µ¿Æ¼¼·¢Õ¹ÓÐÏÞÔðÈι«Ë¾-m-1.html on this server.

===================================================

although I am getting forbidden status response, the url clearly indicates that .htaccess is doing its job, it rewrites the url correctly, like this: http://127.0.0.1/oscommerce/catalog/xxxxx-...8a441673434ac16 , and if I refresh and reload the page, the page was shown as it should be.

 

I checked the log file, the error message in the log file is:

===================================================

Invalid argument: Cannot map GET /oscommerce/catalog/\xb1\xb1\xbe\xa9\xb4\xef\xcc\xd8\xbf\xb5\xbf\xc6\xbc\xbc\xb7\xa2\xd5\xb9\xd3\xd0\xcf\xde\xd4\xf0\xc8\xce\xb9\xab\xcb\xbe-m-1.html HTTP/1.1 to file

========================================================

 

if I switch back to English version, then the problem disappears.

 

.htaccess should be working, and it should not have anything to do with the multi-byte chinese language I am using for the site, since other SEO redirects are working fine, such as products_info page, etc.

 

I spent quite some time trying to figure this out, but apparently this was beyond my knowledge. it is very disappointing that I might have to give up this nicely done contribution just due to this annoying problem.

 

Any help or pointer will be greatly appreciated, thanks a lot...

Edited by dyzh8888

Share this post


Link to post
Share on other sites

Ok, thanks for the instructions on Step 3 I've done everything else now. However, on Step 5 I couldn't find the EXACT function described. So I tried a number of different options and nothing worked. I would only get an error message stating that line ### on my html_output.php page.

 

Here's what my html_output.php page originally looked like (well approx 1/2 the page but I didn't think you needed the full thing). What should I replace?

 

 

////

// The HTML href link wrapper function

function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) {

global $request_type, $session_started, $SID, $spider_flag;

 

if (!tep_not_null($page)) {

// die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine the page link!<br><br>');

die('</td></tr></table></td></tr></table><br><br><font color="#ff0000">'.TEP_HREF_LINK_ERROR1);

}

 

if ($connection == 'NONSSL') {

$link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;

} elseif ($connection == 'SSL') {

if (ENABLE_SSL == true) {

$link = HTTPS_SERVER . DIR_WS_HTTPS_CATALOG;

} else {

$link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;

}

} else {

//die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine connection method on a link!<br><br>Known methods: NONSSL SSL</b><br><br>');

die('</td></tr></table></td></tr></table><br><br><font color="#ff0000">'.TEP_HREF_LINK_ERROR2);

}

 

if (tep_not_null($parameters)) {

while ( (substr($parameters, -5) == '&') ) $parameters = substr($parameters, 0, strlen($parameters)-5);

$link .= $page . '?' . tep_output_string($parameters);

$separator = '&';

} else {

$link .= $page;

$separator = '?';

}

 

// Add the session ID when moving from different HTTP and HTTPS servers, or when SID is defined

// there is a minor logic problem with the original osCommerce code

// the SESSION_FORCE_COOKIE_USE must not be honored if changing from nonssl to ssl

if ( ($add_session_id == true) && ($session_started == true) ){

if ( ( ($request_type == 'NONSSL') && ($connection == 'SSL') && (ENABLE_SSL == true) ) || ( ($request_type == 'SSL') && ($connection == 'NONSSL') ) ) {

if (HTTP_COOKIE_DOMAIN != HTTPS_COOKIE_DOMAIN) {

$_sid = tep_session_name() . '=' . tep_session_id();

} elseif ( tep_not_null($SID) && (SESSION_FORCE_COOKIE_USE == 'False') ) {

$_sid = $SID;

}

}

}

 

/*--------------------------------------------------------*\

# Page cache contribution - by Chemo

# CRE Mods - by Clarocque

\*--------------------------------------------------------*/

if (!tep_session_is_registered('customer_id') && ENABLE_PAGE_CACHE == 'true' &&

class_exists('page_cache')) {

$link .= $separator . '<osCsid>';

} elseif (isset($_sid) && !$spider_flag) {

$link .= $separator . tep_output_string($_sid);

}#eof if

# eof Page Cache

 

// AJAX Addto shopping_cart - Begin

$pidpos = strpos($parameters, 'product')+12;

$mypid = substr($parameters, $pidpos);

$link_ajax = '';

if( tep_not_null($parameters) && preg_match("/buy_now/i", $parameters) && $page != 'ajax_shopping_cart.php'){

$link_ajax = '" onclick="return doBuyNowGet(\'' . $parameters . '\', ' . $mypid . ');';

}

 

return $link . $link_ajax;

// AJAX Addto shopping_cart - End

 

}

 

////

// The HTML image wrapper function

function tep_image($src, $alt = '', $width = '', $height = '', $parameters = '') {

if ( (empty($src) || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false') ) {

return false;

}

 

// alt is added to the img tag even if it is null to prevent browsers from outputting

// the image filename as default

$image = '<img src="' . tep_output_string($src) . '" border="0" alt="' . tep_output_string($alt) . '"';

 

if (tep_not_null($alt)) {

$image .= ' title=" ' . tep_output_string($alt) . ' "';

}

 

if ( (CONFIG_CALCULATE_IMAGE_SIZE == 'true') && (empty($width) || empty($height)) ) {

if ($image_size = @getimagesize($src)) {

if (empty($width) && tep_not_null($height)) {

$ratio = $height / $image_size[1];

$width = $image_size[0] * $ratio;

} elseif (tep_not_null($width) && empty($height)) {

$ratio = $width / $image_size[0];

$height = $image_size[1] * $ratio;

} elseif (empty($width) && empty($height)) {

$width = $image_size[0];

$height = $image_size[1];

}

} elseif (IMAGE_REQUIRED == 'false') {

return false;

}

}

 

if (tep_not_null($width) && tep_not_null($height)) {

$image .= ' width="' . tep_output_string($width) . '" height="' . tep_output_string($height) . '"';

}

 

if (tep_not_null($parameters)) $image .= ' ' . $parameters;

 

$image .= '>';

 

return $image;

}

 

 

// The Javascript Image wrapper build a image tag for a dummy picture,

// then uses javascript to load the actual picure. This approach prevents spiders from stealing images.

function tep_javascript_image($src, $name, $alt = '', $width = '', $height = '', $parameters = '', $popup = 'false') {

global $product_info;

$image = '';

if ( empty($name) || ((empty($src) || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false')) ) {

return false;

}

// Do we need to add the pop up link code?

if ( $popup ) {

$image .= '<div align="center"><a href="java script:popupWindow(\'' . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . $product_info['products_id'] . 'ℑ=0') . '\')">' . "\n";

}

// alt is added to the img tag even if it is null to prevent browsers from outputting

// the image filename as default

$image .= '<img name="' . tep_output_string($name) . '" src="' . DIR_WS_IMAGES . 'pixel_trans.gif" border="0" alt="' . tep_output_string($alt) . '"';

 

if (tep_not_null($alt)) {

$image .= ' title=" ' . tep_output_string($alt) . ' "';

}

 

if ( (CONFIG_CALCULATE_IMAGE_SIZE == 'true') && (empty($width) || empty($height)) ) {

if ($image_size = @getimagesize($src)) {

if (empty($width) && tep_not_null($height)) {

$ratio = $height / $image_size[1];

$width = $image_size[0] * $ratio;

} elseif (tep_not_null($width) && empty($height)) {

$ratio = $width / $image_size[0];

$height = $image_size[1] * $ratio;

} elseif (empty($width) && empty($height)) {

$width = $image_size[0];

$height = $image_size[1];

}

} elseif (IMAGE_REQUIRED == 'false') {

return false;

}

}

 

if (tep_not_null($width) && tep_not_null($height)) {

$image .= ' width="' . tep_output_string($width) . '" height="' . tep_output_string($height) . '"';

}

 

if (tep_not_null($parameters)) $image .= ' ' . $parameters;

 

$image .= '>' . "\n";

 

if ( $popup ) {

$image .= '<br>' . tep_template_image_button('image_enlarge.gif', TEXT_CLICK_TO_ENLARGE) . '</a></div>' . "\n";

}

 

// Now for the Javascript loading code

$image .= '<script type="text/javascript"><!-- ' . "\n";

$image .= "document['" . tep_output_string($name) . "'].src = '" . tep_output_string($src) . "'" . "\n";

$image .= ' //--></script>' ."\n";

 

return $image;

}

Share this post


Link to post
Share on other sites
Ok, thanks for the instructions on Step 3 I've done everything else now. However, on Step 5 I couldn't find the EXACT function described.

 

Step 5 you just add a simple function to the bottom of admin/includes/functions/general.php

Share this post


Link to post
Share on other sites
Step 5 you just add a simple function to the bottom of admin/includes/functions/general.php

 

I see what I've done. I've should of read this thread PRIOR to downloading the function. I've downloaded the latest version and I've done all the steps except for Step 5 (which looks like Step 3 in the 2.1d version). Should I continue and just finish off or should I be trying to start over using the 2.1d version. If I'm to continue I'm still at a loss. Step 5 (Step 3 in 2.1d version)asks me to replace with a new info. I however can't find the EXACT info. This is what I have (well it's 1/2 of the page), what part should I replace?

 

Thanks:

 

////

// The HTML href link wrapper function

function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) {

global $request_type, $session_started, $SID, $spider_flag;

 

if (!tep_not_null($page)) {

// die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine the page link!<br><br>');

die('</td></tr></table></td></tr></table><br><br><font color="#ff0000">'.TEP_HREF_LINK_ERROR1);

}

 

if ($connection == 'NONSSL') {

$link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;

} elseif ($connection == 'SSL') {

if (ENABLE_SSL == true) {

$link = HTTPS_SERVER . DIR_WS_HTTPS_CATALOG;

} else {

$link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;

}

} else {

//die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine connection method on a link!<br><br>Known methods: NONSSL SSL</b><br><br>');

die('</td></tr></table></td></tr></table><br><br><font color="#ff0000">'.TEP_HREF_LINK_ERROR2);

}

 

if (tep_not_null($parameters)) {

while ( (substr($parameters, -5) == '&') ) $parameters = substr($parameters, 0, strlen($parameters)-5);

$link .= $page . '?' . tep_output_string($parameters);

$separator = '&';

} else {

$link .= $page;

$separator = '?';

}

 

// Add the session ID when moving from different HTTP and HTTPS servers, or when SID is defined

// there is a minor logic problem with the original osCommerce code

// the SESSION_FORCE_COOKIE_USE must not be honored if changing from nonssl to ssl

if ( ($add_session_id == true) && ($session_started == true) ){

if ( ( ($request_type == 'NONSSL') && ($connection == 'SSL') && (ENABLE_SSL == true) ) || ( ($request_type == 'SSL') && ($connection == 'NONSSL') ) ) {

if (HTTP_COOKIE_DOMAIN != HTTPS_COOKIE_DOMAIN) {

$_sid = tep_session_name() . '=' . tep_session_id();

} elseif ( tep_not_null($SID) && (SESSION_FORCE_COOKIE_USE == 'False') ) {

$_sid = $SID;

}

}

}

 

/*--------------------------------------------------------*\

# Page cache contribution - by Chemo

# CRE Mods - by Clarocque

\*--------------------------------------------------------*/

if (!tep_session_is_registered('customer_id') && ENABLE_PAGE_CACHE == 'true' &&

class_exists('page_cache')) {

$link .= $separator . '<osCsid>';

} elseif (isset($_sid) && !$spider_flag) {

$link .= $separator . tep_output_string($_sid);

}#eof if

# eof Page Cache

 

// AJAX Addto shopping_cart - Begin

$pidpos = strpos($parameters, 'product')+12;

$mypid = substr($parameters, $pidpos);

$link_ajax = '';

if( tep_not_null($parameters) && preg_match("/buy_now/i", $parameters) && $page != 'ajax_shopping_cart.php'){

$link_ajax = '" onclick="return doBuyNowGet(\'' . $parameters . '\', ' . $mypid . ');';

}

 

return $link . $link_ajax;

// AJAX Addto shopping_cart - End

 

}

 

////

// The HTML image wrapper function

function tep_image($src, $alt = '', $width = '', $height = '', $parameters = '') {

if ( (empty($src) || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false') ) {

return false;

}

 

// alt is added to the img tag even if it is null to prevent browsers from outputting

// the image filename as default

$image = '<img src="' . tep_output_string($src) . '" border="0" alt="' . tep_output_string($alt) . '"';

 

if (tep_not_null($alt)) {

$image .= ' title=" ' . tep_output_string($alt) . ' "';

}

 

if ( (CONFIG_CALCULATE_IMAGE_SIZE == 'true') && (empty($width) || empty($height)) ) {

if ($image_size = @getimagesize($src)) {

if (empty($width) && tep_not_null($height)) {

$ratio = $height / $image_size[1];

$width = $image_size[0] * $ratio;

} elseif (tep_not_null($width) && empty($height)) {

$ratio = $width / $image_size[0];

$height = $image_size[1] * $ratio;

} elseif (empty($width) && empty($height)) {

$width = $image_size[0];

$height = $image_size[1];

}

} elseif (IMAGE_REQUIRED == 'false') {

return false;

}

}

 

if (tep_not_null($width) && tep_not_null($height)) {

$image .= ' width="' . tep_output_string($width) . '" height="' . tep_output_string($height) . '"';

}

 

if (tep_not_null($parameters)) $image .= ' ' . $parameters;

 

$image .= '>';

 

return $image;

}

 

 

// The Javascript Image wrapper build a image tag for a dummy picture,

// then uses javascript to load the actual picure. This approach prevents spiders from stealing images.

function tep_javascript_image($src, $name, $alt = '', $width = '', $height = '', $parameters = '', $popup = 'false') {

global $product_info;

$image = '';

if ( empty($name) || ((empty($src) || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false')) ) {

return false;

}

// Do we need to add the pop up link code?

if ( $popup ) {

$image .= '<div align="center"><a href="java script:popupWindow(\'' . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . $product_info['products_id'] . 'ℑ=0') . '\')">' . "\n";

}

// alt is added to the img tag even if it is null to prevent browsers from outputting

// the image filename as default

$image .= '<img name="' . tep_output_string($name) . '" src="' . DIR_WS_IMAGES . 'pixel_trans.gif" border="0" alt="' . tep_output_string($alt) . '"';

 

if (tep_not_null($alt)) {

$image .= ' title=" ' . tep_output_string($alt) . ' "';

}

 

if ( (CONFIG_CALCULATE_IMAGE_SIZE == 'true') && (empty($width) || empty($height)) ) {

if ($image_size = @getimagesize($src)) {

if (empty($width) && tep_not_null($height)) {

$ratio = $height / $image_size[1];

$width = $image_size[0] * $ratio;

} elseif (tep_not_null($width) && empty($height)) {

$ratio = $width / $image_size[0];

$height = $image_size[1] * $ratio;

} elseif (empty($width) && empty($height)) {

$width = $image_size[0];

$height = $image_size[1];

}

} elseif (IMAGE_REQUIRED == 'false') {

return false;

}

}

 

if (tep_not_null($width) && tep_not_null($height)) {

$image .= ' width="' . tep_output_string($width) . '" height="' . tep_output_string($height) . '"';

}

 

if (tep_not_null($parameters)) $image .= ' ' . $parameters;

 

$image .= '>' . "\n";

 

if ( $popup ) {

$image .= '<br>' . tep_template_image_button('image_enlarge.gif', TEXT_CLICK_TO_ENLARGE) . '</a></div>' . "\n";

}

 

// Now for the Javascript loading code

$image .= '<script type="text/javascript"><!-- ' . "\n";

$image .= "document['" . tep_output_string($name) . "'].src = '" . tep_output_string($src) . "'" . "\n";

$image .= ' //--></script>' ."\n";

 

return $image;

}

Share this post


Link to post
Share on other sites

Hiya,

 

I think this contribution is great, but I've just noticed a funny thing happening where I've used it:

 

I set it up on a pre-existing site for someone who came to me looking for someone to update their shop, and sometimes I get this:

 

http://www.hoppocketwine.co.uk/celtic-spir...e3fa9e9b981bff7

and at others I get:

http://www.hoppocketwine.co.uk/celtic-spir...pack-p-393.html

 

Yesterday I only seemed to get the extra digits on the home page, but today it's all over the site - I know that it's pretty crazy to say it comes and goes, but that is how it seems...

 

Has anyone else experienced this/got any ideas?

 

Thanks!

 

lisa x

Share this post


Link to post
Share on other sites
someone who came to me looking for someone to update their shop

 

It is the session id which is fundamental. It shows for one or two clicks then disappears if the sites configuration is correct.

 

You really shouldn't be working on other peoples sites if you don't understand the fundamentals.

Edited by FWR Media

Share this post


Link to post
Share on other sites
Hello!

 

I have download the file,but how to install it?

Does the file include any instruction?

Thanks!

 

Diana

Hello,

 

Any files you download are downloaded in the .zip format. So you would need a program such as Winzip to unzip the downloaded file. Once unzipped you be able to open the folder and find all files you need including instructions.

 

Hope that helps.

Share this post


Link to post
Share on other sites

Hi i have a problem with some links on my site after installing :Ultimate Seo Urls v2.5 FullPackage

I have problems with Products Images popup you can look at this product (pop up open with a window of non products category):

http://www.librerialuces.cl/r-y-m-investig...es-p-18494.html

And i have problems with some products review (404 error):

http://www.librerialuces.cl/abrecarta-a-pi...er-p-15625.html

 

Sorry about my spelling but english is not my primary language.

 

Also Great Contribution

Share this post


Link to post
Share on other sites

Hi Bobby

 

Thats a really great contribution rolleyes.gif

 

now i found an bug, so i can not create an account, after browsing the db there are dont exist an customer_id (0) at the last record

even the account fields are empty after new user creation is done !! huh.gif

 

with disabled SEO urls it works


((Don.K))

Share this post


Link to post
Share on other sites
Hi Bobby

 

Thats a really great contribution rolleyes.gif

 

now i found an bug, so i can not create an account, after browsing the db there are dont exist an customer_id (0) at the last record

even the account fields are empty after new user creation is done !! huh.gif

 

with disabled SEO urls it works

 

This is not an issue with seo urls. So it must be an issue with your site.

Share this post


Link to post
Share on other sites
Yes??

 

And what has this to do with this contribution?

 

if disable SEO URLs it works, so has to do with this


((Don.K))

Share this post


Link to post
Share on other sites
if disable SEO URLs it works, so has to do with this

 

Which version have you got installed?

Share this post


Link to post
Share on other sites
Which version have you got installed?

 

i installed Ultimate Seo Urls v2.5 (18 Aug 2008)

i saw another user in this thread he get same output then me


((Don.K))

Share this post


Link to post
Share on other sites
i installed Ultimate Seo Urls v2.5 (18 Aug 2008)

i saw another user in this thread he get same output then me

 

Aah I see, sorry I only support version 2.1d original updated.

Share this post


Link to post
Share on other sites
i have this error in create_account.php plaese help me :

 

0 -

 

insert into customers_info (customers_info_id, customers_info_number_of_logons, customers_info_date_account_created) values ('0', '0', now())

 

[TEP STOP]

 

yes, I got same output, after that occur I delete the last record out from phpMyAdmin, from the address_bock and customers also customers_info

 

thereafter users can create new accounts again

I've seen with enabled SEO URLs that didn't generate new customer_id into the tables


((Don.K))

Share this post


Link to post
Share on other sites

Hi

 

I have installed Ultimate Seo Urls v2.5 (18 Aug 2008)

 

and It has been installed on my site (westonehosting.com) for about a week now and I have put up to google a site map (dynamic_sitemap_v4.0.1) and a robots.txt (robots.txt Sample File by Java Roasters

6 Mar 2008), But I am seeing in my google Webmaster Tools account that I am getting about 1,000 urls A DAY and now it is at 7,780 Ultimate Seo Urls restricted by my robots.txt.

 

what is going on all over this forum we are told to install all this "SEO" thing all to get 1,000 urls restricted a day.

 

I would not care or be here if I had 7,000 + urls on my site but I only have about 43 product and 6 - 9 info pages so not that big of a site.

 

Please, Please, Please, Please, Please, Please Help

Edited by West One Hosting

Thanks Simon

 

osCommerce Version: Online Merchant v2.2 RC 2a - Test Site with: oscommerce-2.2ms2-060817

cPanel Version: 11.23.4-RELEASE - Apache version: 2.0.63 - PHP version: 5.2.5 - MySQL version: 5.0.51a-community - Operating system: Linux

========================================================================

Share this post


Link to post
Share on other sites

None of you should be using anything later than v2.1d by Yesudo.

 

That version is perfectly stable, so I don't know why other people have been messing with it.

 

Vger

Share this post


Link to post
Share on other sites
None of you should be using anything later than v2.1d by Yesudo.

 

That version is perfectly stable, so I don't know why other people have been messing with it.

 

Vger

 

Hi

 

ok got that if i downgrade to V2.1d and then see if the above post Qty go down?

do you now the best way to get my google account to look better?


Thanks Simon

 

osCommerce Version: Online Merchant v2.2 RC 2a - Test Site with: oscommerce-2.2ms2-060817

cPanel Version: 11.23.4-RELEASE - Apache version: 2.0.63 - PHP version: 5.2.5 - MySQL version: 5.0.51a-community - Operating system: Linux

========================================================================

Share this post


Link to post
Share on other sites
Aah I see, sorry I only support version 2.1d original updated.

 

ok! now I use 2.1d update by yesudo, got same, cannot create new users


((Don.K))

Share this post


Link to post
Share on other sites
None of you should be using anything later than v2.1d by Yesudo.

 

That version is perfectly stable, so I don't know why other people have been messing with it.

 

Vger

 

I understand what you are saying and I have been trying to steer users back to 2.1d but it is not now stable in its original form as below: -

 

  • Use of short tags
  • Not MySQL 5 compatible
  • Needed tep_ouput_string added
  • Redirect bug with W3C option
  • Uses getenv('PATH_INFO') which is unreliable and differs on certain servers. (causes index.php?<directory>= urls)

 

Which is why I put up a 2.1d ORIGINAL updated version in the hope of stopping the wrecking of what is after all a great contribution. Also the original was in need of some form of validation because the original accepts ..

 

http://www.mysite.com/my-great-product-c-22.html

 

To be the same as ..

 

http://www.mysite.com/-c-22.html

 

The latter tends to be caused by a MySQL5 server rejecting the 2.1d original SQL code.

Share this post


Link to post
Share on other sites
I understand what you are saying and I have been trying to steer users back to 2.1d but it is not now stable in its original form as below: -

 

  • Use of short tags
  • Not MySQL 5 compatible
  • Needed tep_ouput_string added
  • Redirect bug with W3C option
  • Uses getenv('PATH_INFO') which is unreliable and differs on certain servers. (causes index.php?<directory>= urls)

 

Which is why I put up a 2.1d ORIGINAL updated version in the hope of stopping the wrecking of what is after all a great contribution. Also the original was in need of some form of validation because the original accepts ..

 

http://www.mysite.com/my-great-product-c-22.html

 

To be the same as ..

 

http://www.mysite.com/-c-22.html

 

The latter tends to be caused by a MySQL5 server rejecting the 2.1d original SQL code.

 

Hi, Robert

 

Just a idea why not just upload and start a new mod and then lock it then start a new Topic but just call it like "seo" then it could be for most seo mods like site map, G feed, url ect..

Edited by West One Hosting

Thanks Simon

 

osCommerce Version: Online Merchant v2.2 RC 2a - Test Site with: oscommerce-2.2ms2-060817

cPanel Version: 11.23.4-RELEASE - Apache version: 2.0.63 - PHP version: 5.2.5 - MySQL version: 5.0.51a-community - Operating system: Linux

========================================================================

Share this post


Link to post
Share on other sites
Hi, Robert

 

Just a idea why not just upload and start a new mod and then lock it then start a new Topic but just call it like "seo" then it could be for most seo mods like site map, G feed, url ect..

 

The main reason being that this contribution was written by Chemo and should be recognised as such.

 

I preferred to bring his original up-to-date rather than starting it as a "new" contribution. This is also why independent validation is "independent" it allowed me to add the validation functionality without taking SEO URLs code away from the original.

Share this post


Link to post
Share on other sites
I understand what you are saying and I have been trying to steer users back to 2.1d but it is not now stable in its original form as below: -

 

  • Use of short tags
  • Not MySQL 5 compatible
  • Needed tep_ouput_string added
  • Redirect bug with W3C option
  • Uses getenv('PATH_INFO') which is unreliable and differs on certain servers. (causes index.php?<directory>= urls)

 

Which is why I put up a 2.1d ORIGINAL updated version in the hope of stopping the wrecking of what is after all a great contribution. Also the original was in need of some form of validation because the original accepts ..

 

http://www.mysite.com/my-great-product-c-22.html

 

To be the same as ..

 

http://www.mysite.com/-c-22.html

 

The latter tends to be caused by a MySQL5 server rejecting the 2.1d original SQL code.

 

 

I've got such a headache from reading through the thread and checking various versions to figure out which one to use. It sounds like yours is the most current, stable, complete package and the one we should be using.

 

Just to be clear, are you referring to the download marked:

 

2.1d ORIGINAL updated

Uploaded by FWR Media

on 23 Feb 2008

 

If so are there any issues with it that need to be addressed or is it golden just the way it is?

 

I hope I'm not being a pain. It just looks like a long and complicated install and I'd hate to put all that effort into the wrong version :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×