Jump to content
Chemo

[Contribution] Ultimate SEO URLs - by Chemo

Recommended Posts

also i can just use filezilla and delete all folders except public html?

 

No ..be careful .. I just noticed some "potential" osc files in there

 

admin .. download .. images .. includes .. install ..

 

They could well be used for an entirely different script but if not at least delete those (backup first though in case you delete a necessity)

Edited by FWR Media

Share this post


Link to post
Share on other sites
is your .htaccess

 

Rewritebase /catalog/

 

?

 

I never changed it from /database/. I was hoping it would be something that easy. It works now. Thanks for your help!

Share this post


Link to post
Share on other sites
Hello,

 

I am using Ultimate SEO URLs 2.2.2 and I get this url for products:

 

http://www.mysite.com/my-nice-product-p-99.html

 

Is it possible to get this url instead without the p-99?:

 

http://www.mysite.com/my-nice-product.html

 

 

Thanks

 

No USU uses the -p-99 to rewrite to products_info.php?products_id=99

Share this post


Link to post
Share on other sites

thanks FWR Media

 

but why doesnt mine say

my-nice-product

i didnt use version 2.1d updated i just used the standard 2.1d is this why?

Share this post


Link to post
Share on other sites
thanks FWR Media

 

but why doesnt mine say

my-nice-product

i didnt use version 2.1d updated i just used the standard 2.1d is this why?

 

 

Quite possibly 2.1d was updated for a reason. That reason mainly being php5 and MySQL5

Share this post


Link to post
Share on other sites
Quite possibly 2.1d was updated for a reason. That reason mainly being php5 and MySQL5

is this a big deal or should i just leave it as it is?

Share this post


Link to post
Share on other sites
is this a big deal or should i just leave it as it is?

 

No not a big deal but you may just want to change the seo.class.php anyway for the future.

 

the contribution and all of its changes are the same. (as long as it is not that version that adds unique urls to the product pages)

Share this post


Link to post
Share on other sites
No not a big deal but you may just want to change the seo.class.php anyway for the future.

 

the contribution and all of its changes are the same. (as long as it is not that version that adds unique urls to the product pages)

ok i replaced the old seo.class.php file with the new one...thanks

Share this post


Link to post
Share on other sites

I installed Ultimate SEO URLs 2.1d plus verification a couple of weeks ago. Everything looks fine. But now I seem to be accumulating broken links according to Google webmaster tools. The links Google thinks are broken are things like

 

http://www.myshop.com/shop/2243?page=2

 

These are not links that even look like any valid link in oscommerce before or after installing these modifications. Does anybody have any idea about this? Are these links appearing somewhere on the site that I haven't discovered or are they phantoms appearing to the googlebot for some reason?

 

I'd be grateful for any ideas!

 

Toby

Share this post


Link to post
Share on other sites
I installed Ultimate SEO URLs 2.1d plus verification a couple of weeks ago. Everything looks fine. But now I seem to be accumulating broken links according to Google webmaster tools. The links Google thinks are broken are things like

 

http://www.myshop.com/shop/2243?page=2

 

These are not links that even look like any valid link in oscommerce before or after installing these modifications. Does anybody have any idea about this? Are these links appearing somewhere on the site that I haven't discovered or are they phantoms appearing to the googlebot for some reason?

 

I'd be grateful for any ideas!

 

Toby

 

Check that configuration>My Store>Use Search-Engine Safe URLs (still in development) is set to false

 

If not that then we'd need a site link.

Share this post


Link to post
Share on other sites
Check that configuration>My Store>Use Search-Engine Safe URLs (still in development) is set to false

 

If not that then we'd need a site link.

 

Robert,

 

Thanks for your interest.

 

"... still in dev" is indeed off. But I realised that I turned that off a bit after installing SEO, so I have just cleared the SEO cache hoping that might cure the problem.

 

The site's actual name is mcadirect. But I really can't see where that anomolous link is coming from. Although Webmaster Tools throws it up as a broken link, if you actually look through all the link data on webmaster tools there is no sign there that the nonexistent URLs are linked to either internally or externally.

 

It's annoying that webmaster tools lists unreachable pages without giving any clue of why it thinks the given page should exist (e.g. specifying what other page contains a link to it).

 

As I said, I'd be grateful for any ideas.

 

Toby

 

PS using SEO URL's seems to be an art form in itself. I have read some of the huge thread without finding much that helps. I note for instance that Ultimate SEO does not rewrite the "what's new" pages. Perhaps they should be forbidden by robots.txt, given that they are continually changing. I suppose though that the same applies to departments pages too. Ideally google would read them but link only to actual product pages. Perhaps I just need to read more about this!

Share this post


Link to post
Share on other sites

Robert,

 

I have had Ultimate Seo Url's installed for quite a while and never did catch the potential duplicate entry error. Logged into the contribution and saw that you had posted a solution to a problem I did not know existed.

 

 

Validated it is truly a possible problem, installed the correction and it works as advertised.

 

 

Well done.

 

 

 

 

cheers

Share this post


Link to post
Share on other sites

I installed version 2.4 but I cannot find settings in admin configuration file.

I think that probably some SQL where not executed for configuration table (I found only two SQLs in the contribution and they update other tables).

 

Probably it will help:

I installed that contribution couple months ago, but uninstalled it later because my host didn't support rewritable functions in htaccess file. Now I moved to other host, so I installed Ultimate SEO Urls again.

I open store all right, no errors, but again, I cannot see settings in configuration, and my links look like contribution is off.

 

Thanks for any help.

 

Mike


Computers777dotcom

Share this post


Link to post
Share on other sites

I remember when I installed it first time I also didn't see settings in Admin/Configuration but some how solved it. Now I don't remember what it was. I read some posts where others have same problem.

Can anybody give some light?

I just cannot find any SQL which apdates the table for these settings.

Thanks


Computers777dotcom

Share this post


Link to post
Share on other sites

It looks like that contribution installs some DB changes for configuration automatically but I cannot find that magic "button" anywhere. :(

Thanks for any help.

Mike


Computers777dotcom

Share this post


Link to post
Share on other sites

I just now installed the ultimate seo url script on my website half an hour ago and it stopped working sad.gifsad.gif . Please help me.

 

I have downloaded the latest script and installed it for the first time. After I have completed all the steps written in the install file and also additional updates, I opened my website and its not opening. This is the url : http://www.hblshop.com .

 

Please help guys.. I am in deep trouble. What should I do to make it work. Can anyone help please?

 

Here is the server info where my website is hosted. http://www.hblshop.com/info.php . Please help.

 

Regards

Henrik

Share this post


Link to post
Share on other sites
I just now installed the ultimate seo url script on my website half an hour ago and it stopped working sad.gifsad.gif . Please help me.

 

I have downloaded the latest script and installed it for the first time. After I have completed all the steps written in the install file and also additional updates, I opened my website and its not opening. This is the url : http://www.hblshop.com .

 

Please help guys.. I am in deep trouble. What should I do to make it work. Can anyone help please?

 

Here is the server info where my website is hosted. http://www.hblshop.com/info.php . Please help.

 

Regards

Henrik

 

Probably your host dosn't support rewritable functions in htaccess file (I had that problem).

To check, just undo or comment changes you did in your htaccess file.

Edited by AlwaysNewbie

Computers777dotcom

Share this post


Link to post
Share on other sites

I noticed onething in the package I downloaded. In the install.txt file it says the following things :

 

 

Step #2 - Modify files

These files has been modified:

admin/categories.php

admin/includes/functions/general.php

admin/includes/functions/database.php

includes/application_top.php

includes/functions/html_output.php

 

I am not able to find the changes to be done in the "admin/includes/functions/database.php" . Can anybody tell me what are the changes to be made in this file?

 

Thanks

Henrik

Share this post


Link to post
Share on other sites
I had checked that and the server allows rewritation feature. The CRE loaded URL rewrite works well on the same server.

 

Well, probably somewhere something wasn't done right then. I don't know.

I am still try to find out how to run database setting script (I cannot find any reference in instruction what, where, and how :( ) and still hope somebody will help.


Computers777dotcom

Share this post


Link to post
Share on other sites

I think I also need the database instructions and querries to run so that it gets updated in the phpmyadmin and the wbesite can fetch the right urls.

 

The script says when we will open the website for the first time after installing the Ultimate SEO Url then it will aitometically update the database and insert values.

 

In my case, I am not able to open the first page only.

Share this post


Link to post
Share on other sites

guys can I only install seo url's on a clean osc installation :o?

 

if that is the case then i should start all over with my website in order to install this or?

Share this post


Link to post
Share on other sites
guys can I only install seo url's on a clean osc installation :o?

 

if that is the case then i should start all over with my website in order to install this or?

 

No USU is an easy install and is unlikely to confilct unless you have modified includes/functions/html_output function tep_href_link().

 

I'd suggest you just install it using version 2.1d UPDATED.

 

Pay particular attention to the install instructions for .htaccess and RewriteBase.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×