Jump to content
Chemo

[Contribution] Ultimate SEO URLs - by Chemo

Recommended Posts

yup as I said .. it bears little resemblance to the code as stated in 2.1d updated

 

Options +FollowSymLinks is commented out

 

There's no RewriteBase

 

The rules are different.

 

My support ends until you install a proper version.

 

Nowhere did I see where you told me anything about a "proper version" This is straight from the latest update posted on 7/7/08. I made no changes to it whatsoever.

 

Which version is the "proper version" to use (post date)?

Share this post


Link to post
Share on other sites
Nowhere did I see where you told me anything about a "proper version" This is straight from the latest update posted on 7/7/08. I made no changes to it whatsoever.

 

Which version is the "proper version" to use (post date)?

Ultimate SEO URLS v21d_UPDATED


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

If you have v2.1e, how do you uninstall it and install v2.1d_Updated?


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites
Ultimate SEO URLS v21d_UPDATED

 

Thanks. I just overwrote my .htaccess file with the included code from that version and it seems to be working...for now...we'll see if it continues to do so tomorrow morning.

Share this post


Link to post
Share on other sites
If you have v2.1e, how do you uninstall it and install v2.1d_Updated?

Undo the install steps in v2.1e, and do the install steps in v2.1d_Updated

 

The install of v2.1d_Updated is really easy, I do not know about the other.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Hello,

 

I have a question about this contribution.

 

Everything is working perfectly but I have one problem with it.

I have a few products where the product's name contains a number.

Now, is there a way to display this number in the URL?

 

Thanks,

Hans

Share this post


Link to post
Share on other sites
Ok so I am using 2.1D's .htaccess file and it's still doing the same problem. Should I overwrite the other files with 2.1d's also?

Yes, and check the install file to what changes to files can stay, and reset cache any anything else.

 

Is it morning already?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

There's too many versions in the contribution list.. :) so, the Ultimate SEO original 2.1d works fine?

 

I am also experiencing the 404 errors when I try to click on the product list. I've looked at .htaccess, but it seems to be fine. (Its the original one copied from 2.1d)

Share this post


Link to post
Share on other sites
There's too many versions in the contribution list.. :) so, the Ultimate SEO original 2.1d works fine?

 

I am also experiencing the 404 errors when I try to click on the product list. I've looked at .htaccess, but it seems to be fine. (Its the original one copied from 2.1d)

2.1d UPDATED.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
No I just can't replicate it.

 

Search your configuration table for configuration_key SEO_URLS_CACHE_RESET

 

Check that field use_function contains ..

 

tep_reset_cache_data_seo_urls

 

Hi,

Thanks for your reply.

 

Do you mean in the /catalog/admin/includes/functions/general.php file?

 

I have this on line 755-769

////

// Alias function for module configuration keys

function tep_mod_select_option($select_array, $key_name, $key_value) {

reset($select_array);

while (list($key, $value) = each($select_array)) {

if (is_int($key)) $key = $value;

$string .= '<br><input type="radio" name="configuration[' . $key_name . ']" value="' . $key . '"';

if ($key_value == $key) $string .= ' CHECKED';

$string .= '> ' . $value;

}

 

return $string;

}

 

////

and this before the ending ?> tag

 

// Function to reset SEO URLs database cache entries

// Ultimate SEO URLs v2.1

function tep_reset_cache_data_seo_urls($action){

switch ($action){

case 'reset':

tep_db_query("DELETE FROM cache WHERE cache_name LIKE '%seo_urls%'");

tep_db_query("UPDATE configuration SET configuration_value='false' WHERE configuration_key='SEO_URLS_CACHE_RESET'");

break;

default:

break;

}

# The return value is used to set the value upon viewing

# It's NOT returining a false to indicate failure!!

return 'false';

}

}

?>

 

In the install step 5 says to put this last part before the ending tag. Before the ending tag I have two } like this

}

}

?>

In the install step there is only one. If I leave out the one I get a parse errror.

 

Also, I deleted the catalog/admin/includes/seo_reset_cache.php and the error was exactly the same. I uploaded again and the error is still there

Warning: call_user_func(tep_reset_cache_data_seo_urls): First argument is expected to be a valid callback ....

 

Hope someone can help.

Thanks again!

Share this post


Link to post
Share on other sites
Ok all the files for USU 2.1d are on my system now and followed the instructions exactly and it still does:

 

http://www.games4gamersonline.com/catalog/...roduct_info.php

 

Product not found...

 

I'm lost...

I think your link is not right. But your site seems to do what SEO urls are supposed to do.

By the way which wishlist contribution did you use? It looks good!

 

Thanks in advance

Share this post


Link to post
Share on other sites

Edit:

 

I just tried it and when I click a featured product it doesn't seem to work, however if I use the category nav, the first time it shoots back to the home page, then the second time it works. This is really odd.

 

 

 

Thanks for the compliments. When I click on a product, it shows that as the URL, what does it do for you?

 

The wishlist contribution I used is apparently called:

 

Guest Enhanced Wishlist 3.5 for osCommerce ms2

 

I believe this is the link:

 

http://www.oscommerce.com/community/contri...search,wishlist

 

I don't recall which version of 3.5 I used however.

Edited by games4gamers

Share this post


Link to post
Share on other sites
Edit:

 

I just tried it and when I click a featured product it doesn't seem to work, however if I use the category nav, the first time it shoots back to the home page, then the second time it works. This is really odd.

 

 

 

Thanks for the compliments. When I click on a product, it shows that as the URL, what does it do for you?

 

The wishlist contribution I used is apparently called:

 

Guest Enhanced Wishlist 3.5 for osCommerce ms2

 

I believe this is the link:

 

http://www.oscommerce.com/community/contri...search,wishlist

 

I don't recall which version of 3.5 I used however.

 

Ok Thanks for the info. When I sort out the SEO contribution I will try it.

I clicked on your featured products and they work fine. The product name is in your url and title the way it should be.

Share this post


Link to post
Share on other sites
Ok Thanks for the info. When I sort out the SEO contribution I will try it.

I clicked on your featured products and they work fine. The product name is in your url and title the way it should be.

 

Hmm ok, well that is good then. What browser? I use Firefox 3 primarily.

Share this post


Link to post
Share on other sites
Hmm ok, well that is good then. What browser? I use Firefox 3 primarily.

Hi,

I use IE7 but I tried it with Firefox as well. I didn't see anything wrong.

Share this post


Link to post
Share on other sites
Hi,

I use IE7 but I tried it with Firefox as well. I didn't see anything wrong.

 

Hmm that's really strange, wonder why it does it to me then?

Share this post


Link to post
Share on other sites

Hmm. I get the following after installation:

 

The requested URL /directory/product_info.php was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

:blink:

 

FIXED. Wrong settings in .htaccess

Edited by modix

Share this post


Link to post
Share on other sites

HI,

I just installed the contribution last posted by FWR Media which is 2.1d ORIGINAL UPDATED

I also installed the validation part to redirect the incorrect URLs to correct ones as well.

However I am facing following problems:

 

1. If I turn this contribution off in the admin>Configuration, my old URLs dont work fine. They just take me to the catalog page with a strange URL like: http://india1imports.com/catalog/index.php?catalog=index.php

 

2. When I turn it on, my URLs are much simpler and non dynamic as expected, but aren;t my old product page URLs supposed to be forwarded to th enew product URLs. However, if I use my old URL, which is probably already crawled by Google bot, then it says that Product not found.

 

3. I had updated my paypal.php file some time back to pass on the whole shopping cart to paypal. It works fine after Ultimate SE URL contribution installed without discount coupons, but with discount coupons, it is getting messed up in passing the parameters to Paypal. Why would this contribution affect that at all!!. - See my post at:

http://forums.oscommerce.com/index.php?sho...39217&st=40 (posted on Jun 7).

 

4. When I first installe dthis contribution, I was not able to go to from shopping cart to checkout (checkout_shipping.php). The error I was getting was:

*********************

 

2013 - Lost connection to MySQL server during query

 

select c.categories_id, cd.categories_name, c.parent_id from categories c, categories_description cd where c.parent_id = '0' and c.categories_id = cd.categories_id and cd.language_id='1' order by sort_order, cd.categories_name

 

[TEP STOP]

 

2006 - MySQL server has gone away

 

select count(*) as total from sessions where sesskey = '2e5a73ff1e7440adab496739447fac98'

 

[TEP STOP]

 

 

Warning: Unknown(): A session is active. You cannot change the session module's ini settings at this time. in Unknown on line 0

****************

Its fixed by otself, but I am wondering why that would have happened.

Is my .htaccess file okay?

 

 

Thanks to anyone whoe spares time to help me.

 

-Abhay

Share this post


Link to post
Share on other sites

okay, from above post, #3 and #4 are cleared.

 

Now, I am left with #1 and #2. repeating questions:

After I installed Ultimate SEO URL 2.1d ORIGINAL UPDATED by FWR Media, I have two issues:

1. even after I turn it off in Admin>Configuration, my old URLs are not generated and it takes me to catalog page if I click on any category.

2. How do I make my old URLs redirected to the new URLs. Seems like there is a swich in the configuration, but I have turned it on and it does not work still.

 

Thanks,

Abhay

Share this post


Link to post
Share on other sites
okay, from above post, #3 and #4 are cleared.

 

Now, I am left with #1 and #2. repeating questions:

After I installed Ultimate SEO URL 2.1d ORIGINAL UPDATED by FWR Media, I have two issues:

1. even after I turn it off in Admin>Configuration, my old URLs are not generated and it takes me to catalog page if I click on any category.

2. How do I make my old URLs redirected to the new URLs. Seems like there is a swich in the configuration, but I have turned it on and it does not work still.

 

Thanks,

Abhay

 

I think we'd need to see a link for this one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×