Jump to content
Chemo

[Contribution] Ultimate SEO URLs - by Chemo

Recommended Posts

Does this contribution have to be on a clean install of os, i tried to install it on an already populated store with STS running and I am getting some strange errors.

 

300 options being one of them...

 

any ideas.

 

thanks

Share this post


Link to post
Share on other sites

Hi.

I instaled Ultimate_SEO_URLs_v2-2.2eFIXEDReload.

has some problems. Everything working allright excluding sort page and next page.

Doesnt sort pages by price by name.

Doesnt open next page.

When I hover on link i see category-c-24.html?sort=2d&page=1

But when i push it it opens category-c-24.html

The same problem with next page.

The link tools-c-25.html?page=2&sort=2a

It redirects to tools-c-25.html . I see the same page.

I think mod_rewrite doesnt accept ?page=2&sort=2a

 

I think something wrong with my httaccess. It looks

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

 

Can anyone help me?

Thank you.

Share this post


Link to post
Share on other sites

I installed Ultimate SEO URLs and it appears to be functioning except for a couple of things...

 

(using Ultimate_SEO_URLSv21d appears to be the best version according to this thread)

osCommerce 2.2-MS2

 

No matter what I do the "SEO URLs" link will not show up in the admin configuration menu, tried clearing cache, reinstalling, different versions of USU. Nothing would work. In phpmyadmin I see the configuration options are in the database, so they just aren't showing up in the admin menu. This is on two different stores, same behavior.

 

Secondly,

"Featured Products" Is there something to add so featured products will work? I have four featured products on my home page and after installing USU they links are broken, for example:

 

https://www.example.com/store/product_info....products_id=733

leads me to "product not found"

 

are there some additional steps to get this to work with featured products? admin config options?

 

Thanks

Share this post


Link to post
Share on other sites
I installed Ultimate SEO URLs and it appears to be functioning except for a couple of things...

 

(using Ultimate_SEO_URLSv21d appears to be the best version according to this thread)

osCommerce 2.2-MS2

 

No matter what I do the "SEO URLs" link will not show up in the admin configuration menu, tried clearing cache, reinstalling, different versions of USU. Nothing would work. In phpmyadmin I see the configuration options are in the database, so they just aren't showing up in the admin menu. This is on two different stores, same behavior.

 

Secondly,

"Featured Products" Is there something to add so featured products will work? I have four featured products on my home page and after installing USU they links are broken, for example:

 

https://www.example.com/store/product_info....products_id=733

leads me to "product not found"

 

are there some additional steps to get this to work with featured products? admin config options?

 

Thanks

 

If USU doesn't install correctly then there is either a conflict in the configuration tables (something with the same id, installed twice etc). Or a sloppily written contribution that has parked itself at the very last available id.

 

I'd delete all USU configuration options via phpmyadmin then let USU reinstall itself

 

Is there something to add so featured products will work?

 

I'm not familiar with this contribution but if it used tep_href_link correctly then it would work with USU

Edited by FWR Media

Share this post


Link to post
Share on other sites
If USU doesn't install correctly then there is either a conflict in the configuration tables (something with the same id, installed twice etc). Or a sloppily written contribution that has parked itself at the very last available id.

 

I'd delete all USU configuration options via phpmyadmin then let USU reinstall itself

 

Is there something to add so featured products will work?

 

I'm not familiar with this contribution but if it used tep_href_link correctly then it would work with USU

 

Thanks for the tips.

 

I've checked configuration table

There are no duplicate configuration_ids. They go up from 1 to 60 then 86 to 100 up to 250 skipping a few numbers here and there and at 337-352 I see USU config options.

The configuration ID's are not in complete numerical order but there are no id's above 352.

 

and the configuration_group table

I see SEO URLs listed

 

I deleted the SEO configuration and SEO URLS configuration_group, loaded up the site to 'reinstall'. The SEO URLs are working, but the admin config link is still missing. hmm.

 

Regarding the featured products, I may have been mistaken, I saw the "featured product" option on the edit products page and assumed there was some module responsible for that... or is that a default oscommerce option? When I updated the maximum number of "new products" 0 all the featured products that were on the home page disappeared.

 

I'm guessing new_products probably uses the tep_href_link function. Does something with new products need to be updated to work with USU?

Edited by internets

Share this post


Link to post
Share on other sites

Don't know if this has been addressed yet or not, but I'm using 2.1d and keep getting this error:

 

Not Found

The requested URL /catalog/lego-indiana-jones-p-285.html was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/1.3.33 Server at www.games4gamersonline.com Port 80

 

It does this for any product. Not sure what else I need to do...thanks for any help.

 

Here's my .htaccess

 


# $Id: $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)



# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers



#<IfModule mod_setenvif.c>

#  <IfDefine SSL>

#    SetEnvIf User-Agent ".*MSIE.*" \

#             nokeepalive ssl-unclean-shutdown \

#             downgrade-1.0 force-response-1.0

#  </IfDefine>

#</IfModule>



# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter



# AcceptPathInfo On



# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)



# php_value session.use_trans_sid 0

# php_value register_globals 1



DirectoryIndex catalog/index.php

# Ultimate SEO URLs BEGIN
<IfModule mod_rewrite.c>
#  dont work option
#Options +FollowSymLinks
 RewriteEngine On
 RewriteBase catalog/

 RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

Share this post


Link to post
Share on other sites
Don't know if this has been addressed yet or not, but I'm using 2.1d and keep getting this error:

 

Not Found

The requested URL /catalog/lego-indiana-jones-p-285.html was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/1.3.33 Server at www.games4gamersonline.com Port 80

 

It does this for any product. Not sure what else I need to do...thanks for any help.

 

Here's my .htaccess

 


# $Id: $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)



# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers



#<IfModule mod_setenvif.c>

#  <IfDefine SSL>

#    SetEnvIf User-Agent ".*MSIE.*" \

#             nokeepalive ssl-unclean-shutdown \

#             downgrade-1.0 force-response-1.0

#  </IfDefine>

#</IfModule>



# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter



# AcceptPathInfo On



# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)



# php_value session.use_trans_sid 0

# php_value register_globals 1



DirectoryIndex catalog/index.php

# Ultimate SEO URLs BEGIN
<IfModule mod_rewrite.c>
#  dont work option
#Options +FollowSymLinks
 RewriteEngine On
 RewriteBase catalog/

 RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

 

 

Try

RewriteBase /catalog/

 

in your htaccess instead of

 

RewriteBase catalog/

 

Also, my htaccess has

Options +FollowSymLinks

uncommented

Edited by internets

Share this post


Link to post
Share on other sites
Thanks for the tips.

 

I've checked configuration table

There are no duplicate configuration_ids. They go up from 1 to 60 then 86 to 100 up to 250 skipping a few numbers here and there and at 337-352 I see USU config options.

The configuration ID's are not in complete numerical order but there are no id's above 352.

 

and the configuration_group table

I see SEO URLs listed

 

I deleted the SEO configuration and SEO URLS configuration_group, loaded up the site to 'reinstall'. The SEO URLs are working, but the admin config link is still missing. hmm.

 

Regarding the featured products, I may have been mistaken, I saw the "featured product" option on the edit products page and assumed there was some module responsible for that... or is that a default oscommerce option? When I updated the maximum number of "new products" 0 all the featured products that were on the home page disappeared.

 

I'm guessing new_products probably uses the tep_href_link function. Does something with new products need to be updated to work with USU?

 

 

In response to my own question, I had to edit the new_products file because the original developers hardcoded certain parts of the URL which prevented SEO URLs from working.

 

 

But I still can not get the SEO URLs config link to show up in the admin interface.

Share this post


Link to post
Share on other sites
Try

RewriteBase /catalog/

 

in your htaccess instead of

 

RewriteBase catalog/

 

Also, my htaccess has

Options +FollowSymLinks

uncommented

 

 

I've tried both and no dice. My colleague said I need to have static pages made for this to work, is that correct? Also when I leave the options uncommented, the rewriting doesn't work at all...

Share this post


Link to post
Share on other sites
I've tried both and no dice. My colleague said I need to have static pages made for this to work, is that correct? Also when I leave the options uncommented, the rewriting doesn't work at all...

 

 

No I don't think you should have to make static pages...

 

 

Did you try setting:

DirectoryIndex catalog/index.php

to

DirectoryIndex /catalog/index.php

or commenting out DirectoryIndex catalog/index.php

 

in addition to

RewriteBase /catalog/

 

What directory is your .htaccess file stored in?

It should be

public_html/catalog/.htaccess

 

Here is my htaccess file basically copied from the USU documentation.

 

 

 

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
 <IfDefine SSL>
SetEnvIf User-Agent ".*MSIE.*" \
		 nokeepalive ssl-unclean-shutdown \
		 downgrade-1.0 force-response-1.0
 </IfDefine>
</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter
#
# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)
#
<IfModule mod_php4.c>
 php_value session.use_trans_sid 0
 php_value register_globals 1
</IfModule>

<IfModule mod_php5.c>
 php_value session.use_trans_sid 0
 php_value register_globals 1
</IfModule>

Options +FollowSymLinks
RewriteEngine On 
RewriteBase /catalog/

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

Share this post


Link to post
Share on other sites

Edit: My .htaccess is in /catalog

 

Ok, DirectoryIndex seems to have no effect...

 

When I do RewriteBase /catalog/

 

It rewrites the links as:

 

http://www.games4gamersonline.com/catalog/...roduct_info.php

 

When I do RewriteBase catalog/

 

It rewrites the links as: http://www.games4gamersonline.com/catalog/...ning-p-117.html

 

(i.e. the way it's supposed to), but it still does file not found....

 

No I don't think you should have to make static pages...

 

 

Did you try setting:

DirectoryIndex catalog/index.php

to

DirectoryIndex /catalog/index.php

or commenting out DirectoryIndex catalog/index.php

 

in addition to

RewriteBase /catalog/

 

What directory is your .htaccess file stored in?

It should be

public_html/catalog/.htaccess

 

Here is my htaccess file basically copied from the USU documentation.

 

 

 

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
 <IfDefine SSL>
SetEnvIf User-Agent ".*MSIE.*" \
		 nokeepalive ssl-unclean-shutdown \
		 downgrade-1.0 force-response-1.0
 </IfDefine>
</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter
#
# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)
#
<IfModule mod_php4.c>
 php_value session.use_trans_sid 0
 php_value register_globals 1
</IfModule>

<IfModule mod_php5.c>
 php_value session.use_trans_sid 0
 php_value register_globals 1
</IfModule>

Options +FollowSymLinks
RewriteEngine On 
RewriteBase /catalog/

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

Edited by games4gamers

Share this post


Link to post
Share on other sites

I asked this question once before but did not get any resolution so I try again.

 

SEO URLs

 

Warning: call_user_func(tep_reset_cache_data_seo_urls) [function.call-user-func]: First argument is expected to be a valid callback in /home/wihirt/public_html/catalog/admin/includes/functions/general.php on line 1351

 

This is just above the SEO URL control panel in admin. How do I see if the contribution is working properly?

 

Any ideas?

 

Thxs

 

www.koolkatjazz.com

 

Peder


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites
I asked this question once before but did not get any resolution so I try again.

 

SEO URLs

 

Warning: call_user_func(tep_reset_cache_data_seo_urls) [function.call-user-func]: First argument is expected to be a valid callback in /home/wihirt/public_html/catalog/admin/includes/functions/general.php on line 1351

 

This is just above the SEO URL control panel in admin. How do I see if the contribution is working properly?

 

Any ideas?

 

Thxs

 

www.koolkatjazz.com

 

Peder

 

Did you upload reset_seo_cache.php to your \catalog\admin\includes directory? If not, you need to do that.

Share this post


Link to post
Share on other sites

I've just installed this contribution and it appears to be working - I can see it in admin and the urls have changed.

 

Except now Im getting errors at the top of the website, top of admin and while using the shopping cart: www.seedbeading.com.au

 

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/seedbead/public_html/includes/functions/html_output.php:388) in /home/seedbead/public_html/includes/functions/sessions.php on line 101

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/seedbead/public_html/includes/functions/html_output.php:388) in /home/seedbead/public_html/includes/functions/sessions.php on line 101

Im hoping it will be a simple fix, because I really want to use this contrib but I need to get this fixed quickly. Im a real novice at this so Im sort of after 'php advice for dummies' lol

 

Im using the version 2.1e

 

Should I try a different version perhaps? I've also just installed the 'meta tags on the fly' contrib so Im wondering if this might be conficting

Share this post


Link to post
Share on other sites
I've just installed this contribution and it appears to be working - I can see it in admin and the urls have changed.

 

Except now Im getting errors at the top of the website, top of admin and while using the shopping cart: www.seedbeading.com.au

 

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/seedbead/public_html/includes/functions/html_output.php:388) in /home/seedbead/public_html/includes/functions/sessions.php on line 101

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/seedbead/public_html/includes/functions/html_output.php:388) in /home/seedbead/public_html/includes/functions/sessions.php on line 101

Im hoping it will be a simple fix, because I really want to use this contrib but I need to get this fixed quickly. Im a real novice at this so Im sort of after 'php advice for dummies' lol

 

Im using the version 2.1e

 

Should I try a different version perhaps? I've also just installed the 'meta tags on the fly' contrib so Im wondering if this might be conficting

Ultimate SEO URLS v21d_UPDATED


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Did you upload reset_seo_cache.php to your \catalog\admin\includes directory? If not, you need to do that.

Yes I did


-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites
Yes I did

 

Did you make your changes to general.php? What version of USU are you using?

 

And btw to those who were helping me, I managed to solve my problem. I downloaded the update to 2.1d from 7/7/08 and it fixed the problem, yay. :) Thanks again all.

Share this post


Link to post
Share on other sites

Hi,

I have the same problem.

Warning: call_user_func(tep_reset_cache_data_seo_urls): First argument is expected to be a valid callback in /home/content/a/r/t/xxxxxxx/html/catalog/admin/includes/functions/general.php on line 1195 .

I have uploaded the reset_seo_cache php file in catalog/admin/includes folder and I have made the changes in the install steps.

 

The file says this

tep_db_query("DELETE FROM cache WHERE cache_name LIKE '%seo_urls%'");

?>

I am using ultimate seo urls v 21d updated .

Thank you in advance.

Share this post


Link to post
Share on other sites
Hi,

I have the same problem.

Warning: call_user_func(tep_reset_cache_data_seo_urls): First argument is expected to be a valid callback in /home/content/a/r/t/xxxxxxx/html/catalog/admin/includes/functions/general.php on line 1195 .

I have uploaded the reset_seo_cache php file in catalog/admin/includes folder and I have made the changes in the install steps.

 

The file says this

tep_db_query("DELETE FROM cache WHERE cache_name LIKE '%seo_urls%'");

?>

I am using ultimate seo urls v 21d updated .

Thank you in advance.

 

I'm seeing this a lot, but I can't replicate it. I wonder if it relates to php5.

 

I'll look into it.

Share this post


Link to post
Share on other sites
I'm seeing this a lot, but I can't replicate it. I wonder if it relates to php5.

 

I'll look into it.

 

No I just can't replicate it.

 

Search your configuration table for configuration_key SEO_URLS_CACHE_RESET

 

Check that field use_function contains ..

 

tep_reset_cache_data_seo_urls

Share this post


Link to post
Share on other sites

Yay, new problem for me. I got the .htaccess to work and all, but now it seems to be randomly overwritten server side or something. That is, it randomly decides to not rewrite correctly. Currently it's giving me:

 

http://www.games4gamersonline.com/catalog/...roduct_info.php

 

Where it should be something like:

 

http://www.games4gamersonline.com/catalog/...name-p-215.html

 

Any ideas why this is happening?

Share this post


Link to post
Share on other sites
Yay, new problem for me. I got the .htaccess to work and all, but now it seems to be randomly overwritten server side or something. That is, it randomly decides to not rewrite correctly. Currently it's giving me:

 

http://www.games4gamersonline.com/catalog/...roduct_info.php

 

Where it should be something like:

 

http://www.games4gamersonline.com/catalog/...name-p-215.html

 

Any ideas why this is happening?

 

This never happens unless it's a fork of oscommerce or you have additional conflicting rules in .htaccess.

Edited by FWR Media

Share this post


Link to post
Share on other sites
This never happens unless it's a fork of oscommerce or you have additional conflicting rules in .htaccess.

 

Hmm weird...well here's the htaccess file:

 

# Ultimate SEO URLs BEGIN
<IfModule mod_rewrite.c>
#  dont work option
#  Options +FollowSymLinks
 RewriteEngine On 

 RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}
# Ultimate SEO URLs END
# Added to fix article glitch on sub-articles (lonniew at gmail dot com)
 RewriteRule ^(.*)-t-([0-9]+_[0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
# Added polls e newsdesk by lavoriamopervoi.com
 RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
</IfModule>

Share this post


Link to post
Share on other sites
Hmm weird...well here's the htaccess file:

 

# Ultimate SEO URLs BEGIN
<IfModule mod_rewrite.c>
#  dont work option
#  Options +FollowSymLinks
 RewriteEngine On 

 RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}
# Ultimate SEO URLs END
# Added to fix article glitch on sub-articles (lonniew at gmail dot com)
 RewriteRule ^(.*)-t-([0-9]+_[0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
# Added polls e newsdesk by lavoriamopervoi.com
 RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
 RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
</IfModule>

 

yup as I said .. it bears little resemblance to the code as stated in 2.1d updated

 

Options +FollowSymLinks is commented out

 

There's no RewriteBase

 

The rules are different.

 

My support ends until you install a proper version.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×