Jump to content
Chemo

[Contribution] Ultimate SEO URLs - by Chemo

Recommended Posts

2.1d original updated works without any problems, is this the one you are using?

 

Yes. I'm using 2.1d. I'm now thinking it's something in my product_info.php or elsewhere. Because SEO URL is working fine otherwise. + on my product pages, the javascript popup / product image link is also dead. -

 

http://www.kickerfilms.com/pushprocess-p-399.html

Share this post


Link to post
Share on other sites

It was my product_info.php. Sorry. Reviews work now.. 'Click to Enlarge' is still dead but I can live with that for the moment.

Share this post


Link to post
Share on other sites

Hey,

 

I am working on getting 2.1d updated workin on a customers osc system which is pretty customized, which may be why there are problems, but it doesnt seem to be picking up the RewriteRule in the htaccess file. The htaccess is located in my wwwroot and the Ult. SEO is linking it correctly but I keep getting the page not found error. any ideas? Thanks.

 

Art Armstrong

Share this post


Link to post
Share on other sites

Great job, installed perfectly and worked perfectly out of the box. Now I have added a directory tree of categories and my breadcrumbs are blank for this new tree. Any ideas? Do I need to stop and start this "service" or something? Any info would be appreciated.

 

The new category tree is sports. The old one which still has working breadcrumbs is tools.

 

Please see www.bluebuyers.com

Share this post


Link to post
Share on other sites
Hey,

 

I am working on getting 2.1d updated workin on a customers osc system which is pretty customized, which may be why there are problems, but it doesnt seem to be picking up the RewriteRule in the htaccess file. The htaccess is located in my wwwroot and the Ult. SEO is linking it correctly but I keep getting the page not found error. any ideas? Thanks.

 

Art Armstrong

 

The htaccess is located in my wwwroot

 

Is the shop in wwwroot because the USU .htaccess is meant to be in shop root.

 

RewriteBase for shop at www.mysite.com = RewriteBase /

 

RewriteBase for shop at www.mysite.com/shop/ = RewriteBase /shop/

 

Other than that is it a linux apache server?

 

Is mod rewrite loaded in apache?

 

Does AllowOverride give sufficient permission for .htaccess to Rewrite URLs?

Share this post


Link to post
Share on other sites
Is the shop in wwwroot because the USU .htaccess is meant to be in shop root.

 

RewriteBase for shop at www.mysite.com = RewriteBase /

 

RewriteBase for shop at www.mysite.com/shop/ = RewriteBase /shop/

 

Other than that is it a linux apache server?

 

Is mod rewrite loaded in apache?

 

Does AllowOverride give sufficient permission for .htaccess to Rewrite URLs?

 

 

I just found out today its a Windows Apache Server, which build works with that, if any? Thanks for the help!

Edited by artarmstrong

Share this post


Link to post
Share on other sites
I just found out today its a Windows Apache Server, which build works with that, if any? Thanks for the help!

 

2.1b I think

Share this post


Link to post
Share on other sites

Hello

 

Anyone can help me ?

 

I changed the ultimate SEO URL to v2.1d and installed the validate version of Mr. FWR but the problem is still there.

 

http://www.site.com/-c-12.html

 

instead of http://www.site.com/books-c-12.html

 

I 've tried every things that everyone posted in this thread but it 's not good.

 

Anyone can help ???

 

I am stuck in this for a while. !

 

This is my site Computer Parts

Share this post


Link to post
Share on other sites
Hello

 

Anyone can help me ?

 

I changed the ultimate SEO URL to v2.1d and installed the validate version of Mr. FWR but the problem is still there.

 

http://www.site.com/-c-12.html

 

instead of http://www.site.com/books-c-12.html

 

I 've tried every things that everyone posted in this thread but it 's not good.

 

Anyone can help ???

 

I am stuck in this for a while. !

 

This is my site Computer Parts

 

All seems to be working

Share this post


Link to post
Share on other sites
All seems to be working

 

If you type my website and enter in IE, then point the mouse to any links ( any products, any catagories ) ..

 

the web address will be something like http://site/-c-121.html or http://site/-p-134.html <-- problem occured

 

but when you refresh the page or click to other page, it will not be any problem..

 

Only first time, when you go to my website, the bad web address will occur. Wonder why..

 

Google have kept getting this error and indexed it

 

this is my web http://computeronlinestore.net

Edited by pokbluesky

Share this post


Link to post
Share on other sites

Hi, I just installed this contribution and everything seems to be working great..but I was wondering what this option was for in the admin section....special character conversions....what does it do...and how would I do it??

 

 

Thanks in advance for the support

 

 

BTW...GREAT CONTRIBUTION!!!!!! :D

Edited by herblife

Gloria

Share this post


Link to post
Share on other sites
Whenever I edit or add products, my html code like <br> or <p> changes to _br_ or _p_ and therefore, no html changes take place. This only started happening after I tried installing SEO URLs, anyone know what's wrong?

 

I also have this issue, could you please give some advice asap?

 

Thanks & Best Regards,

Share this post


Link to post
Share on other sites
I also have this issue, could you please give some advice asap?

 

Thanks & Best Regards,

 

USU doesn't touch html code .. only links.

Share this post


Link to post
Share on other sites

Hi

 

I have Ultimate SEO installed and working like a charm. I have just changed my domain name and using rewrite 301 for redirection in the .htaccess. Problem I have is that none of the html pages are showing up.

 

The page isn't redirecting properly. Flock has detected that the server is redirecting the request for this address in a way that will never complete.

 

any sugestions appreciated.

 

Liam

Share this post


Link to post
Share on other sites

I get the following message at the top of seo urls in my admin panel: Warning: call_user_func(tep_reset_cache_data_seo_urls) [function.call-user-func]: First argument is expected to be a valid callback in /mnt/w0207/d18/s05/b02d72b0/www/catalog/catalog/admin/includes/functions/general.php on line 1245

Ichecked the code but don't see a problem.


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites

I installed version 2.1e, but if I add code to .htaccess file in a root directory I got Internal Server Error.

My store placed in a root directory, right under domain name.

Without adding in .htaccess file I can open site. In admin panel I can see new option SEO URLs in Configuration folder and it looks fine and doesn't give me any errors when I try to change settings.

What can be problem?

 

Thanks!


Computers777dotcom

Share this post


Link to post
Share on other sites
I installed version 2.1e, but if I add code to .htaccess file in a root directory I got Internal Server Error.

My store placed in a root directory, right under domain name.

Without adding in .htaccess file I can open site. In admin panel I can see new option SEO URLs in Configuration folder and it looks fine and doesn't give me any errors when I try to change settings.

What can be problem?

 

Thanks!

Ultimate SEO URLS v21d_UPDATED is the best one to use.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Ultimate SEO URLS v21d_UPDATED is the best one to use.

 

Well, if you want to say that version 2.1e is not that good, probably you may bring an argument.

Anyway, I tried to downgrade to version d and got the same error after writing into the .htacces file.

 

Anybody?


Computers777dotcom

Share this post


Link to post
Share on other sites
Well, if you want to say that version 2.1e is not that good, probably you may bring an argument.

Anyway, I tried to downgrade to version d and got the same error after writing into the .htacces file.

 

Anybody?

 

No argument.

 

2-2.2e intended to add validation to the original code of the author Chemo which was a good idea but the code was buggy and caused numerous issues.

 

Other than validation 2-2.2e offers nothing over the old original solid 2.1d.

 

Given that 2.1d was brought up to date for php5/MySQL5 and has validation available as an independent add on if you want to add it, there really are no benefits to 2-2.2e.

 

The fixed, fixed again multiple versions of 2-2.2e make things very confusing also whereas 2.1d has been solid code for many years and is used by, who knows how many, shops.

 

As with everything though it is personal choice as to what you wish to install in your shop.

Share this post


Link to post
Share on other sites
I installed version 2.1e, but if I add code to .htaccess file in a root directory I got Internal Server Error.

My store placed in a root directory, right under domain name.

Without adding in .htaccess file I can open site. In admin panel I can see new option SEO URLs in Configuration folder and it looks fine and doesn't give me any errors when I try to change settings.

What can be problem?

 

Thanks!

 

server errors of this type are always related to .htaccess

 

Is it a linux apache server?

 

Is RewriteBase correct?

e.g. www.mysite.com = RewriteBase /

www.mysite.com/shop/ = RewriteBase /shop/

 

Does your server have mod_rewrite installed?

 

Does allowOverride have sufficient permissions to allow the rewrites?

Share this post


Link to post
Share on other sites
server errors of this type are always related to .htaccess

 

Is it a linux apache server?

 

Is RewriteBase correct?

e.g. www.mysite.com = RewriteBase /

www.mysite.com/shop/ = RewriteBase /shop/

 

Does your server have mod_rewrite installed?

 

Does allowOverride have sufficient permissions to allow the rewrites?

 

FWR Media,

 

Thanks for reply and advice.

Well, my store placed in a root of my domain, not in the special folder, so I just added this to end of my file:

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

 

RewriteCond %{QUERY_STRING} ^options\=(.*)$

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2%1

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

 

Obviously something wrong with .htaccess file but I have no knowledge to correct this.

 

Yes, it is linux apache server.

I'm not sure if my server have mod_rewrite installed and have no idea where I can check allowOverride. :(

 

Thanks for any help.

Edited by AlwaysNewbie

Computers777dotcom

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×