Jump to content
Chemo

[Contribution] Ultimate SEO URLs - by Chemo

Recommended Posts

Well i have just installed the ultimate seo URLs v1.

 

and i ignored the create a cache directory

 

and i ignored =

Configure the settings-

- Admin Control Panel => Configuration => Cache Directory => FULL PATH to the cache directory INCLUDING END SLASH

 

 

because i dont know what cache directory is.

 

Now after the install i am obviously getting errors

these are the errors i have on my home page =

 

 

Warning: fopen(): open_basedir restriction in effect. File(/path/to/your/cache/directory/seo_english.cache) is not within the allowed path(s): (d:\users) in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 159

 

Warning: fopen(/path/to/your/cache/directory/seo_english.cache): failed to open stream: Operation not permitted in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 159

 

Warning: fwrite(): supplied argument is not a valid stream resource in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 160

 

Warning: fclose(): supplied argument is not a valid stream resource in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 161

 

Warning: main(): open_basedir restriction in effect. File(d:\/path/to/your/cache/directory/seo_english.cache) is not within the allowed path(s): (d:\users) in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

Warning: main(/path/to/your/cache/directory/seo_english.cache): failed to open stream: Operation not permitted in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

Warning: main(): Failed opening '/path/to/your/cache/directory/seo_english.cache' for inclusion (include_path='.;c:\php4\pear') in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

 

 

so i guess i need to sort out the cache directory.

 

Help is needed because im very stupid.

 

Thanks,

Paulie.

Edited by paulieGB

Share this post


Link to post
Share on other sites

Also i have two 'SEO URLs' in my admin.

One of them was there before i installed ultimate seo, I noticed it after i installed header tags this week,

BUT it might have been there before that, because i have tryed to install ultimate seo the new version v2.1 or something, and that didn't work, so i uninstalled it.

 

But anyway the point is =

in the original 'SEO URLs' that was there before i installed ultimate seo, i have an error come up on the page.

This is the error =

 

Warning: call_user_func(tep_reset_cache_data_seo_urls): First argument is expected to be a valid callback in d:\users\foxycardsuk\public_html\admin\includes\functions\general.php on line 1195

 

 

Now i have no idea if it was there before, because i only noticed the 'seo url' in my admin this week and never clicked on it to open the page,

Do i need two 'SEO URLs' in my admin ?

Do i just need the 'SEO URLs' that came with the ultimate seo that i installed today ?

What about the error ?

 

Also i have the errors on my home page in my above post still, and please i really need help.

 

Paulie.

Edited by paulieGB

Share this post


Link to post
Share on other sites

i have changed the path to cache directory.

i found a folder in catalog called cache.

 

this is the new errors i have in my homepage =

 

 

Warning: fopen(): open_basedir restriction in effect. File(/foxycardsuk/public_html/cache/seo_english.cache) is not within the allowed path(s): (d:\users) in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 159

 

Warning: fopen(/foxycardsuk/public_html/cache/seo_english.cache): failed to open stream: Operation not permitted in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 159

 

Warning: fwrite(): supplied argument is not a valid stream resource in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 160

 

Warning: fclose(): supplied argument is not a valid stream resource in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 161

 

Warning: main(): open_basedir restriction in effect. File(d:\/foxycardsuk/public_html/cache/seo_english.cache) is not within the allowed path(s): (d:\users) in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

Warning: main(/foxycardsuk/public_html/cache/seo_english.cache): failed to open stream: Operation not permitted in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

Warning: main(): Failed opening '/foxycardsuk/public_html/cache/seo_english.cache' for inclusion (include_path='.;c:\php4\pear') in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

 

 

still need help,

im really stuck.

 

Paulie.

Share this post


Link to post
Share on other sites

ok.

 

I have just added a code to the general.php file and that took away the errors in admin.

Now the only error i have are on my homepage.

these are the errors =

 

Warning: fopen(): open_basedir restriction in effect. File(/foxycardsuk/public_html/cache/seo_english.cache) is not within the allowed path(s): (d:\users) in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 159

 

Warning: fopen(/foxycardsuk/public_html/cache/seo_english.cache): failed to open stream: Operation not permitted in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 159

 

Warning: fwrite(): supplied argument is not a valid stream resource in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 160

 

Warning: fclose(): supplied argument is not a valid stream resource in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 161

 

Warning: main(): open_basedir restriction in effect. File(d:\/foxycardsuk/public_html/cache/seo_english.cache) is not within the allowed path(s): (d:\users) in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

Warning: main(/foxycardsuk/public_html/cache/seo_english.cache): failed to open stream: Operation not permitted in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

Warning: main(): Failed opening '/foxycardsuk/public_html/cache/seo_english.cache' for inclusion (include_path='.;c:\php4\pear') in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

 

 

I have had a look in the seo_cache.php file. And near the top section of the file it says =-

# DO NOT EDIT BELOW THIS POINT UNLESS YOU KNOW WHAT YOU'RE DOING #

 

so i havent changed anything in the file , not that i would know what to change anyway.

 

I would appreciate some help with this.

Paulie.

Edited by paulieGB

Share this post


Link to post
Share on other sites
wow,

 

can no one help ?

see post 1650


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

ow well i was told Ultimate SEO URLs v1.0 was compatable with windows ?

 

do i have to uninstall everything then ?

Share this post


Link to post
Share on other sites
wow,

 

can no one help ?

 

Apart from the fact that you are using the wrong version.

 

The following error message: -

 

Warning: fopen(): open_basedir restriction in effect. File(/foxycardsuk/public_html/cache/seo_english.cache) is not within the allowed path(s): (d:\users) in d:\users\foxycardsuk\public_html\includes\seo_cache.php

 

Suggests to me that your server open_basedir settings do not allow fopen dir on same level as httpdocs/public_html.

 

You should be able to cure this by moving the dir folder out of root with a path like ..

/foxycardsuk/public_html/tmp/cache/seo_english.cache

Share this post


Link to post
Share on other sites

ok thx,

 

when you say change path im asuming you mean to change the path of cache directiory in admin.

so i did that and now get these errors =

 

 

 

Warning: fopen(): open_basedir restriction in effect. File(/foxycardsuk/public_html/tmp/cache/seo_english.cacheseo_english.cache) is not within the allowed path(s): (d:\users) in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 159

 

Warning: fopen(/foxycardsuk/public_html/tmp/cache/seo_english.cacheseo_english.cache): failed to open stream: Operation not permitted in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 159

 

Warning: fwrite(): supplied argument is not a valid stream resource in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 160

 

Warning: fclose(): supplied argument is not a valid stream resource in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 161

 

Warning: main(): open_basedir restriction in effect. File(d:\/foxycardsuk/public_html/tmp/cache/seo_english.cacheseo_english.cache) is not within the allowed path(s): (d:\users) in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

Warning: main(/foxycardsuk/public_html/tmp/cache/seo_english.cacheseo_english.cache): failed to open stream: Operation not permitted in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

Warning: main(): Failed opening '/foxycardsuk/public_html/tmp/cache/seo_english.cacheseo_english.cache' for inclusion (include_path='.;c:\php4\pear') in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

 

 

is that what you meant ?

 

do i just need to uninstall and install the 2.0b version ?

 

thank you,

paulie

Share this post


Link to post
Share on other sites
ok thx,

 

when you say change path im asuming you mean to change the path of cache directiory in admin.

so i did that and now get these errors =

 

 

 

Warning: fopen(): open_basedir restriction in effect. File(/foxycardsuk/public_html/tmp/cache/seo_english.cacheseo_english.cache) is not within the allowed path(s): (d:\users) in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 159

 

Warning: fopen(/foxycardsuk/public_html/tmp/cache/seo_english.cacheseo_english.cache): failed to open stream: Operation not permitted in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 159

 

Warning: fwrite(): supplied argument is not a valid stream resource in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 160

 

Warning: fclose(): supplied argument is not a valid stream resource in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 161

 

Warning: main(): open_basedir restriction in effect. File(d:\/foxycardsuk/public_html/tmp/cache/seo_english.cacheseo_english.cache) is not within the allowed path(s): (d:\users) in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

Warning: main(/foxycardsuk/public_html/tmp/cache/seo_english.cacheseo_english.cache): failed to open stream: Operation not permitted in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

Warning: main(): Failed opening '/foxycardsuk/public_html/tmp/cache/seo_english.cacheseo_english.cache' for inclusion (include_path='.;c:\php4\pear') in d:\users\foxycardsuk\public_html\includes\seo_cache.php on line 164

 

 

 

is that what you meant ?

 

do i just need to uninstall and install the 2.0b version ?

 

thank you,

paulie

 

The key is ..

 

/foxycardsuk/public_html/tmp/cache/seo_english.cacheseo_english.cache

 

Which you have obviously input wrongly.

 

Yes uninstall and reinstall the newer version.

 

Also please PaulieGB don't post loads and loads of times in this thread as you are just making it impossible for others to find solutions .. do as much as you can .. collect the issues and error messages then just list them in a single post where possible.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hi guys,

I've just installed Ultimate SEO URLs v21e and am getting an 'Error 404 - Page not found' message

when I attempt any navigation. The URL changes ok, ie. testarea/mcilduff/nt1213-fox-net-p-114.html

 

My platform information is below

 

Apache 1.3.37 (Unix)

PHP 4.4.4

MySQL 4.1.22-standard

 

Any ideas?

 

thanks in advance

 

Tony

Share this post


Link to post
Share on other sites
Hi guys,

I've just installed Ultimate SEO URLs v21e and am getting an 'Error 404 - Page not found' message

when I attempt any navigation. The URL changes ok, ie. testarea/mcilduff/nt1213-fox-net-p-114.html

 

My platform information is below

 

Apache 1.3.37 (Unix)

PHP 4.4.4

MySQL 4.1.22-standard

 

Any ideas?

 

thanks in advance

 

Tony

 

.htaccess

 

RewriteBase /testarea/

Share this post


Link to post
Share on other sites
my url always like this

http://www.site.com/cartoons-c-3_13.html?o...c9acee032f87b2e

 

what's wrong with it?

 

SEO URL looks fine. If the osCsid is permanent then your configure settings are wrong but that is not a USU issue.

Share this post


Link to post
Share on other sites

the osCsid is permanent , i try the configure many times

that's my current settings. anything wrong?

Enable SEO URLs? true

Add cPath to product URLs? false

Add category parent to begining of URLs? false

Filter Short Words 2

Output W3C valid URLs (parameter string)? false

Enable SEO cache to save queries? true

Enable product cache? true

Enable categories cache? true

Enable manufacturers cache? true

Enable articles cache? true

Enable topics cache? true

Enable information cache? true

Enable automatic redirects? true

Choose URL Rewrite Type Rewrite

Enter special character conversions

Remove all non-alphanumeric characters? false

Reset SEO URLs Cache false

Enable SEO URLs?

Share this post


Link to post
Share on other sites

Having a weird sort of problem at the moment - I'm not sure where it's come from but this is the only contribution I've installed recently.

 

When I go to a manufacturer page it works fine and the URL is as follows (sid removed from the end for clarity):

 

http://www.asdfasdf.co.uk/catalog/index.php?manufacturers_id=48

 

However, when I click on the 'Next' button at the bottom of the page to see the next 20 results it goes back to the front end of the shop and the URL is as follows:

 

http://www.asdfasdf.co.uk/catalog/index.php?page=2&sort=2a&mName=patagonia

 

I've been trawling through the code but I can't seem to find where the problem is. Has anyone else experienced anything like this? I've had SEO URLs on for a while now but have only just noticed this little bug! The first thing that springs to mind for me is that the first page (which works) uses the manufacturer id whereas the next page (showing the home page) uses the manufacturer name, which in this case is patagonia.

 

Cheers!

Sam

Edited by High Sports

Share this post


Link to post
Share on other sites
Having a weird sort of problem at the moment - I'm not sure where it's come from but this is the only contribution I've installed recently.

 

When I go to a manufacturer page it works fine and the URL is as follows (sid removed from the end for clarity):

 

http://www.asdfasdf.co.uk/catalog/index.php?manufacturers_id=48

 

However, when I click on the 'Next' button at the bottom of the page to see the next 20 results it goes back to the front end of the shop and the URL is as follows:

 

http://www.asdfasdf.co.uk/catalog/index.php?page=2&sort=2a&mName=patagonia

 

I've been trawling through the code but I can't seem to find where the problem is. Has anyone else experienced anything like this? I've had SEO URLs on for a while now but have only just noticed this little bug! The first thing that springs to mind for me is that the first page (which works) uses the manufacturer id whereas the next page (showing the home page) uses the manufacturer name, which in this case is patagonia.

 

Cheers!

Sam

 

Firstly the url for manufacturers_id is wrong it should be an SEO URL

 

Secondly it looks like you are using version 2-2.2e which is buggy try using 2.1d original updated.

Share this post


Link to post
Share on other sites

i use the method ingwa recommands.

it works.

 

Issue with links. ingwa 27 May 2008

 

 

SEO URL looks fine. If the osCsid is permanent then your configure settings are wrong but that is not a USU issue.

Share this post


Link to post
Share on other sites
i use the method ingwa recommands.

it works.

 

Issue with links. ingwa 27 May 2008

 

Don't know what you are talking about. Get your config files right and the oscSid will disappear.

Share this post


Link to post
Share on other sites

I installed Ultimate SEO URL some time ago. It works & URLs are generated correctly. However, if I click a product review button, I get a 'page not found'.

 

Typical URL -

 

http://www.kickerfilms.com/twitchhoodrich-p-401.html

 

& when product review is clicked, it tries to proceed to -

 

http://www.kickerfilms.com/twitchhoodrich-pr-401.html%22

 

If I delete the %22 from the URL, the review page comes up correctly. Any ideas?

 

Thanks much!

Edited by Mike T

Share this post


Link to post
Share on other sites
I installed Ultimate SEO URL some time ago. It works & URLs are generated correctly. However, if I click a product review button, I get a 'page not found'.

 

Typical URL -

 

http://www.kickerfilms.com/twitchhoodrich-p-401.html

 

& when product review is clicked, it tries to proceed to -

 

http://www.kickerfilms.com/twitchhoodrich-pr-401.html%22

 

If I delete the %22 from the URL, the review page comes up correctly. Any ideas?

 

Thanks much!

 

Just saying ULTIMATE SEO URLS isn't enough .. the last version that (to my knowledge was worked on by the original author Chemo) was the solid version 2.1d which is now updated for php5 mysql5 and called 2.1d original updated, the rest have proved buggy.

Edited by FWR Media

Share this post


Link to post
Share on other sites
Just saying ULTIMATE SEO URLS isn't enough .. the last version that (to my knowledge was worked on by the original author Chemo) was the solid version 2.1d which is now updated for php5 mysql5 and called 2.1d original updated, the rest have proved buggy.

 

 

I'm using version 2.1 - by chemo. I went back & double checked my install/config. It works & the links display correctly in my status bar on rollover. So I'm thinking the added %22 may be coming from somewhere else.

Share this post


Link to post
Share on other sites
I'm using version 2.1 - by chemo. I went back & double checked my install/config. It works & the links display correctly in my status bar on rollover. So I'm thinking the added %22 may be coming from somewhere else.

2.1d original updated works without any problems, is this the one you are using?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×