Jump to content
Chemo

[Contribution] Ultimate SEO URLs - by Chemo

Recommended Posts

If you have troubles with the htaccess just skip it and use the cName option.  However, the rewrite is a more powerful and spider friendly option.

 

For those that are still following along after 12 pages I have just released the cache base class.  I'll be uploading a new version of Ultimate SEO URLs to work from the database cache and move away from filesystem cache.

 

The majority of support requests have been with filesystem path related problems and this will eliminate them completely. 

 

Bobby

 

Bobby does the rewrite code for the htacess file need to be inserted anywhere?

What about CHMOD?

 

It works great, but in rewrite mode I get the internal server error when I try to log in or checkout, if I take the rewrite code out of the htaccess then the server error disapears, but then I can use the rewrite option!

 

TIA

 

Scott

Share this post


Link to post
Share on other sites
For those that are still following along after 12 pages I have just released the cache base class.  I'll be uploading a new version of Ultimate SEO URLs to work from the database cache and move away from filesystem cache.

 

That's me! Will you post links to the relevant contributions in your sig, if nowhere on this forum? (I'm not sure about the forum rules about this.)

 

Thanks!

Susan

Share this post


Link to post
Share on other sites
I just installed this Contribution and all seemed to go well except for the application_top.php file. For some reason I am getting an "unexpected {" error for that file. It says the error is at line 435, but that doesn't seem right to me. Although this is a heavily modified file, could someone please tell me where the error is in this application_top.php code? We would really appreciate it. Thanks!!!!

 

"heavily modified" is an understatement. :D

 

This bit of code appears to be the culprit.

 // Fin Wishlist Checkboxes
      
    // performed by the 'buy now' button in product listings and review page
    case 'buy_now' :        if (isset($HTTP_GET_VARS['products_id'])) {
                           //Wishlist 2.0.1 Modification
                              if (tep_session_is_registered('customer_id')) { tep_db_query("delete from " . TABLE_WISHLIST . " WHERE customers_id=$customer_id AND products_id=$products_id"); }
                              // End Wishlist 2.0.1 Modification
                              (tep_has_product_attributes($HTTP_GET_VARS['products_id'])) {
                               tep_redirect(tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $HTTP_GET_VARS['products_id']));
                             } else {
                               $cart->add_cart($HTTP_GET_VARS['products_id'], $cart->get_quantity($HTTP_GET_VARS['products_id'])+1);
                             }
                           }

 

You are missing part of this mods code.

                               if

Right arter this line

                              // End Wishlist 2.0.1 Modification

 

I think. ;)

 

Paul

Share this post


Link to post
Share on other sites
Bobby does the rewrite code for the htacess file need to be inserted anywhere?

What about CHMOD?

 

It works great, but in rewrite mode I get the internal server error when I try to log in or checkout, if I take the rewrite code out of the htaccess then the server error disapears, but then I can use the rewrite option!

 

TIA

 

Scott

Usually, I place the rewrite code at the bottom. Make sure the base is set correctly...if your store is in your root is should be a single forward slash. If your store is in a directory then it must be like /directory/.

 

That's me! Will you post links to the relevant contributions in your sig, if nowhere on this forum? (I'm not sure about the forum rules about this.)

 

Thanks!

Susan

I've released the base class but am still tweaking it for use with the various contributions. I will most likely get a release out for Ultimate SEO URLs on Tuesday or shortly thereafter.

 

"heavily modified" is an understatement. :D

 

This bit of code appears to be the culprit.

...

I think. ;)

 

Paul

Paul,

 

I looked at that code for a solid 15 or 20 minutes and could not find it...you are the man! :)

 

Bobby

Share this post


Link to post
Share on other sites

Bobby,

 

Glad to be of assistance. ;)

 

I won't even say how long I looked at it, before it finally jumped out at me.

 

Paul

Share this post


Link to post
Share on other sites

Hello Bobby,

 

Your contribution is great and for me it will be the first big step in SEO for my shop but .....

 

I have a osCommerce 2.2 MS1 shop which is heavily modified with contributions. Can I get your contribution to work on my shop?

 

Regards,

 

Wico van den Berg

vaOz.com

Share this post


Link to post
Share on other sites
Hello Bobby,

 

Your contribution is great and for me it will be the first big step in SEO for my shop but .....

 

I have a osCommerce 2.2 MS1 shop which is heavily modified with contributions. Can I get your contribution to work on my shop?

 

Regards,

 

Wico van den Berg

vaOz.com

It *should* still work on an MS1 store...install it and if you get a missing function error just download MS2 and copy it from includes/functions/general.php

 

Bobby

Share this post


Link to post
Share on other sites

Hello

http://www.oasefilter.de/product_info.php?pName=eheim-ehfiaktiv-spezialaktivkohle-10-l&cName=filtermedien-eheim&osCsid=d30cb3166d48d7bdbd230dbb39886a6

 

www.oasefilter.de

 

Contributions from 23 Jan 2005 - Ultimate SEO URLs v1.4

 

I have the following problem: I implanted the contribution at the webpage, all Cache folders are busy/occupied, the "sio_german is saved in the cache-files. All SearchFriendlyEnergy url?s are on false (applicationTop.php and at/in Admin) I do not like to show the contribution and OSCSid in the URL, if anybody can help me --- pls. answer ASAP!!!

 

When cName is turned on

This must be removed!!!

&osCsid=d30cb3166d48d7bdbd230dbb39886a6

 

 

This is how it is supposed to look like!!!

 

http://www.oasefilter.de/product_info.php?...termedien-eheim

 

and here is "rewrite" in use/turned on

 

http://www.oasefilter.de/eheim-aktivkohlep...96e3b4a83646797

 

 

 

This must be removed!!!

osCsid=cc99db9febbcbccbc96e3b4a83646797

 

This is how it is supposed to look like!!!

http://www.oasefilter.de/eheim-aktivkohlep...lter-p-168.html

 

This is how it is supposed to look like!!!

Share this post


Link to post
Share on other sites

Check your cookie domain settings. It should be "..oasefilter.de" (notice the period in front) making sure there is no http://www or www. in front. Thist sets the cookie scope domain wide.

 

However, it is normal operation to set the osCsid on the first page of a customers visit. Then, if they have cookies turned on it will save the osCsid in the cookie and will not append it to the end of the URL. If the osCsid is persistent that indicates a problem with your cookie settings.

 

Bobby

Share this post


Link to post
Share on other sites
Check your cookie domain settings.  It should be "..oasefilter.de" (notice the period in front) making sure there is no http://www or www. in front.  Thist sets the cookie scope domain wide.

 

However, it is normal operation to set the osCsid on the first page of a customers visit.  Then, if they have cookies turned on it will save the osCsid in the cookie and will not append it to the end of the URL.  If the osCsid is persistent that indicates a problem with your cookie settings.

 

Bobby

 

 

Where do I find the "Cookie-settings"?

Share this post


Link to post
Share on other sites
Where do I find the "Cookie-settings"?

 

The configure in the catalog

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.oasefilter.de'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'http://www.oasefilter.de'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', false); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', '..oasefilter.de');
 define('HTTPS_COOKIE_DOMAIN', '..oasefilter.de');
 define('HTTP_COOKIE_PATH', '..oasefilter.de');
 define('HTTPS_COOKIE_PATH', '..oasefilter.de');
 define('DIR_WS_HTTP_CATALOG', '/');
 define('DIR_WS_HTTPS_CATALOG', '/');
 define('DIR_WS_IMAGES', 'images/');

 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', '/home/www/web2/html/oasefilter/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
 // BEGIN newdesk
define('DIR_WS_RSS', DIR_WS_INCLUDES . 'modules/newsdesk/rss/');
// END newsdesk
//USAGE - call the url /rss.php?box=categories or /rss.php?box=whats_new or /rss.php?box=newsdesk_latest.php

// define our database connection
 define('DB_SERVER', '******'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', '****');
 define('DB_SERVER_PASSWORD', '*****');
 define('DB_DATABASE', '**********');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

 

What ist my problem ????

Share this post


Link to post
Share on other sites

These:

define('HTTP_COOKIE_DOMAIN', '..oasefilter.de');
define('HTTPS_COOKIE_DOMAIN', '..oasefilter.de');
define('HTTP_COOKIE_PATH', '..oasefilter.de');
define('HTTPS_COOKIE_PATH', '..oasefilter.de');

should be like this:

define('HTTP_COOKIE_DOMAIN', '.oasefilter.de');
define('HTTPS_COOKIE_DOMAIN', '.oasefilter.de');
define('HTTP_COOKIE_PATH', '/');
define('HTTPS_COOKIE_PATH', '/');

Notice you had 2 periods in front of the domain and also the cookie path should a single forward slash (since you are in the root).

 

Bobby

Share this post


Link to post
Share on other sites

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.oasefilter.de'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'http://www.oasefilter.de'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', '.oasefilter.de');

define('HTTPS_COOKIE_DOMAIN', '.oasefilter.de');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

 

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/www/web2/html/oasefilter/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// BEGIN newdesk

define('DIR_WS_RSS', DIR_WS_INCLUDES . 'modules/newsdesk/rss/');

// END newsdesk

//USAGE - call the url /rss.php?box=categories or /rss.php?box=whats_new or /rss.php?box=newsdesk_latest.php

 

// define our database connection

http://www.oasefilter.de/product_info.php?pName=eheim-ehfikarbon-aktivkohle-mit-netzbeutel-20-l&cName=heizer-regelerheizer&osCsid=6982e8d4670ffa9d9975445b4a167e42

Share this post


Link to post
Share on other sites

Warning: tep_cache_categories_box(includes/boxes/categories.php): failed to open stream: No such file or directory in /home/www/web2/html/oasefilter/includes/functions/cache.php on line 105

 

Warning: tep_cache_categories_box(): Failed opening 'includes/boxes/categories.php' for inclusion (include_path='.') in /home/www/web2/html/oasefilter/includes/functions/cache.php on line 105

 

 

look to www.oasefilter.de

Thanks

Share this post


Link to post
Share on other sites
Warning: tep_cache_categories_box(includes/boxes/categories.php): failed to open stream: No such file or directory in /home/www/web2/html/oasefilter/includes/functions/cache.php on line 105

 

Warning: tep_cache_categories_box(): Failed opening 'includes/boxes/categories.php' for inclusion (include_path='.') in /home/www/web2/html/oasefilter/includes/functions/cache.php on line 105

look to www.oasefilter.de

Thanks

 

 

Hooo

 

I have the Cache of false at is running

 

look www.oasefilter.de

Thanks

Share this post


Link to post
Share on other sites

Hello all,

 

The contri works perfect except for the categories box which shows me after a product update in admin the following.

 

Warning: in_array(): Wrong datatype for second argument in /home/pc/public_html/catalog/includes/boxes/categories.php on line 41

 

Noticed also a small discussion in this thread about this warning but i still can't figure this out how to avoid such a warning in the category box.

 

somebody can help me out !

 

Tks in advance,

Chayenne

Share this post


Link to post
Share on other sites

I'm almost ready to release v2.0 which moves away completely from filesystem cache. It uses the database to cache and will not give that in_array error. I have released the osC - Advanced Cache Class which will be the back bone of all my contributions from here on out...so, hold on for a bit and install v2.0! It'll be worth it :)

 

Bobby

Share this post


Link to post
Share on other sites
I'm almost ready to release v2.0 which moves away completely from filesystem cache.  It uses the database to cache and will not give that in_array error.  I have released the osC - Advanced Cache Class which will be the back bone of all my contributions from here on out...so, hold on for a bit and install v2.0!  It'll be worth it :)

 

Bobby

 

Man, I am waiting. Patiently? :D

Share this post


Link to post
Share on other sites
Cathy,

 

First, nice site.

 

It looks like a configure.php problem to me...make sure your settings look like this:

 

 ?define('HTTP_COOKIE_DOMAIN', '.pawzypet.com');
?define('HTTPS_COOKIE_DOMAIN', '.pawzypet.com');
?define('HTTP_COOKIE_PATH', '/');
?define('HTTPS_COOKIE_PATH', '/');

 

Notice there is a period before the domain name and does not include the "www" or http: protocol.  That is the most common reason why they have "sticky SIDs".

 

Bobby

 

Hi Bobby,

 

Thanks so much for your help, it works fine now

Share this post


Link to post
Share on other sites
Usually, I place the rewrite code at the bottom. Make sure the base is set correctly...if your store is in your root is should be a single forward slash. If your store is in a directory then it must be like /directory/.

 

Bobby I checked the base and it looks ok, is there anything else I can try?

Share this post


Link to post
Share on other sites
Bobby I checked the base and it looks ok, is there anything else I can try?

 

Scott,

 

Maybe if you posted the contents here. Might be able to figure it out. Also, post a link. :)

 

Paul

Share this post


Link to post
Share on other sites
Scott,

 

Maybe if you posted the contents here. Might be able to figure it out. Also, post a link. :)

 

Paul

 

Paul not sure what info to post?

 

I installed the contribution and it works great but I get a server error meesage when I try to go to my account or checkout so I am unable checkout when the rewrite code is in the htaccess file.

If I remove the rewrite code from the htaccess file the server error goes away!!

I have checked and double checked the code, my htaceess file is in my catalog folder so the base is /catalog/

Doesn't seem to matter where I put the rewrite code in the htaccess file I always get the server error message at checkout!

I chaged the CHMOD to 777 but it didnt make any difference :(

Share this post


Link to post
Share on other sites
Paul not sure what info to post?

 

I installed the contribution and it works great but I get a server error meesage when I try to go to my account or checkout so I am unable checkout when the rewrite code is in the htaccess file.

If I remove the rewrite code from the htaccess file the server error goes away!!

I have checked and double checked the code, my htaceess file is in my catalog folder so the base is /catalog/

Doesn't seem to matter where I put the rewrite code in the htaccess file I always get the server error message at checkout!

I chaged the CHMOD to 777 but it didnt make any difference :(

...and your .htaccess file is located in your catalog directory (and NOT in your document root)??

 

Excellent, outstanding contribution.

 

Exactly what I was looking for.

 

Many thanks,

 

Fish

Thank you...glad to see it meets your needs and expectations.

 

Bobby

Share this post


Link to post
Share on other sites

Chemo,

Quick question for you. I asked something like this before but after running a few spider tools on my system, it is caching all links with the long if not longer original OSC strings. It isn't until someone actually clicks on the first link that they get the proper string with html endings. The total first page is still using the old strings while it's being crawled...am I correct? If so, then that negates all the positive effects I thunk it was doing. I also noticed my rank on search engines has changes slightly to a lesser side and IS caching the super long OSC strings.

 

Suggestions?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×