Jump to content
Alpha Ray

UK-Based: Default osCommerce Installation.

Recommended Posts

Hi Schneckster

 

I'm Glad you got this working.

It would be great if you could post the solution as a contribution Update.

 

Ken

Share this post


Link to post
Share on other sites

i dont know if this has been asked before, but i have my shop already set up using the US OSC.

Is there a way to update it to the UK one without losing my products, customers etc?

I have also installed some other contributions....

Share this post


Link to post
Share on other sites
i dont know if this has been asked before, but i have my shop already set up using the US OSC.

Is there a way to update it to the UK one without losing my products, customers etc?

I have also installed some other contributions....

If you are posting here, it is assumed that you found the contribution. Since it was written for an older osc, you do not overwrite files. You use the contribution as a guide for what you want to do.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Hi Schneckster

 

I'm Glad you got this working.

It would be great if you could post the solution as a contribution Update.

 

Ken

Just pm him for the sql file. It is no good doing it as a contribution update because of all of the other changes.

Edited by Coopco

The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

There is a Couty dropdown menu described in this contribution (shown in the image previews).

 

How can I implement that into my signing up process?

Share this post


Link to post
Share on other sites

My bad. Realise it's only shown if there is an error in the input of it... WHICH IF SUPERB! Great Contribution, but try to do this BEFORE you run the install.

 

Was hard work when established already... Although do-able :)

Share this post


Link to post
Share on other sites
Hi Guys

 

Right im using the uk contrib but have noticed several countrys missing:

Azores

Balearic isles

Corsica

Guernsey

Jersey

Maderia

Sardinia

Sicily

and this is just with a quick look through.

 

Im in the process of writing a contrib for Parcelforce Euro 48 and International standard shipping rates so realy could do with pointing in the direction of whereever you managed to find a list of country codes.

Im a good way through this so the sooner i can get this info the sooner it will be available. Taken a while as Parcel Force breaks down into TEN zones :(

 

Cheers guys

 

You can get the up-to-date countries list from the ISO site:

http://www.iso.org/iso/country_codes/iso_3...de_elements.htm

 

I've mentioned to Harald several times by email that the current country list in osC is out of date but no-one seems to be bothered to update it.

Luckily, it's easy to update the countries table yourself by just adding the missing countries from the current ISO list.


* * * * * * * * * * * * * * * * * * * * *

Porpoises are most happy when wet!

\ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _ \ _

Share this post


Link to post
Share on other sites

i hope i am in the right place here for this Question:

 

i have done most or at least i think i have done all the mods manualy for the UK based OSC 2.2 MS 2

 

the date format is right

the address layout is right

the currency is right

 

everything is working fine, the only thing that does not seem to be working is the Added UK Zones

 

the SQL file has been uploaded to my host using phpmyadmin and under zones with an SQL query the UK Zones are there, but:

 

under Admin or within the shop these zones can not be found?

 

can anyone help please!!!

 

O and by the way Happy New Year

 

:thumbsup:

Share this post


Link to post
Share on other sites

all problems sorted, i had a test database and loaded it into there insted of the active one, sorry for my stupid Question

Share this post


Link to post
Share on other sites

Hi Guys.

 

Having a problem with installing this, Not sure if the problems with me.. The server or the installation so ill just walk you through what i've done and whats happening.

 

To install it i removed the US version of OSC completely (Deleted the files, deleted database etc - Wasn't a problem for me because i was only testing OSC to see if its suitable.)

 

Then i copied the UK /catalog/ folder over into a fresh unzipped OSC folder on my desktop and let it overwrite the US files with the UK files.

 

Uploaded all the files to the webserver.

 

CHMOD'd everything.

 

Ran the installer. It worked fine.

 

I can view and use the catalog normally. Create user accounts etc. However, when i try to go to the administration panel i get the error:

 

1146 - Table 'kits_ajosc.administrators' doesn't exist

 

select id from administrators limit 1

 

[TEP STOP]

 

I've checked and that table indeed does not exist. Is this an error in the installation file, causing it not to create the administration details?

 

Any ideas would be greatly appreciated.

 

edit:

 

Also, just noticed there is a mySQL error message at the end of the installer.

 

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in ***/osc/catalog/install/includes/functions/database.php on line 39

 

Line 39:

function osc_db_num_rows($db_query) {
Edited by Mr.AJ

Share this post


Link to post
Share on other sites

Think i've fixed it now.

 

DROP TABLE IF EXISTS administrators;

CREATE TABLE administrators (

id int NOT NULL auto_increment,

user_name varchar(32) binary NOT NULL,

user_password varchar(40) NOT NULL,

PRIMARY KEY (id)

);

 

 

Manually executed this SQL and then created admin account. administrators table is missing from the SQL commands i downloaded... all seems to be working fine now.

Share this post


Link to post
Share on other sites

Thanks Mr.AJ

I had similar problem & started searching old SQL file for format of administrators table but than I found your post.

Manually ran the sql statement & it's working noiw (well, that part is...!)

cheers

Robert

Share this post


Link to post
Share on other sites

i have been converting dates and adress formats to UK format and all works well in catalog .. my problem is in admin when i look at the address format on orders it always has the post code before the county/state

 

now that has not been a problem until i tried to print address labels where of course the format is wrong for the uk

 

anybody know which files relate to the address format in admin ??

 

thanks in advance

Share this post


Link to post
Share on other sites
i have been converting dates and adress formats to UK format and all works well in catalog .. my problem is in admin when i look at the address format on orders it always has the post code before the county/state

 

now that has not been a problem until i tried to print address labels where of course the format is wrong for the uk

 

anybody know which files relate to the address format in admin ??

 

thanks in advance

There is only one, but it would not give you your problem. Maybe you missed an edit in the catalog side.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
There is only one, but it would not give you your problem. Maybe you missed an edit in the catalog side.

 

i have basicly followed the instruction on the first page of this thread to manually change the date format in catalog and admin and the address format in catalog

 

files edited were

 

catalog/includes/languages/english.php

catalog/admin/includes/languages/english.php

catalog/includes/modules/address_book_details.php

catalog/create_account.php

 

as i say it all seems fine and all is working except the post code still comes before the county in the address in admin

 

any other files i should be looking at ?

Share this post


Link to post
Share on other sites

The address format table holds the way to display addresses, first page does not mention addresses in admin

 

This is address format 5

 

$firstname $lastname$cr$streets$cr$postcode $city$cr$country

 

Don't know if this changes layout in admin area though


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
The address format table holds the way to display addresses, first page does not mention addresses in admin

 

This is address format 5

 

$firstname $lastname$cr$streets$cr$postcode $city$cr$country

 

Don't know if this changes layout in admin area though

 

i guess from the look of that code it is in the mysql database .. not sure im ready to tackle fiddling in there quite yet ..hehe

Share this post


Link to post
Share on other sites
i guess from the look of that code it is in the mysql database .. not sure im ready to tackle fiddling in there quite yet ..hehe

Yes, it is mysql. If you have a look at the contribution address format change, it wil tell you how to do it. Pity that osc can't do it automatically, based on on the shipping address, but that is another thread.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Yes, it is mysql. If you have a look at the contribution address format change, it wil tell you how to do it. Pity that osc can't do it automatically, based on on the shipping address, but that is another thread.

 

awsome thanks ever so .. that worked perfectly

Share this post


Link to post
Share on other sites

hi all,

 

Im looking to uk my site, I feel confident about changing the php side of things. My only concern is the sql file..

 

What changes to the sql file included in the contribution do i need to make to ensure that it works smoothly..

 

Thanks in advance

Share this post


Link to post
Share on other sites

I've installed this.

 

I had a real problem when I installed the sql file - I've now repaired my db. I've tried again but do not get Address line 2 or a drop down box for county - in fact do not get county at all. Could you tell me how I get Address line2 and county please?

 

I also want to have UK VAT but I'm not sure how to do this.

 

I'm guessing with the sql file I should have just installed parts but there is no installation guide so I'm really confused, I could really do with some help.

 

Thanks

Share this post


Link to post
Share on other sites
Yes, it is mysql. If you have a look at the contribution address format change, it wil tell you how to do it. Pity that osc can't do it automatically, based on on the shipping address, but that is another thread.

I tried this but still no joy. I have two problems:

 

1) In Admin I have no address line 2, and the county box is not drop down

2) From the customer side, Address Line 2 and County entries are not storing in the DB this means I can't configure postage either.

 

Is there anyone that can help, I've tried everything I can think of.

Share this post


Link to post
Share on other sites

I've installed this contrib with the latest version of OsCommerce and had the 1146 database error, but thanks to the MySQL code above I've managed to fix it. On the account.php page I get the following error:

 

1054 - Unknown column 's.public_flag' in 'where clause'

 

select count(*) as total from orders o, orders_status s where o.customers_id = '2' and o.orders_status = s.orders_status_id and s.language_id = '1' and s.public_flag = '1'

 

[TEP STOP]

 

This happens I log in as a customer and go to "My Account", so customers won't be able to view their account details.

 

Any help very much appreciated?

Share this post


Link to post
Share on other sites

I am trying to install a UK shop for the first time. I have downloaded the UK contibution and uploaded the files to the specified location. the installation goes smoothly but at the end i can not log onto the admin. I am getting error:

 

1146 - Table 'gutsamhuri.administrators' doesn't exist

 

select id from administrators limit 1

 

[TEP STOP]

My understading was that if I use the UK shop contributions then I would require no further configuration to get he shop working again

 

 

What could I be doing wrong here?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×