Jump to content
Alpha Ray

UK-Based: Default osCommerce Installation.

Recommended Posts

Hi,

 

I'm trying to use the contib but have a problem with Lodon as a state, I live in Twickenham Middlesex, Middlesex isn't listed as a state so I used London. However when I continue I get asked to select a county from the pull down, I select London and go round in the same loop?

Any help would be greatlt appreciated,

 

Regards,

 

Martin

 

 

Just add it to the list of zones in admin.

Apologies if you've already figured that out but I only just found this thread which, I have to say has been invaluble!!

Share this post


Link to post
Share on other sites

Hi there,

Not sure how I should install this. OSC is provided by my host, and just gets installed onto my server, so I don't get the chance to see or overwrite any of the installation files. Can somebody please tell me what to do.

Regards,

Claire

Share this post


Link to post
Share on other sites

great contribution......

 

however, i have copied all the files on to a fresh install of oscommerce and added the sql and updated the database to make it UK1/US2 - but have the following problem:-

 

i) create_account.php

 

when registering as a new customer, i select United Kingdom and 'continue', it takes me back to the same page asking to select 'county/state', but when i select London it just keeps referring me back to the same damn page!!! I tink all the other counties work but not London

 

please advise me on what to do.. thanks


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Same problem for me too..

 

When we choose LONDON, it just does not allow further

Share this post


Link to post
Share on other sites

Great Contrib.

 

One problem, now that I have installed the contrib, the VAT is no longer displayed with the price. I haven't changed any of the files and am running with the database data contributed. Any ideas why this should be?

 

 

ken.

Share this post


Link to post
Share on other sites

Ah the stupidity of age :'(

 

After racking my tiny little brain trying to find out what was wrong I eventually found it - the product wasn't in a taxable group so there would be no VAT to show up!

 

Creeps quietly out of this topic now....................

 

Ken.

Share this post


Link to post
Share on other sites

I also have the problem when a customer chooses London for both the city and county it goes in a loop. Has anyone managed to fix this yet?

Share this post


Link to post
Share on other sites

Whilst waiting for a programmer to come up with a solution, I came up with this:

 

I changed the name of 'Londonderry' in the zone list to 'Londoonderry' and everything works fine.

 

To be honest, I don't expect many visitors from there, and only a small percentage of those would notice the spelling mistake.

 

The reason I added an extra 'o' rather than changing letters around is to keep the same alphabetical listing... no other reason ;)

 

Other things I have found in the zone list:

Duplicated "Jersey" (I know I was drunk when I visited the island, but I'm sure there is only 1!) :P

Duplicated "Gwynedd" (I hope there is only 1!) :o

Lower case "west" in "North West Highlands"

 

Hope this helps

Steve

Share this post


Link to post
Share on other sites

excellent stuff from the brits!

 

shame i didn't come across this about 4 weeks ago, when i got the usa version. but i've changed bits and bobs and am quite happy with the way my site is.

 

i might change a few bits to suggestions in this forum, but i am sure customers will be ok with it.

 

keep it up!

Share this post


Link to post
Share on other sites

Hi Everyone,

 

Just spend 2 days trying to sort my download out & then find out that Fantastico does it all for you 20 seconds... Nice piece of info. No one told me...

 

I've installed the osCommerce & it looks just what I need - then I notice that it's all in US... I came across this thread & it looks just what I need -

 

Installation:

Replace the US based installation files with the UK based files included in this package.

Install osCommerce in the usual manner.

 

Sorry to sound stupid - But where are the UK installation files are they all sorted or are they in the pipe line... It would be nice to set the shop up with all the stuff right from the start... Any help.. thanks in advance... :'(

Edited by igarden

Share this post


Link to post
Share on other sites
Hi Everyone,

 

Just spend 2 days trying to sort my download out & then find out that Fantastico does it all for you 20 seconds... Nice piece of info. No one told me...

 

I've installed the osCommerce & it looks just what I need - then I notice that it's all in US... I came across this thread & it looks just what I need -

 

Installation:

Replace the US based installation files with the UK based files included in this package.

Install osCommerce in the usual manner.

 

Sorry to sound stupid - But where are the UK installation files are they all sorted or are they in the pipe line... It would be nice to set the shop up with all the stuff right from the start... Any help.. thanks in advance... :'(

 

Theyre in the contributions area and you will have to start fresh (ie not use the Fantastico install) if you dont want a million and one problems.

Share this post


Link to post
Share on other sites

Hi all,

 

I have tried to install this contribution on a fresh version and it works a treat!!

 

BUT!!!

 

I have only one database and require multiple shops so I have used the Table prefix contibution together with the uk oscommerce contribution and I have problems on install.

 

Could anyone please advise of how to get both contirbutuions working together.

 

Cheers!

Share this post


Link to post
Share on other sites

=============================================

'LONDON' bug (looping) FIX

=============================================

 

This is the fix I have put in place. USE AT YOUR OWN RISK. I take no responsibility for the consequences.

 

===================

Start Mod

===================

 

1. Open

catalog/address_book_process.php

.

2. Find near line 105 the following:

 

$zone_query = tep_db_query("select distinct zone_id from " . TABLE_ZONES . " where zone_country_id = '" . (int)$country . "' and (zone_name like '" . tep_db_input($state) . "%' or zone_code like '%" . tep_db_input($state) . "%')");

 

Replace with:

 

$zone_query = tep_db_query("select distinct zone_id from " . TABLE_ZONES . " where zone_country_id = '" . (int)$country . "' and (zone_name='" . tep_db_input($state) . "' or zone_code like '%" . tep_db_input($state) . "%')");

 

===================

End Mod

===================

 

This changes the following. Instead of searching for a match in the database similar to the string the user has entered in the 'County/State' box, it searches for an exact match (case insensitive).

 

This does mean that if a user mistypes their state (e.g. 'Londo' instead of 'London') they will have to manually select it from the drop down box.

Share this post


Link to post
Share on other sites

I am too dumb to work out how to edit my post above so I added this one.

 

=============================================

'LONDON' bug (looping) FIX - Part 2

=============================================

 

3. Open catalog/create_account.php

 

4. Find the following around 135:

 

$zone_query = tep_db_query("select distinct zone_id from " . TABLE_ZONES . " where zone_country_id = '" . (int)$country . "' and (zone_name like '" . tep_db_input($state) . "%' or zone_code like '%" . tep_db_input($state) . "%')");

 

and replace with:

 

$zone_query = tep_db_query("select distinct zone_id from " . TABLE_ZONES . " where zone_country_id = '" . (int)$country . "' and (zone_name ='" . tep_db_input($state) . "' or zone_code like '%" . tep_db_input($state) . "%')");

Share this post


Link to post
Share on other sites

this is working great

id like to put the post code on a new line when the address is viewed. can this be done?

 

it looks like this at the minute

first + last name

street address 1

street address 2

city, county/state, post code

country

 

id like it like this in both the address the customers see and in the admin section on the invoice and the packing slip

 

first + last name

street address 1

street address 2

city, county/state

post code

country

 

can this be done easily? it sound like an easy mod but im not sure how to do it.

 

thanks

Share this post


Link to post
Share on other sites

Hi can anyone advise as to why the counties drop down does not appear on the create account page and just allows the customer to manually enter their county - which sometimes they don't and then it defaults to 'Aberdeenshire'?

 

However it does appear as a dropdown when they go into view/change their account details.

 

Also how would i update the counties as i have London missing?

 

Thank you

 

Steve

 

My Webpage


Hope it helps...

PC Planet

Share this post


Link to post
Share on other sites

Woohooo! Think I am done!

 

First found this contrib as a fresh install, which worried me as I have products, customers and orders all stored. The SQL file had me going and I was ready to pick through it line by line - but a quick read of this thread and I am up and running with full UK formatting and all orignial data in tact! Looks great - thanks for all the coding, tutorials and help here!

 

My turn to give a little (well, I did say little!) back!

 

this is working great

id like to put the post code on a new line when the address is viewed. can this be done?

 

Yup - it can and is easy - when you know what you are looking for. I did it with a table edit from phpMyAdmin - hope you have access to this.

 

Choose 'shop_database' -> 'address_format' -> Browse

 

Edit the relevant field (#2 for me, as I had already applied the country fix above so UK address used Field #2)

 

Input the below string against 'address_format' in the table:

 

$firstname $lastname$cr$streets$cr$city, $state$cr$postcode$cr$country

 

Note : You can add spaces and commas at will. The '$cr' gives your required line return in the formatting.

 

Job's a good 'un! ;)

Edited by darkside

Share this post


Link to post
Share on other sites
excellent stuff from the brits!

 

shame i didn't come across this about 4 weeks ago, when i got the usa version. but i've changed bits and bobs and am quite happy with the way my site is.

 

i might change a few bits to suggestions in this forum, but i am sure customers will be ok with it.

 

keep it up!

 

Same problem for me. Thanks Sandbag for the fix. I am testing now.

Edited by allcam

Share this post


Link to post
Share on other sites
I have tested your fix but Sorry it does not work!

 

The best way to get around is to go into your MySQL with phpmyadmin and go to Zones and edit London to Greater London. I tested that and it works.

 

HTH

 

Giovanna

Share this post


Link to post
Share on other sites
I have tested your fix but Sorry it does not work!

 

Oh. That's odd. Maybe my version is slightly different. Has anyone used my fix successfully apart from me? (:blush:) Changing London to Greater London sounds like an easier option.

Share this post


Link to post
Share on other sites
Oh. That's odd. Maybe my version is slightly different. Has anyone used my fix successfully apart from me? (:blush:) Changing London to Greater London sounds like an easier option.

Yes that 's a great idea, thanks

Share this post


Link to post
Share on other sites
Yes that 's a great idea, thanks

Yes your fix does works on a fresh installation of osCommerce 2MS2, so it must be some of the other contributions made the difference. Sorry for the rush.

Share this post


Link to post
Share on other sites

I'd just like to say thanks to all (if you are still reading etc!) of the people who posted fixes and things, and indeed to Ray the contributor - everyone's been an immense help and I've got a fine UK based shop running - all I have to do now is mess around with products... :D

 

I like many others started off with the US version and was distressed to realise how much work was needed to change everything!

 

Again a massive thank you to everyone :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×