Jump to content
Sign in to follow this  
cyberbizco

2checkout v2 on OSC 2.2

Recommended Posts

Even if you change in the 2Checkout LOOK & FEEL and make both URL go to:

www.yourdomain.com/catalog/checkout_process.php

 

then it will STILL work.

 

So I guess no need to make it go to pm2checkout_process.php and THEN to checkout_process.php

 

It worked with me

 

Yes that method works as long as Direct Return is set to No, but then they have to click the 'Finalize Order' button. If it is set to Yes then the customer will not be returned to the site.

 

I prefer setting Direct Return to Yes and directing to pm2checkout_process.php since the customer does not have to click anything to be redirected.

Share this post


Link to post
Share on other sites

True Alex, I never thought of that ....

 

Maybe I will change it to YES also and make it go to pm2checkout ..

Share this post


Link to post
Share on other sites

Sooo to recap everything.....doing this:

 

 define('HTTP_COOKIE_PATH', 'cookies/');
define('HTTPS_COOKIE_PATH', 'cookies/');

 

Changed to

 

 define('HTTP_COOKIE_PATH', '/');
define('HTTPS_COOKIE_PATH', '/');

 

Will fix this:

 

We attempted to create the following product but couldn't find all the

required paramters.

 

The following paramters are required for product creation:

c_prod

c_name

c_price

c_description

 

For this product: c_prod_0 = Tanic 830 2s

We did NOT receive a name, it should have been sent as c_name_0

We did NOT receive a description, it should have been sent as c_description_0

We did NOT receive a price, it should have been sent as c_price_0

 

As well as fix the issue of products being sent to 2checkout and with with the simple cookie fix, we'll have the items showing in the cart, and do away with that pesky email.

 

Geof.

Edited by Morb

Share this post


Link to post
Share on other sites

Actually the email was due to ANOTHER typo I made in v2.0b, which has been fixed in today's version. Sorry! I was operating on 3 hours sleep yesterday!

Share this post


Link to post
Share on other sites
Sooo to recap everything.....doing this:

 

 define('HTTP_COOKIE_PATH', 'cookies/');
define('HTTPS_COOKIE_PATH', 'cookies/');

 

Changed  to

 

 define('HTTP_COOKIE_PATH', '/');
define('HTTPS_COOKIE_PATH', '/');

 

Will fix this:

As well as fix the issue of products being sent to 2checkout and with with the simple cookie fix, we'll have the items showing in the cart, and do away with that pesky email.

 

Geof.

 

oh, CRIMINY...LOL....no problems..will download that tonight and get it running. So, just getting rid of cookies in that cookie path will get rid of that annoying warning then....

 

Geof.

Share this post


Link to post
Share on other sites
I find this work on my one:

 

IN File:                2pmcheckout.php

 

For TEST MOde -

 

-------cut-------

 

Live Transaction Mode:

 

$process_button_string = tep_draw_hidden_field('sid', MODULE_PAYMENT_2CHECKOUT_LOGIN) .

tep_draw_hidden_field('total', number_format($cOrderTotal, 2, '.', '')) .

tep_draw_hidden_field('cart_order_id', date('YmdHis')) .

tep_draw_hidden_field('c_prod', '1') .

tep_draw_hidden_field('id_type', '2') .

tep_draw_hidden_field('x_receipt_link_url', tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL')) .

tep_draw_hidden_field('card_holder_name', $order->customer['firstname'] . ' ' . $order->customer['lastname'] ) .

tep_draw_hidden_field('street_address', $order->customer['street_address']) .

tep_draw_hidden_field('city', $order->customer['city']) .

tep_draw_hidden_field('state', $order->customer['state']) .

tep_draw_hidden_field('zip', $order->customer['postcode']) .

tep_draw_hidden_field('country', $order->customer['country']['title']) .

tep_draw_hidden_field('email', $order->customer['email_address']) .

tep_draw_hidden_field('phone', $order->customer['telephone']) .

tep_draw_hidden_field('ship_name', $order->delivery['firstname'] . ' ' . $order->delivery['lastname']) .

tep_draw_hidden_field('ship_street_address', $order->delivery['street_address']) .

tep_draw_hidden_field('ship_city', $order->delivery['city']) .

tep_draw_hidden_field('ship_state', $order->delivery['state']) .

tep_draw_hidden_field('ship_zip', $order->delivery['postcode']) .

tep_draw_hidden_field('ship_country', $order->delivery['country']['title']) .

tep_draw_hidden_field('x_receipt_link_url', tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL')) .

tep_draw_hidden_field('email_merchant', ((MODULE_PAYMENT_2CHECKOUT_EMAIL_MERCHANT == 'True') ? 'TRUE' : 'FALSE'));

did work ok - and i hope it will be of help - and I wish all Oscommerce to be safe and well - and get out of the 2CO  version 2 hell as soon as possible !

 

marc

 

I successfully ran a test transaction with 2CO V2 from my site which is a snapshot from Sep 2002, though, without the required c_prod and id_type parameters. My pm2checkout.php code is below.

 

Why do you have (c_prod, '1') and ('id_type', '2')? The '2' for id_type indicates a system-assigned (i.e. 2CO-assigned) product ID. Isn't that for those who have their products hosted at 2CO? And the '1' for c_prod indicates you are just passing a number 1 through for the product id. Isn't c_prod supposed to match your product id as uploaded in the 2CO database?

 

Seems that us OSC users would have to code c_prod to actually pass our product id in the string and we'd want to set the id_type as '1'.

 

Am I correct, or missing something?

 

Thanks,

 

Mark

 

      $process_button_string = tep_draw_hidden_field('x_login', MODULE_PAYMENT_2CHECKOUT_LOGIN) .
                              tep_draw_hidden_field('x_amount', number_format($order->info['total'], 2)) .
                              tep_draw_hidden_field('x_invoice_num', date('YmdHis')) .
                              tep_draw_hidden_field('demo', Y) .
                              //tep_draw_hidden_field('x_card_num', $CardNumber) .
                              //tep_draw_hidden_field('x_exp_date', $this->cc_expires_month . $this->cc_expires_year) .
                              tep_draw_hidden_field('x_first_name', $order->customer['firstname']) .
                              tep_draw_hidden_field('x_last_name', $order->customer['lastname']) .
                              tep_draw_hidden_field('x_address', $order->customer['street_address']) .
                              tep_draw_hidden_field('x_city', $order->customer['city']) .
                              tep_draw_hidden_field('x_state', $order->customer['state']) .
                              tep_draw_hidden_field('x_zip', $order->customer['postcode']) .
                              tep_draw_hidden_field('x_country', $order->customer['country']['title']) .
                              tep_draw_hidden_field('x_email', $order->customer['email_address']) .
                              tep_draw_hidden_field('x_phone', $order->customer['telephone']) .
                              tep_draw_hidden_field('x_ship_to_first_name', $order->delivery['firstname']) .
                              tep_draw_hidden_field('x_ship_to_last_name', $order->delivery['lastname']) .
                              tep_draw_hidden_field('x_ship_to_address', $order->delivery['street_address']) .
                              tep_draw_hidden_field('x_ship_to_city', $order->delivery['city']) .
                              tep_draw_hidden_field('x_ship_to_state', $order->delivery['state']) .
                              tep_draw_hidden_field('x_ship_to_zip', $order->delivery['postcode']) .
                              tep_draw_hidden_field('x_ship_to_country', $order->delivery['country']['title']) .
                              tep_draw_hidden_field('x_receipt_link_url', tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'NONSSL')) .
                              tep_draw_hidden_field('x_email_merchant', MODULE_PAYMENT_2CHECKOUT_EMAIL_MERCHANT);

     return $process_button_string;

Share this post


Link to post
Share on other sites

Hello, I followed the instructions and was getting the same message about enabling cookies, however now when I add a product oscommerce shows me a page where it says the cart is empty. My store is at www.deguate.com/shopping and this is what I have in my configure.php file if someone can help me please!

 

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://deguate.com/shopping');

define('HTTPS_SERVER', 'https://deguate.com/shopping');

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.deguate.com');

define('HTTPS_COOKIE_DOMAIN', 'www.deguate.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', '/shopping/images/');

define('DIR_WS_ICONS', '/shopping/icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

Share this post


Link to post
Share on other sites

Forgot to mention: I was able to place a demo purchase with Force Cookie Usage set to FALSE but since everybody says it has to be turned to TRUE I guess there is a problem somewhere in my store!

Share this post


Link to post
Share on other sites
Forgot to mention: I was able to place a demo purchase with Force Cookie Usage set to FALSE but since everybody says it has to be turned to TRUE I guess there is a problem somewhere in my store!

 

since you have an SSL store you need to define('HTTPS_COOKIE_PATH', '/');

Share this post


Link to post
Share on other sites

Hello arm1tage, thx for the reply, I made the change you suggested but I still get the same error. I have tried turning ssl to TRUE and FALSE but I get the same results with both. The only way it adds a product to the cart is when I change Force Cookie Usage to FALSE!!

Share this post


Link to post
Share on other sites
Hello arm1tage, thx for the reply, I made the change you suggested but I still get the same error. I have tried turning ssl to TRUE and FALSE but I get the same results with both. The only way it adds a product to the cart is when I change Force Cookie Usage to FALSE!!

 

try changing

define('HTTP_COOKIE_DOMAIN', 'www.deguate.com');
define('HTTPS_COOKIE_DOMAIN', 'www.deguate.com');

 

to

define('HTTP_COOKIE_DOMAIN', '.deguate.com');
define('HTTPS_COOKIE_DOMAIN', '.deguate.com');

 

since your URL does not have the www prefix.

Share this post


Link to post
Share on other sites
Sooo to recap everything.....doing this:

 

 define('HTTP_COOKIE_PATH', 'cookies/');
define('HTTPS_COOKIE_PATH', 'cookies/');

 

Changed  to

 

 define('HTTP_COOKIE_PATH', '/');
define('HTTPS_COOKIE_PATH', '/');

 

Will fix this:

As well as fix the issue of products being sent to 2checkout and with with the simple cookie fix, we'll have the items showing in the cart, and do away with that pesky email.

 

Geof.

 

If you have your store installed in a sub-directory, such as 'store' (as in, http://www.domain.com/store/), would it still be PATH','/'?

 

The default for mine is PATH','/store/' -- seems like if I drop that, it'd be referring to the root directory OUTSIDE of the store directory... wouldn't it?

 

Just guessing, and trying to figure out why I can get this work when others have. Any help is appreciated.

Share this post


Link to post
Share on other sites

http://www.oscommerce.com/community/contributions,904 :rolleyes:

 

It should be noted that 2CO is not a payment processor. They are a retailer / reseller.

 

I am glad that everyone has worked things out, but also remember that OSC is third party software to 2CO and the instructions that were provided before we done out of generosity as an attempt to help everyone. They did not have to be that detailed, but at least they were able to point you in the right direction. If you have better suggestions, you could email feedback@2co.com with your suggestions on how they could improve their response because it is provided because 2CO was told by numerous vendors that those instructions worked. That doesn't mean that they can not be improved to help even more vendors.

 

Here is an updated set of those instructions after 2CO was informed of the new module.

 

1.) First and foremost, you must have the cart itself installed properly. There is a text file that is distributed with the cart, as well as the module mentioned in step 3 below, and this file will explain how to install and set up the cart and module. Please first verify that the installation of the cart and 2CO payment module are correct.

 

2.) You must be using OSCommerce 2.2 Milestone 2 or later. If you are using any other version, it will not work and you will be unable to use our services. If in doubt as to the version currently running on your cart, install the latest version.

 

3.) There is a module that has been developed for OSCommerce that is needed to work with the V2 system. This module is absolutely necessary to be compliant with our V2 system. You may find this module at the following URL :

 

>> http://www.oscommerce.com/community/contributions,904

 

4.) It is a common problem to have the sales work in the 2CO account but not the OSCommerce cart after a sale. This is because there has to a be return URL set up in your V2 account to tell the 2CO system were to send the sale information after it is placed. OSCommerce needs this information to correctly process and finish the sale on your end. This URL can be set up on the Look & Feel setting page of your 2CO V2 account. You will find this link under the Helpful Links section of your account homepage.

 

On the Look & Feel Page in your account, the URL below must be in both the Pending and Approved URL boxes. If you installed OSC to a directory other than the default directory, you will need to use that directory structure here. Be sure to replace "www.your-domain.com" with your actual domain name.

 

>> http://www.your-domain.com/catalog/pm2checkout_process.php

 

5.) It is also strongly recommended that you set the Direct Return option on the Look and Feel page to Yes. This will help ensure that the customer is returned to the OSCommerce shopping cart after the sale.

 

There is also a known issue that OSCommerce has alerted us of. The OSCommerce cart requires 'Force Cookie Use' set to ON. This means that web Sites using a shared-SSL cert will not work. Most problems with the OSCommerce contribution are due to cookies not being set up properly and there unfortunately is not a work around for this.

Share this post


Link to post
Share on other sites

Using the contrib PM2CHECKOUT do I need to add each product to my product section in the vendor area on 2checkout.com? I read in the readme.txt file for the pm2checkout contrib it stated something about the required codes being passed each time a LIVE order was done and the product list being auto updated. As I have just started using 2CO I am a little confused and want to make sure all is working well. I did a successful TEST order but when making payment on the 2CO site it didnt show what exactly was being purchased, however that was not a LIVE order. Any help would be appreciated :)

Share this post


Link to post
Share on other sites
Using the contrib PM2CHECKOUT do I need to add each product to my product section in the vendor area on 2checkout.com?? I read in the readme.txt file for the pm2checkout contrib it stated something about the required codes being passed each time a LIVE order was done and the product list being auto updated.? As I have just started using 2CO I am a little confused and want to make sure all is working well.? I did a successful TEST order but when making payment on the 2CO site it didnt show what exactly was being purchased, however that was not a LIVE order.? Any help would be appreciated :)

I did it by using the v2.1 I was able to rid of that perimater issue that they were telling me I needed to add all products via excel. Now it just passes by and redirects back to OSC. But it is not showing up in the 2co list.

I am at the same spot as you are, and now on the phone with them.

:-"

Edited by g33kg1rl

Share this post


Link to post
Share on other sites

Using the contrib PM2CHECKOUT V2.1a do I need to add each product to my product section in the vendor area on 2checkout.com? when I get to be redirected from the OSC to the 2co site I get this error from thier site:

 

"Parameter Error

 

Incorrect parameters were supplied, therefore this purchase cannot begin.

 

If you are attempting to purchase from a web site please contact the web site so that they can correct the error. "

 

 

I'm in Colombia, is so hard to find information in Spanish. Thanks a lot for your help. this is my mail.

 

edgarraul@gmail.com

Share this post


Link to post
Share on other sites
Using the contrib PM2CHECKOUT V2.1a do I need to add each product to my product section in the vendor area on 2checkout.com? when I get to be redirected from the OSC to the 2co site I get this error from thier site:

I'm in Colombia, is so hard to find information in Spanish. Thanks a lot for your help. this is my mail.

 

edgarraul@gmail.com

When I talked to them yesterday he told me that we didn't need to have each product listed on both sites.

In the same he said that they would not support it unless we did, because OSC has made changes to the code.

 

When I was using V2.1 (not with the a) it fixed that error message for me.

Share this post


Link to post
Share on other sites

Look in includes/application_top.php fpr these lines:

 

// define the project version

define('PROJECT_VERSION', 'osCommerce 2.2-MS2');


Your online success is Paramount.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×