Jump to content
Sign in to follow this  
BlueYon

Seach Engine Friendly URL Support

Recommended Posts

Ok I can fix this, but you do know this is a bug with osc.

 

should not display session id with force cookies.

 

I agree there is a bug with oscommerce,what i was saying a bug is

 

this

http://myserver:9090/catalog?

has to be

http://myserver:9090/catalog/

not ?

and one more thing you can also check for port

Edited by baluvee

Share this post


Link to post
Share on other sites

Hi,

 

I've re-installed again, this time I've also started with a new database! :)

 

Cache is working, cookies are enabled.

 

I haven't installed this mod yet, but I did try using the "Use search-engine safe urls" option and that also doesn't work.

The URLs are changed but I get "No input file specified."

 

My url is www.stylewallahs.com/shop if anyone has time to help out this n00b :)

 

TIA

Edited by FunkyCkicken

Share this post


Link to post
Share on other sites
Hi,

 

I've re-installed again, this time I've also started with a new database! :)

 

Cache is working, cookies are enabled.

 

I haven't installed this mod yet, but I did try using the "Use search-engine safe urls" option and that also doesn't work.

The URLs are changed but I get "No input file specified."

 

My url is www.stylewallahs.com/shop if anyone has time to help out this n00b :)

 

TIA

 

what does your .htaccess says ?

copy and paste the contents of .htaccess which can be found in your shop folder

Share this post


Link to post
Share on other sites
what does your .htaccess says ?

copy and paste the contents of .htaccess which can be found in your shop folder

 

Well, I haven't looked at them as my host is using IIS6. I do have security on the required folders though. But as far as the scripts are concerned they have full rights.

Share this post


Link to post
Share on other sites
HI BlueYon

Is it possible to SEF Information pages?

if so how to go about it?

Thanks in advance

 

Yes you can do the whole lot!

 

You can have:

 

/Reviews/

/Shipping-Methods/

 

etc..

Share this post


Link to post
Share on other sites
do we have to change the code ?

if so can you help me plz

 

This sort of thing would not be hard , but again it takes time to test. I could end up with the problems like when I let the added the .html at the end.

 

I know when MS3 is released this modification should work alot better because some of the old bugs will be gone. They also use a service module to change the URL in MS3.

Share this post


Link to post
Share on other sites
This sort of thing would not be hard , but again it takes time to test. I could end up with the problems like when I let the added the .html at the end.

 

I know when MS3 is released this modification should work alot better because some of the old bugs will be gone. They also use a service module to change the URL in MS3.

 

I can Understand.

if possible plz send me the code snippets as PM

Thanks

Share this post


Link to post
Share on other sites

Hello,

 

I'm in need of some help. :(

 

So I went through your installation steps, did everything, and then tried going to the categories, but I got a 500 error. I thought I would try deleting all categories and products, but once re-added nothing worked still.

 

My site is:

http://www.omarskicks.com/

 

The names of the categories are

 

Nike Air Forces Ones

Nike Air Jordans

Other Shoes

Nike Dunks

Womens Shoes

 

so if I add any of those to the url like:

http://www.omarskicks.com/Nike-Air-Force-Ones/

 

That's when I get the 500 error.

 

Your help is appreciated.

 

Thanks,

Sean.

Share this post


Link to post
Share on other sites
Hello,

 

I'm in need of some help.  :(

 

So I went through your installation steps, did everything, and then tried going to the categories, but I got a 500 error. I thought I would try deleting all categories and products, but once re-added nothing worked still.

 

My site is:

http://www.omarskicks.com/

 

The names of the categories are

 

Nike Air Forces Ones

Nike Air Jordans

Other Shoes

Nike Dunks

Womens Shoes

 

so if I add any of those to the url like:

http://www.omarskicks.com/Nike-Air-Force-Ones/

 

That's when I get the 500 error.

 

Your help is appreciated.

 

Thanks,

Sean.

I think you have installed Ultimate SEO urls not search engine friendly Urls

Share this post


Link to post
Share on other sites

No, I had previously installed Ultimate URLs but didnt like it and wanted to try this contribution. I know the links from my navigation menu are still the old Ultimate SEO URLs, thats just because I haven't changed them since the new ones aren't working yet. :)

Share this post


Link to post
Share on other sites

RewriteEngine on

 

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.*) index.php

 

 

^^^^^

Thats what I have in the .htaccess of root directory.

Share this post


Link to post
Share on other sites
RewriteEngine on

 

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.*) index.php

^^^^^

Thats what I have in the .htaccess of root directory.

 

your htaccess is good

check if you had uninstalled the previous Ultimate SEO Urls completely

because it may be a problem

Share this post


Link to post
Share on other sites

Yeah, I agree. I am trying to make sure I have properly uninstalled it, but there is not uninstall feature, nor is there uninstall instructions. I deleted the two files it uses, and i went through and removed all code it asks you to put into existing files.

 

However it is still in

Configuration --> SEO URLs

 

So obviously I haven't uninstalled everything. Any ideas?

Share this post


Link to post
Share on other sites

On second thought, maybe I should take this party over to the Ultimate SEO urls thread and ask them how to uninstall properly.

Share this post


Link to post
Share on other sites
Yeah, I agree. I am trying to make sure I have properly uninstalled it, but there is not uninstall feature, nor is there uninstall instructions. I deleted the two files it uses, and i went through and removed all code it asks you to put into existing files.

 

However it is still in

Configuration --> SEO URLs

 

So obviously I haven't uninstalled everything. Any ideas?

 

first remove the file named seo.class.php from catalog/includes/classes

then

try this using phpMyAdmin or any other mysql query tool

DELETE FROM `configuration_group` WHERE `configuration_group_title` LIKE '%SEO URL%';

DELETE FROM `configuration` WHERE `configuration_key` LIKE '%SEO%';

this will clear off all the SEO parameters

Then enable Search Engine friendly URLs in mystore configuration

Share this post


Link to post
Share on other sites

Okay, I deleted all of that stuff from the mysql db and the SEO URLs is no longer in my admin. But the urls still dont work.

Share this post


Link to post
Share on other sites
Okay, I deleted all of that stuff from the mysql db and the SEO URLs is no longer in my admin. But the urls still dont work.

You Have to bring all the files affected by Ultimate SEO urls to orginal state

like tep_href would have been changed ..etc

so revert back all the files to orginal condition before the Instllation of Ultimate SEO urls

Share this post


Link to post
Share on other sites

I've reverted the following files according to the install instructions for Ultimate SEO URLs.

 

includes/application_top.php

includes/functions/html_output.php

admin/categories.php

admin/includes/functions/general.php

.htaccess

 

Sorry for being a nuissance, but I dont know which other files have been altered by ultimate seo urls?

Share this post


Link to post
Share on other sites

If I remember correctly the advice on Ultimate SEO URL's it is to only install it if you have tried using the default 'Use Search Engine Friendly URL's' and confirmed that they will work on your server.

 

Vger

Share this post


Link to post
Share on other sites
If I remember correctly the advice on Ultimate SEO URL's it is to only install it if you have tried using the default 'Use Search Engine Friendly URL's' and confirmed that they will work on your server.

 

Vger

 

 

Hey,

 

Not sure what you mean by that. I've already installed Ultimate SEO URLs and it worked just fine. The only problem I am having now is with Search Engine Friendly URLs, not Ultimate SEO URLs.

 

The only concern in regards to Ultimate SEO URLs is I may not have properly uninstalled everything.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×