Jump to content
Sign in to follow this  
BlueYon

Seach Engine Friendly URL Support

Recommended Posts

replacing product listing seemed to do the trick!

i'm not sure how i got that file so messed up, but prior to installing your mod i was looking for search-engine friendly mods, tried and failed at installing many. i must have forgot to fully uninstall one / part of a code.

 

yours works perfectly from what i can see, thank you very much for the help!! :)

Share this post


Link to post
Share on other sites

Updated again! Should now work weather in the root directory or not.

 

Please test away!

Share this post


Link to post
Share on other sites
Updated again! Should now work weather in the root directory or not.

 

Please test away!

 

Thanks a Lot.

There is a bug in the code.

Selecting the products gives correct result.

While selecting the manufacturer is throws error

like 'http://myserver:9090/catalog.html?manufacturers_id=9&osCsid=e643d620aacff4183a9663b1a3df0736'

 

Still testing for other things

Any How thanks a lot

Share this post


Link to post
Share on other sites

Hi,

 

I am new to OSC and installed 1.7 of the SEO URL mod.

 

Did exactly what was said to do and I dont think its working.

 

Under catagory "Baby Gift Baskets" the url appears as:

http://my-baby-gift-baskets.com/index.php/cPath/21

 

rather than, http://www.my-baby-gift-baskets.com/baby-gift-baskets.html as I want it too. Also, may be related but the Home page is fine, but when I switch to a catagory page, at the bottom I get this error:

 

Error!

 

Unable to determine the page link!

 

I add the www manually in the browser and same error.

 

I would great appreciate any help you could give.

 

Chris

Share this post


Link to post
Share on other sites

A small note, this error:

 

Error!

 

Unable to determine the page link!

 

It is usually an error which shows up if your server does not accept the standard oscommerce sef urls.

Admin -> Configuration -> My Store -> Use Search-Engine Safe URLs (still in development) -> True

 

The fix is:

Admin -> Configuration -> My Store -> Use Search-Engine Safe URLs (still in development) -> false

 

 

If this is correct in your case you can not use this SEO url mod since it is dependant on the original sef url function.

 

There are several other sef/seo url contributions which do not utilize the original osc sef functions in the contribution section.

Edited by toyicebear

Share this post


Link to post
Share on other sites
Hi,

 

I am new to OSC and installed 1.7 of the SEO URL mod.

 

Did exactly what was said to do and I dont think its working. 

 

Under catagory "Baby Gift Baskets" the url appears as:

http://my-baby-gift-baskets.com/index.php/cPath/21

 

rather than, http://www.my-baby-gift-baskets.com/baby-gift-baskets.html as I want it too.  Also, may be related but the Home page is fine, but when I switch to a catagory page, at the bottom I get this error:

 

Error!

 

Unable to determine the page link!

 

I add the www manually in the browser and same error.

 

I would great appreciate any help you could give.

 

Chris

 

 

I don't think you have the config setup correctly.

 

I'n fact you have session ID's in your links. What version of the script are you using?

 

You need to setup your force cookies, search engine safe URL and cache.

Share this post


Link to post
Share on other sites
Updated again! Should now work weather in the root directory or not.

 

Please test away!

 

There is a bug in the code.

Selecting the products gives correct result.

While selecting the manufacturer is throws error

like 'http://myserver:9090/catalog.html?manufacturers_id=9&osCsid=e643d620aacff4183a9663b1a3df0736'

 

Can you help?

Share this post


Link to post
Share on other sites

i got a big problem!!

at first, i installed the Search Engine Friendly URL 1.5 according to the intall.htm instruction. But unfortunately, the final step:

In "/admin/includes/functions/general.php"

Before (around line 956):

 

}

 

 

Add this code (around line 956):

 

@unlink(DIR_FS_CACHE . 'categories_array.cache');

@unlink(DIR_FS_CACHE . 'manufacturers_array.cache');

@unlink(DIR_FS_CACHE . 'products_array.cache');

 

 

Note: Should be the reset cache function!

 

 

i cannot find any function about resetting the cache.

 

 

Therefore, i gave up and delete all and wanted to install version 1.4;

 

but the unfortune happened again: i just follow the instrution step by step, but after this installation, just nothing changed, nothing...

 

i'm very confused now as i do not know much about this contrib, i just followed the instruction.....

Share this post


Link to post
Share on other sites
i got a big problem!!

at first, i installed the Search Engine Friendly URL 1.5 according to the intall.htm instruction. But unfortunately, the final step:

In "/admin/includes/functions/general.php"

Before (around line 956):

 

  }

Add this code (around line 956):

 

    @unlink(DIR_FS_CACHE . 'categories_array.cache');

    @unlink(DIR_FS_CACHE . 'manufacturers_array.cache');

    @unlink(DIR_FS_CACHE . 'products_array.cache');

Note: Should be the reset cache function!

i cannot find any function about resetting the cache.

Therefore, i gave up and delete all and wanted to install version 1.4;

 

but the unfortune happened again: i just follow the instrution step by step, but after this installation, just nothing changed, nothing...

 

i'm very confused now as i do not know much about this contrib, i just followed the instruction.....

 

You should install the latest version!

 

but it should be the before the end bracket of the tep_reset_cache_block function.

 

Do a search in /admin/includes/general.php for tep_reset_cache_block, it is the last } around 956

Share this post


Link to post
Share on other sites
There is a bug in the code.

Selecting the products gives correct result.

While selecting the manufacturer is throws error

like 'http://myserver:9090/catalog.html?manufacturers_id=9&osCsid=e643d620aacff4183a9663b1a3df0736'

 

Can you help?

 

 

session id

 

&osCsid=e643d620aacff4183a9663b1a3df0736

 

yeah I think i need to release a manufacturing and currency box

Share this post


Link to post
Share on other sites

Actually I think this is a slite bug with oscommerce. it should not have session ids when changing manufacturers.

 

Looks liks I will be changing the contribtuion after all to allow session ids.

Share this post


Link to post
Share on other sites

You should install the latest version!

 

but it should be the before the end bracket of the tep_reset_cache_block function.

 

Do a search in /admin/includes/general.php for tep_reset_cache_block, it is the last } around 956

 

--------------------------

i installed the version 1.5, then the url is just changed to www.mywebsite.com, and without any behind.

why????

i did follow the instruction step by step

Share this post


Link to post
Share on other sites
You should install the latest version!

 

but it should be the before the end bracket of the tep_reset_cache_block function.

 

Do a search in /admin/includes/general.php for tep_reset_cache_block, it is the last } around 956

 

--------------------------

i installed the version 1.5, then the url is just changed to www.mywebsite.com,  and without any behind.

why????

i did follow the instruction step by step

 

 

whats your site?

Share this post


Link to post
Share on other sites
whats your site?

 

----

 

http://rcteam.sarge.com/

 

and

 

do i have to replace the index.php?? if i replace, it will lead to a mess. So, if i don't want to replace the index.php, what can i do?

 

This index.php needs changing. You will have to go thorugh the code and fit it to your cuurrent design. Or if you looked at the php you could see which parts I have pulleds out from product_info.php.

 

Anyway I can not access you site to check this. Are you sure the address is correct?

Share this post


Link to post
Share on other sites

Removed the extention changin feature that was requested. It causes problems I did not design this contribtuion to have an extention. as I said before there is no point to have it it does not offer anything in terms of SEO.

 

Releasing an upodated version without this today.

Share this post


Link to post
Share on other sites

Hi,

 

I like the look of this mod and so installed it, made sure that my cache was working.. set my cookies as per the instructions. Followed the instructions to the letter.. and I got the following HTML output: No input file specified.

 

I then did a clean install of oscommerce, followed by the basic config as per the instructions in v1.8 of this mod and still the same.

 

Am I missing something here?

 

Many thanks

 

:thumbsup:

Share this post


Link to post
Share on other sites
Hi,

 

I like the look of this mod and so installed it, made sure that my cache was working.. set my cookies as per the instructions. Followed the instructions to the letter.. and I got the following HTML output: No input file specified.

 

I then did a clean install of oscommerce, followed by the basic config as per the instructions in v1.8 of this mod and still the same.

 

Am I missing something here?

 

Many thanks

 

:thumbsup:

 

 

Sorry, I should say that the URLs themselves do appear in the new format and that the error message I got was as a result of clicking on a product.

 

Cheers

Share this post


Link to post
Share on other sites
Sorry, I should say that the URLs themselves do appear in the new format and that the error message I got was as a result of clicking on a product.

 

Cheers

 

One more bit! :blush:

 

Original url: http://www.site.com/shop/product_info.php?products_id=18

New url: http://www.site.com/shop/product_info.php/products_id/18

 

includes/configure.php contains:

define('HTTP_COOKIE_DOMAIN', 'www.site.com');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/shop/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/shop/');

define('DIR_WS_HTTPS_CATALOG', '');

 

 

Cheers

Share this post


Link to post
Share on other sites
One more bit!? :blush:

 

Original url: http://www.site.com/shop/product_info.php?products_id=18

New url: http://www.site.com/shop/product_info.php/products_id/18

 

includes/configure.php contains:

? define('HTTP_COOKIE_DOMAIN', 'www.site.com');

? define('HTTPS_COOKIE_DOMAIN', '');

? define('HTTP_COOKIE_PATH', '/shop/');

? define('HTTPS_COOKIE_PATH', '');

? define('DIR_WS_HTTP_CATALOG', '/shop/');

? define('DIR_WS_HTTPS_CATALOG', '');

Cheers

 

This mod won't work if your site is not in root.New version 1.8 which supports site not in root still has bugs

Edited by baluvee

Share this post


Link to post
Share on other sites
This mod won't work if your site is not in root.New version  1.8 which supports site not in root still has bugs

 

1.8 works fine with or without root directory.

 

I only removed the feature to change thye extantion.

 

If you've found bugs please tell me the error messages.

Share this post


Link to post
Share on other sites
1.8 works fine with or without root directory.

 

I only removed the feature to change thye extantion.

 

If you've found bugs please tell me the error messages.

I have already reported the bug

 

There is a bug in the code.

Selecting the products gives correct result.

While selecting the manufacturer is throws error

like 'http://myserver:9090/catalog?manufacturers_id=9&osCsid=e643d620aacff4183a9663b1a3df0736'

Share this post


Link to post
Share on other sites
I have already reported the bug

 

There is a bug in the code.

Selecting the products gives correct result.

While selecting the manufacturer is throws error

like 'http://myserver:9090/catalog?manufacturers_id=9&osCsid=e643d620aacff4183a9663b1a3df0736'

 

Ok I can fix this, but you do know this is a bug with osc.

 

should not display session id with force cookies.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×