Jump to content
Sign in to follow this  
Calotherm

Royal Mail Module

Recommended Posts

Hello, basically i am ultra new to this, but not webdiegn and some coding, all my other problems i have been able to fix from answers in the forum but alas nothing on this one that can help me.

 

We have setup the shop on temp domain to add products etc before we move away from ebay and the address is - http://s116665026.websitehome.co.uk/ -

 

The problem we are having is that the royal mail modual is saying that shipping option not availble on this order.

 

I have tried changing weights in the product catagory,

adding multiple items,

adding single items,

taking the weight off the product,

turning the zones on and off.

 

I just dont know why it wont allow me to select it, appreciated i may have to update the rates soon to comply with RM but thats if i can get the thing to work first.

 

One thing i am confused about in the product manager is what does the weight measure in, is it lb's / oz's or kg's / g's

 

so for instance the hl2 game ways 350g's i add that in, save and then go back to shop to check it out. this would normally be fine for Recorded deliv but it wont let me set it up.

 

I have set the zone for the item to UK and also tried United Kingdom but neither will bring up a value.

 

 

Looking for any help as it will be most appreciated, if you need any extra info from me just shout out and i will do it soon as poss.

 

Thanks in advance,

Andy

Share this post


Link to post
Share on other sites

Hi,

 

How are you inputting the weights. I believe they are in kgs, so 350g would be entered as 0.350.

 

I'm getting a similar problem to you but mine is that when multiple items are entered I get the same message.

 

Matt

Share this post


Link to post
Share on other sites

Hello, i am also putting in the weights at e.g. 0.350

its a strange one but woudl be great if someone could say how to get this mod working.

 

cheers

 

Hi,

 

How are you inputting the weights. I believe they are in kgs, so 350g would be entered as 0.350.

 

I'm getting a similar problem to you but mine is that when multiple items are entered I get the same message.

 

Matt

Share this post


Link to post
Share on other sites
Hello, i am also putting in the weights at e.g. 0.350

its a strange one but woudl be great if someone could say how to get this mod working.

 

cheers

 

 

 

Just been playing with this mod myself, could not get it to work either. THEN.......... The default zones that this service is available to is US etc, you need to change to UK. Seems a hack of the ups mod, but if you make a few changes seems as though it will work.

Share this post


Link to post
Share on other sites

The units are whatever you want then to be. It is simple as that. Just change the text from lbs to kgs. The module is simply the zones module set up to have 4 zones plus the addition of a few images afaik. It adds things to the database automatically when you install it.

 

If you cannot get this one working then just use zones, but I expect the problem lies elsewhere.

 

Btw the international 2 letter code for the United Kingdom is GB.

Share this post


Link to post
Share on other sites
you need to change to UK. 

 

 

Sorry make that change the Zone 1 countries to GB and it works.

You will also need to update the weights, costs etc as they are either out of date or not from Royal Mail.

Share this post


Link to post
Share on other sites

Does anyone know how oscommerce calculates the shipping as my problem is somewhat different.

 

I've placed a post here http://forums.oscommerce.com/index.php?showtopic=129139&hl= which explains it in more detail but basically some products won't affect the cart while others when added give:

 

This is currently the only shipping method available to use on this order. 

  Royal Mail Registered 

Sorry, this shipping option is not available for this order

 

It's completely bizzare.

 

Matt

Share this post


Link to post
Share on other sites
Sorry make that change the Zone 1 countries to GB and it works.

You will also need to update the weights, costs etc as they are either out of date or not from Royal Mail.

 

Yeah changing the Zone1 Countries to JUST 'GB' (without quotes) makes it work fine :)

Share this post


Link to post
Share on other sites
Yeah changing the Zone1 Countries to JUST 'GB' (without quotes) makes it work fine :)

 

 

I have now got rid of the problem module when i thought i had it all working, i didn't tho. its the reg.php which gives error's:-

 

it seems to work fine if somthing is on the first weight setting, but soon as you add more items and it goes over to the next price it fails and says its not available.

 

Anyways i spent to long on it and so removed now, setup my own zones shipping as recorded so i have the same functions.

 

only now lol, when an order is above weight the zone doesn't cater for ( in this case 1.0) it will say its not available which is fine, BUT the radio button to check and use that shipping service remains active withuot a price.

 

How can i hide this radio button please as customers cannot check it by mistake.

 

The royal mail module that doesn't work for me did hide the radio check box but this wont.

 

And ideas?

 

Cheers in advance..

Andy

Share this post


Link to post
Share on other sites

Hi there,

 

Perhaps this is a stupid question.

 

I am trying to understand how zones work. Am I correct in understanding that zone 1 will be the country itself? Also, where does a person change which countries belong to zone 1, zone 2 etc.? One final related question, if I add a new zone e.g. zone 2, does that mean shipping will then be applicable to all zone 2 countries and only zone 2 countries?

 

Thank you in advance.

 

 

 

I have now got rid of the problem module when i thought i had it all working, i didn't tho. its the reg.php which gives error's:-

 

it seems to work fine if somthing is on the first weight setting, but soon as you add more items and it goes over to the next price it fails and says its not available.

 

Anyways i spent to long on it and so removed now, setup my own zones shipping as recorded so i have the same functions.

 

only now lol, when an order is above weight the zone doesn't cater for ( in this case 1.0) it will say its not available which is fine, BUT the radio button to check and use that shipping service remains active withuot a price.

 

How can i hide this radio button please as customers cannot check it by mistake.

 

The royal mail module that doesn't work for me did hide the radio check box but this wont.

 

And ideas?

 

Cheers in advance..

Andy

Share this post


Link to post
Share on other sites

Hi David,

 

Once again many thanks. I now have OSC coming both ears eyss and nose and am missing the obvious. Think I need to take a break.

 

Thanks for this. I guarantee I wouldn't have seen this tonight thus have a good few hours of worrying saved.

 

Cheers,

 

Brad

 

See your admin panel once you have installed the contribution. All will become clear.

Share this post


Link to post
Share on other sites

Has anyone got the royal mail module working yet? I am still trying to solve that problem and I tried everything I could think of with no positive result?

 

If that royal mail contrib is buggy (possibly) then I think it should be removed from the Contribs area.

Share this post


Link to post
Share on other sites
Has anyone got the royal mail module working yet? I am still trying to solve that problem and I tried everything I could think of with no positive result?

 

If that royal mail contrib is buggy (possibly) then I think it should be removed from the Contribs area.

 

I am also having probs trying to make sense of this contrib, I have installed it, and all is not clear, it just doesn't behave as expected, if anyone works this contrib out, maybe they could post a brief idiots guide (speaking for myself!)

Thanks

Share this post


Link to post
Share on other sites
I am also having probs trying to make sense of this contrib, I have installed it, and all is not clear, it just doesn't behave as expected, if anyone works this contrib out, maybe they could post a brief idiots guide (speaking for myself!)

Thanks

 

 

Part solution:

 

Yes, at least I did until yesterday.

 

I fixed two of them (Special Delivery, and Standard) by putting GB in the Zone 1 country on the admin display for these modules. I found that by looking in the php code, and reading up on the comments.

 

However, try as I might, I cannot get the Registered one to work and it still displays that message.

 

Anyone else had problems with the Registered module ?

 

courtesy of tanwen from this thread.

Share this post


Link to post
Share on other sites

If anyone is going to do the Royal Mail properly they will need the following rates.

 

Maximum weight First class letter and small package.

60g 28p

100g 42p

150g 60p

200g 75p

250g 88p

300g ?1.01

350g ?1.15

400g ?1.33

450g ?1.50

500g ?1.68

600g ?2.03

700g ?2.38

750g ?2.55

800g ?2.73

900g ?3.10

1kg ?3.45

 

Parcels

1.5kg ?4.45

2kg ?4.78

4kg ?7.20

6kg ?7.86

8kg ?8.96

10kg ?9.62

20kg ?11.21

 

Give me a shout when someone has done it please.

Share this post


Link to post
Share on other sites
The royal mail contrib seems to be very buggy, i used this one :2 zone contrib.

And set the zones up as each shipping method, 1 for parcel force and one for special delivery, they seem to work See here!

 

I dont really know what zones are really. Plus do you mean that one can use the above contribution in such way that one can enable( or say make available) any shipping method at a store? If yes, is it ok to use zones as shipping methods?

 

Regards,

|rf@N


Irfan,

Share this post


Link to post
Share on other sites

I have added the Royal Mail module and after putting GB into the zone1 section of the admin console it works

 

now i wanted to put the up to date postage prices posted by clothahump above, how do i do this ?

 

I tried entering this into the Zone 1 Shipping table field:-

 

0.06:0.28,0.10:0.42,0.15:0.60,0.20:0.75,0.25:0.88,0.30:1.01,0.35:1.15,0.40:1.33,

0.45:1.50,0.50:1.68,0.60:2.03,0.70:2.38,0.75:2.55,0.80:2.73,1:3.45

 

but this doesnt work.

Share this post


Link to post
Share on other sites

Well after looking at another post, i decided to try and make life easie to debug so i deactivated the registered and special delivery sections of the contribution

and then added these as my table:-

 

1:3.96,1.5:4.95,2:5.28,4:8.30,6:8.99,8:10.10,10:10.77,20:12.36

 

i then made one of my products to be 0.95 as its weight

 

i have tare set to 0

 

yet the shipping costs shown was ?4.95 !!! which means the system thinks it is between 1 and 1kg

 

any ideas ???

Share this post


Link to post
Share on other sites

Hi

Guys, I am new to all this and have just installed the contribution myself... so this may help some of you... from the newbie mistakes I made at first.

 

You need to set number of zones in .php file ( I just used 1)

You need designate the iso codes for all countries in that zone, (GB is what I used for UK)

 

Then like many of u I have probs with weights and prices...

 

Remember to set the tare weights of parcels.... in Admin>Configuration>shipping/packaging

 

eg, i set small packets to 0.04, and the percentage to 150, because i got parcels at about 6kg

 

Hope this helps.

Alex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×