Jump to content
Sign in to follow this  
-albert-

Servired module

Recommended Posts

Hi Albert;

 

I?ve installed your contribution for Sabadell Atalantico but I have write to them choose "Comercio con campo de verificaci?n" and they answer to me What is this?

 

Vamos, que no se enteran ni del Nodo por lo que se ve? Qu? puedo hacer? Gracias?

Share this post


Link to post
Share on other sites

Hola,

 

Mil Gracias por hacer la adaptaci?n!!!

 

Lo he probado y va bien.

Lo ?nico que se podr?a mejorar (aunque quiz?s no dependa del m?dulo en s?) es que cuando vuelve, despues de aceptar el pago en servired, te pide el nombre de usuario y password (login).

 

Se espera la p?gina ok!

Share this post


Link to post
Share on other sites

Hi! I'm hooking up Caixa de Catalunya but get this ERROR after installing the payment module:

 

Parse error: parse error, unexpected T_FINAL, expecting T_STRING in /var/www/lightprice/shop/catalog/includes/modules/payment/servired.php on line 467

 

Any idea why? I get the same with the quadram scripts from their site (but on another row..)

 

Thanks for any help!

/Salomon

 

 

Servired payment module (used by various entities in Spain -> Caixa de Catalunya, Banc de Sabadell ...)

 

It's just the qadra m "caixa de catalunya"'s module with few improvements.

Download it from: http://www.oscommerce.com/community/contributions,2790

Edited by Johnson

Share this post


Link to post
Share on other sites

Hola,

 

Lo he instalado para el Banco Sabadell Atlantico y al igual a otros miembros los del banco

me dicen que no saben que es eso del campo de verificaci?n.

 

En cualquier caso me da el error "Data error. Contact the Merchant" en la p?gina

de la TPV.

 

?Podrias indicarme como corregirlo?

 

Gracias

Benjamin

Share this post


Link to post
Share on other sites

Hola a todos,

estoy teniendo los mismos problemas con el tpv de banco sabadell, alguien podria echarme un cable por favor? , me dice que los datos no le llegan bien, pero en el administrador de oscommerce la url esta bien , el id de comercio tambien y la clave tambien. no se que puede ser. si alguien puede echarme una mano lo agradecere muchisimo.

gracias

jordi.

Share this post


Link to post
Share on other sites

Hola Salomon, al parecer la palabra final ha sido a?adida a PHP5 por lo que est? reservada, yo ten?a el mismo problema con el m?dulo de la Caixa Catalunya y reemplac? la palabra final por finale tanto en la funci?n como en la aplicaci?n del JavaScript y ahora me funciona.

 

function finale() {

for( $i=0; $i<$this->buffsize; ++$i) {

$last_block[$i] = $this->buffer[$i];

}

...

function hash_bytes( $bytes ) {

$this->init();

$this->update( $bytes );

return $this->finale();

}

 

La palabra reservada final PHP5:

http://es2.php.net/manual/es/language.oop5.final.php

 

Espero que te funcione :thumbsup:

 

Hi! I'm hooking up Caixa de Catalunya but get this ERROR after installing the payment module:

 

Parse error: parse error, unexpected T_FINAL, expecting T_STRING in /var/www/lightprice/shop/catalog/includes/modules/payment/servired.php on line 467

 

Any idea why? I get the same with the quadram scripts from their site (but on another row..)

 

Thanks for any help!

/Salomon

Share this post


Link to post
Share on other sites

I'm having a serious problem with the Servired module... Once the user has entered the credit card and he's being charged, there's not order associated to the user !!!! The order dissapears !!!!

 

Thanks a lot for any help... Please, it's very urgent !!!!

Share this post


Link to post
Share on other sites

I have noticed some problems with the module, mainly the one i mentioned you messages before about charges to a card made without order in the program... It seems like people make the order, go to the payment module but they have some problems, maybe when returning to OSCommerce...

 

Also, i received today an order that the payment was not autorizhed... It's a minor problem because i check all the orders' payment but it's a serious one because if there's too much orders, we have to check all the payments correctly made, whoa... :-)

Share this post


Link to post
Share on other sites

Hi i think is some error in the data sent to the Secure server not ok as i installed now the module with Os commerce shop all work perfect i got only error when i confirm order and i get to the page of SERVIRED and my bank there is error below

 

*************************

 

General order details

Order number Total amount

 

 

11168298340 84,00 Euro

 

 

 

 

It was not possible to carry out the transaction because:

 

Data error. Contact the merchant.

 

 

*********************************

 

well i get this error before when i installed Virtuemart shopping card well there my bank told me to change this

 

**************************************

 

<?PHP

// Calculo del hash para firmar los datos.

$order = '000'.$db->f("order_id");

$amount=$db->f("order_total")*100;

$sha = new SHA;

$message = $amount.$order.$code.$currency.$tipoOperacion.$urlMerchant.$clave;

$digest1 = $sha->hash_string($message);

$signature = strtoupper ($sha->hash_to_string( $digest1 ));

?>

 

************************************

 

after i put this way all working in virtuemart pefect but why not now in os commerce can you help please

Share this post


Link to post
Share on other sites

Ok I sort this problem .......

 

 

but now i get other problem after payment is done and confirmed i see this message ~~ Click on "Continue" in order to return to ***** shop *** ok i click i go back to my shop url but white page no data and block there i click refresh nothing happned i check in admin no order was aded and no email come to me as client only bank confirmation that the payment was success any help

Share this post


Link to post
Share on other sites

I'm having the same problem...

 

Ok I sort this problem .......

but now i get other problem after payment is done and confirmed i see this message ~~ Click on "Continue" in order to return to ***** shop *** ok i click i go back to my shop url but white page no data and block there i click refresh nothing happned i check in admin no order was aded and no email come to me as client only bank confirmation that the payment was success any help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×