Jump to content
Sign in to follow this  
akmac

Page Cache help

Recommended Posts

I installed Page Cache-and am very pleased with it. However, when adding categories in Admin I'm getting the errors:

 

-------------------------

 

Warning: Invalid argument supplied for foreach() in /catalog/admin/includes/reset_seo_cache.php on line 5

 

Warning: Cannot modify header information - headers already sent by (output started at /catalog/admin/includes/reset_seo_cache.php:5) in /home/alaskaje/public_html/catalog/admin/includes/functions/general.php on line 18

 

--------------------------

 

The categories get added, but I have to navigate back to the page I want to use because of the error. Anybody found a fix for this?

 

-Cleve


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites

You have white space (spaces and or newlines) at either the beggining or end of /catalog/admin/includes/reset_seo_cache.php.

 

Remove those with a good editor (not the osCommerce file Manager/editor) and you'll be good to go.

 

Also, see knowledgebase article on this.

 

http://www.oscommerce.info/kb/osCommerce/Common_Problems/15

 

HTH

Tom

Share this post


Link to post
Share on other sites

Checked it and that's not it-no white space or lines before or after. Any other suggestions?


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites

OK...that is two problems you've found with foreach() so I am guessing that your host has upgraded PHP to 4.3.10 and negelected Zend Optimizer/Accelerator.

 

Tell you host to upgrade Zend and the functions will work correctly.

 

Reference this page: PHP 4.3.10 / Zend Optimizer incompatibilities

 

As a summary, it's not the code that is at fault but rather your host negelecting to upgrade all the software properly.

 

Bobby

Share this post


Link to post
Share on other sites

Ok Bobby,

 

Sorry for polluting with shared server specific issues.

 

Hopefully someone else will be helped. Meanwhile-I'm on hold w/ipower.

 

-akmac


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites

Chemo - When debugging, I'm finding the page cache contribution adds a double slash as follows. Is this a problem, or something I should try and fix:

 

[cache_dir] => /home/jim.com//cache/

[cache_file] => /home/jim.com//cache/_index.php__english_USD.cache

 

Thanks, and happy new year !!

Share this post


Link to post
Share on other sites

I'm a perfectionist and would recommend you fix the problem...

 

Look through the settings and if you need help just ask!

 

Bobby

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×