Jump to content
adam5532

QBI Quickbooks Import

Recommended Posts

When using QBI in a store that doesn't do online credit card processing (this is done in Quickbooks), will the new orders be easily accessible in Quickbooks (able to be distinguished quickly) in order to process them after being imported?

QB will mark paid orders as PAID, so it is easy to see where you have left off. You can also set QBI to mark new orders "To Print," and this will get cleared when you print your invoices.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Hello I want to say thanks for this contribution and I hope it will speed p things in my company.

 

For the moment I am making successfully exports of products orders and customers.

I am able to import customers and products to the QB.

 

When trying to imports Orders I am getting this message:

QuickBooks has detected that one of your items does not have an account associated with it. Go to the item list to make sure all items are associated with accounts.

 

After clicking ok I have:

 

Error on line 13: Can’t record invalid transaction.

[ok/cancel]

 

What should I do?

 

Thanks Martin.

Share this post


Link to post
Share on other sites
1) You may not have completed Set-up and Match for discounts.

2) Some discount modules set the sign differently. This can be identified by looking at the iif file. If you can send it to me I will check this and tell you how to fix it.

 

Thanks,

Adam

 

 

Hi-

I emailed an iif file but I'm not sure if I had the right e-mail address. I'm getting a little desperate to get this repaired. Will you let me know if you received the file? Thanks.

Share this post


Link to post
Share on other sites
Hello I want to say thanks for this contribution and I hope it will speed p things in my company.

 

For the moment I am making successfully exports of products orders and customers.

I am able to import customers and products to the QB.

 

When trying to imports Orders I am getting this message:

QuickBooks has detected that one of your items does not have an account associated with it. Go to the item list to make sure all items are associated with accounts.

 

After clicking ok I have:

 

Error on line 13: Can’t record invalid transaction.

[ok/cancel]

 

What should I do?

 

Thanks Martin.

Make sure that you have properly filled in the accounts on the QBI configuration page.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
Hi-

I emailed an iif file but I'm not sure if I had the right e-mail address. I'm getting a little desperate to get this repaired. Will you let me know if you received the file? Thanks.

(This post has been answered personally)

- Adam

Share this post


Link to post
Share on other sites
Any news about a UK compatible version of QBI?

 

Vger

I've been moving from California to Portland Oregon the last few months, hence the slow responses. I will have the office set back up by the end of this week, so I will be able to put more time into QBI 4.x (which will support UK QB). It will probably be a couple more months. I will give a more accurate prediction when I get closer to completion.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

I keep getting an error when importing on line 11. Then if I am importing mulitiple order it follows that pattern, line 22,33,44,55 etc. Odly enough on the last order it actully created the invoice, but otherwise and when only importing one order it imports the customer name and address etc into qb but doesn't create the invoice. Thanks for you help. This is the best contrib in the WORLD. :thumbsup:

Share this post


Link to post
Share on other sites

Does it matter what version of Quickbooks you use with this contribution, or will it work for any version? I was asking cause I have quickbooks 2006 Primere edition i just wanted to make sure there wouldn't be any problems using this contribution.

 

Thanks

Share this post


Link to post
Share on other sites
Does it matter what version of Quickbooks you use with this contribution, or will it work for any version? I was asking cause I have quickbooks 2006 Primere edition i just wanted to make sure there wouldn't be any problems using this contribution.

 

Thanks

No problem. Pro, Premier, or Enterprise, many years back.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
I keep getting an error when importing on line 11. Then if I am importing mulitiple order it follows that pattern, line 22,33,44,55 etc. Odly enough on the last order it actully created the invoice, but otherwise and when only importing one order it imports the customer name and address etc into qb but doesn't create the invoice. Thanks for you help. This is the best contrib in the WORLD. :thumbsup:

You have not set up QBI completely. Line 11 will be the end of the transaction. Open the iif file in Excel, and look at the line items in the transaction right above line 11. Something will be missing or be the wrong amount. Likely a discount item, low order fee, etc that isn't set up. Sales tax must also be set up correctly.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
I agree, it was an odd error message. I worked around it by removing the ', EDD: March 09, 2006' portion of the string and now it works.

 

Can anyone expand on this? I am having the same problem and I don't know what file needs to be eddited to fix it.

Also, does this mean turning off the estimated delivery date functionality, or just excluding it from the shipping method query QBI is using?

 

edit:

The shipping module is UPSXML.

The error message was copied correctly in sirfergy's original post: here it is again.

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Estimated Delivery Date'>EDD: August 14, 2007' AND so.qbi_shiposc_car_' at line 1

 

SELECT * FROM qbi_shiposc AS so, qbi_shiposc_shipqb AS soqb, qbi_shipqb AS sqb WHERE qbi_shiposc_car_text='United Parcel Service' AND qbi_shiposc_serv_text='UPS Ground, EDD: August 14, 2007' AND so.qbi_shiposc_car_code=soqb.qbi_shiposc_car_code AND so.qbi_shiposc_serv_code=soqb.qbi_shiposc_serv_code AND sqb.qbi_shipqb_refnum=soqb.qbi_shipqb_refnum

 

[TEP STOP]

Edited by voysinmyhead

Share this post


Link to post
Share on other sites
Can anyone expand on this? I am having the same problem and I don't know what file needs to be eddited to fix it.

Also, does this mean turning off the estimated delivery date functionality, or just excluding it from the shipping method query QBI is using?

 

edit:

The shipping module is UPSXML.

The error message was copied correctly in sirfergy's original post: here it is again.

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Estimated Delivery Date'>EDD: August 14, 2007' AND so.qbi_shiposc_car_' at line 1

 

SELECT * FROM qbi_shiposc AS so, qbi_shiposc_shipqb AS soqb, qbi_shipqb AS sqb WHERE qbi_shiposc_car_text='United Parcel Service' AND qbi_shiposc_serv_text='UPS Ground, EDD: August 14, 2007' AND so.qbi_shiposc_car_code=soqb.qbi_shiposc_car_code AND so.qbi_shiposc_serv_code=soqb.qbi_shiposc_serv_code AND sqb.qbi_shipqb_refnum=soqb.qbi_shipqb_refnum

 

[TEP STOP]

Hi,

 

'Estimated Delivery Date' doesn't appear in the SQL string, so I suspect that this wasn't copied correctly. Nevertheless, it is likely that the > or : is causing a problem in the SQL statement. QBI 3.x has corrected this issue.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

I had the problem below also, and just discovered the solution:

 

I had to set the chmod permissions to 777 not only to the folder but also the files themselves. For some reason just changing the folder permissions didn't correct the error. Maybe because I was reinstalling and the files were already setup? I don't know. I hope this helps. Thanks.

 

 

 

Arrgh! Newbie startup probs. I've beat my head against the wall for days on this and really would appreciate some help.

 

When using the QBI panel buttons to download current orders I keep getting permission errors as shown below even though my admin / qbi_output directory chmode is 777 and the admin / qbi_input directory is chmode is 755:

 

Warning: fopen(qbi_output/error_log_orders.txt): failed to open stream: Permission denied in /home/Mysite/public_html/catalog/admin/includes/functions/qbi_functions.php on line 612

 

Warning: fopen(qbi_output/qbi_orders.iif): failed to open stream: Permission denied in /home/Mysite/public_html/catalog/admin/includes/qbi_engine_orders.php on line 58

 

Warning: fwrite(): supplied argument is not a valid stream resource in /home/Mysite/public_html/catalog/admin/includes/qbi_engine_orders.php on line 357

 

and so on?

 

When I try the Create iff command in the QBI control panel nothing seems to happen.

The error_log_orders.txt, qbi_orders.iif, qbi_prod.iif all appear unchanged from July 20, even though orders are being generated.

 

Thanks

TimC.

Share this post


Link to post
Share on other sites
I had the problem below also, and just discovered the solution:

 

I had to set the chmod permissions to 777 not only to the folder but also the files themselves. For some reason just changing the folder permissions didn't correct the error. Maybe because I was reinstalling and the files were already setup? I don't know. I hope this helps. Thanks.

Yes, changing the folder to 777 or 755 doesn't change any of the existing files. For that reason, it is always good to tell your FTP program or other interface to change both the folder and the files.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Hi, i just installed this and went to admin > catalog > Quickbooks Import QBI

 

and the page has this:

 

Quickbooks Import QBI

 

Database table upgrades successfull. Now you must go to the configuration page.

1) Recheck your configuration options and configure new options.

2) Click "Update" at the bottom of the page.

Note: You must click update to finish the upgrade, even if you did not change any settings!

 

Now you must go to the configuration page.

 

 

so i clicked on the "Now you must go to the configuration page." which is the link: http://pureg.net/shop/admin/qbi_config.php

 

but nothing happens, the page refreshes and same info

 

can someone please help, thank you

Share this post


Link to post
Share on other sites

Hi-

Whenever I import files it flashes very quickly to your orders have been imported instead of showing the progress bar and taking a couple of seconds. Then, the orders are nowhere to be found. Any thoughts?

thanks.

Share this post


Link to post
Share on other sites
Hi-

Whenever I import files it flashes very quickly to your orders have been imported instead of showing the progress bar and taking a couple of seconds. Then, the orders are nowhere to be found. Any thoughts?

thanks.

Are there actually orders in the file? How many did it say there were? Did you check both your Invoices and Sales Receipts for the new orders?

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

What would be the best way to tie Quickbooks data into OSCommerce so that a customer can view invoices/purchases not made through OSCommerce (services, orders via phone, etc.) I'd like to set up an all-in-one solution where orders through OSCommerce are exported to quickbooks...and when the customer logs in they can view their Quickbooks data. If I have to manually import the data into Quickbooks that's fine...but I would really like a real-time solution that reads right from the Quickbooks database for the Customer Self-Service portion.

 

It's a hassle having customers call and ask about their account balance or asking for copies of their invoices for services and products that weren't ordered online and they are always confused as to why this data isn't available to them online.

Share this post


Link to post
Share on other sites
What would be the best way to tie Quickbooks data into OSCommerce so that a customer can view invoices/purchases not made through OSCommerce (services, orders via phone, etc.) I'd like to set up an all-in-one solution where orders through OSCommerce are exported to quickbooks...and when the customer logs in they can view their Quickbooks data. If I have to manually import the data into Quickbooks that's fine...but I would really like a real-time solution that reads right from the Quickbooks database for the Customer Self-Service portion.

 

It's a hassle having customers call and ask about their account balance or asking for copies of their invoices for services and products that weren't ordered online and they are always confused as to why this data isn't available to them online.

Quickbooks just isn't designed for this. As far as I know there isn't a product that does what you want, but you might check through the Add-ons at http://marketplace.intuit.com

 

There are products that can connect to the QB database from the web using the QB-SDK, so I'd think it would theoretically be possible for someone to write something if it doesn't exist.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

I really appreciate your response. We also use a program called ACCTivate! that piggybacks on Quickbooks...and they offer an add-on that would do the basic features of what I want but I can't justify the $1000 at this time for something so basic. I was hoping there was another solution that I could do more with.

 

My ultimate goal is simply to tie Customer Self-Service and osCommerce into a single login for all customers. The accounting portion is more important than the osCommerce portion since osCommerce sales will be put into Quickbooks anyway.

 

I definitely have a better idea of where I'm at and regardless of which solution I end up using I can almost guarantee your contribution will be involved.

Share this post


Link to post
Share on other sites
Hi, i just installed this and went to admin > catalog > Quickbooks Import QBI

 

and the page has this:

 

Quickbooks Import QBI

 

Database table upgrades successfull. Now you must go to the configuration page.

1) Recheck your configuration options and configure new options.

2) Click "Update" at the bottom of the page.

Note: You must click update to finish the upgrade, even if you did not change any settings!

 

Now you must go to the configuration page.

so i clicked on the "Now you must go to the configuration page." which is the link: http://pureg.net/shop/admin/qbi_config.php

 

but nothing happens, the page refreshes and same info

 

can someone please help, thank you

 

I am having the exact same problem along with others many others (based on browsing through these forums). Has anybody come up with a solution for this or are we just dead in the water?

Share this post


Link to post
Share on other sites
I am having the exact same problem along with others many others (based on browsing through these forums). Has anybody come up with a solution for this or are we just dead in the water?

In /catalog/admin/includes/qbi_version.php try commenting out the section "Check if QB Import configured and installed" (lines 33 - 39). Then go to your database and in the qbi_config table set qbi_active to 1. See if this works.

 

Occasionally people have trouble with the installation. QBI 2.10 is 2-1/2 years old and has long been superseded by the 3.x series. When QBI 4.0 is released, which should be fairly soon, I plan to upload a basic version as a free contribution.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
In /catalog/admin/includes/qbi_version.php try commenting out the section "Check if QB Import configured and installed" (lines 33 - 39). Then go to your database and in the qbi_config table set qbi_active to 1. See if this works.

 

Occasionally people have trouble with the installation. QBI 2.10 is 2-1/2 years old and has long been superseded by the 3.x series. When QBI 4.0 is released, which should be fairly soon, I plan to upload a basic version as a free contribution.

 

Thanks,

Adam

 

Many thanks for the quick response! I went ahead and just ran the qbi_0-00_2-10.sql file manually in phpmyadmin and was able to get to the next step.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×