Jump to content
adam5532

QBI Quickbooks Import

Recommended Posts

I'm looking to purchase Quickbooks Pro 2007 - is Quickbooks Import QBI 2.10 compatible with this?

 

Thanks!

Yes, it is.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

hi

after reading the articles in this topic they all seem to be very similar to my error but not exactly the same, if any one could help i would greatly appreciate it.

 

when i'm adding info to my returns page i am getting the error:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'returns', language_id='1'' at line 1

 

REPLACE extra_info SET description='Here you will find all the information you need to return any order you are not 100% satisfied with.

 

We guarantee to refund any item youre not totally - '', name='returns', language_id='1'

 

[TEP STOP]

 

i know why this is, it is the ' character that is causing it, there may be others but i have not investigated them all yet.

 

i am alos using the fck editor

 

thanks Nat

Share this post


Link to post
Share on other sites
hi

after reading the articles in this topic they all seem to be very similar to my error but not exactly the same, if any one could help i would greatly appreciate it.

 

when i'm adding info to my returns page i am getting the error:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'returns', language_id='1'' at line 1

 

REPLACE extra_info SET description='Here you will find all the information you need to return any order you are not 100% satisfied with.

 

We guarantee to refund any item youre not totally - '', name='returns', language_id='1'

 

[TEP STOP]

 

i know why this is, it is the ' character that is causing it, there may be others but i have not investigated them all yet.

 

i am alos using the fck editor

 

thanks Nat

I think you posted this in the wrong forum. This isn't a QBI issue.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Adam, I am trying to install QBI, but when it says please continue to the configuration page, it directs me back to the database tables install screen/button. I have tried re-installing several times. But, I must say that its a great contrib..if I can get it to work

 

 

:)

 

Brent

Share this post


Link to post
Share on other sites
Adam, I am trying to install QBI, but when it says please continue to the configuration page, it directs me back to the database tables install screen/button. I have tried re-installing several times. But, I must say that its a great contrib..if I can get it to work

:)

 

Brent

Did you follow all the steps, including adding the database table definitions to the database_tables.php file?

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
Did you follow all the steps, including adding the database table definitions to the database_tables.php file?

 

Thanks,

Adam

 

 

Yes, I just double-checked to make sure that everything was done correctly. Still non-working.

 

Thanks for the quick reply.

 

Brent

Share this post


Link to post
Share on other sites
Yes, I just double-checked to make sure that everything was done correctly. Still non-working.

 

Thanks for the quick reply.

 

Brent

Are all the database tables, including qbi_config, actually installed, or are they not installed?

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Is there a way to make Quick books and OSC inventory to sync because I sometimes have on the phone orders too.

Share this post


Link to post
Share on other sites

Is there a way to make Quick books and OSC inventory to sync because I sometimes have on the phone orders too.

Share this post


Link to post
Share on other sites

Is there a way to make Quick books and OSC inventory to sync because I sometimes have on the phone orders too.

Share this post


Link to post
Share on other sites
Are all the database tables, including qbi_config, actually installed, or are they not installed?

 

Thanks,

Adam

 

Hi Adam,

I'm having the same issue. Uploaded all the files added the parts that needed to be added. When I go to the admin>catelog>QuickBooks Importer QBI

I get the Success message and it say now go to configuration page. The DataBase was not updated and when I click the configure button it just reloads the same page.

------------------------------

MySQL 5.0.27

PHP 4.4.4

osCommerce 2.2-MS2

------------------------------

 

Thakns,

Share this post


Link to post
Share on other sites
Are all the database tables, including qbi_config, actually installed, or are they not installed?

 

Thanks,

Adam

 

 

Sorry for not being a bit clearer. Yes, the tables were in fact properly installed.

Share this post


Link to post
Share on other sites
Hi Adam,

I'm having the same issue. Uploaded all the files added the parts that needed to be added. When I go to the admin>catelog>QuickBooks Importer QBI

I get the Success message and it say now go to configuration page. The DataBase was not updated and when I click the configure button it just reloads the same page.

------------------------------

MySQL 5.0.27

PHP 4.4.4

osCommerce 2.2-MS2

------------------------------

 

Thakns,

I'm not quite following. Were the database tables in fact installed? Were you able to go to the configuration page? If so, did you click on Update at the bottom of the page to activate QBI?

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
Is there a way to make Quick books and OSC inventory to sync because I sometimes have on the phone orders too.

QB inventory will always be correct. You will have to adjust the osC inventory if you do off-line orders, and when you purchase more inventory.

 

The ability to automatically sync osC is planned for QBI 4.0, due in a few months.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
I'm not quite following. Were the database tables in fact installed? Were you able to go to the configuration page? If so, did you click on Update at the bottom of the page to activate QBI?

 

Thanks,

Adam

 

 

No the tables did not install. It never asked if I wanted to install. When the page loaded it said install successfull and shows the text link to get to the configuration page. If I click on the link it just refreshed the page.

Share this post


Link to post
Share on other sites
I'm not quite following. Were the database tables in fact installed? Were you able to go to the configuration page? If so, did you click on Update at the bottom of the page to activate QBI?

 

Thanks,

Adam

 

 

Adam, he nor I am able to visit the configuration page. When we click the link that would direct us there after installing the tables/databases it loops us back to the install tables button. but if we click that button we get an error.

 

1060 - Duplicate column name 'qbi_imported'

 

ALTER TABLE `orders` ADD `qbi_imported` TINYINT(2) UNSIGNED DEFAULT '2' NOT NULL;

 

[TEP STOP]

 

Thus, we can't get to the configuration page after originally installing the databases/tables.

 

Brent

Share this post


Link to post
Share on other sites
Adam, he nor I am able to visit the configuration page. When we click the link that would direct us there after installing the tables/databases it loops us back to the install tables button. but if we click that button we get an error.

 

1060 - Duplicate column name 'qbi_imported'

 

ALTER TABLE `orders` ADD `qbi_imported` TINYINT(2) UNSIGNED DEFAULT '2' NOT NULL;

 

[TEP STOP]

 

Thus, we can't get to the configuration page after originally installing the databases/tables.

 

Brent

 

 

I do not even get that far. It looks as Brent at least has the database updated. There is not a button or link on my page to update the database, just the success message and the text link to go to the configuration page which only refreshes the page. :blink:

Share this post


Link to post
Share on other sites

I have qbi 2.10 installed and everything seems to be good.

 

I'm trying to import about 5,000 orders and it always times out when I try to download the iif file 'all previous orders'

 

Is there a way I can just import the orders from the year 2007 since that's all I really need? Or put a where clause in there somewhere to only import invoices between 4,500 and 5,000 for example?

 

Thanks!!!

Share this post


Link to post
Share on other sites
Adam, he nor I am able to visit the configuration page. When we click the link that would direct us there after installing the tables/databases it loops us back to the install tables button. but if we click that button we get an error.

 

1060 - Duplicate column name 'qbi_imported'

 

ALTER TABLE `orders` ADD `qbi_imported` TINYINT(2) UNSIGNED DEFAULT '2' NOT NULL;

 

[TEP STOP]

 

Thus, we can't get to the configuration page after originally installing the databases/tables.

 

Brent

Brent,

 

I'm not sure why this is happening, but the free version 2.10c is a very old version of QBI and in occasional cases the automatic installation does not work correctly -- the installation routine was completely rewritten for 3.x and does not have any problems. But to defeat the automatic routine in 2.10:

 

File: /catalog/includes/qbi_version.php

Lines: 34 - 40

Action: Comment out (add // to the beginning of each line)

 

Also, make sure that in the table qbi_config the field qbi_config_active is set to 1.

 

This will defeat QBI's check that the tables are installed and configured, and assuming that they really are installed and the check is just failing to know that, then it should work fine. If, however, your tables (specifically the table qbi_config) were not installed, or the database_tables.php file was not properly updated (to contain the constant QBI_TABLE_CONFIG among other QBI tables), then the check was failing like it is supposed to when something is wrong.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
I have qbi 2.10 installed and everything seems to be good.

 

I'm trying to import about 5,000 orders and it always times out when I try to download the iif file 'all previous orders'

 

Is there a way I can just import the orders from the year 2007 since that's all I really need? Or put a where clause in there somewhere to only import invoices between 4,500 and 5,000 for example?

 

Thanks!!!

There are a few solutions:

 

1) You can increase the time-out in your php.ini file.

2) You can easily add a where clause on the qbi_create.php page by adding another where clause function call after the existing where clause call on line 47

$iif_form->where_clause("date_purchased>2006-12-31");

3) You can write an SQL statement in your MySQL administrator to set the field qbi_imported in the orders table to any number greater than 2 for the orders that you want to exclude.

 

It is best not to try to go back too far when importing orders. If your sales tax rate has changed, or you have deleted any products (don't do that -- always set to Inactive instead of deleting), you will have errors when importing those old orders.

 

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
Brent,

 

I'm not sure why this is happening, but the free version 2.10c is a very old version of QBI and in occasional cases the automatic installation does not work correctly -- the installation routine was completely rewritten for 3.x and does not have any problems. But to defeat the automatic routine in 2.10:

 

File: /catalog/includes/qbi_version.php

Lines: 34 - 40

Action: Comment out (add // to the beginning of each line)

 

Also, make sure that in the table qbi_config the field qbi_config_active is set to 1.

 

This will defeat QBI's check that the tables are installed and configured, and assuming that they really are installed and the check is just failing to know that, then it should work fine. If, however, your tables (specifically the table qbi_config) were not installed, or the database_tables.php file was not properly updated (to contain the constant QBI_TABLE_CONFIG among other QBI tables), then the check was failing like it is supposed to when something is wrong.

 

Thanks,

Adam

 

 

Now the button to install the QBI databases is replaced by an upgrade tables button and when I click it i get the error of "Error: Database upgrade file not found."

 

Still no config page

 

Brent

Share this post


Link to post
Share on other sites
Now the button to install the QBI databases is replaced by an upgrade tables button and when I click it i get the error of "Error: Database upgrade file not found."

 

Still no config page

 

Brent

Brent,

 

I will contact you privately to troubleshoot this further.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Adam,

 

I just installed your contribution and love it so far. I did not have any cliches at all. However when I went to do the import method listed in the directions...I uploaded a lists.iif to store/catalog/admin/qbi_import folder with 777 access and when I clicked on set up products, it said there was no list.iif to import. I have double checked my installation steps (found one mistake) and still have no clue why I can't import the list it describes that I outputed and uploaded to that file. Did I miss something?? I am using 2007 QBI by the way.

Share this post


Link to post
Share on other sites
Adam,

 

I just installed your contribution and love it so far. I did not have any cliches at all. However when I went to do the import method listed in the directions...I uploaded a lists.iif to store/catalog/admin/qbi_import folder with 777 access and when I clicked on set up products, it said there was no list.iif to import. I have double checked my installation steps (found one mistake) and still have no clue why I can't import the list it describes that I outputed and uploaded to that file. Did I miss something?? I am using 2007 QBI by the way.

 

 

nevermine I found out I had version 1.01, so installed 2.10, working now, thanks!!!!!

Share this post


Link to post
Share on other sites
Brent,

 

I'm not sure why this is happening, but the free version 2.10c is a very old version of QBI and in occasional cases the automatic installation does not work correctly -- the installation routine was completely rewritten for 3.x and does not have any problems. But to defeat the automatic routine in 2.10:

 

File: /catalog/includes/qbi_version.php

Lines: 34 - 40

Action: Comment out (add // to the beginning of each line)

 

Also, make sure that in the table qbi_config the field qbi_config_active is set to 1.

 

This will defeat QBI's check that the tables are installed and configured, and assuming that they really are installed and the check is just failing to know that, then it should work fine. If, however, your tables (specifically the table qbi_config) were not installed, or the database_tables.php file was not properly updated (to contain the constant QBI_TABLE_CONFIG among other QBI tables), then the check was failing like it is supposed to when something is wrong.

 

Thanks,

Adam

 

I did as you state above. Now when it loads I am on the down load page with the tabs Create iff, Set up, Match, Configure, About

at the top. I selected "Configure"

and the URL changes to this "...cat2/admin/cat2/admin/qbi_config.php" so I deleted the second set of "cat2/admin/" and the configuration page loads. I enetered all the settings and hit update which just resets the form. Nothing is saved. Am I missing some thing else?

 

Thanks for the help :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×