Jump to content
adam5532

QBI Quickbooks Import

Recommended Posts

I've just installed the Quickbooks contrib on my system and am also having a problem with Frobidden Access'. Sounds similar to your problem.

 

I've looked through the contribs and haven't found one that sounds like what you used.  I would appreciate it if you could pass along then name on the contrib and any specifics about it that would be useful in fixing the problem.

 

Thanks,

Jay

 

Fixed the problem!

 

After more head scratching I looked in Admin and found the fix in my system. Don't know if there was a contrib that had been installed but I did find a section in my Admin screen listed as 'Administrator'. Under it was a section labeled 'File Access' that allowed me to add the 'qbi' files to the store. Then things worked fine.

 

Jay

Share this post


Link to post
Share on other sites

hey adam, I have a question regarding international qbi users. You said that there are problems with the tax system.

 

Well, I thought I could use the Quickbooks US version and set up the tax accordingly. My store is in Germany, so I have a 16% sales tax. Is there no way to set this tax in QB?

 

Also, when are you planning on releasing the zen-cart version?

 

Thanks!

Share this post


Link to post
Share on other sites
hey adam, I have a question regarding international qbi users. You said that there are problems with the tax system.

 

Well, I thought I could use the Quickbooks US version and set up the tax accordingly. My store is in Germany, so I have a 16% sales tax. Is there no way to set this tax in QB?

If you are using one of the Quickbooks US versions then QBI should work, but that is not guaranteed depending on how tax is set up in osC. Try it and let me know.

Also, when are you planning on releasing the zen-cart version?

I am planning on releasing the Zen Cart version at about the same time as the next osC version, which should be in 1 or 2 weeks.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Hi Adam,

 

I had everything working just great - at least for the exporting of customers only into QBKS but all of a sudden the qbi_cust.iif is empty - nothing there!

 

Where would I start looking? The only contrib I've updated is Order Editor, Packing & Invoice formats.

 

Thanks again,

Greg

Share this post


Link to post
Share on other sites
Hi Adam,

 

I had everything working just great - at least for the exporting of customers only into QBKS but all of a sudden the qbi_cust.iif is empty - nothing there!

 

Where would I start looking?  The only contrib I've updated is Order Editor, Packing & Invoice formats.

 

Thanks again,

Greg

That's strange! Something must have been changed. You've opened the iif in Excel and there are no customer entries? But, you should only need to import customers once, as any new customers automatically get imported with their orders. The import customers function is only if you wish to import past customers into QB for historical reasons, and is not needed for importing orders.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Hi Adam,

 

Yes, I thought it was strange too! Nothing in the iif when opened in Notepad, and I checked the dates since my last create file and found no new order/customers were added.

 

I did fool around with shipping text though, but that shouldn't have caused this, would it have?

 

Let me try iif orders, as if you remember I have multiple attributes and it crashes my QBKS.

 

Thanks,

Greg

Share this post


Link to post
Share on other sites
Hi Adam,

 

Yes, I thought it was strange too!  Nothing in the iif when opened in Notepad, and I checked the dates since my last create file and found no new order/customers were added.

When you say nothing, I assume you mean that the headers are all there but there are no detail lines with customers? If it is absolutely completely empty, then that's a different issue. Please clarify.

I did fool around with shipping text though, but that shouldn't have caused this, would it have?

 

Let me try iif orders, as if you remember I have multiple attributes and it crashes my QBKS.

I've corresponded with so many people, it's hard to remember who is who! What problem are you still having with multiple attributes? The latest version supports multiple attributes if they are passed through (not matched).

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Hi,

 

So far I love this, but...

 

Please help an accounting noob, but when I import into QB I get what I set as the NET cost, but how do I get the "Cost of Goods Sold" that seems to just show "0" for all items. Or, I am setup wrong?

 

I thought QB would track:

 

Our cost (Cost of goods?)

Selling Price (Net?)

 

Also, is there anyway to track TAX when you have multible tax zones?

Right now I need to collect tax from SC,RI,CA at different rates.

 

Thank you.


The way of life, and the way we work for you.

Share this post


Link to post
Share on other sites
Hi,

 

So far I love this, but...

 

Please help an accounting noob, but when I import into QB I get what I set as the NET cost, but how do I get the "Cost of Goods Sold" that seems to just show "0" for all items. Or, I am setup wrong?

 

I thought QB would track:

 

Our cost (Cost of goods?)

Selling Price (Net?)

These are things that QB tracks, but osC doesn't. So, if you imported your osC products into QB using the QBI Import Products utility, you need to open each of those products in QB and fill in the additional information.

Also, is there anyway to track TAX when you have multible tax zones?

Right now I need to collect tax from SC,RI,CA at different rates.

That feature will be added in the future, but currently QBI can only use one tax rate and agency.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Hi Adam,

 

Thank you, but I am still confused, in my products table in osC I have both products_price and products_cost, is QBI only looking at the products_price?

 

Thanks..

 

These are things that QB tracks, but osC doesn't. So, if you imported your osC products into QB using the QBI Import Products utility, you need to open each of those products in QB and fill in the additional information.

 

That feature will be added in the future, but currently QBI can only use one tax rate and agency.

 

Thanks,

Adam


The way of life, and the way we work for you.

Share this post


Link to post
Share on other sites
Hi Adam,

 

Thank you, but I am still confused, in my products table in osC I have both products_price and products_cost, is QBI only looking at the products_price?

I see why you are confused! My products table only has products_price!

 

I am using osC2.2 MS2 CVS snapshot Sept 10, 2003. Either you have a later version that has added this, or you have a contribution that adds this field.

 

If we can clarify how it got there, I could add the cost to the import without too much trouble.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Sorry!, I forgot I added Margin Report v2.56

 

It added these to the tables....

ALTER TABLE `products` ADD `products_cost` DECIMAL( 15, 4 ) DEFAULT '0.0000' NOT NULL AFTER `products_price`;
ALTER TABLE `orders_products` ADD `products_cost` DECIMAL( 15, 4 ) DEFAULT '0.0000' NOT NULL AFTER `products_price`;

 

If you can help me out I would appreciate it.

 

Thanks Adam.

 

I see why you are confused! My products table only has products_price!

 

I am using osC2.2 MS2 CVS snapshot Sept 10, 2003. Either you have a later version that has added this, or you have a contribution that adds this field.

 

If we can clarify how it got there, I could add the cost to the import without too much trouble.

 

Thanks,

Adam


The way of life, and the way we work for you.

Share this post


Link to post
Share on other sites

Hi Adam, for a quick change I did this, can you tell me if that is a ok or bad way for QB? as I said I am not good with QB, we have a member who takes care of the books.

 

changes in qbi_engine.php

$prod_cost=round($myrowpd["products_cost"],2);

added after $prod_price

 

Then modifed this section of $prod_data.="

to look like this:

.ITEM_ASSET_ACCT."\t$prod_cost\t$prod_price\t0\

 

removing .ITEM_COG_ACCT. in place of the cost...

 

Thank you.


The way of life, and the way we work for you.

Share this post


Link to post
Share on other sites
Hi Adam, for a quick change I did this, can you tell me if that is a ok or bad way for QB? as I said I am not good with QB, we have a member who takes care of the books.

 

changes in qbi_engine.php

$prod_cost=round($myrowpd["products_cost"],2);

added after $prod_price

 

Then modifed this section of $prod_data.="

to look like this:

.ITEM_ASSET_ACCT."\t$prod_cost\t$prod_price\t0\

 

removing .ITEM_COG_ACCT. in place of the cost...

 

Thank you.

Not correct. The item detail lines need to match the headers, so QB knows what it is looking at. ITEM_COG_ACCT should not be changed. If you look at the header after the line

 

// iiif header

 

you'll see that COST follows right after PRICE. So, you'll want to replace the 0 after price so it reads

 

\t$prod_price\t$prod_cost\t

 

instead of

 

\t$prod_price\t0\t

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Thank you sir :) , I was not sure what the heck the COGS was all about :)...


The way of life, and the way we work for you.

Share this post


Link to post
Share on other sites

Did this get worked out, I am having the same issue only with payments.iif

 

Warning: Invalid argument supplied for foreach()

qbi_functions.php on line 611

 

Thanks.

 

Having a problem with importing the payment method list.

When I upload the payments.iif and then go into QBI Admin-->Set Up-->Payment.

I see "Found iif import file. Import now?" and then I click the Import button?

I get the following error message:

Warning: array_diff(): Argument #1 is not an array in /public_html/admin/includes/functions/qbi_functions.php on line 582

 

Warning: Invalid argument supplied for foreach() in /public_html/admin/includes/functions/qbi_functions.php on line 583

Setup successful!

 

If I click the Update Payments Button:

Warning: Invalid argument supplied for foreach() in /home/destinat/public_html/dd-admin/includes/functions/qbi_functions.php on line 611

Any ideas?


The way of life, and the way we work for you.

Share this post


Link to post
Share on other sites
Did this get worked out, I am having the same issue only with payments.iif

 

Warning: Invalid argument supplied for foreach()

qbi_functions.php on line 611

 

Thanks.

I will be adding better error checking in the next version to avoid the php error and give a more useful message to correct the problem.

 

The error "Invalid argument supplied for foreach()" happens because your import file doesn't contain the expected QB information. (It will also happen in the match screen if you try to match but haven't done set-up yet.)

 

In this case, make sure that you checked "payment methods" when you made the QB export file.

 

If you really did name the file payments.iif, then this is your problem. The file name should be payment.iif (no S). If you named it incorrectly, and had also uploaded items.iif or lists.iif, then QBI is actually reading one of those files and isn't finding the payment methods in them.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

(Sorry if this is a double post. I tried to post this yesterday and I'm not sure what happened.)

 

 

Adam, thanks so much for this great contributions, thanks for the documentation and thanks for your ongoing support on this thread.

 

I just realized that Authorize.net is not supported by this contribution yet. I use authorize.net to process the credit card payments on my store. As a reult, when I QBI, my credit card payments are not showing up as pre-paid. So in Quickbooks I get Invoices and not Sales Receipts.

 

I did see that there was a quick hack to fix this, but I also use a Purchase Order contribution. Payments made throught this module are NOT Pre-Paid.

 

Does anyone know of a way that I can get QBI to work properly with Authorize.net and Purchase Orders?? Please.

 

Thanks so very much, jp

Edited by jpepper

Share this post


Link to post
Share on other sites
(Sorry if this is a double post. I tried to post this yesterday and I'm not sure what happened.)

Adam, thanks so much for this great contributions, thanks for the documentation and thanks for your ongoing support on this thread.

 

I just realized that Authorize.net is not supported by this contribution yet.

Authorize.net is definitely supported by QBI -- that's what I use to process my orders.

 

You just need to do the Payments:Set Up and Payments:Match in QBI, and set it as a Prepaid Payment in Payments:Set Up and then it will be imported as a Sales Receipt.

 

Import your QB payment methods into QBI as instructed in the manual. In Set Up, you will then see the payment methods you have set up in Quickbooks. If you don't already have a method for Authorize.net, you should add something like "Authorize.net" or "Credit Card Online" before importing. Set this as a "Prepaid Online" method. Then, in match, match it to "Credit Card Via Authorize.net."

 

In Config, make sure that Payments:Import Payments is set to "As Sales Receipt."

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
Does anyone know of a way that I can get QBI to work properly with Authorize.net and Purchase Orders?? Please.

 

Thanks so very much, jp

Forgot to add:

 

Do the same Set Up and Match for Purchase Orders, but set it as "Not Prepaid." Purchase orders will then import as Invoices and you will record the payment in QB when it is received.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Hi Adam,

 

Any news on the contents/features added or updated for QBI's next release?

 

Specifically UK Support? As we are in limbo not being able to link oSc to QB.

 

Thanks

Andy


Literally, Laterally Thinking! If you cannot get through it, go round it.

Share this post


Link to post
Share on other sites

Thanks again Adam. I apologize. I went back last night and re-read the documentation and noticed that Authorize.net is supported. I think I have QBI configured correctly. Here are what seem to be the relevant settings:

 

QBI version 2.02

 

Configure:

Invoice terms paid online: Credit Card

Invoice terms no prepaid: Net 30

Import payments: As Sales Receipt

 

Set Up > Payment:

American Express: Paid online

Cash: Not prepaid

Check: Not prepaid

Credit Card: Paid online

Discover: Paid online

MasterCard: Paid online

Visa: Paid online

 

Match > Payment

Cash on Delivery: Cash

Check/Money Order: Check

Credit Card: Credit Card

Purchase Order: (*No Set)

Visa, MasterCard or American Express**: Credit Card

 

* Purchase Order is not set because we don't have a payment method for purchase orders. Purchase order orders are in reality paid in the future with a check. Should we still create a payment method called 'Purchase Orders'? I don't think this is my problem with credit card orders though.

 

** 'Visa, MasterCard or American Express' -- This is my authorize.net module. I changed the text in the module so it would read 'Visa, MasterCard or American Express' instead of Authorize.net.

 

Here is a record from a credit card payment from the IIS file. I have changed the personal data for security purposes:

 

!CUST NAME BADDR1 BADDR2 BADDR3 BADDR4 BADDR5 SADDR1 SADDR2 SADDR3 SADDR4 SADDR5 PHONE1 PHONE2 FAXNUM EMAIL NOTE CONT1 CONT2 CTYPE TERMS TAXABLE TAXITEM LIMIT RESALENUM REP COMPANYNAME SALUTATION FIRSTNAME LASTNAME

CUST Smith-41 Michael Smith 300 Maple Lane New York NY 11111 Michael Smith 300 Maple Lane New York NY 11111 212-111-1111 smith@email.net Michael Smith Net 30 N sales tax Michael Smith

!TRNS TRNSID TRNSTYPE DATE ACCNT NAME CLASS AMOUNT DOCNUM MEMO CLEAR TOPRINT ADDR1 ADDR2 ADDR3 ADDR4 ADDR5 SADDR1 SADDR2 SADDR3 SADDR4 SADDR5 NAMEISTAXABLE TERMS SHIPVIA REP FOB INVMEMO PAYMETH PONUM

!SPL SPLID TRNSTYPE DATE ACCNT NAME CLASS AMOUNT DOCNUM MEMO CLEAR QNTY PRICE INVITEM TAXABLE PAYMETHOD EXTRA

!ENDTRNS

TRNS INVOICE 03/16/2005 Accounts Receivable Smith-41 77.85 34-web N Y Michael Smith 300 Maple Lane New York NY 11111 Michael Smith 300 Maple Lane New York NY 11111 N Net 30 Method not set 34-web

SPL INVOICE 03/16/2005 Sales:Kits -64.95 Kit Combination N -1 64.95 KIT300HT N

SPL INVOICE 03/16/2005 N

SPL INVOICE 03/16/2005 Postage and Delivery -12.9 Shipping N -1 12.9000 Shipping N

SPL INVOICE 03/16/2005 Sales Tax Payable Division of Taxation, NY 0 N 6% sales tax N AUTOSTAX

ENDTRNS

Edited by jpepper

Share this post


Link to post
Share on other sites
Thanks again Adam. I apologize. I went back last night and re-read the documentation and noticed that Authorize.net is supported. I think I have QBI configured correctly. Here are what seem to be the relevant settings:

...

 

Visa, MasterCard or American Express**: Credit Card

 

* Purchase Order is not set because we don't have a payment method for purchase orders. Purchase order orders are in reality paid in the future with a check. Should we still create a payment method called 'Purchase Orders'? I don't think this is my problem with credit card orders though.

QBI will show all payment modules in osC, including those that are not enabled. If you don't have it enabled as a payment option, then there is no need to match it.

** 'Visa, MasterCard or American Express' -- This is my authorize.net module. I changed the text in the module so it would read 'Visa, MasterCard or American Express' instead of Authorize.net.

This might have to do with the problem. QBI is not finding a match, and is therefore not recognizing it as pre-paid.

 

Go to your Orders table, and look at the coumn field labeled payment_method. Is the text for your credit card orders exactly 'Visa, MasterCard or American Express'?

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
Hi Adam,

 

Any news on the contents/features added or updated for QBI's next release?

 

Specifically UK Support? As we are in limbo not being able to link oSc to QB.

 

Thanks

Andy

Features already added to the next version (not released yet) so far include:

Matching to noninventory and services (as well as inventory).

Products export as noninventory and services (as well as inventory).

Default product option (for non-matched items).

Rewrite of the product import engine to properly import products with up to 2 levels of attributes (3 and 4 will be added later).

iif creation options of New, Previous, and All products (like orders).

Log file creation option to help in troubleshooting.

CSS styles for all elements and prettier screens.

Menus moved off of pages into an include file.

Misc bug fixes.

Misc instruction manual revisions.

Still to do for this release:

Eliminate php "array" errors, provide more feedback for set-up and match errors.

This version will also be ported to Zen Cart and released at the same time there.

 

Priorities after the next version is released will include International versions and US multiple tax rates.

 

Unfortunately, paying work has to come first, but I fit in work on QBI as I can. I worked on it 1-1/2 days last weekend. I keep saying one or two more weeks, but I've said that for a while now! I'll do the best I can to get the next version out in not too much longer.

 

If you wish to donate towards a particular feature or international version, please contact me by email or by private forum message.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
Go to your Orders table, and look at the coumn field labeled payment_method. Is the text for your credit card orders exactly 'Visa, MasterCard or American Express'?

 

Thanks Adam. Here are the two payment methods that show up in the orders table:

 

"Visa, MasterCard or American Exp"

 

and

 

"Purchase Order"

 

What should I change in QBI to match "Visa, MasterCard or American Exp" as a credit card order?

 

Thanks again so very much.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×