Jump to content
adam5532

QBI Quickbooks Import

Recommended Posts

Hi! Adam,

Can you show me how to convert the importing format from invoice to the sales order!

many thanks!

T.

1) Choose the sales order option for paid orders in the config

2) Set up and match the payment methods

3) Indicate in the payment setup which methods are paid online

 

You can not import sales orders if it is not paid online, as sales orders always have to have a payment. More details are in the instruction manual.

 

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
is this module limited to the Quickbooks 2004 PRO version or are newer versions supported as well? what about international versions?

Quickbooks Pro 2005 is supported (that's what I'm using now).

 

International versions are not supported, because the tax systems are different. They will be added in the future.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

hey adam

 

i just redid my whole store but i noticed something.. when i instaleld the contrib the new orders don't get counted to the "new orders" but nistead it goes to "previous orders" Is it a known issue?

 

Overall i can't d/l new orders unless i d/l all previous ones

Share this post


Link to post
Share on other sites
hey adam

 

i just redid my whole store but i noticed something.. when i instaleld the contrib the new orders don't get counted to the "new orders" but nistead it goes to "previous orders" Is it a known issue?

 

Overall i can't d/l new orders unless i d/l all previous ones

What do you mean by "redid?" If you reinstalled the osC tables, then you are probably missing the qbi_imported field that gets added to the orders table when you install QBI. This is necessary so QBI knows what is new and what has been downloaded. Look in the SQL file with QBI to get the exact syntax.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
What do you mean by "redid?" If you reinstalled the osC tables, then you are probably missing the qbi_imported field that gets added to the orders table when you install QBI. This is necessary so QBI knows what is new and what has been downloaded. Look in the SQL file with QBI to get the exact syntax.

 

Thanks,

Adam

 

well the outside wise like looks.. admin section is all the same. the order table still has the qbi_imported sql in there. also i notcied that if i d/l NEW orders i dont' get an out of balance error. but previous orders i do. would you know why by any chance?

 

taxes are the same CA Only. my store is very basic

Share this post


Link to post
Share on other sites

Sorry but.. i looked at the iff file and i noticed only the orders w/ the - sign get imorted correctly but i dont' THINK the others do. Does that have to do w/ grouped or non-grouped items? also what does group/non grouped items mean?

 

thanks

Share this post


Link to post
Share on other sites

Hello:

 

The problem is that QBI doesn`t read or reconoice the IIF files in the import folder.

 

I has change the modes of this folder to 777, and some another things recomended in this forum but nothing happend.

 

If some one of you know a forum were I can find the solution will be great or if some body can give a hand I`ll appreciate it a lot.

 

Thanks adam5532

Share this post


Link to post
Share on other sites
Hello:

 

The problem is that QBI doesn`t read or reconoice the IIF files in the import folder.

 

I has change the modes of this folder to 777, and some another things recomended in this forum but nothing happend.

 

If some one of you know a forum were I can find the solution will be great or if some body can give a hand I`ll appreciate it a lot.

 

Thanks adam5532

Do you mean the output folder? The output folder is where the iif files are put for downloading. The input folder is for setting up items/shipping/discounts-fees/payments from iif files you generate in QB and import to QBI.

 

Make sure the path is correct:

admin/qbi_output/qbi_orders.iif

 

(and the input folder should be at admin/qbi_input/)

 

If it still doesn't work, then I suspect the problem is not related to QBI, but has to do with your server, permissions, PHP version, osC set up, etc.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
Sorry but.. i looked at the iff file and i noticed only the orders w/ the - sign get imorted correctly but i dont' THINK the others do. Does that have to do w/ grouped or non-grouped items? also what does group/non grouped items mean?

 

thanks

This was a bug in version 2.0 and 2.01. Please upgrade to version 2.02b (just posted) to fix this.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

I've just posted version 2.02b. This corrects the error in the SQL file that was causing the new qbi_disc table to not be added when upgrading from version 1. The only file that has been changed is qbi_1-00_2-02.sql Otherwise, there is no other change.

 

If you already installed version 2.00, 2.01, or 2.02, you need to add the qbi_disc table manually if you haven't already done so. Installing 2.02b will not do that for you (I don't know of any command in MySQL like IF !EXISTS CREATE TABLE -- if anyone knows a way to do this please let me know).

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
I've just posted version 2.02b. This corrects the error in the SQL file that was causing the new qbi_disc table to not be added when upgrading from version 1. The only file that has been changed is qbi_1-00_2-02.sql Otherwise, there is no other change.

 

If you already installed version 2.00, 2.01, or 2.02, you need to add the qbi_disc table manually if you haven't already done so. Installing 2.02b will not do that for you (I don't know of any command in MySQL like IF !EXISTS CREATE TABLE -- if anyone knows a way to do this please let me know).

 

Thanks,

Adam

 

 

mmm.. i added the tables but i dnot' think that was causing the issue. I SEE the errors but i don't know how to fix it in the IFF Files. For eg. it says, "Line in error 33 23 382 596 656..... etc.. they all had no "-" sign below it and those are the ones that are causing the out of balance Errors that i'm getting.

 

 

table.jpg

Edited by superman123

Share this post


Link to post
Share on other sites
mmm.. i added the tables but i dnot' think that was causing the issue. I SEE the errors but i don't know how to fix it in the IFF Files. For eg.  it says, "Line in error 33 23 382 596 656..... etc..  they all had no "-" sign below it and those are the ones that are causing the out of balance Errors that i'm getting.

table.jpg

The blank line is normal -- that is inserted before shipping to create a blank line on the invoice. What's wrong though is that your sale item is missing. What item did the customer buy in order 79? How is that different that the item bought in 78 and 80?

 

Also, in the future, do not post customer information in the forum -- x out any personal information, or send me the iif to my email.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
The blank line is normal -- that is inserted before shipping to create a blank line on the invoice. What's wrong though is that your sale item is missing. What item did the customer buy in order 79? How is that different that the item bought in 78 and 80?

 

Also, in the future, do not post customer information in the forum -- x out any personal information, or send me the iif to my email.

 

Thanks,

Adam

 

 

thanks for the headsup for the info stuff. He bought a Microsoft Keyboard. Do you know why the sales item is missing? And how can i fix it? The sales item is missing on more than one instance such as this one.

Edited by superman123

Share this post


Link to post
Share on other sites
thanks for the headsup for the info stuff.  He bought a Microsoft Keyboard. Do you know why the sales item is missing? And how can i fix it?  The sales item is missing on more than one instance such as this one.

It looks like the Sony 1.44 Floppy Drive is showing up, but the Microsoft Keyboard isn't. Can you identify what the difference is between them? Do either of them have attributes? Is either of them "matched" in QBI, or do you import them as-is with the same part number.

 

Is your store multilingual? Did all those customers order using the same language? Do you have your products set up in all the languages?

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
It looks like the Sony 1.44 Floppy Drive is showing up, but the Microsoft Keyboard isn't. Can you identify what the difference is between them? Do either of them have attributes? Is either of them "matched" in QBI, or do you import them as-is with the same part number.

 

Is your store multilingual? Did all those customers order using the same language? Do you have your products set up in all the languages?

 

Thanks,

Adam

 

oh NM.. i figured it out. These products when i first started my company back then are products that i dont' sell anymore and i took them off the site. i was trying to look for something all the errors had in common and what it is that they don't exist in my products list anymore.

 

Therefore, If you have orders lets say from a yr ago or any day and you erased it from your catalog and try to import.. there won't be any product to input when it createes the file. it creates the file anyway but w/o the item and that will cause quickbooks to give you the tranasaction balance error.

 

btw.. i don't use any other language than english

 

Thanks adam

Share this post


Link to post
Share on other sites
oh NM.. i figured it out. These products when i first started my company back then are products that i dont' sell anymore and i took them off the site. i was trying to look for something all the errors had in common and what it is  that they don't exist in my products list anymore.

 

Therefore, If you have orders lets say from a yr ago or any day and you erased it from your catalog and try to import.. there won't be any product to input when it createes the file. it creates the file anyway but w/o the item and that will cause quickbooks to give you the tranasaction balance error.

 

btw.. i don't use any other language than english

 

Thanks adam

Yup, that will do it! In the future, you can set old products to Inactive instead of deleting them, although there probably isn't a reason to have to import them again.

 

I will in the future add some more error checking, so that if a product doesn't exist you'll get a useful error message.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Having a problem with importing the payment method list.

When I upload the payments.iif and then go into QBI Admin-->Set Up-->Payment.

I see "Found iif import file. Import now?" and then I click the Import button?

I get the following error message:

Warning: array_diff(): Argument #1 is not an array in /public_html/admin/includes/functions/qbi_functions.php on line 582

 

Warning: Invalid argument supplied for foreach() in /public_html/admin/includes/functions/qbi_functions.php on line 583

Setup successful!

 

If I click the Update Payments Button:

Warning: Invalid argument supplied for foreach() in /home/destinat/public_html/dd-admin/includes/functions/qbi_functions.php on line 611

 

 

Any ideas?


"There is no doubt about precisely when folks began racing each other in automobiles. It was the day they built the second automobile." - Richard Petty

Share this post


Link to post
Share on other sites
Having a problem with importing the payment method list.

When I upload the payments.iif and then go into QBI Admin-->Set Up-->Payment.

I see "Found iif import file. Import now?" and then I click the Import button?

I get the following error message:

Warning: array_diff(): Argument #1 is not an array in /public_html/admin/includes/functions/qbi_functions.php on line 582

 

Warning: Invalid argument supplied for foreach() in /public_html/admin/includes/functions/qbi_functions.php on line 583

Setup successful!

 

If I click the Update Payments Button:

Warning: Invalid argument supplied for foreach() in /home/destinat/public_html/dd-admin/includes/functions/qbi_functions.php on line 611

Any ideas?

I will fix the cryptic error messages in the next version.

 

But the reason you are getting the errors is likely because no payments were found. If the payments are imported successfully, you should see a list of your QB payment methods after hitting the import button. The "Setup Successful" message just means it read the file, not that it found anything (I'll fix this too!).

 

Open your payments.iif file and make sure that it actually has your QB payment methods listed in it.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Adam,

This is the contents of my payments.iif file

 

!HDR PROD VER REL IIFVER DATE TIME ACCNTNT ACCNTNTSPLITTIME

HDR QuickBooks Pro Edition Version 12.0D Release R9P 1 2005-02-25 1109374760 N 0

!PAYMETH NAME REFNUM TIMESTAMP HIDDEN

PAYMETH Cash 1 1065654687 N

PAYMETH Check 2 1065654687 N

PAYMETH Money Order 8 1066187635 N

PAYMETH PayPal 7 1065670051 N

 

 

 

This means that I do have payment methods, right?

 

If I go into go into QBI Admin-->Match-->Payment the drop-down box under the Quickbooks column is empty.

 

Also, when I import the qbi_orders.iif, there is a space after the entrys on the invoice. How do I get rid of that?


"There is no doubt about precisely when folks began racing each other in automobiles. It was the day they built the second automobile." - Richard Petty

Share this post


Link to post
Share on other sites
Adam,

This is the contents of my payments.iif file

 

!HDR PROD VER REL IIFVER DATE TIME ACCNTNT ACCNTNTSPLITTIME

HDR QuickBooks Pro Edition Version 12.0D Release R9P 1 2005-02-25 1109374760 N 0

!PAYMETH NAME REFNUM TIMESTAMP HIDDEN

PAYMETH Cash 1 1065654687 N

PAYMETH Check 2 1065654687 N

PAYMETH Money Order 8 1066187635 N

PAYMETH PayPal 7 1065670051 N

This means that I do have payment methods, right?

 

If I go into go into QBI Admin-->Match-->Payment the drop-down box under the Quickbooks column is empty.

 

Also, when I import the qbi_orders.iif, there is a space after the entrys on the invoice. How do I get rid of that?

It looks totally fine. Were you able to successfully import your products, shipping methods, discounts/fees etc? Check that the permissions are set to CHMOD 777 for the input folder and this file and let me know. I suspect it is not able to read it for some reason.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

All the other lists import just fine. Permissions are OK. Tried importing multiple times.


"There is no doubt about precisely when folks began racing each other in automobiles. It was the day they built the second automobile." - Richard Petty

Share this post


Link to post
Share on other sites

I am sorry to pick up on an old issue. I hope you got the issue resolved for the German language id. It would be nice if you could post how you resolved the problem. I also do show empty drop downs. Thanks and congrats to your great job!

 

look the pic is it Normal ?

 

and when I activate TAX that does not export the TAX??

!INVITEM	NAME	INVITEMTYPE	DESC	PURCHASEDESC	ACCNT	ASSETACCNT	COGSACCNT	PRICE	COST	TAXABLE	PAYMETH	TAXVEND	TAXDIST	PREFVEND	REORDERPOINT	EXTRA

INVITEM 2x2cabel INVENTORY Adapter OBD2 auf 2x2 Adapter OBD2 auf 2x2 8400 7140 8980 17.16 0 Y     

INVITEM AK 2180 INVENTORY D-SUB Verl?ngerung, 1:1, 9-pol., BU/BU, 1,8m D-SUB Verl?ngerung, 1:1, 9-pol., BU/BU, 1,8m 8400 7140 8980 2.5 0 Y     

INVITEM AK 230 INVENTORY D-SUB Verl?ngerung, 1:1, 9-pol., ST/BU, 1,8m D-SUB Verl?ngerung, 1:1, 9-pol., ST/BU, 1,8m 8400 7140 8980 4.22 0 Y     

INVITEM AK 234 INVENTORY D-SUB Verl?ngerung, 1:1, 9-pol., ST/BU, 5m D-SUB Verl?ngerung, 1:1, 9-pol., ST/BU, 5m 8400 7140 8980 4.3 0 Y     

INVITEM Benz cable INVENTORY Benz Kabel Benz Kabel 8400 7140 8980 17.16 0 Y     

INVITEM BENZ-38P INVENTORY BENZ-38P BENZ-38P 8400 7140 8980 25 0 Y     

INVITEM BMW cable INVENTORY BMW cable BMW cable 8400 7140 8980 17.16 0 Y     

INVITEM BMW-20P INVENTORY BMW-20P BMW-20P 8400 7140 8980 25.85 0 Y     

INVITEM C-BMW INVENTORY Adapter-BMW Adapter-BMW 8400 7140 8980 11.98 0 Y     

INVITEM CAB4100 INVENTORY CAB4100 CAB4100 8400 7140 8980 861.21 0 Y     

INVITEM carcode INVENTORY BLAUPUNKT UND FORD AUTO RADIO CODE FINDER BLAUPUNKT UND FORD AUTO RADIO CODE FINDER 8400 7140 8980 162.93 0 Y     

INVITEM carpc INVENTORY abidig Kompletette Auto Computer mit 7 abidig Kompletette Auto Computer mit 7 8400 7140 8980 775 0 Y     

annt.jpg

[right][post=515290]<{POST_SNAPBACK}>[/post][/right]

Share this post


Link to post
Share on other sites

Hmm.. Please help me understand your instructions a little better. Do I understand you right, that each product in osc needs to be matched with quickbooks items? Or, can I just download all products from osc and import them in quickbooks? I tried downloading the products and importing them, but they don't show up under the items. Also strange, the product import on osc worked, but they won't show up to be matched. Is it language specific, the product upload to osc? My default language is 2.

Share this post


Link to post
Share on other sites
All the other lists import just fine. Permissions are OK. Tried importing multiple times.

Hmmm. Could you please send me your paymeth.iif file by private email and I'll try importing it into mine copy and see if I can duplicate the error.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites
Hmm.. Please help me understand your instructions a little better. Do I understand you right, that each product in osc needs to be matched with quickbooks items? Or, can I just download all products from osc and import them in quickbooks? I tried downloading the products and importing them, but they don't show up under the items. Also strange, the product import on osc worked, but they won't show up to be matched. Is it language specific, the product upload to osc? My default language is 2.

It looks like you are still using version 1.0 or 1.01. Version 2.02b is much better and has fixed a lot of problems. It also has a much better manual (18 pages!) that will help explain the matching better.

 

I suggest that you upgrade to version 2.02b and then let me know if you still have a problem.

 

I received a couple of German translations for version 1, but since I changed a lot in version 2.0, I didn't include them since I don't speak German and wasn't able to make those changes. If anyone has an updated German translation I would be glad to include it with the next release.

 

Thanks,

Adam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×