Jump to content
Sign in to follow this  
anatolius

Easy Populate : cannot upload

Recommended Posts

Hello,

 

InstalledEasyPopulate v2_74_MS2_1.

I can download file and open it with Excel (text format with tabs).

I delete all the products from admin panel and I upload the file I previously downloaded without any modification, but nothing will be imported.

 

In the admin panel, I get the following message:

 

Easy Populate 2.74-MS2 - Default Language : Fran?ais(1)

 

File uploaded.

Temporary filename: /tmp/phpkj6N2c

User filename: EP2004Dec24-0909.txt

Size: 3189

 

and in httpd log:

 

[client 192.168.0.101] PHP Warning:  move_uploaded_file(/var/www/html/catalog//catalog/temp/EP2004Dec24-0909.txt) [<a href='function.move-uploaded-file'>function.move-uploaded-file</a>]: failed to open stream: No such file or directory in /var/www/html/catalog/admin/easypopulate_functions.php on line 32, referer: http://192.168.0.200/catalog/admin/easypopulate.php?split=0

 

[client 192.168.0.101] PHP Warning:  move_uploaded_file() [<a href='function.move-uploaded-file'>function.move-uploaded-file</a>]: Unable to move '/tmp/phpPsMmR5' to '/var/www/html/catalog//catalog/temp/EP2004Dec24-0909.txt' in /var/www/html/catalog/admin/easypopulate_functions.php on line 32, referer: http://192.168.0.200/catalog/admin/easypopulate.php?split=0

 

[client 192.168.0.101] PHP Warning:  file(/var/www/html/catalog//catalog/temp/EP2004Dec24-0909.txt) [<a href='function.file'>function.file</a>]: failed to open stream: No such file or directory in /var/www/html/catalog/admin/easypopulate.php on line 657, referer: http://192.168.0.200/catalog/admin/easypopulate.php?split=0

 

[client 192.168.0.101] PHP Warning:  Invalid argument supplied for foreach() in /var/www/html/catalog/admin/easypopulate.php on line 680, referer: http://192.168.0.200/catalog/admin/easypopulate.php?split=0

 

Thanks for your help.


Pierre

 

MS2 Fr - Easy Populate - Main Categories - Colissimo suivi - Send order html email - Box Image Thema - admin : copy, move and delete multiple products - Add new Fields - Featured Products - Ultimate SEO URLs - Faster Page Loads, Less DB queries - Page Cache - Credit Class & Gift Voucher - Specials on Default

Share this post


Link to post
Share on other sites

My /catalog/tmp is already read/writeable (777)


Pierre

 

MS2 Fr - Easy Populate - Main Categories - Colissimo suivi - Send order html email - Box Image Thema - admin : copy, move and delete multiple products - Add new Fields - Featured Products - Ultimate SEO URLs - Faster Page Loads, Less DB queries - Page Cache - Credit Class & Gift Voucher - Specials on Default

Share this post


Link to post
Share on other sites
Hello,

 

InstalledEasyPopulate v2_74_MS2_1.

I can download file and open it with Excel (text format with tabs).

I delete all the products from admin panel and I upload the file I previously downloaded without any modification, but nothing will be imported.

 

In the admin panel, I get the following message:

and in httpd log:

Thanks for your help.

Share this post


Link to post
Share on other sites

Anatolius,

I too have had this problem, searched the database and found little to help. So I had a go myself. Now, while I work in IT (indeed e-procurement), I have little experience with osCommerce but have found that the following is working for me. Where you see 'catalog' in the pathname on the error, I checked and have no physical directory called 'catalog'. I believe this to be a generic name for the top-level directory. So, as my top level directory is 'enteropenevents', I changed the configuration settings in easypopulate.php for $tempdir and $tempdir2, changing 'catalog' to 'enteropenevents'.

 

I can now load ok, hope it works for you.

Share this post


Link to post
Share on other sites

I am also getting file upload errors with easy populate. Is there a soulution to this?

Here is the error I get when attempting to upload:

 

File uploaded.

Temporary filename: /tmp/phpSSJIfH

User filename: EP2004Dec30-1604u.txt

Size: 977

 

Warning: file(): Unable to access /home/virtual/site9/fst/var/www/html/catalog//catalog/temp/EP2004Dec30-1604u.txt in /home/virtual/site9/fst/var/www/html/catalog/admin/easypopulate.php on line 657

 

Warning: file(/home/virtual/site9/fst/var/www/html/catalog//catalog/temp/EP2004Dec30-1604u.txt): failed to open stream: No such file or directory in /home/virtual/site9/fst/var/www/html/catalog/admin/easypopulate.php on line 657

 

Warning: Invalid argument supplied for foreach() in /home/virtual/site9/fst/var/www/html/catalog/admin/easypopulate.php on line 680

 

 

And if I use temp dir. then I get this error:

Easy Populate 2.74-MS2 - Default Language : English(1)

 

 

 

Filename: EP2004Dec30-1604u.txt

 

Warning: file(): Unable to access /home/virtual/site9/fst/var/www/html/catalog//catalog/temp/EP2004Dec30-1604u.txt in /home/virtual/site9/fst/var/www/html/catalog/admin/easypopulate.php on line 675

 

Warning: file(/home/virtual/site9/fst/var/www/html/catalog//catalog/temp/EP2004Dec30-1604u.txt): failed to open stream: No such file or directory in /home/virtual/site9/fst/var/www/html/catalog/admin/easypopulate.php on line 675

 

Warning: Invalid argument supplied for foreach() in /home/virtual/site9/fst/var/www/html/catalog/admin/easypopulate.php on line 680

Share this post


Link to post
Share on other sites

I have this same problem:

 

File uploaded.

Temporary filename: /tmp/phpkj6N2c

User filename: EP2004Dec24-0909.txt

Size: 3189

 

with no import of data.

 

Does anybody know how I can fix it?

 

Ricky

Share this post


Link to post
Share on other sites
Warning: file(): Unable to access /home/virtual/site9/fst/var/www/html/catalog//catalog/temp/EP2004Dec30-1604u.txt in /home/virtual/site9/fst/var/www/html/catalog/admin/easypopulate.php on line 675

 

I'm getting this problem also - I think the problem lies with the duplicate entry here "/catalog//catalog/" - It should just be "/catalog/" I think - but I ain't a programmer and have no idea of where to look to solve this :'(

 

I'm going to look in the contribution support forum

Share this post


Link to post
Share on other sites

here is the official support thread for easypopulate, please post any and all questions/comments there.

also all your questions are answered in the same support thread.

the contribution has not changed, it is all in how you have your system setup.

and most have problems with the document root, thus post your admin/includes/configure.php in the support thread as well as that your temp file settings are in your easypopulate.php file

 

AGAIN POST IN THE OFFICIAL SUPPORT THREAD:

 

http://forums.oscommerce.com/index.php?showtopic=64945


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

OK - its nothing to do with Easy Populate - its to do with your configure.php

 

/catalog/admin/includes/configure.php

 

in this line

 

  define('DIR_FS_DOCUMENT_ROOT', '/home/user/www/public_html/'); // where the pages are located on the server

 

I had it pointing to my oscommerce install like this

 

  define('DIR_FS_DOCUMENT_ROOT', '/home/user/www/public_html/catalog/'); // where the pages are located on the server

 

whereas it should have been as the top line - pointing to my document root only.

 

It worked for me :)

Edited by Tye

Share this post


Link to post
Share on other sites

you will still have problems, as your document root is still not right. search your server info in admin/tools and you will see.

 

easypopulate doesnt work properly unless you have proper definitions.

 

and most change their document root and it doesnt need to be changed from doing the default installation

Edited by Mibble

John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

Sorry for replying again here Mibble - but I thought this was related to this thread.

 

How is my document root still wrong?

 

 

 

 

you will still have problems, as your document root is still not right.  search your server info in admin/tools and you will see.

 

easypopulate doesnt work properly unless you have proper definitions.

 

and most change their document root and it doesnt need to be changed from doing the default installation

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×