Jump to content

Archived

This topic is now archived and is closed to further replies.

imagixx

PHP Problem w/ include_path Please Help Me.

Recommended Posts

Hello All,

 

I'm having a terrible time getting this to work. I'm running PHP Version 4.0.5.

 

When I access either catalog or admin, I get the error:

 

Fatal error: Failed opening required 'includes/languages/.php' (include_path='.:/usr/local/bin/php') in /home3/www/rms-republic/catalog/includes/application_top.php on line 285

 

in admin, the same error, but on line 130

 

With my php.ini vacant for this value, my defaul is: .:/usr/local/lib/php

 

When I add a definition within my php.ini file for

 

include_path = ".:/usr/local/lib/php"

 

My Catalog will work for one or two clicks, but then the same error will shortly reappear.

 

I've changed the path to everything imaginable, accessing php, the catalog, whatever. Sometimes it will work one or two clicks before the error reappears.

 

Now, when I have www.domain.com and I get the error, I can sometimes drop the "www" and access only domain.com, and I'll get the catalog. But then, too, the error reappears after just one or two clicks.

 

Any help would be greatly appreciated.

 

Thanx.

 

Marty >_<

Share this post


Link to post
Share on other sites

I wonder if it is something to do with your language files? The error says

Fatal error: Failed opening required 'includes/languages/.php' 
but it should say something like
Fatal error: Failed opening required 'includes/languages/english.php'
Do you have language files?

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites
I wonder if it is something to do with your language files?  The error saysbut it should say something likeDo you have language files?

 

Jack

 

Thanks Jack. Yes, all my language files are in place. In fact, I can change the reference in my config.php to languages/english and it will work! But, again, only for a short time. Then, at times, it references englishenglish.php, adding the correct english before the .php!!!

 

I think there's something either in PHP or the server reference.

 

Any other suggestions?

 

Thanx again.

 

Martin

Share this post


Link to post
Share on other sites
hmmm

 

by chance are you using Frontpage or your site has frontpage extensions enabled?

 

I don't believe so. But, by experimentation, I can sometimes shuttle between www.domain.com/catalog/ and domain.com/catalog getting pages to work intermittantly before the error occurs. It may be the way apache reads the files. Maybe my Apache did not include include_path in its configuration. I'm checking.

 

Incidentally, the site is http://www.rms-republic.com/catalog

 

If that doesn;t work, try without the www. I notice if I close then re-open my browser, I can get a page. But, after a few clicks, I'm gone.

 

More suggestions are welcome. I like what I see, if only I can get itr working...

 

Thanks.

 

Martin

Share this post


Link to post
Share on other sites

I think that there may be a conflict somewhere with phpBB2, Gallery, phpShop (which I'd like to discontinue) and osCommerce.

 

Any thoughts? Am I on the right track?

 

Thanx.

 

Martin

Share this post


Link to post
Share on other sites

Made good progress. In configure.php, set from mysql to '' as follows:

 

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

 

Now, I can't get to my secure server. Time to go to bed. Another day.

 

Thanx.

Share this post


Link to post
Share on other sites

×