Jump to content
Sign in to follow this  
aslan23

Authorize.Net and cURL Problems

Recommended Posts

I have just installed the cURL contribution. I consistently get the following error from Authorize.Net:

 

There was an unspecified error processing your credit card.

 

My Authorize.Net username and transaction key were copied and pasted from Authorize.Net's email to me.

 

cURL Setup is "Not Compiled" (Windows server)

cURL Path is C:/curl/curl (correct path)

 

Transaction mode is "Test"

Transaction method is "Credit Card"

Processing mode is "Authorize and Capture"

 

Sort order is "1"

Customer Notifications is "false"

 

All credit card types are selected.

 

I am using credit card numbers from your "readme.html"

I am using CVV numbers from my own credit cards because I was getting errors by trying to leave them blank or entering random strings of digits.

 

Any help you can offer will be much appreciated.

 

Best!

 

Randall

Share this post


Link to post
Share on other sites

For some reason, for the first time I am getting this...

 

"The server cannot connect to Authorize.net. Please check your cURL and server settings." in a red bar across the top while in test mode.

 

I have no idea. I was just changing the sort order of Order Totals as my PayPal IPN wasn't discounting coupons or gift vouchers.

Share this post


Link to post
Share on other sites

I get this between confirmation and finished. and now I am clueless on what is going on.

 

now the discount no longer is deducted... like it disappeared. I was adjusting the Order Totals but it shouldn't do all THIS

 

 

 

 

For some reason, for the first time I am getting this...

 

"The server cannot connect to Authorize.net. Please check your cURL and server settings." in a red bar across the top while in test mode.

 

I have no idea.  I was just changing the sort order of Order Totals as my PayPal IPN wasn't discounting coupons or gift vouchers.

Share this post


Link to post
Share on other sites

Access Admin > Tools > Server Information and review the cURL information there to ensure that cURL support is indeed compiled in and you have the correct path.


"Great spirits have always found violent opposition from mediocre minds. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices but honestly and courageously uses his intelligence." - A. Einstein

Share this post


Link to post
Share on other sites

CURL support enabled

CURL Information libcurl/7.10.3 OpenSSL/0.9.6g ipv6 zlib/1.2.1

 

 

Order Total Modules

Modules Sort Order Action

Discount Coupons 740

Gift Vouchers 9 Info

Low Order Fee Info

Shipping 2 Info

Sub-Total 1 Info

Tax 3 Info

Total 900 Info

 

 

THANKS GUYS!!!

 

-Eric (remixstore.com)

Share this post


Link to post
Share on other sites
the normal way of the gv/discount you have reversed.  also note, that if shipping is 2, then you are also giving a discount on shipping.

 

Order Total Modules

Modules Sort Order Action

Discount Coupons 740 Info

Gift Vouchers 760

Low Order Fee Info

Shipping 800 Info

Sub-Total 1 Info

Tax 3 Info

Total 900 Info

 

BETTER? How would you do it ? This thing is killing me. either way... I still get this dang cURL error

Share this post


Link to post
Share on other sites
Access Admin > Tools > Server Information and review the cURL information there to ensure that cURL support is indeed compiled in and you have the correct path.

 

Authorize.net Consolidated v1.7 by Austin519

 

Enable Authorize.net Module

True

 

cURL Setup

Compiled

 

cURL Path

libcurl/7.10.3 OpenSSL/0.9.6g ipv6 zlib/1.2.1

 

Transaction Mode

Test

 

Transaction Method

Credit Card

 

Processing Mode

Authorize And Capture

 

Sort Order Of Display

1

 

Customer Notifications

True

 

Accepted Credit Cards

Mastercard, Visa

 

So, is that what I am supposed to put for the cURL?

Share this post


Link to post
Share on other sites

I reloaded the Authorize.net Consolidated for AIM ? 2004

 

and I did 2 successful MC test transactions... but not in a row. I haven't changed anything else and it gave this error between and after with a different mock account as well

 

"There was an error processing your credit card ():"

Share this post


Link to post
Share on other sites

The path appears to be correct. But we've tried all of these variations:

 

C:/curl/curl

C:\curl\curl.exe

C:/curl/curl.exe

 

All behave the same.

Share this post


Link to post
Share on other sites
which cc did u use?  if the test cc's then that is the error you will receive

Are you saying that we are supposed to receive the error:

There was an unspecified error processing your credit card.

if we have successfully completed a test transaction using one of the test credit card numbers found in the Authorize.net Consolidated Ver. 1.7 contribution's readme.htm???

Share this post


Link to post
Share on other sites

yeah, we are using test CCs but sometimes they go thru... sometimes they don't so i don't think it's that

 

like we can get successful test transactions and have before

 

 

and in response... we do not host our own site. and as far as the php.ini I have no idea. i've never messed with it

Edited by remixstore

Share this post


Link to post
Share on other sites
which cc did u use?  if the test cc's then that is the error you will receive

 

 

The path appears to be correct.  But we've tried all of these variations:

 

C:/curl/curl

C:\curl\curl.exe

C:/curl/curl.exe

 

All behave the same.

 

 

From what I understand if your server has cURL it should say Compiled and then left blank.

Share this post


Link to post
Share on other sites

we're going to try re-installing... there's an update.

 

http://www.oscommerce.com/community/contri...h,authorize.net

 

And fyi...

Any of the following card numbers can be used to run tests on your Authorize.Net account. It must be noted that these are not real card accounts, and will not generate an approval if your account is in live mode. They will return a decline in live mode, and an approval in test mode. Use any expiration date after today unless indicated differently.

 

370000000000002 American Express Test Card

6011000000000012 Discover Test Card

5424000000000015 MasterCard Test Card

4007000000027 Visa Test Card

4012888818888 second Visa Test Card

3088000000000017 JCB Test Expiration Date 0905

38000000000006 Diners Club/ Carte Blanche Test Expiration Date 0905 4222222222222 Visa Error Test

 

The last testing card number is used to generate errors. THIS CARD IS INTENDED TO PRODUCE ERRORS, and should only be used if that is your intent. The system has been designed so that this special test credit card number can be used to generate error responses from Authorize.Net. To cause the system to generate a specific error, send a transaction with the card number 4222222222222, and an amount equal to the number of the error you want the system to return.

 

For example, if a transaction is sent to the system in test mode with a credit card number of 4222222222222, and an amount of 12 dollars, the system will respond with error 12, "Authorization Code is required but is not present"

Share this post


Link to post
Share on other sites

well... after battling with this for DAYS... I think we found the problem. it was with the required fields of our authorize.net settings.

 

Settings and Profile > Payment Form > Form Fields

Share this post


Link to post
Share on other sites
well... after battling with this for DAYS... I think we found the problem. it was with the required fields of our authorize.net settings.

 

Settings and  Profile > Payment Form > Form Fields

 

Can you explain what setting needed to be adjusted, I am getting this mesage "There was an unspecified error processing your credit card" and I am goign nuts trying to find the problem.

 

Thanks.


The way of life, and the way we work for you.

Share this post


Link to post
Share on other sites

Thank you,

 

Just gave that a try and no go, still get "There was an unspecified error processing your credit card." using the test card numbers from A.net...

 

any other ideas?

 

Thanks.

 

try getting a new transaction key


The way of life, and the way we work for you.

Share this post


Link to post
Share on other sites

o u r doing testing, i bypassed that and set it to live, then tested with live credit cards, just reversed the transactions when they went thru.


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

funny I removed thr cURL fix and now that message is gone and it says processed?

Just tried the card number 4222222222222 that should error and get "There was an error processing your credit card (78): (TESTMODE) The card code is invalid"

 

So I take it all is working? but I see no unsetteled transactions in the Authorize.net web screen, is that normal?

 

Thanks again...


The way of life, and the way we work for you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×