Jump to content
Sign in to follow this  
xirocco

CA sales tax is being charged to all orders

Recommended Posts

In a recent osCommerce setup (2.2) we only have to charge sales tax to California customers. The cart is applying CA sales tax to all orders, regardless of where the ship-to address is.

 

Settings:

Tax Zones: California (only one entry showing here - for CA)

Tax Classes: Taxable goods (only entry)

Tax Rates: (only one entry showing here):

Priority: 0

Zone: CA

Tax Rate: 8.25%

 

Config - MyStore: Zone = California

Config - Shipping/Packaging: Zip code is correct for CA location

 

Store URL: http://www.synchronicityshoppe.com

 

Any help would be greatly appreciated.

 

Kevin Mc.

Edited by xirocco

Kevin Mc.

Share this post


Link to post
Share on other sites

I'm in Michigan and am having the same problem.

My settings are the same (Michigan equivalents, obviously).

 

Right now I am furiously scouring this forum, because I have to believe that we aren't the first ones to face this issue.

 

If I find the answer I'll let you know - would you be so kind as to do the same?


cdickson

Share this post


Link to post
Share on other sites

I figured it out:

 

1. Login to your admin area

2. Click on Locations/Taxes

3. Click on Tax Zones

4. On the initial Tax Zone list that shows, where you have entered California should have a file folder icon next to it. The trick is that it goes one level deeper.

5. Click on the file folder - If it isn't set up correctly there should be a display of "Displaying 0 to 0 (of 0 countries)"

6. Click the Insert button

7. The message will read "Please enter the new sub zone information"

8. Choose United States for the Country and California for the Zone

9. Click Insert

 

You should be all set!

Edited by cdickson

cdickson

Share this post


Link to post
Share on other sites
I figured it out:

 

1.  Login to your admin area

2.  Click on Locations/Taxes

3.  Click on Tax Zones

4.  On the initial Tax Zone list that shows, where you have entered California should have a file folder icon next to it.  The trick is that it goes one level deeper.

5.  Click on the file folder - If it isn't set up correctly there should be a display of "Displaying 0 to 0 (of 0 countries)"

6.  Click the Insert button

7.  The message will read "Please enter the new sub zone information"

8.  Choose United States for the Country and California for the Zone

9.  Click Insert

 

You should be all set!

 

OK, I checked my settings again and everything is just like you said it should be, but I still am having tax applied to every order, not just for my state.

 

Any other ideas :blink:


My Favorite Quote from a movie.

 

Question: How do you know women sooo well?

 

Answer: I think of a man, then take away reason and accountability.

Share this post


Link to post
Share on other sites
OK, I checked my settings again and everything is just like you said it should be, but I still am having tax applied to every order, not just for my state.

 

Any other ideas :blink:

 

 

That worked for me too! Thanks.

Share this post


Link to post
Share on other sites

I wish I had your problem. I'm trying to get my shop to charge a tax rate for each of the US fifty states and for three days now have had no luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×