Jump to content
Sign in to follow this  
blurb

Batch Print Center (support thread)

Recommended Posts

hey there, i've posted a fix for this missing print label bug.. you can check out the fix at my blog, i've uploaded the files there.

i basically just modified the print_address function at the bottom of the batch_print.php..

 

have fun! :thumbsup:

 

oyster.collector,

 

If you have found a solution, thank you very much. I came to this thread last year when I was finishing my templates, and I just came back because I was going to give it another go, since it is starting to become boring adding an extra number before what I really want to print. I have the labels template and two more shipping templates based on that one with which I am having this problem, the first record never shows up.

 

But now, on your blog you state: "The main while orders loop in the batch_print.php (line 85) creates the first order object, but when it goes into the Labels.php template file, the print_address function re-creates the order object using the 2nd order already"

 

That is a good hint for me to get started. But heck, why on earth haven't you posted the exact details? Sure, you want to gain some visits on your blog, but you could make it easier for the rest of us. Out of your 3 links, the first two are not working ("Standard" and "Fix for Error 1054"), so I just downloaded the full ZIP file. But of course, my contribution is already heavily modded, so I can nost just wipe all my current templates or even my /admin/batch_print.php without breaking all the contribution, which means I have to play "hide and seek" with whatever code you have changed on your contribution without even knowing on what version it is based for. Hopefully I will find whatever change you have done on print_address quick :D

 

Oh well... No more bugging, will check it out and try to report back with a fix. It amazes me for how long this contribution has had this template broken, I find it so useful that it makes me wonder how can people live without it, or what contribution does everyone else use for their admin printing needs.

 

Thanks!


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites

Oh well, I have been unable to get it to work with more than one page. With the supplied changes on function print_address, it does print ok the first label, it doesn't get skipped any more.

 

BUT... The problem used to be that the first label on each page was missing. If you printed labels 1-30 on a layout that has 10 labels on each page, you would get 2-11 on the first page, 13-22 on second page, and 24-30 on third page. Labels 1,12,23 were missing.

 

With the new changes, the first page will indeed print labels 1-10 as expected, but the next page will be empty :( So I guess some more work will need to be done on this...

 

Edit: The fields o.orders_prefix and h.comments need to be removed from the $orders_query on oyster.collector version, they must belong to some contribution he has added on his store. I just installed all the files from his contribution to make sure there wasn't anything wrong with my templates, and nope, it is not working, only the labels on the first page get printed.

Edited by MindTwist

MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites

So I finally got it fixed, after all. I have to say that even I really like the time this BPC contribution saves me, it would need a major rewrite.

 

The code could hardly become any more complicated even if they were trying to make it so. It doesn't make sense things like that the main batch_print.php will call the template file, which in turn will call again batch_print.php because the print_address function is stored in there. If you use several templates, you will probably need either a more sofisticated print_address, or a different function alltoguether since you will not always print the address the same way. I use BPC for making two different size of labels, and the list with the shipment relations with two different carriers, and on 4 places where I put the customer address, I need a different print_address function.

 

Code like an "if" for knowing if you are the first label and need to create a new page should NOT be on the print_address function. Code for fetching more orders to print labels should NOT be on the print_address function. There are many many things that should be changed on the way this contrib works.

 

And I am not saying it is not useful, you bet it is! Once you have it up and working, it is great. But heck, you surely do not want to be changing anything at all once it is up and working, because it is a pain in the ass from the way the mod is structured.

 

I will try to install later oyster.collector contrib from scratch and post a step by step guide here on the few changes that need to be done.

 

Finally I can print say 50 labels all at a time...!!


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites

I've been using Batch Print Center for a while and something is bugging me (or rather, the person that prints out our order sheets).

 

Any apostrophe characters ( ' ) are printed in the PDF as "'", which looks terrible in words such as Who's ( Who's ) or names like O'Neil ( O'Neil ).

 

I've looked at the templates and can see the Villains and Cools arrays in there, which I assume are supposed to be some kind of Search/Replace option, but if that's what they are, they aren't working for me.

 

Any help would be gratefully received, as this is an excellent contribution!

Share this post


Link to post
Share on other sites

I installed this contribution but don't get more than one label page printed. Instead of a second page with labels just a white page is printed. Does anybody have a solution for this?

Share this post


Link to post
Share on other sites
oyster.collector,

 

If you have found a solution, thank you very much.

 

That is a good hint for me to get started. But heck, why on earth haven't you posted the exact details? Sure, you want to gain some visits on your blog, but you could make it easier for the rest of us. Out of your 3 links, the first two are not working ("Standard" and "Fix for Error 1054")

 

So I finally got it fixed, after all. I have to say that even I really like the time this BPC contribution saves me, it would need a major rewrite.

 

I will try to install later oyster.collector contrib from scratch and post a step by step guide here on the few changes that need to be done.

 

Finally I can print say 50 labels all at a time...!!

 

Hi MindTwist, I hope you can upload the step by step guide here, or you can also upload the whole file as an update. Maybe this saves time for you.

 

Please share your solution with us, the link to the blog isnt working anymore. I have the same problem, always the first number is not printed out.

 

Thank you!

Share this post


Link to post
Share on other sites

LED-Store,

 

I am sorry, I did not have the time to do it one year ago, and I wouldn't even remember what I modified now.

 

I do remember that BPC seemed VERY badly done when I had to take a look. It is a great contribution, but it would need a major rewrite, which I do not think it will happen any time soon (that is, until OSC3 is done, and a OSC3 version comes out).

 

Looking at my own code now, I think I can only give 2 hints that might (or might not) help. On the labels template, I have this line at the beginning:

 

//MINDTWIST puta missing label bug
$pos = 0;

 

And I have modified this IF (where it said $num, now it says $pos). The commented print_r is ther eonly for debuging purposes:

 

	for ($x = STARTX; $x < STARTX + NUM_COLUMNS * LABEL_WIDTH; $x += LABEL_WIDTH){
//print_r('startpos ' . $startpos . ' $pos ' . $pos . ' $num ' . $num . ' $endpos ' . $endpos . ' -- ');	
//		if ($startpos <= $pos && $num < $endpos){
//MINDTWIST sindrome de la pegata desaparecida
	if ($startpos <= $pos && $pos < $endpos){
		if (print_address($x, $y, $num))
			$num++;
	}
	$pos++;
}

 

I am unable to tell if I modified anything on the main module (/admin/batch_print.php) since my version is heavily modified.


MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites

MindTwist,

thank you very much, of course this is helpful for me, I'm already testing your "way". Maybe you can post your function print_address into the batch_print.php, I think then the problem is solved. I would be very grateful for that!!

 

I also can share something, I made this with a friend. If you have different billing and delivery addresses, now it prints both addresses out. Maybe someone can use it, heres the function print_adress:

 

function print_address($x, $y){
global $pdf, $num, $customer, $x, $y;

$pos = $y;
global $orders_query;
if ($orders = tep_db_fetch_array($orders_query)){
$order = new order($orders['orders_id']);
if ($order->delivery['street_address'] == $order->billing['street_address']) {
if ($customer == true) {
$addressparts1 = explode("\n", tep_address_format($order->delivery['format_id'], $order->delivery, 1, '', " \n"));
}else{
$addressparts1 = explode("\n", tep_address_format($order->billing['format_id'], $order->billing, 1, '', " \n"));
}} else {
$addressparts1 = explode("\n", tep_address_format($order->billing['format_id'], $order->billing, 1, '', " \n"));
$addressparts2 = explode("\n", tep_address_format($order->delivery['format_id'], $order->delivery, 1, '', " \n"));
}

//print ("orderID=" . $orders['orders_id'] . "<br>");
//print("DEBUG: inside 1nd addr. - " . "pos = " . $pos . " / y=" . $y . " / x=" . $x . "<br>");

$pdf->addText($x + LABEL_WIDTH - ORDERIDXOFFSET,$y + ORDERIDYOFFSET,ORDERIDFONTSIZE,$orders['orders_id']);

foreach($addressparts1 as $addresspart){

$fontsize = GENERAL_FONT_SIZE;
while ($pdf->getTextWidth($fontsize, $addresspart) > LABEL_WIDTH - (2*STARTX)){
	$fontsize--;
}
//$addresspart = preg_replace("%,[[:space:]]*$%", "", $addresspart);
$pdf->addText($x,$pos -=GENERAL_LINE_SPACING,$fontsize,$addresspart);
}


if (isset($addressparts2)) {
// 2. addr vorhanden !

// prüfen ob eins nach unten verschoben werden muss
if ( $x >= STARTX + (2*LABEL_WIDTH)) {
	// eins nach unten
	$y -= LABEL_HEIGHT;
	// an den Zeilenanfang
	$x = STARTX;
} else {
	$x += LABEL_WIDTH;
}
//	print("DEBUG: inside 2nd addr. - " . "pos = " . $pos . " / y=" . $y . " / x=" . $x . "<br>");

$pdf->addText($x + LABEL_WIDTH - ORDERIDXOFFSET,$y + ORDERIDYOFFSET,ORDERIDFONTSIZE,$orders['orders_id']);

foreach($addressparts2 as $addresspart2){
	$fontsize = GENERAL_FONT_SIZE;

	while ($pdf->getTextWidth($fontsize, $addresspart2) > LABEL_WIDTH - (2*STARTX)){
		$fontsize--;
	}
$pdf->addText($x,$y-=GENERAL_LINE_SPACING,$fontsize,$addresspart2);
}

$num++;

if ($x < STARTX + NUM_COLUMNS * LABEL_WIDTH) {
	$y += LABEL_HEIGHT / 2;
}	
}

} else {
return false;
}

}

Share this post


Link to post
Share on other sites

Maybe its also in this section, in the batch_print.php:

 

if (!tep_db_num_rows($orders_query) > 0) { message_handler('NO_ORDERS'); }
$num = 0;

while ($orders = tep_db_fetch_array($orders_query)) {

 $order = new order($orders['orders_id']);

if ($num != 0) { $pdf->EzNewPage(); }

Share this post


Link to post
Share on other sites

Hope it helps, code is quite messed up...

 

Just one more note, I know there are still things that do not work ok; I think that if you try printing by date, or something like that, it was not working. But I always print labels by numbers, and I have no problem at all, I could print something like 10,12,15,20-27,13,30-44 and all the labels will come out ok.

 

//MINDTWIST - esta funcion imprime UNA pegatina desde el template de pegatinas.
//No se que hace aqui, en lugar de estar en el propio template de las pegatinas :?
function print_address($x, $y, $nums){
global $pdf, $num, $billing;
$pos = $y;
global $orders_query;
global $order;
global $orders;
global $languages_id;
global $HTTP_POST_VARS;

//if ($orders = tep_db_fetch_array($orders_query)){
//$order = new order($orders['orders_id']);
if ($order){

if ($billing == true)
$addressparts = explode("\n", tep_address_format($order->billing['format_id'], $order->billing, 1, '', " \n"));
else
$addressparts = explode("\n", tep_address_format($order->delivery['format_id'], $order->delivery, 1, '', " \n"));


$fontsize = GENERAL_FONT_SIZE + 1;
$pdf->addText($x,$pos -=GENERAL_LINE_SPACING,$fontsize,'<b>Destino:</b>');

$aitor = 0;	
foreach($addressparts as $addresspart){
$fontsize = GENERAL_FONT_SIZE;
while ($pdf->getTextWidth($fontsize, $addresspart) > 260){
	$fontsize--;
}
//$addresspart = preg_replace("%,[[:space:]]*$%", "", $addresspart);
//MINDTWIST BEGIN
//hack guarro, añado IF para que no ponga el Pais en la pegatina del envio, sin tener que modificar nada del address_format del oscommerce
if ($addresspart != 'Spain') {
$pdf->addText($x+5,$pos -=GENERAL_LINE_SPACING,$fontsize,$addresspart);
$aitor = $aitor +1;
//print_r ($addresspart);
}	
//MINDTWIST END
}
//MINDTWIST si la direccion tenia 3 lineas, añadimos una 4a en blanco para no descuadrar etiquetas
if ($aitor == 3) {
  $pdf->addText($x,$pos -=GENERAL_LINE_SPACING,$fontsize,'');
}

//salto una linea mas ya que aqui no hay telefono
  $pdf->addText($x,$pos -=GENERAL_LINE_SPACING,$fontsize,'');

//$pos -=GENERAL_LINE_SPACING;
//

//MINDTWIST
//Aqui posava el FROM de las pegatas.
//Ara ho he pasat a /templates/from.php , de forma q sempre omplo el full de FROMs encara q no siguin 120 pegatas.
//Aqui ja nomes poso el NUMERO DE PEDIDO
//   $fontsize = GENERAL_FONT_SIZE-1;
//   $pdf->addText($x,$pos -=GENERAL_LINE_SPACING,$fontsize,'<b>Remite:</b>');
  $fontsize = GENERAL_FONT_SIZE-4;
  $pdf->addText($x+60,$pos-15,$fontsize,$orders['orders_id']);
//   $fontsize = GENERAL_FONT_SIZE-2;
//   $pdf->addText($x+5,$pos -=13,$fontsize,'Twisted Reality (At. Aitor Fernandez)');
//   $pdf->addText($x+5,$pos -=13,$fontsize,'c/ Rosellon 372, Local');
//   $pdf->addText($x+5,$pos -=13,$fontsize,'Barcelona 08025');

//$pdf->addText($x + LABEL_WIDTH - ORDERIDXOFFSET,$y + ORDERIDYOFFSET,ORDERIDFONTSIZE,$orders['orders_id']);

 if(($nums % NUM_LABELS_PER_PAGE) == (NUM_LABELS_PER_PAGE-1))
 {
$order = false;
return false;
 } else {
if($orders = tep_db_fetch_array($orders_query))
  {
	$order = new order($orders['orders_id']);
	return true;
  } else {
	$order = false;
	return false;
  }
}

 } else {
return false;
 }

}

Edited by MindTwist

MindTwist of Twisted Reality and Twisted Tienda

Share this post


Link to post
Share on other sites

You are the greatest, it works!! :)

 

On the second page the last label is white, and on the third page the error begins again that one label is missing per pagebreak. But I never have more than 2 pages to print. Now the first label appears and the first pagebreak is also good.

 

It works even with my billing and delivery address modification, so feel free to insert into your shop.

 

Thanks,

cosmo

Share this post


Link to post
Share on other sites

I replaced the file and this is waht I get now:

 

0, 'text' => 'None'); while ($orders_status = tep_db_fetch_array($orders_status_query)) { $orders_statuses[] = array('id' => $orders_status['orders_status_id'],'text' => $orders_status['orders_status_name']); } ?> $file,'text' => $filename); } } ?>

 

Also the template pull-down is empty.

 

Thanks, again.

 

I have exactly the same problem. Did you ever find a solution to this?

Share this post


Link to post
Share on other sites

Hi all,

 

I have installed Batch Print Center to the letter (at least I think) but get the following errors:

 

Warning: require(BATCH_PRINT_INCbatch_print_header.php) [function.require]: failed to open stream: No such file or directory in /var/www/admin/batch_print.php on line 140

 

Fatal error: require() [function.require]: Failed opening required 'BATCH_PRINT_INCbatch_print_header.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/admin/batch_print.php on line 140

 

Any ideas? I have double-checked the file locations, but canot see what is wrong. Using Batch Print Center 3.11 01-12-2005.

 

Thanks,

 

Mike

Share this post


Link to post
Share on other sites

OK the plot thickens. I start changing lines on batch_print.php from:

require(BATCH_PRINT_INC . 'batch_print_header.php'');

require(BATCH_PRINT_INC . 'batch_print_body.php');

require(BATCH_PRINT_INC . 'batch_print_footer.php');

to:

require('/var/www/admin/includes/modules/batch_print/batch_print_header.php');

require('/var/www/admin/includes/modules/batch_print/batch_print_body.php');

require('/var/www/admin/includes/modules/batch_print/batch_print_footer.php');

 

and batch_print_body.php from:

$directory = BATCH_PRINT_INC . 'templates';

to:

$directory = '/var/www/admin/includes/modules/batch_print/templates';

 

and I managed to get the form on screen, but it looks odd, all the form fields are not in their friendly names i.e. HEADING_TITLE, TEXT_CHOOSE_TEMPLATE, TEXT_ORDER_NUMBERS_RANGES etc and when I submit the form I get:

 

Not Found

The requested URL /admin/BATCH_PRINT_FILE was not found on this server.

 

So I guess my attempted workaround is no good, has anyone spotted something I am doing wrong?

Edited by a1200

Share this post


Link to post
Share on other sites

Its ok, I've sorted the problem. What it was, the version I downloaded had the file batch_print.php in the languages directory, the variables needed copying and pasting to english.php. Sorted! Now to tidy up the layout of the invoice :)

Edited by a1200

Share this post


Link to post
Share on other sites

HELP! i need to add a field from the PRODUCTS table to the invoice print outs generated by batch print. anyone with better php/mysql and knowledge of this contrib who is able to help it would be greatly appreciated.

Share this post


Link to post
Share on other sites

HELP! i need to add a field from the PRODUCTS table to the invoice print outs generated by batch print. anyone with better php/mysql and knowledge of this contrib who is able to help it would be greatly appreciated.

 

Is there anyone who can help with this request? Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

I have been using Batch Print 2.2 for a long time. We print the Invoices with it and process our own credit cards. I include the CC info on the print. We recently switch our CC processor. WE now need the CCV , when I switch to the CCV module no credit card info prints on the invoice. Is there anyway to fix that? I'd love to keep using it.

 

Ken

Share this post


Link to post
Share on other sites

I replaced the file and this is waht I get now:

 

0, 'text' => 'None'); while ($orders_status = tep_db_fetch_array($orders_status_query)) { $orders_statuses[] = array('id' => $orders_status['orders_status_id'],'text' => $orders_status['orders_status_name']); } ?> $file,'text' => $filename); } } ?>

 

Also the template pull-down is empty.

 

Thanks, again.

 

Hi, did you found solution to your problem. I have the same and I wonder did you and how solved it.

Share this post


Link to post
Share on other sites

Hi, did you found solution to your problem. I have the same and I wonder did you and how solved it.

 

 

Well, I am NOT "serverguy" BUT I accidently self induced the problem.... The problem was induced when I changed a setting the php.ini. The variable was short_open_tag. In php 5.3 these are the developer recommended settings

; Default Value: On

; Development Value: Off

; Production Value: Off

; http://php.net/short-open-tag

 

When I moved it (what I thought was incorrect ) from "ON" as follows

short_open_tag = On

 

to the recommended "OFF" - that stupid problem presented itself...

 

Since I had been working on the deprecated commands also I thought I had caused it with a typo. Have spent the last 4 and half hours copying ALL the files from a backup server. Copying the files DID NOT solve the issue. SO the deprecation fixes were not the problem. Realizing that the only other thing I had worked with was the php.ini I decided to verify from the back up server. Changing the variable above from "OFF" to "ON" in the php.ini solved the problem.

 

Enjoy

 

BJ

Share this post


Link to post
Share on other sites

Hi guys, I'm trying to add the credit card type (visa, m/c etc) to my invoice template but get no joy so far... I'm very new... if anyone can help?

 

I'm using the Moneris Payment API.

 

I have change this code

// payment method  
if ($HTTP_POST_VARS['show_pay_method']) {
$pos = $pdf->ezText("<b>" . ENTRY_PAYMENT_METHOD . "</b> " . str_replace($vilains , $cools, $order->info['payment_method']),GENERAL_FONT_SIZE);

if ($order->info['payment_method'] == PAYMENT_TYPE) {
$pos = $pdf->ezText("<b>" . ENTRY_PAYMENT_TYPE . "</b> " . $order->info['cc_type'],GENERAL_FONT_SIZE);
$pos = $pdf->ezText("<b>" . ENTRY_CC_OWNER . "</b> " . $order->info['cc_owner'],GENERAL_FONT_SIZE);
	if ($HTTP_POST_VARS['show_cc']) {
	$pos = $pdf->ezText("<b>" . ENTRY_CC_NUMBER . "</b> " . $order->info['cc_number'],GENERAL_FONT_SIZE);
	}

	$pos = $pdf->ezText("<b>" . ENTRY_CC_EXP . "</b> " . $order->info['cc_expires'],GENERAL_FONT_SIZE);
}

}
$pos -= SECTION_DIVIDER;

 

To this:

 

// payment method
if ($HTTP_POST_VARS['show_pay_method']) {
$pos = $pdf->ezText("<b>" . ENTRY_PAYMENT_METHOD . "</b> " . str_replace($vilains , $cools, $order->info['payment_method']),GENERAL_FONT_SIZE);

 if (is_array($payment_modules->modules)) {
   if ($confirmation = $payment_modules->confirmation()) {
	$pos = $pdf->ezText("<b>" . ENTRY_PAYMENT_METHOD . "</b> " . $confirmation['title'],GENERAL_FONT_SIZE);
}

}
$pos -= SECTION_DIVIDER;

 

I also had to add an extra "}" at the end of the file (I must have missed it somewhere...but don't konw where)?

 

Anyway... I get nothing from my VERY "newbe" code hack.

 

Thank you in advance.

Share this post


Link to post
Share on other sites

I've got a fix for the missing first label, if anybody needs it.

 

In short, what I did was add a little bit of code to the "print_address" function in /admin/batch_print.php, and set one global variable in /templates/Labels.php, to test which record we were on. And if we were on the first record of the first page, we would reset the cursor in the $orders_query array back to the start.

 

Here are the pieces of code in question - compare them to what you have, and good luck! :)

 

in admin/batch_print.php, ~line 227

 

function print_address($x, $y){
global $pdf, $num, $billing;
$pos = $y;
global $orders_query;
global $no;
global $num;
if ($no == 0 && $num == 0) {
   mysql_data_seek($orders_query, 0);
}
if ($orders = tep_db_fetch_array($orders_query)){
$order = new order($orders['orders_id']);

     if ($billing == true)
       $addressparts = explode("\n", tep_address_format($order->billing['format_id'], $order->billing, 1, '', " \n"));
     else
       $addressparts = explode("\n", tep_address_format($order->delivery['format_id'], $order->delivery, 1, '', " \n"));
     foreach($addressparts as $addresspart){
       $fontsize = GENERAL_FONT_SIZE;
       while ($pdf->getTextWidth($fontsize, $addresspart) > LABEL_WIDTH){
         $fontsize--;
       }
       //$addresspart = preg_replace("%,[[:space:]]*$%", "", $addresspart);
       $pdf->addText($x,$pos -=GENERAL_LINE_SPACING,$fontsize,ucwords(strtolower($addresspart)));
     }
$pdf->addText($x + LABEL_WIDTH - ORDERIDXOFFSET,$y + ORDERIDYOFFSET,ORDERIDFONTSIZE,$orders['orders_id']);
$no++;
} else {
return false;
}

}

 

And in /admin/includes/modules/batch_print/templates/Labels.php, ~line 51

 

Add this --

 

$no = 0;

-- just before this --

 

for($y = $pdf->ez['pageHeight'] - STARTY; $y > LABEL_HEIGHT - STARTY; $y -= LABEL_HEIGHT) {

Share this post


Link to post
Share on other sites

I have exactly the same problem. Did you ever find a solution to this?

 

For everyone getting this error on the Admin area:

 

"0, 'text' => 'None'); while ($orders_status = tep_db_fetch_array($orders_status_query)) { $orders_statuses[] = array('id' => $orders_status['orders_status_id'],'text' => $orders_status['orders_status_name']); } ?> $file,'text' => $filename); } } ?>"

 

Go to:

/admin/includes/modules/batch_print/batch_print_body.php

 

Replace the short tags like: <? with <?php. I think there are 2.

Share this post


Link to post
Share on other sites

Hi,

 

We've been using batch print center for years, quite happily. Now a php 5.3 update has been forced upon us and batch_print doesn't work properly anymore. It is ignoring whatever invoice numbers are entered and complaining about the date entered instead (which we don't use).

 

I've changed all occurances of $HTTP_GET_VARS and $HTTP_POST_VARS to $_GET and $_POST, but it still isn't working. Has anyone kept this contribution up to date?

Share this post


Link to post
Share on other sites

Hi,

 

I've been using the barcode rendering contribution for my manual invoice printing and it really does help a lot. I was wondering if there is any way to add the barcode generated from this contribution into a template from batch-print-centre. Basically I would like the Code39 version of the order number to visible on each batch printed invoices. The insturctions with barcode-render do say to add the following line

 

<td class="main"><IMG SRC="<?php echo 'barcodegen.php?barcode=' . $PHPVARIABLE; ?>"></td>

 

to any files where you want the barcode to appear but I can't seem to get this to work in any of the templates.php files.

 

Any help would be much appreciated.

Thanks guys.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×