Jump to content
Sign in to follow this  
Butch

[Contribution] Advanced Categories Admin

Recommended Posts

It'll be permanently on the top unless you install the contribution or delete the module from admin/includes/modules/categories.

 

Not perfect, should be changed. I add it to my todo list.

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Hi!

 

I am not really sure how to make use of this contribution. Could you please tell me exactly what to do with it? I have STS 4.4 installed and Basic Design Pack and this ACA. Now I want to make use of the Header Tags Controller. I made some changes under the insructions included with STS 4.3.2 with HTC . The only changes that are lacking are the ones for admin/categories.php and admin/manufacturers.php. There's an example for SPPC but did'nt really understand it 100%. I left these lacking changes and waiting for an advise how to make use of the ACA.

 

Thanks!

:rolleyes:

Share this post


Link to post
Share on other sites

When you install HTC, instructions tells you to modify admin/categories.php in many places. If you have ACA, just take the modules and enable them. No need to make any modifications into categories.php. The idea of ACA is to not modify categories.php for each contribution you want to install.

 

ACA has nothing to do with STS.


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites
When you install HTC, instructions tells you to modify admin/categories.php in many places. If you have ACA, just take the modules and enable them. No need to make any modifications into categories.php. The idea of ACA is to not modify categories.php for each contribution you want to install.

 

ACA has nothing to do with STS.

I am having problems with header tags controller, about permission warnings with page control and text control, not with fill tags. I tried setting to 755 and 777, the same permission problems. I had made also the changes for osc 060817. Here is what I did.

At first I did use the HTC contribution files. Since I got a problem in the middle of installation, I was adviced that I should use the HTC from STS package, since I am using STSv4.4. I reinstalled HTC again from STSv4.3.2 pack . I made the necessary manual modifications except the ones for admin/categories.php. The admin/categories.php is with ACA modifications. As I understand, I have to do all the HTC modifications leaving only categories.php file, which is to be enabled at the ACA module. Did I do it right?

But the above warning shows.

 

Hopefully there is a solution, otherwise I have to remove this installation totally if the HTC won't work.

 

Thanks. :blush:

Fidela

Share this post


Link to post
Share on other sites

Seems like your ACA is working ok. Fill tags fills the database, nothing to do with file permission. Try the HTC forum, for sure you are not the only one having such problem.

When admin is working correctly, you can try the catalog side, which should not ne a problem with STS.

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites
Seems like your ACA is working ok. Fill tags fills the database, nothing to do with file permission. Try the HTC forum, for sure you are not the only one having such problem.

When admin is working correctly, you can try the catalog side, which should not ne a problem with STS.

 

- Rigadin

Hi Rigadin!

 

I asked the HTC forum, and was adviced to look at the HTC version of ACA modules. I was told that it is probably still outdated. That is correct, coz' the file HTC.php is still version 2.0. I am using now version 2.6.

 

How do I go from here? What's the best way to do?

 

Thanks! for your time. :rolleyes:

Fidela

Share this post


Link to post
Share on other sites

The ACA module for HTC is v2.0 because is has been made for ACA v2.x and it has not been updated since. There is no link between ACA module version number and HTC version number.

 

The ACA module is only saving datas to database. If the meta tags you enter in your product editor are saved to database, then ACA has made its job. ACA does not deal with file permissions, page control nor text control. If datas are in database, then problem is somewhere else.

 

- Rigadin2


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites
Hi Vines,

I had the same warning messages. It turned out to be missing files afterall :blush:

Be sure to upload the categories_description.php (and not category_description.php) to ../admin/includes/functions, at least it solved my problem with this message.

 

Strange thing is that this should not be required according to the Category Description contribution installation txt file, hope this is not causing any mystery failure... because ...now I have no error or warning message, but still there is no title nor any description field visible in the catalog category header... :(

 

Noticed that the ACA module Config Description, is showing +install button and does not react when I press the button, not sure if this is correct behavior, but the only clue I have....

 

Any suggestion someone?

categories_description.php did not exist in the installation folder nor the unpacked files. It was missing all together. Where can I get it. The installation is otherwise working. Was it supposed to exist in the most recent version of the ACA v2.6SP1.zip ?

Share this post


Link to post
Share on other sites

The function file comes with the Category Description contribution. ACA does not provide files that belongs to other contributions, it would be too hard to maintain. You anyway need to install the Category Description contribution to have it display something on the catalog side. ACA will just make the editing possible in categories.php.

 

- Rigadin2


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

I like this contribution and i would love to see more modules made available to use it. Ajax attribute manager seems like a perfect candidate to me and there are more. Is there a chance that more modules are made available for use with ACA?

Share this post


Link to post
Share on other sites

Ajax Attribute manager is very easy to install in categories.php, it would be more complicated to make a module for it.

For contributions that only add some more fields in the database, modules can be copied from header_tags module and adapted.

For more complicated contributions... it's a bit more complicated.

 

What contributions you were thinking of?

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

hi rigadin2

 

is it possible to get this plugin/contrib to work with ACA.. Hide Products from Customers. its not a simple mod to add so if you can that would be great!..

 

http://www.oscommerce.com/community/contri...all/search,sppc

 

 

i tried but i got not errors but it doing weird things.. but i am going to try again.. but i thought to ask if you can assist and add this to your lovely contrib..

 

hope to hear good news soon.

Share this post


Link to post
Share on other sites

Hi

I got ploblem with new module pack ACA2 modules_1_2_3_4_5_6

 

first, I just install new oscommerce in to /robin/ not in /catalog/

second, i install ATAv2.6SP1 nothing error

then after copy module into /admin/*.*

 

when i config at Module > ATA for catagories

 

i got msg error like this

 

Warning: include(includes/functions/categories_description.php) [function.include]: failed to open stream: No such file or directory in C:\AppServ\www\robin\admin\includes\modules\categories\category_description.php on line 14

 

Warning: include() [function.include]: Failed opening 'includes/functions/categories_description.php' for inclusion (include_path='.;C:\php5\pear') in C:\AppServ\www\robin\admin\includes\modules\categories\category_description.php on line 14

 

can you help me?

also i found this file in to this directory too

admin\includes\modules\categories\category_description.php

 

but don't have file in

admin\includes\functions\categories_description.php

 

best regard.

Share this post


Link to post
Share on other sites

The missing function file belongs to the category description contribution, so you have to take it from there.

 

- Rigadin2


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Hi,

 

I installed ACA v2.6SP1 and the ACA2 modules_1_2_3_4_5_6.

Then I installed the TinyMCE module for products. At first sight everything seems to work as it should (WYSIWYG, iBrowser, ...) but when I want to ad a product to my catalog and I click the preview button, I only get just that, a preview. Normaly I should also get the three buttons Back, Insert and Cancel but I don't.

 

So far I've upped all the files again, did the installation from scratch, tried in different languages, checked this forum but I can't seem to find the cause. When I disable the TinyMCE module, everything works as it should.

 

Help would be Highly Appreciated ;-)

Share this post


Link to post
Share on other sites

I posted a new module pack. Modules using tinyMCE have been updated and are now PHP5 compatible. I guess that problem with buttons now showing in preview is due to an error due to php5, so please update and try again.

 

A module has been added for the Product sort order contribution (#911).

 

- Chris


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Hi, sorry for my bad english. My expercience with php are very limited and I have a problem with ACA V 2.1sp1, I install in localhost and following the steps , when i try to enter in admin - boxes i receive the message Parse error: parse error, expecting `T_VARIABLE' or `'$'' in g:\oscommerce\catalog\admin\categories.php on line 512 that is the line

 

if (isset ($HTTP_GET_VARS['pID']) && empty(!$HTTP_POST_VARS) ) {
     $product_query = tep_db_query("select pd.products_name, pd.products_description, pd.products_url, p.products_id, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, date_format(p.products_date_available, '%Y-%m-%d') as products_date_available, p.products_status, p.products_tax_class_id, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "'");
     $product = tep_db_fetch_array($product_query

 

 

I'm looking for where is the mistake but I don't find, You can help me please? Thanks

Share this post


Link to post
Share on other sites

Line should be:

if (isset($HTTP_GET_VARS['pID']) && empty($HTTP_POST_VARS)) {

 

Note: This error does not come from the categories.php delivered with ACA.

 

 

- Chris


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Hi,

 

:-" little mistake while adding a post.

 

My post is related to ACA , here is the link

 

Sorry


osCommerce 2.2ms2 - OscAffiliate 2.6 - Super Friendly Admin Menu - Header Tags Controller 2.6.3 - AJAX AttributeManager 2.5.2 - Fix Width Container - Export Universel - Configuration Cache 1.30 - RSS Feed 1.22 - TVA INTRACOM 5.0 - Order Editor 3.0.2.1 - Attribute Sorter and Copier 6.0.2 - Product Description 1.5 - InfoBoxAdmin 2.25 - ACA v2.6 SP1

Share this post


Link to post
Share on other sites

I have installed ACA, but after installing the modules, I get in the admin/Modules/ACA for categories:

 

Warning: main(includes/functions/categories_description.php) [function.main]: failed to open stream: No such file or directory in /usr/home/ws/color/www.coloursite.nl/www/naaldkunst/admin/includes/modules/categories/category_description.php on line 14

 

Warning: main() [function.include]: Failed opening 'includes/functions/categories_description.php' for inclusion (include_path='.:/usr/local/lib/php') in /usr/home/ws/color/www.coloursite.nl/www/naaldkunst/admin/includes/modules/categories/category_description.php on line 14

I have been searching a lot of the old ACA files to see if there is some categories_description.php but I can't find it

 

 

If I go to some product in the admin/catalog section and try to edit it, I get:

1054 - Unknown column 'products_mediumimage' in 'field list'

SELECT products_image, products_mediumimage, products_largeimage FROM products WHERE products_id = '27'

[TEP STOP]

 

And I can't edit any products any more

I hope that someone can help me with this annoying problem.

TIA

Share this post


Link to post
Share on other sites

I got it, I think.

I have deleted a lot of modules I didn't need, and things are looking better

Still, I'd like to have a look at the SM,M,L module, let's see if I can get that thingie installed

Share this post


Link to post
Share on other sites

Shoot, I deleted all modules, exept morepics, sml, and tinymce, but when I try to edit a product in te admin section, still I get:

 

Warning: get_header_js(includes/javascript/tiny_mce/general.php) [function.get-header-js]: failed to open stream: No such file or directory in catalog/admin/includes/modules/products/tinymce.php on line 54

 

Warning: get_header_js() [function.include]: Failed opening 'includes/javascript/tiny_mce/general.php' for inclusion (include_path='.:/usr/local/lib/php') in catalog/admin/includes/modules/products/tinymce.php on line 54

 

Warning: get_header_js(includes/javascript/tiny_mce/product_image_abs.php) [function.get-header-js]: failed to open stream: No such file or directory in catalog/admin/includes/modules/products/tinymce.php on line 58

 

Warning: get_header_js() [function.include]: Failed opening 'includes/javascript/tiny_mce/product_image_abs.php' for inclusion (include_path='.:/usr/local/lib/php') in catalog/admin/includes/modules/products/tinymce.php on line 58

The files are there, I don't get it why the files can't be found.

 

What's up?

Can anybody tell me?

Share this post


Link to post
Share on other sites

Hello! I installed ACA 2.6 version and ACA2 modules_1_2_3_4_5. When I go to the Admin page, under Modules there are ACA for products and ACA for categoriies, and for each an install button. There are no modules display, only the module directory for both categories and products, and the install button, which does not function. If I click, nothing happens.

 

If anyone could help, I would appreciate it. Thank you!

Share this post


Link to post
Share on other sites

Rigadin2,

 

I am really enjoying this contribution. I do have one small glitch, however, which I am sure you can walk me through to correct it. I enabled the "Quantity Price Break + Separate Pricing Per Customer v4" feature, and am being returned with an error, which appears to me that a table is missing in my DB. I re-reviewed the installation notes, however do not see any reference to modifying the DB. Will you direct me to the solution?

 

Here is what I am receiving:

 

1054 - Unknown column 'p.products_price1' in 'field list'

 

select p.products_price1, p.products_price2, p.products_price3, p.products_price4, p.products_price5, p.products_price6, p.products_price7, p.products_price8, p.products_price1_qty, p.products_price2_qty, p.products_price3_qty, p.products_price4_qty, p.products_price5_qty, p.products_price6_qty, p.products_price7_qty, p.products_price8_qty, p.products_qty_blocks from products p where p.products_id = '31'

 

[TEP STOP]

Share this post


Link to post
Share on other sites

Nevermind the above ... I realized it was an incorporated module, so I found where the SQL statements were and put them in for both peices, however, now I do get the following error:

 

1146 - Table 'survivalstore.TABLE_CUSTOMERS_GROUPS' doesn't exist

 

select customers_group_id, customers_group_name from TABLE_CUSTOMERS_GROUPS where customers_group_id != '0' order by customers_group_id

 

[TEP STOP]

 

For Ver 4 of SPPC, the SQL mod was for adding customer_groups, not table_customer_groups. Any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×