Jump to content
medvid

Who's Online Enhancement 1.4

Recommended Posts

got it installed.

 

before the lights would not light up when the customer had something in the cart, but the cart contents would show in the right column. Now, neither the lights work nor does the product show in the right.

 

Im not sure whats wrong here - the only thing that could possibly effect this is i changed the Buy Now links to forms..?

Share this post


Link to post
Share on other sites

Thank you Ed for your contribution.

 

With the changes to general.php done, everything is working just perfect.

Share this post


Link to post
Share on other sites

i use MySQL, with Chemos Ultimate SEO URls newest mod. Any suggestions.. its strange that i could see the cart contents in the earlier version, but not now.. The lights have never worked for me

 

Any suggestions - This mod is great, and id love to get it working..

Share this post


Link to post
Share on other sites
Andrea,

 

What columns are in your whos_online table?

 

ed

 

 

customer_id

 

full_name

 

session_id

 

ip_address

 

time_entry

 

time_last_click

 

last_page_url

 

http_referer

 

 

All the ones that should be I assume. I had the older version installed before and just upgraded. Am I missing something?

Share this post


Link to post
Share on other sites

Jon,

 

I wouldn't think that the Buy Now form tweak should be a problem. I am using Chemo's Ultimate SEO contrib with v1.6 Beta and it works fine.

 

This may sound daft, but check your admin/includes/configure.php. Does it also say "mysql" at the bottom for session data?

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

Andrea,

 

Those are correct. I just don't understand why a simple select is raising an error. I assume you can see actual records in the whos_online table. What do you mean by "on the bottom where the light should be"? The light on the left hand side of every entry row?

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

Hey,

 

I think you ve found it!

 

I installed Chemos Ultimate SEO and thougtht that the contribs installation will cause the sessions to be stored in MySQL. Is this correct?

 

Both of my config.php files are blank for this command like

 

define('STORE_SESSIONS', '');

 

for default handler.

 

Also, i have no tmp/ folder setup for sessions. Im getting orders fine, so everything seems to be okay.

 

Whats going on? Does Chemos mod automatically store sessions in the mySQL as i had thought? Do i just change the configure.php in admin?

Share this post


Link to post
Share on other sites

With me not seeing this tmp folder in my directory anywhere (its odd there is no error in admin for this not being found), and my sessions not being set to mySQL, how is my store operating at all? How can the cart contents be remembered?

 

Also, when i add an item to my cart, logoff, go to another computer, login, the item is still there. How can this be working if my sessions are not stored..?

Share this post


Link to post
Share on other sites

Jon,

 

I don't know about Chemo's contrib. I know it cache's using mySQL. Do you have Force Cookie Use = True? If so, then your customer's browsers are holding the cart data. If not, I have no clue.

 

I just switched to files (define('STORE_SESSIONS', ''); ). I put an item in the cart and got lights and cart contents. Then renamed the session folder so that it didn't match the entry in the admin->Configuration->Sessions entry. Light said no cart and cart description said Empty. Renamed session correctly and all came back.

 

Create the session directory. Set permissions to 777 (I think) and see what happens.

 

ed

Edited by medvid

Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

Appreciate the reply.

 

I have Force Cookie Use set to False.

 

I tried adding items to cart, and reloggin on to my account with cookies enabled and disabled, and the session was remembered.

 

I still dont see the tmp folder in my directory anywhere, even though there is no error in the admin page.

 

Do you think my sessions are being stored via mySQL even without this specified in the configure.php files?

 

And if i should create the /tmp file, i assume this means to create the file in the home directory, with the index.php file, etc..

 

?

Share this post


Link to post
Share on other sites

Hi,

 

Installed OK and was working fine earlier, now I try it and Profile Display does not work, doesn't expand?

 

Ian.

 

 

I updated the contrib to include the v1.6.1Beta ReadMe file with the full v1.6 package.  There are no other changes.

 

ed

Share this post


Link to post
Share on other sites

because its working without being set to mysql, and i am on a shared server, i believe i know what is happening.

 

The tmp/ file must be on my server root , where i can not see it. This could definately be a security risk, if so. Do you think switching to mysql will slow anything down? Here are my daily averages:

 

Visits: 1047

Pages: 6600

Hits: 53710 (alot from the annoying linksmanager)

Bandwidth: 317.34 MB

 

Does this sound like i am correct? Will my DB eventually be slow as molasses if i store sessions? Are they ever removed?

Share this post


Link to post
Share on other sites

Hi, I meant it worked correctly with the 1.6 beta, earlier today - now it doesn't?

 

Ian.

 

 

Hi,

 

Installed OK and was working fine earlier, now I try it and Profile Display does not work, doesn't expand?

 

Ian.

Share this post


Link to post
Share on other sites
Andrea,

 

Those are correct.  I just don't understand why a simple select is raising an error.  I assume you can see actual records in the whos_online table.  What do you mean by "on the bottom where the light should be"?  The light on the left hand side of every entry row?

 

ed

 

 

Yes, where the "Active/Cart", "Active/no cart" (etc...) lights should be that error pops up. I can see them in the DB but the whos_online page has errors. I am having trouble in the old version now as well. I replaced 1.6 beta with the 1.5 I was using and now when I click on certain users to see the referer it cuts the page off in the middle of the table that lists who's online. And the only way to see the full page again is to click on a guest with no referer. So I am assuming it has something to do with the referer part. :(

Share this post


Link to post
Share on other sites

Jon,

 

What exactly is shown as the value for Admin->Configuration->Sessions->Session Directory? Include any slashes.

 

I don't know the effects of bandwidth or database speed if switching to mySQL session storage. The sessions have an expiration time and are automatically removed. You could always switch over and see.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

This is what is shown, the default

 

/tmp

 

Im pretty sure this is a shared tmp folder on the root of my host, as ive read some other posts about this.

 

Before switching to mysql for storage, ive heard the expiry date for the sessions will cause some problems? Is this true? I need the sessions to be auto-deleted to avoid a huge database and slow loading..

 

Did you do and mods first or just change the config.php files to mysql?

Share this post


Link to post
Share on other sites
Yes, where the "Active/Cart", "Active/no cart" (etc...) lights should be that error pops up. I can see them in the DB but the whos_online page has errors.  I am having trouble in the old version now as well. I replaced 1.6 beta with the 1.5 I was using and now when I click on certain users to see the referer it cuts the page off in the middle of the table that lists who's online. And the only way to see the full page again is to click on a guest with no referer. So I am assuming it has something to do with the referer part. :(

 

Andrea,

 

Where are your sessions stored? Files or mySQL? Do you have Force Cookie Use =True or False?

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
This is what is shown, the default

 

/tmp

 

Im pretty sure this is a shared tmp folder on the root of my host, as ive read some other posts about this.

 

Before switching to mysql for storage, ive heard the expiry date for the sessions will cause some problems? Is this true? I need the sessions to be auto-deleted to avoid a huge database and slow loading..

 

Did you do and mods first or just change the config.php files to mysql?

 

Jon,

 

Definitely change it to "tmp", no slash. That is setting it to root. That's why the catalog/tmp directory isn't being used.

 

I simply switched the value in catalog/configure.php and admin/configure.php and it switched right over. However, when I was writing the code, I also had /tmp and it took a while to see it.

 

ed

Edited by medvid

Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×