Jump to content
medvid

Who's Online Enhancement 1.4

Recommended Posts

Hello!!

 

I have a little problem, spanish cities are displayed like this:

 

Málaga instead of Málaga

 

This would be fixed?

 

Thx!!!

Share this post


Link to post
Share on other sites
Hello!!

 

I have a little problem, spanish cities are displayed like this:

 

Málaga instead of Málaga

 

This would be fixed?

 

Thx!!!

 

This is a character set mapping issue. The data source is encoded in UTF-8, but the page is being displayed in ISO-8859-1. It is fairly easy to fix, but I haven't looked at the new map stuff at all. Based on the number of updates, it wasn't tested very well before it was posted.

 

--Glen

Share this post


Link to post
Share on other sites

Hello,

 

I just installed Who's online Enhancement v.3.6.3, and - while the idea is great I did run into a problem. It does not display the browser / system / referer as well as cart status information. I spent last few hours digging through the forum just to find that mysql commands were missing to insert user_agent and referer fields... unfortunataly that did not solve the problem, as the fields to not get populatedd with data. Any ideas (I run osCommerce 2.2-MS2 on Apache 2 server with PHP 5.2.9 )?

 

best regards

tomasz : teleskopy.net

Share this post


Link to post
Share on other sites
I just installed Who's online Enhancement v.3.6.3, and - while the idea is great I did run into a problem. It does not display the browser / system / referer as well as cart status information. I spent last few hours digging through the forum just to find that mysql commands were missing to insert user_agent and referer fields... unfortunataly that did not solve the problem, as the fields to not get populatedd with data. Any ideas (I run osCommerce 2.2-MS2 on Apache 2 server with PHP 5.2.9 )?

 

I'm getting there... found out that the latest 'full packages' do not contain whos_online.php function needed on the client side, the one that inserts data into the database... anyone knows where is the most recent one (i found one in v2.0)

Share this post


Link to post
Share on other sites

Ok, I'm a novice and I currently have an older version of the "Who's Online". I was able to update to a slightly newer version by replacing my who's on line php file; however once the updates included the following, I was lost.

 

Run this line on your MySQL database (through phpMyAdmin, SSH, etc.):

ALTER TABLE whos_online ADD http_referer VARCHAR(255) NOT NULL;

 

What does this mean??


Tara Forsythe

Share this post


Link to post
Share on other sites

For those having problems with the country indicator NOT showing up on the map, the following worked for me:

 

In admin/whos_online.php:

Replace line 414:

geoXml = new GGeoXml("<?php echo HTTP_CATALOG_SERVER . "/visitors_georss.php";?>");

 

With this line:

geoXml = new GGeoXml("<?php echo HTTP_CATALOG_SERVER . "/catalog/visitors_georss.php";?>");

 

This assumes that you have your store in a directory called "CATALOG". If you are using a directory called "STORE" for your store, change "/catalog/visitors_georss.php" to "/store/visitors_georss.php"

 

It worked for me.

 

:D

 

And to get the icon to show up in the 'bubble' that pops up when you click the map indicator, change the following:

 

In visitors_georss.php:

Change line 21 from this:

$flag_link = "<img src="". HTTPSERVER . FLAGSDIR . $image . "" />";

 

To this:

$flag_link = "<img src="". WEBSITE . FLAGSDIR . $image . "" />";

 

Hope this helps someone!

Edited by Sylvester99

Share this post


Link to post
Share on other sites
I'm getting there... found out that the latest 'full packages' do not contain whos_online.php function needed on the client side, the one that inserts data into the database... anyone knows where is the most recent one (i found one in v2.0)

 

Look in version 3.5.4. That was the last version that I uploaded, and was known to be complete.

 

--Glen

Share this post


Link to post
Share on other sites
Ok, I'm a novice and I currently have an older version of the "Who's Online". I was able to update to a slightly newer version by replacing my who's on line php file; however once the updates included the following, I was lost.

 

Run this line on your MySQL database (through phpMyAdmin, SSH, etc.):

ALTER TABLE whos_online ADD http_referer VARCHAR(255) NOT NULL;

 

What does this mean??

It means that you must modify the whos_online table in the database to add a field that is required by the new version. The usual way to do this is to use the database administration tools provided by your host, such as phpMyAdmin. In phpMyAdmin, the procedure is to open the database, click on the "SQL" icon, then paste the line above ("ALTER TABLE...") into the window and click "Go".

 

--Glen

Share this post


Link to post
Share on other sites
Fatal error: Cannot instantiate non-existent class: simplexmlelement in /var/www/shop/admin/whos_online.php

 

I'm getting the same error on my live shop. Works like a champ on my test shop. Same versions of mysql and php.

Share this post


Link to post
Share on other sites

Hi all;

 

I just installed version 3.6.3 and almost have it working. I had to use the simplexml44 fix as my system

does not have php5. I think I loaded all that correctly. I hope.

My who's online page now shows in Admin in Tools, but I have the following error

 

Fatal error: Call to undefined function: stripos() in /home/content/l/a/d/ladykdelights/html/catalog/admin/includes/functions/whos_online.php on line 153

 

The snippet of code on line 153 looks like this

 

if (stripos($hostname, 'otenet') > 0){

$isp_icon = 'logo_otenet.png';

 

Help?

 

Also, in the install instructions it mentions to go " In the Admin area, go to Configuration -> Store -> Google Maps Key and enter the key from the previous step "

 

I have looked for Google Maps in My Store and do not have that. Did I miss something?

 

Thanks for your help :)

Share this post


Link to post
Share on other sites
Hi all;

 

I just installed version 3.6.3 and almost have it working. I had to use the simplexml44 fix as my system

does not have php5. I think I loaded all that correctly. I hope.

My who's online page now shows in Admin in Tools, but I have the following error

 

Fatal error: Call to undefined function: stripos() in /home/content/l/a/d/ladykdelights/html/catalog/admin/includes/functions/whos_online.php on line 153

 

The snippet of code on line 153 looks like this

 

if (stripos($hostname, 'otenet') > 0){

$isp_icon = 'logo_otenet.png';

 

Help?

 

Also, in the install instructions it mentions to go " In the Admin area, go to Configuration -> Store -> Google Maps Key and enter the key from the previous step "

 

I have looked for Google Maps in My Store and do not have that. Did I miss something?

 

Thanks for your help :)

 

 

 

Ok ... I fixed the error I was having. I placed this code at the end of the catalog/admin/includes/functions/who's online.php

before the ?>

 

if(!function_exists('stripos')) {

function stripos($haystack, $needle, $offset = 0) {

return strpos(strtolower($haystack), strtolower($needle), $offset);

}

}

 

Other little issues that I see are when I check the box at the top of the who's online page to Show Map, I get this

 

The Google Maps API server rejected your request. This could be because the API key used on this site was registered for a different web site. You can generate a new key for this web site at http://code.google.com/apis/maps/.

 

I generated the API key and placed it in the SQL code when installing. I placed it in the code where it said 'YOURKEY'

Did I put it in the right place?

Also still do not see Google Maps link in Configuration/MyStore as per install instructions.

Oh question about Referer on the page. All show Not Found. Is this right or did I miss something with the coding?

 

Thanks for your help

Share this post


Link to post
Share on other sites
strange even with included the php4 class i got

It's not working for me either. The solution posted on page 77 by azer doesn't seem to work. Since I don't have PHP 5 on my server, I downloaded and installed the simplexml44 class from http://www.ister.org/code/simplexml44/index.html. However, it's not working. I'm still getting:

Fatal error: Cannot instantiate non-existent class: simplexmlelement in /var/www/shop/admin/whos_online.php on line 184

even with the simplexml44 class installed and properly called from file.

 

Can somebody help, please? :'(

Share this post


Link to post
Share on other sites
for the last version Who's Online Enhancement 3.5.5 Full + IP Address geolocation + Visitors World Map

i had an error if you got php the fonction simplexml doesnt exsit it s in php5

 

you can download a class over there simplexml44 - PHP4 backport of PHP5 SimpleXML

 

then put it in admin/ functions

and call it like this :

require_once(DIR_WS_FUNCTIONS . 'simplexml/class/IsterXmlSimpleXMLImpl.php');

 

 

 

give me some feedback please

 

would you please be so kind and give us little more exact "install" info?

 

I copy whole class to admin/includes/functions ?

where to call it?

 

Thank you

Share this post


Link to post
Share on other sites
would you please be so kind and give us little more exact "install" info?

 

I copy whole class to admin/includes/functions ?

where to call it?

 

Thank you

I copied the whole simplexml44 class folder that I downloaded from http://www.ister.org/code/simplexml44/index.html to admin/includes/functions and then in admin/whos_online.php I added the following line in the beginning of the file, like this:

require('includes/application_top.php');

 

require(DIR_WS_CLASSES . 'currencies.php');

require(DIR_WS_FUNCTIONS . 'whos_online.php');

require_once(DIR_WS_FUNCTIONS . 'simplexml/class/IsterSimpleXMLElement.php');

$currencies = new currencies();

Share this post


Link to post
Share on other sites

huh .. still the same error

 

Fatal error: Cannot instantiate non-existent class: simplexmlelement in /domains/domain.com/public_html/admin/whos_online.php on line 188

Share this post


Link to post
Share on other sites

sorry .. any idea on error i still receive? Where line 188 says

 

$answer = new SimpleXMLElement($d);

 

Thank you

Share this post


Link to post
Share on other sites
sorry .. any idea on error i still receive? Where line 188 says

 

$answer = new SimpleXMLElement($d);

 

Thank you

 

 

If you'll send me your email address I'll send you a copy of my file that I use. I sent it to Irina and it seemed to have worked for her.

 

Take care,

Karen

Share this post


Link to post
Share on other sites

The only workaround to avoid the simplexmlelement error is to comment out the code below:

//$answer = new SimpleXMLElement($backup);

//if (!$backup) return false; // Failed to open connection

//}else{

//$answer = new SimpleXMLElement($d);

//}

The other problem, I saw somebody was asking earlier, but I didn't find a fix for that. The location on the map is not identified neither the Country, Region, City are available when displaying the profiles. Is there any fix for that?

 

Thanks.

Share this post


Link to post
Share on other sites

huh .. another one came up :)

 

Parse error: syntax error, unexpected $end in /domains/domain.com/public_html/admin/whos_online.php on line 1087

 

where 1087 is last line

 

<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

Share this post


Link to post
Share on other sites

OK .... I've been fiddling around some more tonight with this and I do finally have my

Google Map showing. However, I still do not have images showing for Referer, or Country

flags. I have all the images loaded into my server in their assigned folders. The map

looks similar to the one in Google Analytics, where the area is shaded in green.

 

Any ideas?

Share this post


Link to post
Share on other sites

Just installed the new version (3.6.3) in my testing environment since my shopping carts were gone since the new PHP 5.2 that my provide installed. I'm using xampp 1.7.1 for testing with PHP 5.2.9 and getting this error:

 

Fatal error: Call to undefined function curl_init() in C:\xampp\htdocs\testshop\admin\whos_online.php on line 157

 

does anyone know what the problem might be?

Share this post


Link to post
Share on other sites

ok, just found the answer on another forum, maybe it is handy for other people:

 

- Open D:\xampp\apache\bin\php.ini

- Remove the semi-colon in front of this line: extension=php_curl.dll

- Restart Apache

Share this post


Link to post
Share on other sites

Too bad, in my testing environment it works but unfortunately at my website the shoppingcarts are still gone. Are there some things that need to be enabled or disabled in php.ini so that it is going to work again?

Share this post


Link to post
Share on other sites

I found the answer also in this topic (#1203):

 

Session values are encrypted because my server has installed a new php patch named Hardened-PHP , which was founded to protect PHP users and servers against present and future security holes. To bring session values back to normal, just change the suhosin.ini file which is normally located in etc/php4/apache2/conf.d/. Add one line "suhosin.session.encrypt=0" into the suhosin.ini file. Then reboot the apache server. Now when you check the session table in your mysql database, the values are readable. Shopping cart of who's online module works fine now!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×