Jump to content
medvid

Who's Online Enhancement 1.4

Recommended Posts

Thanks for the reply, Glen! My main concern is their indexing pages with session ID's. If you don't think this will happen, I won't worry about them.

 

As best I can tell, indexing is done by the agents that identify themselves as MSNBOT. The ones that masquerade as users follow the MSNBOT accesses by several seconds to several minutes.

 

--Glen

Share this post


Link to post
Share on other sites
The ones that masquerade as users follow the MSNBOT accesses by several seconds to several minutes.

 

That is what I see...they always seem to be right behind a true MSN bot. Thanks for your input!

Share this post


Link to post
Share on other sites

I installed the latest Who's Online 3.5.4 .

I noticed an interested bug.. or at least a problem.

It works fine on a live server and everything. But when running this on a local computer there is a problem.

Let me explain my setup.

I have a network with 3 computer here at home. I run a local apache server (for internal network use only) to test new code and stuff on my local system first before it goes online. So, after installing "whos online", it runs fine and all. I can access the site on the computer the local server is running, but none of my other computers can access it. So I looked up the code and found out where the problem lies.

In /catalog/includes/functions/whos_online.php in line:

function tep_update_whos_online() {
// WOL 1.6 - Need access to spider_flag and user_agent and moved some assignments up here from below
global $customer_id, $spider_flag, $user_agent;

$wo_ip_address = tep_get_ip_address();
$wo_last_page_url = request_uri();

The problem lies in tep_get_ip_address(). When I comment out "$wo_ip_address = tep_get_ip_address();" and write instead "$wo_ip_address = 0;", it works.

Yeah, I know, total crap, but hey, I only use it at the moment, so my other local computers can access the local shop. ONLINE the original code works all fine. As I said, this problem only occurs in a local network with local computers.

I looked up how tep_get_ip_address() is definied, but this goes beyond my understanding to be honest. So, maybe someone else can look into this.

I appreciate any help on this issue.

 

Kind Regards,

Hans

Share this post


Link to post
Share on other sites
I installed the latest Who's Online 3.5.4 .

I noticed an interested bug.. or at least a problem.

It works fine on a live server and everything. But when running this on a local computer there is a problem.

Let me explain my setup.

I have a network with 3 computer here at home. I run a local apache server (for internal network use only) to test new code and stuff on my local system first before it goes online. So, after installing "whos online", it runs fine and all. I can access the site on the computer the local server is running, but none of my other computers can access it. So I looked up the code and found out where the problem lies.

What happens when you attempt to access it from one of the other machines? Is an error message displayed? If so, what do you see?

 

--Glen

Share this post


Link to post
Share on other sites
What happens when you attempt to access it from one of the other machines? Is an error message displayed? If so, what do you see?

 

--Glen

 

It keeps on loading.

So, I changed back the code to original just now to see what happens if I really wait this out. Turns out that after ~20-30 seconds the site DOES load. So, my guess is that it tries to look up something about the IP *shrugs* and it doesn't succeed and continues after a while.

I know, 20-30 seconds is not a lot, but it's a LOT compared to 0 seconds as it should be ^^

Edited by Kadaj

Share this post


Link to post
Share on other sites
It keeps on loading.

So, I changed back the code to original just now to see what happens if I really wait this out. Turns out that after ~20-30 seconds the site DOES load. So, my guess is that it tries to look up something about the IP *shrugs* and it doesn't succeed and continues after a while.

I know, 20-30 seconds is not a lot, but it's a LOT compared to 0 seconds as it should be ^^

 

That is quite odd. I don't have a local server set up, but it wouldn't be too difficult to do so. What are you running for a server?

 

The only thing I can think of that would cause this sort of problem is the DNS resolver timing out. This would slow the first access to a shop page from an IP address that isn't known to the DNS system, such as the private IP addresses on your local network. Subsequent accesses should be quick.

 

--Glen

Share this post


Link to post
Share on other sites
That is quite odd. I don't have a local server set up, but it wouldn't be too difficult to do so. What are you running for a server?

 

The only thing I can think of that would cause this sort of problem is the DNS resolver timing out. This would slow the first access to a shop page from an IP address that isn't known to the DNS system, such as the private IP addresses on your local network. Subsequent accesses should be quick.

 

--Glen

 

Apache Server, mySQL database. Quite standard stuff, nothing extraordinary :)

Share this post


Link to post
Share on other sites
Apache Server, mySQL database. Quite standard stuff, nothing extraordinary :)

 

I could swear I saw an "Edit" button in this forum before.. can't seem to find it now. Oh well, replying to myself then ^^

I want to be a bit more specific on the server:

PHP Version 5.2.8

Apache 2.2.11

mySQL 5.0.51a

 

So, all more or less quite fresh and juicy ^^

Share this post


Link to post
Share on other sites
I could swear I saw an "Edit" button in this forum before.. can't seem to find it now. Oh well, replying to myself then ^^

I want to be a bit more specific on the server:

PHP Version 5.2.8

Apache 2.2.11

mySQL 5.0.51a

 

So, all more or less quite fresh and juicy ^^

 

The edit button is on a timer, so that users can't "retro-moderate" themselves after something like 30 minutes or so.

 

I'm assuming this is all installed on some flavor of Linux.

 

--Glen

Share this post


Link to post
Share on other sites
The edit button is on a timer, so that users can't "retro-moderate" themselves after something like 30 minutes or so.

 

I'm assuming this is all installed on some flavor of Linux.

 

--Glen

 

Nopes.

Standard Windows XP. As I said, nothing special. I am not into Linux ^^

Share this post


Link to post
Share on other sites
I have been using Whos Online Enhancement version 1.5 for about 4 years and just love it. I have it up all day as I am working and it allows me to catch problems and have a real handle on what is going on in my store. Thanks so much to the creators of this awesome contribution !

 

I took a look at the latest version 3.5.4 and installed it on my test store. I do appreciate all the work that has gone into the progression of this contribution, but I actually really prefer my older much simpler version - a couple of reasons being because the ip now goes to a paid service instead of the old free showmyip.com and when clicking on a customer, it no longer opens up their personal info , but mostly I prefer my old version, just because it is simpler.

 

But I think the best feature of the newer versions is the more robust Last Url - my old version just shows the url and not the name of the product or category the customer is viewing. I have looked at the code to see if there is a way to just amend my old version 1.5 to include this feature, but its a bit beyond me.

 

I put a copy of my admin/whos_online.php below, would it be possible to just amend this portion of my old version, or is it out of the question ? If it would be possible, does anyone know what I would change ?

Version 3.5.4 retains showmyip.com as the IP lookup when you click on the address in the IP address column. It only uses dnsstuff.com when you click on the address in the detailed profile display. You can make it use showmyip.com by finding this line:

 

	echo '<b>' . TABLE_HEADING_IP_ADDRESS . ':</b> ' . "<a href='http://www.dnsstuff.com/tools/whois.ch?ip=$whos_online[ip_address]' target='_new'>" . $whos_online['ip_address'] . "</a>";

 

and replacing it with this:

	echo '<b>' . TABLE_HEADING_IP_ADDRESS . ':</b> ' . "<a href="http://www.showmyip.com/?ip=' . $whos_online['ip_address'] . '&get=nmap" target="_blank">" . $whos_online['ip_address'] . "</a>";

 

This version still opens customer info when clicking on the name of a logged in customer. It doesn't do anything for guests, Admin, or bots.

 

--Glen

Share this post


Link to post
Share on other sites

Thanks SteveDallas !

 

I took the plunge and upgraded to the latest version on my store. Have been absolutely enjoying it and been having lots of fun customizing icons and colors which wasn't possible in my old version 1.5. I have been testing it out over the past week and getting accustomed to the new features. You were totally correct in your previous post about when clicking on a logged in customer that it opens the customer info and the ip - my version being installed on a 'test store' originally had limited testing abilities as no outside people were visiting

 

1. I am wondering - my previous version - when the page would refresh, the 'latest click' (top) line would be selected - this really helped me when I was just casually monitoring my store as I worked. The latest version 3.5.4 - always remains on the last line clicked. I was wondering, is it possible for me to change something so that the whos online screen behaves as before, with jumping to the latest click line on auto refresh ?

 

2. Also, wondering if it is possible to have the manufacturers last url and also the popup image url to show the name display as it is with the category and product. (love being able to see the category and product instead of just a url)

Share this post


Link to post
Share on other sites

This is a nice contribution.

 

I have been using Whos Online Enhancement since the first day :)

I just wanna ask if its possible to add some sounds. If this could be done, you do not have to look at the screen always. If a customers are:

Active with Cart

Inactive with Cart

 

It that possible?

Share this post


Link to post
Share on other sites
This is a nice contribution.

 

I have been using Whos Online Enhancement since the first day :)

I just wanna ask if its possible to add some sounds. If this could be done, you do not have to look at the screen always. If a customers are:

Active with Cart

Inactive with Cart

 

It that possible?

 

That is a frequent request. The response I last saw was 'possibly in the next version'. Waiting......

 

Strangely enough I was looking at this thread because I had an enhancement suggestion myself;

 

Column width settings.

My display is often a mess due to the length of the IP field taking up much of the screen width to display a long address such as "host86-147-49-186.range86-147.btcentralplus.com" which is a short example compared to some I have seen.

 

Would it be possible to have a column width variable configuration section in whos_online.php that allows columns to be defined as Variable or Fixed widths? If Fixed then enter the number of characters for that field.

 

My 19" monitor just broke and I am temporarily on a 1024x768 display and BOY does it highlight this issue!

 

Paul.

Share this post


Link to post
Share on other sites

Hey Everyone,

 

First off thanks for the great contrib. ;)

 

We just installed it but have the Suhosin patch running so we can't see carts like other people have talked about. Is this related to the fact that the session data is now encrypted in the database? That's the only thing I could see different from the server we have not running Suhosin where it works.

 

I noticed in an earlier version for a bug they said to do the below which looks like it stops the session encryption, would doing the below to Suhosin.ini get us carts showing up?

 

configure suhosin.ini file by adding one line "suhosin.session.encrypt=0"

 

If not, is this something that might not be possible to get working if Suhosin is installed, or more than likely it will be fixed in the next release?

 

Thanks in advance for any replies, we really need to be able to see active carts.

Share this post


Link to post
Share on other sites
Thanks SteveDallas !

 

I took the plunge and upgraded to the latest version on my store. Have been absolutely enjoying it and been having lots of fun customizing icons and colors which wasn't possible in my old version 1.5. I have been testing it out over the past week and getting accustomed to the new features. You were totally correct in your previous post about when clicking on a logged in customer that it opens the customer info and the ip - my version being installed on a 'test store' originally had limited testing abilities as no outside people were visiting

 

1. I am wondering - my previous version - when the page would refresh, the 'latest click' (top) line would be selected - this really helped me when I was just casually monitoring my store as I worked. The latest version 3.5.4 - always remains on the last line clicked. I was wondering, is it possible for me to change something so that the whos online screen behaves as before, with jumping to the latest click line on auto refresh ?

 

I have been working on this recently. I have the "de-select on refresh" working, but the code to auto-select the first entry in the list is broken. I'm working on resolving this.

 

2. Also, wondering if it is possible to have the manufacturers last url and also the popup image url to show the name display as it is with the category and product. (love being able to see the category and product instead of just a url)

 

This should be possible, and I have thought about doing it, at least for popup images. I'll look into it. There are three tests, depending on the shop configuration (default, Search Engine Friendly URLs, and Ultimate SEO URLs) and I would want to implement a solution that handles all three.

 

--Glen

Share this post


Link to post
Share on other sites
This is a nice contribution.

 

I have been using Whos Online Enhancement since the first day :)

I just wanna ask if its possible to add some sounds. If this could be done, you do not have to look at the screen always. If a customers are:

Active with Cart

Inactive with Cart

 

It that possible?

 

While this is possible, I don't think it's exactly what you want, because it will become quite annoying when you have multiple customers with carts in the shop and at higher refresh rates.

 

What you really want is something that plays a sound when at least one visitor's state changes:

from (any state) to Active with Cart

from Active with Cart to Inactive with Cart.

 

This would require storing the visitor's state from one poll to the next. It is possible to do, but it isn't as easy as it might first appear.

 

--Glen

Share this post


Link to post
Share on other sites
That is a frequent request. The response I last saw was 'possibly in the next version'. Waiting......

 

Strangely enough I was looking at this thread because I had an enhancement suggestion myself;

 

Column width settings.

My display is often a mess due to the length of the IP field taking up much of the screen width to display a long address such as "host86-147-49-186.range86-147.btcentralplus.com" which is a short example compared to some I have seen.

 

Would it be possible to have a column width variable configuration section in whos_online.php that allows columns to be defined as Variable or Fixed widths? If Fixed then enter the number of characters for that field.

 

My 19" monitor just broke and I am temporarily on a 1024x768 display and BOY does it highlight this issue!

 

Paul.

Paul,

I don't recall promising anything on sounds, and I think I'm the only one doing any serious support of this module these days, though I thank those who have provided translations. Please see my previous message in this thread for my thoughts on what it would take to implement properly.

 

A fixed (or maximum) column width would certainly be interesting for the hostname field, especially if coupled with a tooltip showing the full hostname when you mouse over it. I'll look into it.

 

I don't have a lot of time to work on enhancements at the moment, so please don't expect an update this month.

 

--Glen

Share this post


Link to post
Share on other sites
Hey Everyone,

 

First off thanks for the great contrib. ;)

 

We just installed it but have the Suhosin patch running so we can't see carts like other people have talked about. Is this related to the fact that the session data is now encrypted in the database? That's the only thing I could see different from the server we have not running Suhosin where it works.

 

I noticed in an earlier version for a bug they said to do the below which looks like it stops the session encryption, would doing the below to Suhosin.ini get us carts showing up?

 

configure suhosin.ini file by adding one line "suhosin.session.encrypt=0"

 

If not, is this something that might not be possible to get working if Suhosin is installed, or more than likely it will be fixed in the next release?

 

Thanks in advance for any replies, we really need to be able to see active carts.

 

Yes, the issue is session encryption. We store the session data (the cart object) to the database in the user session, then pull it back out in the admin session. Without session encryption, this works fine. With session encryption, we retrieve garbage.

 

If you have the ability to disable session encryption, that should resolve the issue for whos_online, but it is a potential security hole that some administrators may not let you override. I have been thinking about alternate methods of storing the cart data in the database that will always store the cart contents in clear text.

 

--Glen

Share this post


Link to post
Share on other sites
Yes, the issue is session encryption. We store the session data (the cart object) to the database in the user session, then pull it back out in the admin session. Without session encryption, this works fine. With session encryption, we retrieve garbage.

 

If you have the ability to disable session encryption, that should resolve the issue for whos_online, but it is a potential security hole that some administrators may not let you override. I have been thinking about alternate methods of storing the cart data in the database that will always store the cart contents in clear text.

 

--Glen

 

Hi Glen,

 

Thanks for the fast reply mate. :)

 

Yeah I thought the session encryption would be the issue, we actually have our own server, so we can do pretty much what we want, but with saying that security is very important. I was talking to someone today and they said because we are the only ones with access to the server, session encryption is not really needed, what are your thoughts on this?

 

Thanks again for the fast reply.

Share this post


Link to post
Share on other sites

Hi Glen,

 

I just installed the latest version 3.5.4 on my new site. I was disappointed that I cannot view the cart contents like I can on my other sites.

 

I checked my config files and they match. Both are set to mysql.

I don't think I have suhosin, I know I did not install this.

Is there any other reason my cart contents do not show?

The icon blinks when a user has contents, but nothing in the cart column.

 

Tim

 

 

What version would I need to back down to in order to see cart contents again?

Edited by knifeman

Share this post


Link to post
Share on other sites

Boy do i feel stupid. I was reading through the entire thread and after trying numerous things, i decided to log in to the store then check if cart contents showed up. They did not. But then..... I clicked on my name to see the account details. Imagine my surprise when the page did not go to the account details as I was expecting. Further, the cart contents are showing.

 

It has been awhile since I installed this on my other stores. The older versions showed the cart contents of the first customer without clicking on them. They also let you click the customer name to see their customer details. Was this feature removed, or am I still missing something?

 

Tim

Share this post


Link to post
Share on other sites
Boy do i feel stupid. I was reading through the entire thread and after trying numerous things, i decided to log in to the store then check if cart contents showed up. They did not. But then..... I clicked on my name to see the account details. Imagine my surprise when the page did not go to the account details as I was expecting. Further, the cart contents are showing.

 

It has been awhile since I installed this on my other stores. The older versions showed the cart contents of the first customer without clicking on them. They also let you click the customer name to see their customer details. Was this feature removed, or am I still missing something?

 

Tim

 

The "click on customer name" to see the details is still there, but not for a user logged in from the admin IP address. Is this a problem? I can probably change it fairly simply.

 

The "no selected customer defaults to first entry" broke sometime back. I was working on a fix for it, but I got sidetracked because one of the other modules I maintain needed some work, and my shop has kept me busy. I'll have another look at it. The current version retains the selection, even after a refresh. Some people like this, some people prefer the previous behavior. I know how to change this, but until I get the first entry autoselect working, I'm not going to release it.

 

--Glen

Share this post


Link to post
Share on other sites

Thank you for your reply Glen.

 

 

The "click on customer name" to see the details is still there, but not for a user logged in from the admin IP address. Is this a problem? I can probably change it fairly simply.

 

It is not a problem. This is a brand new store and I was the only customer. Also the no selected customer is not a problem, it just confused me. I keep my other stores running on the whos online pages to keep my thumb on any problems. i have salvaged many sales over the past couple years because I was aware of a problem during checkout. These other stores have version 1.9b. So you can see how many changes I have missed.

 

Thanks for all your time keeping this mod alive.

 

Tim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×