Jump to content
medvid

Who's Online Enhancement 1.4

Recommended Posts

Ron

 

More than likely you probably at a guess are on shared server (most people are).

Assuming this is the case you can not just set your sessions before the public to TMP.

Create a directory called "sessions" before the "public_html" ( you should be able to get to this through an FTP client or even Cpanel if using this)

 

Then set the "sessions" directory CHMOD to 777

 

Then set your sessions in the Admin to: /home/trippint/sessions    (/public_html would be the next directory if you were to enter it, but don't)

 

Putting the directory before the public will help in security since it has to be set to 777 and is not a publicly available directory.

 

Also Note, do not put a trailing forward slash "/" at the end of the path.

 

Looking at what you have there is probably a combination of 2 problems

1. you have a trailing slash

2. The standard TMP directory is also commonly used by a number of programs that you may have running, all should have there own TMP directory where possible. This multi use directory means that the session data may be getting mixed up with some other session data from another program or even worse getting mixed up with someone elses cart data.

 

John

 

 

 

Sorry to be such a pain.

 

OK I did as instructed and it worked! But only for about 15 minutes, then I started getting this.

 

Warning: main(includes/languages/false): failed to open stream: No such file or directory in /home/trippint/public_html/admin/includes/application_top.php on line 130

 

Warning: main(includes/languages/false): failed to open stream: No such file or directory in /home/trippint/public_html/admin/includes/application_top.php on line 130

 

Fatal error: main(): Failed opening required 'includes/languages/false' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/trippint/public_html/admin/includes/application_top.php on line 130

 

 

I closed the browser and tried again an got the same error as in my previous post. Closed and re-opened the browser several time and then it started working again. For about 5 minutes and then the errors popped up again. I did look in my sessions folder and noticed that none of the sessions had been deleted and it had been more than 30 minutes since the first one was created. Tried deleting them but it did not help.

 

Thanks for your help guys. :blink:

Share this post


Link to post
Share on other sites
Sorry to be such a pain.

 

OK I did as instructed and it worked! But only for about 15 minutes, then I started getting this.

 

Warning: main(includes/languages/false): failed to open stream: No such file or directory in /home/trippint/public_html/admin/includes/application_top.php on line 130

 

Warning: main(includes/languages/false): failed to open stream: No such file or directory in /home/trippint/public_html/admin/includes/application_top.php on line 130

 

Fatal error: main(): Failed opening required 'includes/languages/false' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/trippint/public_html/admin/includes/application_top.php on line 130

I closed the browser and tried again an got the same error as in my previous post. Closed and re-opened the browser several time and then it started working again. For about 5 minutes and then the errors popped up again. I did look in my sessions folder and noticed that none of the sessions had been deleted and it had been more than 30 minutes since the first one was created. Tried deleting them but it did not help.

 

Thanks for your help guys. :blink:

 

Is this on the admin pages, or the catalog pages?

If catalog whats the address?

Share this post


Link to post
Share on other sites

Warning: main(includes/languages/false): failed to open stream: No such file or directory in /home/trippint/public_html/admin/includes/application_top.php on line 130

Warning: main(includes/languages/false): failed to open stream: No such file or directory in /home/trippint/public_html/admin/includes/application_top.php on line 130

Fatal error: main(): Failed opening required 'includes/languages/false' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/trippint/public_html/admin/includes/application_top.php on line 130

 

Ron

 

Please post around line 130 of your application_top.php file.

 

John

Share this post


Link to post
Share on other sites
Warning: main(includes/languages/false): failed to open stream: No such file or directory in /home/trippint/public_html/admin/includes/application_top.php on line 130

Warning: main(includes/languages/false): failed to open stream: No such file or directory in /home/trippint/public_html/admin/includes/application_top.php on line 130

Fatal error: main(): Failed opening required 'includes/languages/false' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/trippint/public_html/admin/includes/application_top.php on line 130

 

Ron

 

Please post around line 130 of your application_top.php file.

 

John

 

This is 109 - 130. I am not using safe URLs.

 

// set the HTTP GET parameters manually if search_engine_friendly_urls is enabled

if (SEARCH_ENGINE_FRIENDLY_URLS == 'true') {

if (strlen(getenv('PATH_INFO')) > 1) {

$GET_array = array();

$PHP_SELF = str_replace(getenv('PATH_INFO'), '', $PHP_SELF);

$vars = explode('/', substr(getenv('PATH_INFO'), 1));

for ($i=0, $n=sizeof($vars); $i<$n; $i++) {

if (strpos($vars[$i], '[]')) {

$GET_array[substr($vars[$i], 0, -2)][] = $vars[$i+1];

} else {

$HTTP_GET_VARS[$vars[$i]] = $vars[$i+1];

}

$i++;

}

 

if (sizeof($GET_array) > 0) {

while (list($key, $value) = each($GET_array)) {

$HTTP_GET_VARS[$key] = $value;

}

}

}

}

 

 

 

BTW, this error occurs rarely but I still get...

 

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/trippint/public_html/admin/includes/functions/database.php on line 45

0 -

 

select time_entry, time_last_click from whos_online where session_id='306c2f10e7139c467ea7a5ad375a7adb'

 

[TEP STOP]

 

 

nearly every time.

 

 

 

Thanks for the help!!

Share this post


Link to post
Share on other sites

It started to work fine again. It has something to do with when someone places an item in their cart. That's when I get the sql error.

Share this post


Link to post
Share on other sites
It started to work fine again. It has something to do with when someone places an item in their cart. That's when I get the sql error.

 

Firstly you have posted the application_top.php file from the catalog/includes/

I need the catalog/admin/includes/application_top.php

 

The other thing is have you upload the whos_online.php file to the catalog/admin/includes/languages/english/whos_online.php directory?

 

Also looking at that error again and my application_top.phph file it appears to be saying that you do no have the sessions directory where you are supposed to according to what you have set in the admin configuration and or it's not set with correct permissions.

 

Please double check these things.

Share this post


Link to post
Share on other sites
Firstly you have posted the application_top.php file from the catalog/includes/

I need the catalog/admin/includes/application_top.php

 

The other thing is have you upload the whos_online.php file to the catalog/admin/includes/languages/english/whos_online.php  directory?

 

Also looking at that error again and my application_top.phph file it appears to be saying that you do no have the sessions directory where you are supposed to according to what you have set in the admin configuration and or it's not set with correct permissions.

 

Please double check these things.

 

That is my admin application_top.php. Yes the language file is loaded and the session directory is set. Permissions are 777 :huh:

Share this post


Link to post
Share on other sites
That is my admin application_top.php. Yes the language file is loaded and the session directory is set. Permissions are 777 :huh:

Ron if that is your admin application_top file, it's no wonder your having problems.

Because that part of the script only belongs in the catalog application_top

 

I think you may have a few things scramble and may need to start over.

Share this post


Link to post
Share on other sites

Ed,

 

You da' man!!!! :D

 

Wow, I'm a novice... but learning quickly. I made some minor adjustments to the Who's online tool manually before finding your contribution. This one alone has convinced me to become a sponsor!

 

Question from the novice: Why do the bots seem to get stuck at "/catalog/cookie_usage.php"? I'm not forcing cookies. It seems that they get to this page and then branch to another session just to end back there again before repeating the process. i.e. at this moment I have google, msn and yahoo all crawling my site (you don't know how EXCITED I am now). Each have a minimum of 2 entries in the tool (goole has 4) that show them at this page.

 

Would appreciate education on this...

 

Thanks,

David

AllThingsTrendy.com


Anthony David

AllThingsTrendy.com

Share this post


Link to post
Share on other sites

Everyone, sorry to labour the point about settings...but I am battling to consolidate all the info from 24 pages that refer to cookies, sessions, spiders etc.

 

Can someone list the optimal settings that one should have regarding all this type of stuff?

 

Thank you.

Edited by Gamer

Share this post


Link to post
Share on other sites
Ron if that is your admin application_top file, it's no wonder your having problems.

Because that part of the script only belongs in the catalog application_top

 

I think you may have a few things scramble and may need to start over.

 

 

Thanks for the help! Yep that file was jacked up. So I don't get the file error anymore but still dealing with the sql error. I will just roll back to an earlier version.

 

Thanks everyone for the assistance.

Share this post


Link to post
Share on other sites
Wow, I'm a novice... but learning quickly.  I made some minor adjustments to the Who's online tool manually before finding your contribution.  This one alone has convinced me to become a sponsor!

 

Question from the novice:  Why do the bots seem to get stuck at "/catalog/cookie_usage.php"?  I'm not forcing cookies.  It seems that they get to this page and then branch to another session just to end back there again before repeating the process.  i.e. at this moment I have google, msn and yahoo all crawling my site (you don't know how EXCITED I am now).  Each have a minimum of 2 entries in the tool (goole has 4) that show them at this page.

David,

I'm glad you find it useful. Kudos go to the many people who have suggested ideas and shared code.

 

As for cookie_usage.php, do you have Prevent Spider Sessions turn on in Admin->Configuration->Sessions? That may help. The bots shouldn't be seeing the cookie page and prevent spider sessions is how the cart recognizes Bots. You will need to update with the latest spiders.txt contrib as some Bots, like MSNBot, were not around when the original file was released.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
Everyone, sorry to labour the point about settings...but I am battling to consolidate all the info from 24 pages that refer to cookies, sessions, spiders etc.

 

Can someone list the optimal settings that one should have regarding all this type of stuff?

 

Thank you.

Gamer,

Prevent Spider Sessions should be turned on with the latest spiders.txt contrib. Sessions can be stored in mysql or files. The trade-off, IMHO, is files are faster but mysql is more secure. If you use files, DON'T use the default admin setting of /tmp. Set it outside your public web site if at all possible. Technically, those are the biggest issues.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

Thanks for the reply. I have changed the settings as described above with the latest spiders.txt contrib.

 

Now I find the same thing as AllThingsTrendy is, with the bots stopping only on cookie_usage.php page and nothing else.

Share this post


Link to post
Share on other sites

I have installed the new spiders.txt file and still msnbot is not showing up as a bot. NO bosts are showing up as botts. What am i doing wrong?

 

scott

Edited by JustCoral

Share this post


Link to post
Share on other sites
David,

I'm glad you find it useful.  Kudos go to the many people who have suggested ideas and shared code.

 

As for cookie_usage.php, do you have Prevent Spider Sessions turn on in Admin->Configuration->Sessions?  That may help.  The bots shouldn't be seeing the cookie page and prevent spider sessions is how the cart recognizes Bots.  You will need to update with the latest spiders.txt contrib as some Bots, like MSNBot, were not around when the original file was released.

 

ed

 

Ed, below are my session settings. And, I loaded the lastest spider text before installing the contribution. It appears that the bots are recognized. I just often find them inactive at the /catalog/cookie_usage.php . In fact, I just checked and googlebot has four IPs there. Two are active bots and two are inactive.

- Session Directory /tmp

- Force Cookie Use False

- Check SSL Session ID True

- Check User Agent False

- Check IP Address False

- Prevent Spider Sessions True

- Recreate Session True

 

Much appreciate the help!


Anthony David

AllThingsTrendy.com

Share this post


Link to post
Share on other sites

David,

 

I highly recommend putting catalog/cookie_usage.php in your robots file. Note that when you do, the robot may not respond for a few hours or even days as they don't read the file constantly.

 

The rest of the settings are OK. If you are storing sessions in files, I would change the folder from /tmp to something else. Discussion is earlier in this thread.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
I have installed the new spiders.txt file and still msnbot is not showing up as a bot.  NO bosts are showing up as botts.  What am i doing wrong?

 

scott

Scott,

 

Do you have Prevent Spider Sessions = true in Admin->Configuration->Sessions?

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
Yes prevent spider sessions is on.

 

Scott

 

Scott

Where did you upload the "spiders.txt"file too.

It should be in the catalog/includes directory. Check it's there and it's your latest version.

Share this post


Link to post
Share on other sites
Scott

Where did you upload the "spiders.txt"file too.

It should be in the catalog/includes directory. Check it's there and it's your latest version.

 

Gob-

that is the location and it was updated to my server on 7/16/05

from the newest spiders.txt file.

 

Scott

Share this post


Link to post
Share on other sites
Gob-

that is the location and it was updated to my server on 7/16/05

from the newest spiders.txt  file.

 

Scott

 

Did you just upload the new file or merge them?

 

You should merge them.

Also make sure you upload the file in ASCII, not Binary.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×