Jump to content
medvid

Who's Online Enhancement 1.4

Recommended Posts

Personally (on a selfish level) flags have no interest to me at all because 99.9% of my traffic is from UK.? Colours sound good, tho.

 

M.

 

The flags sound fun but aren't too important.

 

As to the lights all I'd ask is that the difference between light and dark is pronounced enough being one of the many with red/green colour blindness :) Failing that making the colours totally different would get around it ie red/yellow red/blue yellow/blue etc etc. A silly little handicap but one that a lot of people have got :blush:

 

That said it'd be easy enough to make a small tweak myself and change the colour if need be. It's the rest of the code someone with my limited abilities struggles with :) So just being released in whatever flavour would be fine.

Edited by Tipsy

Share this post


Link to post
Share on other sites

Ed,

 

I'm so glad you got it to work, I tried, but hadn't gotten it along well enough for others to use...one of these days...

 

Does your version that you started with have the refresh rates??? I love it that it refreshes on it's own and it keeps my admin open so I don't have to log in so often.

 

Colors - I'm so used to the red/lt red and green/lt green and it follows the rest of the admin, so...but whatever works for the mass.

 

Flags - I'd love to have flags...the more info, the better.

 

Is it ready yet? :thumbsup:

Share this post


Link to post
Share on other sites

Tony,

I appreciate the color blindness issue, having a friend with it. The colors are the same as in the screen shots earlier in this thread. I will also add alt text to the img tags so that you get tool tip text. I might play with more colors.

 

airolg,

I'm making 1.5 to be 1.4 + lights and (optional) flags. 1.4 had the refresh buttons. The flag code is there but I haven't added the flag resource files yet. Paul just sent them to me (Thanks Paul). Then I realized another whos online contrib uses them as well.

 

I think one solution is to provide easy instructions on how to turn off flags if they're not wanted. I'll work on that tonight.

 

I'd like to change the Last URL to continue to be a link to the URL but display the page/category/product name instead of the URL. A little more user friendly. I'd also like to clean up the Bot ID code. I don't like the nested if/else with the hardcoded Bot IPs. I'd like to pull on the code that turns off sessions for known spiders. That way, every update to spiders.txt would update this page. I think that will be 1.6...

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

Ed - for the bot thing, wouldn't it be easier to check on the user ID rather than rely on the IP address? True, people may fake the ID but googlebot would be easier to catch especially for new IP addresses.

 

If I'm teaching granny to suck eggs then my apologies...I know nothing about mod building but I assume it'd work...

 

Sheepo

Share this post


Link to post
Share on other sites

I love all your ideas and will be extremely grateful to you for all you are doing to enhance this tool.

 

Since you know what you are doing, I'm going to stop trying to get my red/green lights to work in my code and wait for your upgrade. :D

 

Is it ready yet??? <just kidding>

Share this post


Link to post
Share on other sites
Ed - for the bot thing, wouldn't it be easier to check on the user ID rather than rely on the IP address?  True, people may fake the ID but googlebot would be easier to catch especially for new IP addresses.

 

If I'm teaching granny to suck eggs then my apologies...I know nothing about mod building but I assume it'd work...

 

Sheepo

 

How would I use the userID? Do you mean osCommerce's userID? That's 0 for Guest but that doesn't differentiate from a Bot vs. a person. I'm a coder but there's always something new to learn.

 

Was that a Riddle in the Dark?

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
How would I use the userID?  Do you mean osCommerce's userID?  That's 0 for Guest but that doesn't differentiate from a Bot vs. a person.  I'm a coder but there's always something new to learn.

 

Was that a Riddle in the Dark?

 

ed

 

Now...I have no idea if you can grab the information via the script...but browsers report information in what the browser is - version, etc.

 

This is taken from the apache log of googlebot:

 

"Googlebot/2.1 (+http://www.google.com/bot.html)"

 

So I can tell where the hit came from.

 

As I say...dunno if you can get the user ID from the script...

 

Sheepo

Share this post


Link to post
Share on other sites

Sheepo,

 

I figured I'd have to get it from the browser/session. I think I'm going to have to add a column to the whos_online table and mod the code on the catalog side to fill the column with the bot name when they are hitting pages. Then, the admin side can easily pull the data.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

Folks,

 

I released v1.5. It is just the color status lights. Please let me know if anything isn't working.

 

I added commented code for the flags. That way, anyone who wants the flags can grab the contribution that adds flags and use the commented code as a guide where to integrate.

 

Ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

I'm not sure if it's not working properly or if the lights aren't labelled correctly - I'm getting a dark green when someone is active but with nothing in the cart...and when I do a test and put something in my own cart - that's green too.

 

Sheepo

Share this post


Link to post
Share on other sites

When I able the line 274

   <?php echo tep_image('images/flags/' . strtolower(geoip_country_code_by_addr($gi, $whos_online['ip_address'])) . '.gif', geoip_country_name_by_addr($gi, $whos_online['ip_address'])).' '. geoip_country_code3_by_addr($gi, $whos_online['ip_address']); ?>

my who's online show me this fatal error:

Fatal error: Call to undefined function: geoip_country_code3_by_addr() in /web/htdocs/www.100asa.it/home/securecentoasa/whos_online.php on line 274

Thank you for support


Skype: centoasa

Skype: remigioruberto

Share this post


Link to post
Share on other sites

Just added it on 3 sites. It seems to be fine for the most part so far. I'll post if there's any hiccups.

 

Thanks for all the work guys - appreciated.

Share this post


Link to post
Share on other sites

Great job medvid! (I think, after looking at the including screenshot, didn't install yet)

Edited by PandA.nl

Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

I have a quick question. The other Who's online that I was using, automatically droped the person that was not active after 15 minutes. Now, the timer also was counting up to 15 minutes.

 

My question is just that - How long does an inactive session (bot or otherwise) stay on the page?


Joel Gallant

Share this post


Link to post
Share on other sites
I'm not sure if it's not working properly or if the lights aren't labelled correctly - I'm getting a dark green when someone is active but with nothing in the cart...and when I do a test and put something in my own cart - that's green too.

 

Sheepo

 

Sheepo,

 

The cart code depends on session data. Is your session data stored in mySQL or in a file? I've only tested it for mySQL. The code I used was cut and paste from some other source.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
When I able the line 274

 ? <?php echo tep_image('images/flags/' . strtolower(geoip_country_code_by_addr($gi, $whos_online['ip_address'])) . '.gif', geoip_country_name_by_addr($gi, $whos_online['ip_address'])).' '. geoip_country_code3_by_addr($gi, $whos_online['ip_address']); ?>

my who's online show me this fatal error:

Fatal error: Call to undefined function: geoip_country_code3_by_addr() in /web/htdocs/www.100asa.it/home/securecentoasa/whos_online.php on line 274

Thank you for support

 

How can I solve this problem?


Skype: centoasa

Skype: remigioruberto

Share this post


Link to post
Share on other sites
When I able the line 274

 ? <?php echo tep_image('images/flags/' . strtolower(geoip_country_code_by_addr($gi, $whos_online['ip_address'])) . '.gif', geoip_country_name_by_addr($gi, $whos_online['ip_address'])).' '. geoip_country_code3_by_addr($gi, $whos_online['ip_address']); ?>

my who's online show me this fatal error:

Fatal error: Call to undefined function: geoip_country_code3_by_addr() in /web/htdocs/www.100asa.it/home/securecentoasa/whos_online.php on line 274

Thank you for support

 

100asa,

 

There are some resource files and some additional code in the other whos online contrib. You need to get that contrib and read it thoroughly.

 

My intent was to show where the Flag code needed to be inserted to get the flags in the table but not to fully integrate the Flag code. I did this because there was no consensus on whether people wanted flags or not but I knew people who wanted them would then be asking where to put the code. Sorry if it added more confusion then help.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
I have a quick question. The other Who's online that I was using, automatically droped the person that was not active after 15 minutes. Now, the timer also was counting up to 15 minutes.

 

My question is just that - How long does an inactive session (bot or otherwise) stay on the page?

 

Joel,

 

Active is 0 - 3 minutes.

Inactive is 3 - 15 minutes.

15 minutes is deleted from the table.

 

There are 2 variables in the code, one set to 180 (3 minutes) and one set to 900 (15 minutes). These can be easily changed when you find them. I may move them up top in the future...

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
I love all your ideas and will be extremely grateful to you for all you are doing to enhance this tool.

 

Since you know what you are doing, I'm going to stop trying to get my red/green lights to work in my code and wait for your upgrade.  :D 

 

Is it ready yet??? <just kidding>

 

It's ready!

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
The flags sound fun but aren't too important.

 

As to the lights all I'd ask is that the difference between light and dark is pronounced enough being one of the many with red/green colour blindness :)  Failing that making the colours totally different would get around it ie red/yellow red/blue yellow/blue etc etc. A silly little handicap but one that a lot of people have got  :blush:

 

That said it'd be easy enough to make a small tweak myself and change the colour if need be. It's the rest of the code someone with my limited abilities struggles with :) So just being released in whatever flavour would be fine.

 

Tony,

 

Let me know how the colors work. I added alt text. Also, with Green as active and Red as inactive, and the entries sorted by last click, the Green and Blue lights should be at the top and the Yellow and Red lights should be at the bottom. That might help differentiate.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
Sheepo,

 

The cart code depends on session data.  Is your session data stored in mySQL or in a file?  I've only tested it for mySQL.  The code I used was cut and paste from some other source.

 

ed

 

Urm - dunno about the session data. How can I check?

 

Carts that are empty and carts that are full are all green...only colours I see is green, yellow and white (and no - I'm not colour blind like Tipsy :)

 

Any suggestions?

 

Sheepo

Share this post


Link to post
Share on other sites
Urm - dunno about the session data.  How can I check?

 

Carts that are empty and carts that are full are all green...only colours I see is green, yellow and white (and no - I'm not colour blind like Tipsy :)

 

Any suggestions?

 

Sheepo

 

Sheepo,

 

Your catalog/includes/configure.php sets the session storage. It's down at the bottom near the database entries. Also, what version of osC are you using?

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

About the sessions: I remember I've changed something to the original code concering sessions to make it work with my own cart, but I didn't really understand this part so.....

 

I will try to take another look at it


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

Hey there,

I'm afraid I'm joining the "Who's Online Enhancement 1.5" party a little late. To initially install this for the first time, is all I have to do is download the "Who'sOnlineEnhancement1.5 Folder" and make the changes documented there... or do I have to download prior versions and add code from each release up to 1.5?

 

Thanks!

BD

 

:-"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×