Jump to content
medvid

Who's Online Enhancement 1.4

Recommended Posts

My admin has got 3 languages: english, japanese and french.

I noticed if I click on Referer Url the system change automaticaly the language according the provenance of the customer which is rather annoying. For instance: you are set in english and you click on a japanese URL you have everything in japanese which is not really what I want.

I want to stay in the language that I set up to start with.

 

To eliminate an IP maybe you can look at the Visitors Contribution how they did it.

 

Try change the setting in the Admin Configuration - Store, where it says "Switch To Default Language Currency" to False.

 

I think this may fix it for you.

Share this post


Link to post
Share on other sites
I don't know of anyway to block IP's in this new version, I have not looked into that possibility at all.

But seeing your self a couple of times would generally indicate to me that you have a couple of instances of the broswer open, either way if you do not touch the retail side of the cart it should eventually time your session out and you should not be able to see yourself there any longer.

 

 

Correct, I use Crazy Browser from www.crazybrowser.com and have one window open for Admin and another window (tabs) open for the cart. And yes, I do get times out and disapear. But why not hide the Admin all together?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Try change the setting in the Admin Configuration - Store, where it says "Switch To Default Language Currency" to False.

 

It is already set up like that.

 

For the other problem I setup my cache and session as you said but it is still not that.

I have to remove DIR_WS_CATALOG to allow the system to find the path properly and about 3 minutes I have an error 404. It took a while to settle down when I did the change, I had some problem with the catalog. It seem ok now.

I went back to 5.2 version, no problem there.

Share this post


Link to post
Share on other sites
Correct, I use Crazy Browser from www.crazybrowser.com and have one window open for Admin and another window (tabs) open for the cart. And yes, I do get times out and disapear. But why not hide the Admin all together?

 

I think the reasoning behind not removing the Admin IP is that some users have multiple Administrators and this feature will show this also.

It is also somewhat of a legacy item, as in that was the way the program was setup from the outset and it's continued that way.

I personally would not remove it either. It does not worry me to have it there.

Share this post


Link to post
Share on other sites
It is already set up like that.

 

For the other problem I setup my cache and session as you said but it is still not that.

I have to remove DIR_WS_CATALOG to allow the system to find the path properly and about 3 minutes I have an error 404. It took a while to settle down when I did the change, I had some problem with the catalog. It seem ok now.

I went back to 5.2 version, no problem there.

 

I'm not a real php person, but if I read that coding correctly the DIR_WS_CATALOG entry is a part of an actual calculation and if removed will break the function altogether.

 

Have you checked (with a FTP client) in the cache and sessions directories that this data is being saved in these locations correctly.

There has to be some setting not correct.

EG: in the Admin section under sessions directory setup, it should not have a trailing backslash "/" Cache directory should have it.

 

Also are you changing both the catalog/admin/includes/configure.php and catalog/includes/configure.php to use file sessions?

Share this post


Link to post
Share on other sites
I went back to 1.36 and 1.4 version and there I can see the Shopping Cart without any problem. ??????

 

Why????

My guess has to do with your config.php defines. I have moved to using more of those values in 1.6 Beta. If you are not defining them in the way that my code expects, then the code won't see the sessions and cart correctly.

 

Look further down for a general discussion.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
No, I beg to differ. I'm using the 1.6 version successfully. Everything works as it should.

John,

 

My guess is that we define things in configure.php in a similar way. See below for general discussion.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
This is annoying to me, everytime I log into the Admin or go to my site, Who's Online lists myself and sometimes it will list me 2 or 3 times. Is there any way to block a certain IP address from showing up?

Scooter,

 

Yes. There's some logic in WOE that checks the IP of the admin against the IPs in the whos_online table. If there's a match, it changes the IP to Admin and changes the color of the text. (Some variant of this is done in 1.5 and 1.6)

 

Find that logic (It's commented) and change it to NOT print when there's a match. You may need to do similar logic for the user counts at the bottom.

 

That might be a good new feature...

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

Folks,

 

As time goes on, I am becoming more and more convinced that most of the problems are not with WOE per se (although I've made mistakes :blush: ) but with the multitude of ways people have configured their sites.

 

I have coded WOE to work very well with my site and my site's configuration :-" After all, it's what I have to test with. I tried to minimize difference by referencing the values in configure.php. I'm learning that people still define those values very differently. Everyone comes in with very different configurations.

 

One solution would be to define the paths in whos_online.php instead of using configure.php. The upside is it might work for more people. The downside is a 3rd place to change things.

 

Thoughts?

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
Folks,

 

As time goes on, I am becoming more and more convinced that most of the problems are not with WOE per se (although I've made mistakes  :blush: ) but with the multitude of ways people have configured their sites.

 

I have coded WOE to work very well with my site and my site's configuration  :-"  After all, it's what I have to test with.  I tried to minimize difference by referencing the values in configure.php.  I'm learning that people still define those values very differently.  Everyone comes in with very different configurations.

 

One solution would be to define the paths in whos_online.php instead of using configure.php.  The upside is it might work for more people.  The downside is a 3rd place to change things.

 

Thoughts?

 

ed

 

Ed, I agree with everything you have said above and I believe that a lot of the errors are more due to real novices (No offence intended to anyone. Majority of us are novices when it comes to this cart programing.)

 

There is also another thing that should be checked by users of this contrib.

In the Admin Configuration - Sessions, section.

I use the below settings and I think Ed does also.

 

Session Directory: /home/username/sessions

Force Cookie Use: False

Check SSL Session ID: False

Check User Agent: False

Check I Address: False

Prevent Spider Sessions: True

Recreate Session: True

 

I think from memory, it was "Check SSL Sessions ID" was vital to turn off.

Share this post


Link to post
Share on other sites

:(

i downloaded the contribution of whos online enhancement 6.1beta. After the installion, there an error exists. The error is showned below:

 

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/disk2/www.fotanhk.com/shopping/catalog/admin/includes/functions/database.php on line 45

0 -

 

select session_id, time_entry, time_last_click from whos_online where session_id='21c8202ce96574a94d7ac952c0f786e3'

 

[TEP STOP]

 

Anybody can help me??

Share this post


Link to post
Share on other sites

I totally agree it should be done to the configuration but I think you should give as an example your own configuration system to see if it is matching.

I also agree that when you have to play with cache,sessions and cookies it is more for specialist people.

Thanks for your time guys

 

Below my configuration system:

session path in admin:

/homepages/xx/xxxxxxx/htdocs/sessions

 

cache path in admin:

/homepages/xx/xxxxxxx/htdocs/cache/

 

I checked with FTP the session directory is created at the right place and files are created according the visites.

I checked as well for the cache and I can only see file like also_purchased-english.cache331 created.

I used the same settings for the sessions as you.

 

 

configure.php in catalog

/ Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.mysite.com/'); // eg, http://localhost or - https://localhost should not be NULL for productive servers
 define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', false); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', '');
 define('HTTPS_COOKIE_DOMAIN', '');
 define('HTTP_COOKIE_PATH', '');
 define('HTTPS_COOKIE_PATH', '');
 define('DIR_WS_HTTP_CATALOG', '');
 define('DIR_WS_HTTPS_CATALOG', '');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

//Added for BTS1.0
 define('DIR_WS_TEMPLATES', 'templates/');
 define('DIR_WS_CONTENT', DIR_WS_TEMPLATES . 'content/');
 define('DIR_WS_JAVASCRIPT', DIR_WS_INCLUDES . 'javascript/');
//End BTS1.0
 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . '/download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
 define('DB_SERVER', 'xxxxxxx'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'xxxxxxxx');
 define('DB_SERVER_PASSWORD', 'xxxxxx');
 define('DB_DATABASE', 'xxxxxxxxxxx');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'
?>

 

<?php
 admin
 // Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.tandcandy.com'); // eg, http://localhost or - https://localhost should not be NULL for productive servers
 define('HTTP_CATALOG_SERVER', 'http://www.mysite.com');
 define('HTTPS_CATALOG_SERVER', '');
 define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/homepages/xx/xxxxxxxx/htdocs'); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)
 define('DIR_WS_ADMIN', '/alacave/');
 define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);
 define('DIR_WS_CATALOG', '/'); // '/catalog/'
 define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

// Added for Templating
define('DIR_FS_CATALOG_MAINPAGE_MODULES', DIR_FS_CATALOG_MODULES . 'mainpage_modules/');
define('DIR_WS_TEMPLATES', DIR_WS_CATALOG . 'templates/');
define('DIR_FS_TEMPLATES', DIR_FS_CATALOG . 'templates/');
// define our database connection
 define('DB_SERVER', 'xxxxxxxxxxxxxxxxxx'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'xxxxxxx');
 define('DB_SERVER_PASSWORD', 'xxxxxxx');
 define('DB_DATABASE', 'xxxxxxxxxxx');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'
?>

Share this post


Link to post
Share on other sites
:(

i downloaded the contribution of whos online enhancement 6.1beta. After the installion, there an error exists. The error is showned below:

 

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/disk2/www.fotanhk.com/shopping/catalog/admin/includes/functions/database.php on line 45

0 -

 

select session_id, time_entry, time_last_click from whos_online where session_id='21c8202ce96574a94d7ac952c0f786e3'

 

[TEP STOP]

 

Anybody can help me??

 

Cynthia

 

At a quick guess you have not installed the mysql data base config.

Go back through the instructions for theses details.

Share this post


Link to post
Share on other sites
I totally agree it should be done to the configuration but I think you should give as an example your own configuration system to see if it is matching.

I also agree that when you have to play with cache,sessions and cookies it is more for specialist people.

Thanks for your time guys

 

Below my configuration system:

session path in admin:

/homepages/xx/xxxxxxx/htdocs/sessions

 

cache path in admin:

/homepages/xx/xxxxxxx/htdocs/cache/

 

I checked with FTP the session directory is created at the right place and files are created according the visites.

I checked as well for the cache and I can only see file like also_purchased-english.cache331 created.

I used the same settings for the sessions as you.

configure.php in catalog

 

Thierry

 

You have a number of problems in your config files.

But lets start with sessions section. It really should be this way:

/homepages/xx/xxxxxxx/sessions/ (sessions before htdocs directory (under) )

 

In the client side catalog you have multiple instances of Blank define fields. These should be corrected to (if your catalog is in the root directory):

define('HTTP_COOKIE_DOMAIN', '/'); // To indicate Root directory

 

Just near the top of the file it says and note the Comment after the define field:

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

It should at least look like this:

define('HTTPS_SERVER', 'http://www.mysite.com/');

 

Down near the bottom:

define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));

 

Get rid of that, to many cycling calls, use full path:

/homepages/xx/xxxxxxx/htdocs/

 

The same sort of thing is happening in the admin config file:

 

I will post my files but it's not something that I like to do, it's a fair bit of mucking around and it can be a security risk.

 

catalog/includes/configure.php

  define('HTTP_SERVER', 'http://www.mydomain.net'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://secure.mydomain.net'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'mydomain.net');
 define('HTTPS_COOKIE_DOMAIN', 'secure.mydomain.net');
 define('HTTP_COOKIE_PATH', '/shop/');
 define('HTTPS_COOKIE_PATH', '/shop/');
 define('DIR_WS_HTTP_CATALOG', '/shop/');
 define('DIR_WS_HTTPS_CATALOG', '/shop/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', '/home/username/public_html/shop/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be NULL for productive servers
 define('DB_SERVER_USERNAME', 'username_osc1');
 define('DB_SERVER_PASSWORD', 'XXXXxxXXxxX');
 define('DB_DATABASE', 'username_osc1');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'
//  define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
 // Wish List 2.3 Start
 define('MAX_DISPLAY_WISHLIST_PRODUCTS', '9'); // How many wishlist items to show per page on the main wishlist.php file
 define('MAX_DISPLAY_WISHLIST_BOX', '4');  // How many wishlist items to display in the infobox before it changes to a counter
 // Wish List 2.3 End

 

catalog/admin/includes/configure.php

  define('HTTPS_SERVER', 'https://secure.mydomain.net'); // secure webserver for admin
 define('ENABLE_SSL', 'true');	// enable SSL for customers/orders viewing
 define('HTTP_SERVER', 'http://www.mydomain.net'); // eg, http://localhost - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'http://www.mydomain.net');
 define('HTTPS_CATALOG_SERVER', 'https://secure.mydomain.net');
 define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/home/username/public_html/shop/'); // where the pages are located on the server
 define('DIR_WS_ADMIN', '/shop/admin/'); // absolute path required
 define('DIR_FS_ADMIN', '/home/username/public_html/shop/admin/'); // absolute pate required
 define('DIR_WS_CATALOG', '/shop/'); // absolute path required
 define('DIR_FS_CATALOG', '/home/username/public_html/shop/'); // absolute path required
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
 define('DIR_FS_CATALOG_IMAGECACHE', DIR_FS_CATALOG . 'images/imagecache/');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'username_osc1');
 define('DB_SERVER_PASSWORD', 'XXXXxxxXxXx');
 define('DB_DATABASE', 'username_osc1');
 define('USE_PCONNECT', 'false'); // use persisstent connections?
//  define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'
 // define your ftp connection
define('FTP_SERVER', '216.191.234.215'); // FTP server IP, same info as you use to upload by a FTP client
define('FTP_SERVER_USERNAME', 'username'); // same login info as you use to upload by a FTP client
define('FTP_SERVER_PASSWORD', 'XXxXxXxxxxX'); // same password as you use to upload by a FTP client
define('DIR_FTP_MKDIR', '/public_html/shop/images'); // login by your FTP client to see the path you need

 

 

Hope this helps sort a few things out.

Share this post


Link to post
Share on other sites

Another idea I am thinking about is a debug option. Set debug to true and WOE will spit out some info like where it's looking for sessions. That way, it might be easier to see what the problems are.

 

On the other hand, this might be a good idea as a separate contrib.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites

Thanks again for the support

 

You have a number of problems in your config files.

But lets start with sessions section. It really should be this way:

/homepages/xx/xxxxxxx/sessions/ (sessions before htdocs directory (under) )

 

I cannot do that as the root for my site is after htdocs.

I am not allowed to create anything before htdocs.

 

I did the modifications in the two configure.php

I do not see anything much happening.

 

WOE is still not happy with this session path, it's working without DIR_FS_CATALOG but I do not have the crash problem with DIRWS_IMAGES anymore.

 

What is this debug process that Medvid is talking about ?

Share this post


Link to post
Share on other sites

I wanted to add that:

 

DIR_FS_CATALOG = /homepages/xxxx/xxxxxx/htdocs/ which is expected as it is set up in configure.php

tep_session_save_path() = /homepages/xx/xxxxxx/htdocs/sessions/

 

Therefore DIR_FS_CATALOG is redundant.

I do not think it is right for you ???

Share this post


Link to post
Share on other sites

hi dudes

 

i'm getting this error when i'm cliking on Who's online in admin panel

 

Any idea ??

 

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in c:\easyphp1-8\www\admin\includes\functions\database.php on line 45

0 -

 

select session_id, time_entry, time_last_click from whos_online where session_id='08e30bb67973bc87135126c9addac919'

 

sorry for bad english,i'm frenchy

Share this post


Link to post
Share on other sites
What is this debug process that Medvid is talking about ?

 

I'm talking about putting out a new Beta with a Debug button. When clicked, WOE would display information about where it thinks your sessions are stored and other info. It might help figure out where different users are having problems. It does not yet exist except as an idea in my head.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
hi dudes

 

i'm getting this error when i'm cliking on Who's online in admin panel

 

Any idea ??

sorry for bad english,i'm frenchy

 

oupssssssssssssssss Sorry

 

it's working geat now,i'm putting original sql entry and the htt refered entry and now i'ts woks like a charm

Share this post


Link to post
Share on other sites

Thanks for the help.

I will wait for this debug function and continuing in the meantime to use the version 1.52b which works fine for me. I cannot spent all my hours trying to make this contribution working.

I will monitor this forum anyway.

Share this post


Link to post
Share on other sites

There is already a debug mod in the contribution section. Do a search for debug and you should find it. It works throughout your site and you can turn it on or off in Admin. When on, it shows the cache and session debug info at the bottom of the screen on all pages AND it is only viewable to the admin.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Pop the Top

Is it the Output Queries Debug 1.6 contrib that you are referring to ?

I successfully installed it but (sorry for the question) where should I look for ? I see a lot of info ( verry interresting for a another contrib too) but I do not see any major problem there.

Share this post


Link to post
Share on other sites

I found another one

OSC Configur.php Debugger

I think it is this the one.

I am going to try it on at once.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×