Jump to content
medvid

Who's Online Enhancement 1.4

Recommended Posts

As far as the Profile Issues, I have read throughout this thread and there are others as well where it does not work either. you are doing a great job! Keep up the good work!


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Having this problem.

 

error_online.jpg

 

Can you help me?

 

Thanks

 

 

You have not run the SQL statement as outlined in the instructions.

Also you will need to edit your catalog/admin/includes/laungauge/english/whos_online.php file to fix the Lights definitions.

It should look something like this:

Active with Cart Inactive with Cart

Active No Cart Inactive No Cart

Active Session Bot? Inactive Session Bot?

Share this post


Link to post
Share on other sites

is there a specific place in the SQl statement for this?

 

ALTER TABLE whos_online ADD http_referer VARCHAR(255) NOT NULL;

 

Goes in the end, after Table structure for table `whos_online` or Dumping data for table `whos_online`?

 

Sorry for the questions but i really don't understand this and i belive this is a powerfull tool.

 

thiis is what the error looks like now.

 

erro.jpg

 

 

 

 

You have not run the SQL statement as outlined in the instructions.

Also you will need to edit your catalog/admin/includes/laungauge/english/whos_online.php file to fix the Lights definitions.

It should look something like this:

Active with Cart        Inactive with Cart 

Active No Cart          Inactive No Cart 

Active Session Bot?    Inactive Session Bot?

Share this post


Link to post
Share on other sites
is there a specific place in the SQl statement for this?

 

ALTER TABLE whos_online ADD http_referer VARCHAR(255) NOT NULL;

 

Goes in the end, after Table structure for table `whos_online` or Dumping data for table `whos_online`?

 

Sorry for the questions but i really don't understand this and i belive this is a powerfull tool.

 

thiis is what the error looks like now.

 

erro.jpg

 

Make sure you have backed up your database.

Then just highlight and copy text as in the instructions.

Go to the databsae in phpMyAdmin

Then over on the right hand section click on SQL.

Paste the copied line into there, leave everything at the set default/s.

Click the Go button just below the text input field.

 

The go to the whos_online table and chack that it has entered the field "http_referer".

 

The SQL statement you are pasting in defines exactly what it is supposed to do and where.

 

There should be no problems, but if there is, that's why you backed up the database, Right!

 

Hope this helps.

 

Cheers

John

Share this post


Link to post
Share on other sites

Is there anybody who managed to have the cart working with the sessions in files instead of mySql ?

For me, saving them in files is much faster.

 

Thanks

Edited by thdt98

Share this post


Link to post
Share on other sites

Me too. Works fine.

 

I think also sometimes when you first set the sessions to Files you need to give it some time for it to settle in possibly even a day or so.

Share this post


Link to post
Share on other sites
Me too.  Works fine.

 

I think also sometimes when you first set the sessions to Files you need to give it some time for it to settle in possibly even a day or so.

 

 

Yes, that is true. But even then, I ended up switching back to saving the sessions in PHP. I had less problems with various contributions doing it that way.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Yes, that is true. But even then, I ended up switching back to saving the sessions in PHP. I had less problems with various contributions doing it that way.

 

PopTheTop

 

Whilst some contribs may work that way (I have not come across any personally) I currently run over 100 contribs on my shop plus a large number of my own tweaks and it is almost totally working without hicup and runs at least[/] twice as fast as what it was when storing to Mysql. I ran Mysql sessions for over 6 months before I even realised there was an option and always complained at least to myself that it was slow and after trying the files for a while but changing back because of this contrib playing pranks on us (see previouse posts by a number of people) I thought I would give file sessions another go again only just a few weeks ago, I will now never go back to Mysql sessions. The speed difference is very much measurable.

 

So my recommendation to anyone nowdays is set the sessions to store to files.

 

John

Share this post


Link to post
Share on other sites

I think I found my problem.

 

It is with the session folder. I guess whos on line cannot find it.

 

My session folder is set up as /tmp (setup in the Sessions section in Configuration section)

I notice if I want to see what's inside this folder I cannot see anything. I use either SSH or FTP connection.

Anybody to help me to debug this ?

 

I have to say that my site works fine therefore the sessions should work but how and where that is the question

Share this post


Link to post
Share on other sites

Still researching where the problem lies!!!!

 

I am with 1and1 as a hosting system. Eventhough it is the professionnal package it seems that all sessions are stored somewhere in their system and it is not possible to have access to them. It explains why the /tmp is empty.

 

The only way according to them (their customer service is pretty useless some time, people there do not know what there are talking about) is to record them in the database which I do not want, question of speed.

 

Any ideas about it ?

Thanks

Share this post


Link to post
Share on other sites

I found why the /tmp was empty.

I declared /temp but in fact in mycase I have to declare the full root, I have seen something about it in the other pages too. (useless 1and1)

Now I have the /tmp full with sessions but still no cart.

I will continue then.

Share this post


Link to post
Share on other sites
I found why the /tmp was empty.

I declared /temp but in fact in mycase I have to declare the full root, I have seen something about it in the other pages too. (useless 1and1)

Now I have the /tmp full with sessions but still no cart.

I will continue then.

 

Is /tmp in your catalog folder? I had to set mine up as catalog/tmp but saved it as /tmp in the Admin


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

I set it up directly in the root folder as I do not have a catalog folder

Directory:

/homepages/xx/xxxxxx/htdocs/tmp/

 

Would it be better to put it in the admin folder ?

Share this post


Link to post
Share on other sites

I just found something else new...

 

The Profile display never did work. It never showed anything when you clicked on any of the 4 link options.

 

Today, I deleted the session ID from the address bar and IT NOW WORKS! Wow!

 

But each time I click on those links, I get the session ID added to the address bar and they do not work until I manually delete it.

 

From:

http://www.popthetop.com/catalog/admin/who...gsf67d86hs9hd58

 

To this:

http://www.popthetop.com/catalog/admin/who...ine.php?showAll

 

 

Any ideas on this?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

I went back to 1.36 and 1.4 version and there I can see the Shopping Cart without any problem. ??????

 

Why????

Edited by thdt98

Share this post


Link to post
Share on other sites

Create a directory under/before htdocs or public_html (which ever you use) idealy called: sessions. (This for security reason as well)

Then change the permissions to 777

Then change the settings in the cart Admin (Configuration/Sessions) to the path eg: /home/yourusername/sessions

 

After you first change this you may need to do a complete browser refresh by pressing CTRL-R and all shouls now be working.

 

See how that all works. Works great for me

Share this post


Link to post
Share on other sites

It does work only until the version 1.52b not with the beta one.

Thanks

Share this post


Link to post
Share on other sites
It does work only until the version 1.52b not with the beta one.

Thanks

 

No, I beg to differ. I'm using the 1.6 version successfully. Everything works as it should.

Share this post


Link to post
Share on other sites

Still got problem

 

I found that I have problem with :

line 64

 

if ( (file_exists(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $session_id)) && (filesize(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $session_id) > 0) ) {

$session_data = file(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $session_id);

 

 

line 532

if ( (file_exists(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $info)) && (filesize(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $info) > 0) ) {

$session_data = file(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $info);

 

For my case DIR_FS_CATALOG is redundant as tep_session_save_path has already the right path. I tried to remove it but I have got a problem such an error message with footer.php in line 39, DIR_WS_IMAGES is missing and time to time I have an error 1064 if the customer cart is full.

Light status does not really work.

 

With the version 1.52 everything is alright.

 

I created my file tmp as recommended but not in the admin, should I do it ?

 

I did a little modification to signal clearly if a customer has put something in his cart by putting in red his name. Is it any interresting ?

Edited by thdt98

Share this post


Link to post
Share on other sites

This is annoying to me, everytime I log into the Admin or go to my site, Who's Online lists myself and sometimes it will list me 2 or 3 times. Is there any way to block a certain IP address from showing up?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

My admin has got 3 languages: english, japanese and french.

I noticed if I click on Referer Url the system change automaticaly the language according the provenance of the customer which is rather annoying. For instance: you are set in english and you click on a japanese URL you have everything in japanese which is not really what I want.

I want to stay in the language that I set up to start with.

 

To eliminate an IP maybe you can look at the Visitors Contribution how they did it.

Share this post


Link to post
Share on other sites
Still got problem

 

I found that I have problem with :

line 64

     

if ( (file_exists(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $session_id)) && (filesize(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $session_id) > 0) ) {

        $session_data = file(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $session_id);

line 532 

  if ( (file_exists(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $info)) && (filesize(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $info) > 0) ) {

        $session_data = file(DIR_FS_CATALOG . tep_session_save_path() . '/sess_' . $info);

 

For my case DIR_FS_CATALOG is redundant as tep_session_save_path has already the right path. I tried to remove it but I have got a problem such an error message with footer.php in line 39, DIR_WS_IMAGES is missing and time to time I have an error 1064 if the customer cart is full.

Light status does not really work.

 

With the version 1.52 everything is alright.

 

I created my file tmp as recommended but not in the admin, should I do it ?

 

I did a little modification to signal clearly if a customer has put something in his cart by putting in red his name. Is it any interresting ?

I think for this you are getting 2 things confused.

There is a "cache" directory and a "sessions" directory.

Both are used for completely different reasons.

 

Please try the instructions I posted above.

 

Also the Cache directory idealy should be set with the same sort of instructions a the sessions directory but it can be in the catalog or catalog/admin directory.

It should be addressed like so,

/home/yourusername/public_html/shop/cache/

in the Admin section under Configuration-Cache.

 

the reason as stated above for the session directory to be stored under the public_html (or htdocs) is for security and also if you do not specify the directory properly and your on a shared server (most people are) if anyone else has a cart your sessions and/or cache will get mixed up with theirs and vice versa.

 

Set this stuff first and you will know at least that is correct and then you can move forward, otherwise you are mearly waisting your time.

Share this post


Link to post
Share on other sites
This is annoying to me, everytime I log into the Admin or go to my site, Who's Online lists myself and sometimes it will list me 2 or 3 times. Is there any way to block a certain IP address from showing up?

 

I don't know of anyway to block IP's in this new version, I have not looked into that possibility at all.

But seeing your self a couple of times would generally indicate to me that you have a couple of instances of the broswer open, either way if you do not touch the retail side of the cart it should eventually time your session out and you should not be able to see yourself there any longer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×