Jump to content
Sign in to follow this  
man-machine

osPlayer v2

Recommended Posts

Hi

just a quick query on whether its possible to order the playlist in osplayer v2.0 - so far it seems to play randomly whereas i would like my tracks listed in specific order - is this possible?

 

cheers

BIAB :rolleyes:

Share this post


Link to post
Share on other sites

Hello!

 

I have been trying to add the Osplayer into my column_right so that customers can hear some tracks from the week's new releases. I have set up a "dummy" product and uploaded some mp3's and I have now finally managed to get the Osplayer to appear in the column_right. But I can't figure out the code I need to include that tells the player which product's tracks to play. There is an Mp3 ID no. for each product but how and where do I specify this in the following code from my column_right.php;

 

 

CODE

<?php

echo '<tr><td>';

$info_box_contents = array();

$my_flash = '<object width="150" height="200"> <param name="movie" value="osc_player.swf"> <embed src="includes/osc_player.swf" width="150" height="200"></embed></object>';

$info_box_contents[] = array('align' => 'center',

'text' => $my_flash);

new contentBox($info_box_contents);

echo '</td></tr>';

?>

 

 

Any help greatly appreciated!

 

Cheers,

Mark.

Share this post


Link to post
Share on other sites
osPlayer v2 is OUT !!!

 

:: osPLayer Features :::::::::::::::::::::::

 

The player itself

 

* RealTime audio streaming

* Unlimited playlist driven by php script

* Song position slider

* Play , stop , pause buttons

* Volume control

* Time display

* Song title display

* Loop mode ON/OFF

* Professional design

 

 

Dedicated osCommerce Features

 

* Options control throught the osc backoffice

1. autoplay ON/OFF

2. popup window mode or integrated on your product page

* MP3 files manager throught the osc backoffice

* Add the possibility to display a "play" button on your product list .

* Really easy to install !

 

Find it here: http://www.oscommerce.com/community/contributions,2646

 

Enjoy ;)

 

 

 

Im a Newbee at this and having a hard time trying to setup the tables in my godaddy account for this OSplayer v2 , can anyone be more specific as to how I need to set it up .

Share this post


Link to post
Share on other sites

Hi Guys,

I followed the install (advanced) and when I click the mp3 manager button I get this:

 

1146 - Table 'myusername_osc2.TABLE_PRODUCTS_MP3' doesn't exist

select products_folder from TABLE_PRODUCTS_MP3 where products_id = '29'

[TEP STOP]

 

I had no clue how to fix this... I'm totaly new to osCommerce, please guide me to solve this ?

 

Thanks ahead,

 

 

*Sorry about my bad English.

Share this post


Link to post
Share on other sites

Help please. I installed all the addons to my store on my test server. I got it running. Then I took the folder and uploaded it, changed the configure.php file to read my live site info. Got the front-end to work properly. My problem is -- when I go to add the mp3 to the product. It will not let me create the folder or load mp3.

 

I did notice that when I click on the mp3manager on the test site the heading shows the product number. On the live site it doesn't.

 

Any suggestions as to what my problem is.

Share this post


Link to post
Share on other sites

HI,

 

I have it installed however the MP3 Manager Button (link) are in the Admin/ Catalog Products folder page, NOT 1 step down in the Products Page.

 

What could have caused this?

 

Thanks

 

 

oz

Share this post


Link to post
Share on other sites

Got it working but now would like to be able to limit the amount of song to be heard. say, 30 secs.

 

Would this be done with some added code to this javascript or would it be in the FLA?

 

<!-- osPLayer Start //-->

 

<script language="javascript"><!--

 

function popupWindow(url) {

 

window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,

 

scrollbars=no,resizable=no,copyhistory=no,width=193,height=265,

 

screenX=0,screenY=0,top=300,left=450')

 

}

 

 

 

//--></script>

 

<!-- osPlayer end //-->

 

 

Thanks..

Share this post


Link to post
Share on other sites

Hi all,

Have v2.1 and followed all the manual install instructions.

Via the MP3 Manager, I'm trying to create the audio folder where you see this prompt:

 

 

current path: /home/mywebsite/public_html/catalogue/data/mp3/

There isn't any mp3 folder for this product !

Clic the button below to create one . Folder will look like this :

 

However, regardless of what I enter as a name for the folder, it doesn't create one and takes my back to the prompt again.

I've set my CHMOD to 777 for both the 'data' and 'MP3' folders in case it was a permissions thing, but no luck.

 

Any ideas?

Share this post


Link to post
Share on other sites

Having the same issue as tinRobot.

I am unable to create folders in mp3 dir. Permissions are correct and paths appear to be as well.

Any ideas?

Share this post


Link to post
Share on other sites

Got a big problem... (osplayer_v2.1_for_oscommerc)

In admin under mp3manager the player is shown and when i upload a file into to data/mp3 folder by ftp the mp3 is shown in the player in mp3manager and i can play it.

But when I use the "create folder" button nothing happens, its like the page refresh but there is no error msg or anything - also no folder is created.

(i used the advanced installation - edited all files - cause i also use the new_field_everywhere_1 contrubution)

(i also changed the files that they work with Register_Globals OFF)

 

I checked the files again and again but i cant find the mistake - any hints what could be wrong?

 

Which files and what code did you change to get it to work with register globals OFF?

I spent a day trying to get this to work and finally went in and turned register globals on and it now works.

But of course there is no way I am leaving them on. So if you could post, email or pm me on what you changed.

 

Thanks,

Share this post


Link to post
Share on other sites

Having the same issue as tinRobot.

I am unable to create folders in mp3 dir. Permissions are correct and paths appear to be as well.

Any ideas?

Ok, for me this turned out to be an issue with php.ini and register globals. The problem was it appears it has to be set to on. During testing with globals on I was able to get everything to work, except the listen option. Icon appears, player loads, but hangs at loading data. On the admin side I could hear the music fine.

 

Now if anyone has the cleaned up version that doesn't require register globals to be on, please post it.

Share this post


Link to post
Share on other sites

hi new here

 

i have the same problem install went fine no issues or errors but when i create folder i am for example here "admin/mp3manager.php?product_id=29" when writeing the foldername for that product and pressing create i get bounced back to "admin/mp3manager.php" and nothing have happene .. no entry in databas no folder created nothing :S plz someone help me out here.

Share this post


Link to post
Share on other sites

Did anyone solved this issue?

 

There isn't any mp3 folder for this product !

Clic the button below to create one . Folder will look like this :

Share this post


Link to post
Share on other sites

Hi all,

Have v2.1 and followed all the manual install instructions.

Via the MP3 Manager, I'm trying to create the audio folder where you see this prompt:

 

 

current path: /home/mywebsite/public_html/catalogue/data/mp3/

There isn't any mp3 folder for this product !

Clic the button below to create one . Folder will look like this :

 

However, regardless of what I enter as a name for the folder, it doesn't create one and takes my back to the prompt again.

I've set my CHMOD to 777 for both the 'data' and 'MP3' folders in case it was a permissions thing, but no luck.

 

Any ideas?

 

 

I set this up on my test server and everything works fine. Then I uploaded the site and my live site has the above stated problem as well.

 

My live site and test have the exact same setting: Linux server running Appache 2, mysql 5, php 4.

 

I have tried all the suggested fixes but without any success.

 

What else should I look at?

Share this post


Link to post
Share on other sites

Hi all,

Have v2.1 and followed all the manual install instructions.

Via the MP3 Manager, I'm trying to create the audio folder where you see this prompt:

 

 

current path: /home/mywebsite/public_html/catalogue/data/mp3/

There isn't any mp3 folder for this product !

Clic the button below to create one . Folder will look like this :

 

However, regardless of what I enter as a name for the folder, it doesn't create one and takes my back to the prompt again.

I've set my CHMOD to 777 for both the 'data' and 'MP3' folders in case it was a permissions thing, but no luck.

 

Any ideas?

 

Wow, it seems like it's really hard to get an answer here. MY problem is similar but no one seems to have a direct answer.

 

I am testing my site, I have installed OSCOMMERCE IN AJAX contribution. From a clean install of this contribution I used the advanced installation method.

 

The main difference I have noted in OSCOMMERCE IN AJAX is the fact that the function tep_href_link() does not exist and has been changed to tep_href_link_ajax().

 

I have changed all instances of tep_href_link() in OSplayer to tep_href_link_ajax(). So far everything has gone smoothly up until creating an MP3 folder.

 

I have 5 domains... in my cpanel php config the register globals are off, but I have PHP 5.2.3 and nothing fishy has gone on until now.

 

When I attempt to add a folder the folder space is filled with the product name of the product I have created, I read somewhere that it would be a register globals problem if the product name did not carry over into the text field. The text field is automatically filled with register globals off at this point.

 

When I click to create the folder I am immediately sent to the login page and I have to login to see mp3manager again. At this point the same screen is shown with a blank text field for the folder name. Upon entering the name again I am sent back to the login page again and no folders are being added to my server.

 

The form posts to /oscommerce/admin/mp3manager.php. I am trying to figure out why my session would get thrown out, and why the mp3manager never creates the folder. I have correct permission set as 777 on both /data and /data/mp3/ folders.

 

Can someone point to where the authentication process is located? OR maybe give insight as to why this might happen.

 

Thank You Much

 

 

Safani

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×