Jump to content
Sign in to follow this  
mcki0127

Payment modules not showing

Recommended Posts

I can't get the payment modules to show up in Admin. The only thing that shows is Module Directory: includes/modules/payment/ and the install button.

 

I log into phpMyAdmin and go to the configuration table. Under the MODULE_PAYMENT_INSTALLED field, the configuration_value is blank. It should contain a list of the payment modules, separated by a semicolon. The payment module files do exist in the correct directory. I manually enter paypal.php and save it. However, if I log out of phpMyAdmin and log back in again, the configuration_value is blank again, and the module never shows up in the store admin. This is perplexing. I'm not sure if I'm having osc problems or MySQL problems. The same thing is happening with the shipping and order total modules.

 

I haven't installed any contribs. Could it be a problem with one of my configuration files?

 

Any help is appreciated.

 

Steve


new as they come, and greener than...

Share this post


Link to post
Share on other sites
I can't get the payment modules to show up in Admin.  The only thing that shows is Module Directory: includes/modules/payment/ and the install button.

 

I log into phpMyAdmin and go to the configuration table.  Under the MODULE_PAYMENT_INSTALLED field, the configuration_value is blank.  It should contain a list of the payment modules, separated by a semicolon.  The payment module files do exist in the correct directory.  I manually enter paypal.php and save it.  However, if I log out of phpMyAdmin and log back in again, the configuration_value is blank again, and the module never shows up in the store admin.  This is perplexing.  I'm not sure if I'm having osc problems or MySQL problems.  The same thing is happening with the shipping and order total modules.

 

I haven't installed any contribs.  Could it be a problem with one of my configuration files?

 

Any help is appreciated.

 

Steve

 

 

Did you RENAME your Admin Folder???

 

Pete

Share this post


Link to post
Share on other sites
I can't get the payment modules to show up in Admin.  The only thing that shows is Module Directory: includes/modules/payment/ and the install button.

 

I log into phpMyAdmin and go to the configuration table.  Under the MODULE_PAYMENT_INSTALLED field, the configuration_value is blank.  It should contain a list of the payment modules, separated by a semicolon.  The payment module files do exist in the correct directory.  I manually enter paypal.php and save it.  However, if I log out of phpMyAdmin and log back in again, the configuration_value is blank again, and the module never shows up in the store admin.  This is perplexing.  I'm not sure if I'm having osc problems or MySQL problems.  The same thing is happening with the shipping and order total modules.

 

I haven't installed any contribs.  Could it be a problem with one of my configuration files?

 

Any help is appreciated.

 

Steve

 

I'm having the same problem. All I did was rename my admin folder and now I'm just getting this line /html/catalog/includes/modules/payment/ and the INSTALL button to the left which does not work.

 

Here is my Admin/configure.php

 

I have NO CATALOG folder. The catalog folder is my document root.

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'https://www.zangopill.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'http://www.zangopill.com');
 define('HTTPS_CATALOG_SERVER', '');
 define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/home/content/k/1/w/k1w1guy/html/'); // where the pages are located on the server
 define('DIR_WS_ADMIN', '/newname_admin/'); // absolute path required
 define('DIR_FS_ADMIN', '/home/content/k/1/w/k1w1guy/html/newname_admin/'); // absolute pate required
 define('DIR_WS_CATALOG', '/catalog/'); // absolute path required
 define('DIR_FS_CATALOG', '/home/content/k/1/w/k1w1guy/html/catalog/'); // absolute path required
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

// define our database connection
 define('DB_SERVER', 'mysql.secureserver.net'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'xxxxx');
 define('DB_SERVER_PASSWORD', 'xxxxxx');
 define('DB_DATABASE', 'xxxxx');
 define('USE_PCONNECT', 'false'); // use persisstent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

Share this post


Link to post
Share on other sites
I'm having the same problem. All I did was rename my admin folder and now I'm just getting this line /html/catalog/includes/modules/payment/ and the INSTALL button to the left which does not work.

 

Here is my Admin/configure.php

 

I have NO CATALOG folder. The catalog folder is my document root.

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'https://www.zangopill.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'http://www.zangopill.com');
 define('HTTPS_CATALOG_SERVER', '');
 define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/home/content/k/1/w/k1w1guy/html/'); // where the pages are located on the server
 define('DIR_WS_ADMIN', '/newname_admin/'); // absolute path required
 define('DIR_FS_ADMIN', '/home/content/k/1/w/k1w1guy/html/newname_admin/'); // absolute pate required
 define('DIR_WS_CATALOG', '/catalog/'); // absolute path required
 define('DIR_FS_CATALOG', '/home/content/k/1/w/k1w1guy/html/catalog/'); // absolute path required
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

// define our database connection
 define('DB_SERVER', 'mysql.secureserver.net'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'xxxxx');
 define('DB_SERVER_PASSWORD', 'xxxxxx');
 define('DB_DATABASE', 'xxxxx');
 define('USE_PCONNECT', 'false'); // use persisstent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

 

 

OK I fixed my own problem but I'm not sure how. Since my catalog folder *is* my document root I had to take out all instences of '/catalog/' and make it root '/'

 

I hope that makes sense.

 

Pete

Share this post


Link to post
Share on other sites

I have renamed my catalog directory to the store name ex. www.domain.com/storename. I haven't renamed the admin directory.


new as they come, and greener than...

Share this post


Link to post
Share on other sites

Well, I've managed to screw my admin configure file up enough so that I get a 404 error if I try to click on any link on the admin/index page. Help??

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.storesnsuch.com/norskknits/'); // eg, http://localhost - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'http://www.storesnsuch.com/norskknits/');
 define('HTTPS_CATALOG_SERVER', '');
 define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/var/www/html/norskknits/'); // where the pages are located on the server
 define('DIR_WS_ADMIN', '/norskknits/admin/'); // absolute path required
 define('DIR_FS_ADMIN', '/var/www/html/norskknits/admin'); // absolute pate required
 define('DIR_WS_CATALOG', '/norskknits/'); // absolute path required
 define('DIR_FS_CATALOG', '/var/www/html/norskknits/'); // absolute path required
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

// define our database connection
 define('DB_SERVER', 'www.storesnsuch.com'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'xxxxxx');
 define('DB_SERVER_PASSWORD', 'xxxxxx');
 define('DB_DATABASE', 'xxxxxx');
 define('USE_PCONNECT', 'false'); // use persisstent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>


new as they come, and greener than...

Share this post


Link to post
Share on other sites

Can anyone help me out with my configure file? Since I'm not sure what all the of the directory and server settings etc are, it's hit and miss to find out what works, and so far I haven't had much luck. Thanks.


new as they come, and greener than...

Share this post


Link to post
Share on other sites

OK, I've got my configure file back in order. Now I'm back to my first problem of the modules not showing up. Please read my first original post and tell me if you have any advice. Thanks in advance.

 

Steve


new as they come, and greener than...

Share this post


Link to post
Share on other sites
i've this same problem, someone can help me?

Since the previous post to yours was in 2004, can you explain what your problem is?

Edited by Coopco

The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Since the previous post to yours was in 2004, can you explain what your problem is?

 

I can't get the payment modules to show up in Admin. The only thing that shows is Module Directory: includes/modules/payment/ and the install button.


PeppezZ - from Chaos Net, never died.

Share this post


Link to post
Share on other sites
I can't get the payment modules to show up in Admin. The only thing that shows is Module Directory: includes/modules/payment/ and the install button.

Off the top of my head (oops, nothing there), do you have backup php files in the paymeny directory, have altered any code?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Off the top of my head (oops, nothing there), do you have backup php files in the paymeny directory, have altered any code?

i tried to install a contribution for paypal, but now i tried also to paste the older and fresh modules folder into the new modified.. but i've the same error.

 

I have this message in all section modules:

Directory Moduli: home/public_html/includes/modules/payment/

Directory Moduli: home/public_html/includes/modules/shipping/

Directory Moduli: home/public_html/includes/modules/order_total/

 

What can i do?


PeppezZ - from Chaos Net, never died.

Share this post


Link to post
Share on other sites
i tried to install a contribution for paypal, but now i tried also to paste the older and fresh modules folder into the new modified.. but i've the same error.

What does that mean?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

I have the exact same problem?? In the modules section none of the modules show up it only says which directory to find them. And this directory seems to be correct.

 

Can anyone take a look at this issue.

 

Thanks :)

Share this post


Link to post
Share on other sites
What does that mean?

 

I'm saying that i've altered the payment module installing a contribution for paypal, but i think it isn't this the problem because then i tried to reinstall the modules folder (i copied the original folder) and it still not works


PeppezZ - from Chaos Net, never died.

Share this post


Link to post
Share on other sites
I'm saying that i've altered the payment module installing a contribution for paypal, but i think it isn't this the problem because then i tried to reinstall the modules folder (i copied the original folder) and it still not works

Did they ever show correctly?

Did you change the admin/includes/configure.php file?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
yes

yes

You should look at the second yes.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
i can't understand... how can i fix it?

Check your admin configure.php file for where it refers to the catalog.

 

Depending on what version osc you have, the answer may be here.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

thank you for the answer, and sorry my big delay.

 

My osc version is oscommerce-2.2rc2a (i think, how can i see it exactly?)

 

For the help you've posted:

The first solution doesn't work

In the second i tried but into: catalog/admin/includes/functions/compatibility.php. there is already that line


PeppezZ - from Chaos Net, never died.

Share this post


Link to post
Share on other sites
thank you for the answer, and sorry my big delay.

 

My osc version is oscommerce-2.2rc2a (i think, how can i see it exactly?)

 

For the help you've posted:

The first solution doesn't work

In the second i tried but into: catalog/admin/includes/functions/compatibility.php. there is already that line

Hi

made a mistake once, installed one of the paypal php files that should have gone into the admin in the frontend. I mean by that includes/modules/payment/ the result was that I could no longer see my payment modules in admin after deleting the file everything was ok again do not know why but maybe worth deleting the payment folder and then reinstalling with a fresh one not overwriting completly deleting!!!!

Share this post


Link to post
Share on other sites
thank you for the answer, and sorry my big delay.

 

My osc version is oscommerce-2.2rc2a (i think, how can i see it exactly?)

 

For the help you've posted:

The first solution doesn't work

In the second i tried but into: catalog/admin/includes/functions/compatibility.php. there is already that line

Hi

made a mistake once, installed one of the paypal php files that should have gone into the admin in the frontend. I mean by that includes/modules/payment/ the result was that I could no longer see my payment modules in admin after deleting the file everything was ok again do not know why but maybe worth deleting the payment folder and then reinstalling with a fresh one not overwriting completly deleting!!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×