Latest News: (loading..)
jcall

Customer Updates - Order Comments

37 posts in this topic

Need Help !!!

 

I have a order status called "New Message".

How can a new order status be changed to "New Message", not the default status ? If a new order with user comments ?

 

any help would be greatly appreciated,

 

thank you

 

David

Share this post


Link to post
Share on other sites

Hi,

 

I have just now installed this contrib into my MS1-Shop but I have got an error when trying to make a comment:

 

Fatal error: Call to a member function on a non-object in /home/riedbornshop/www/catalog/account_history_info.php on line 63

 

the lines 62-64 looks like this:

 

  if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'updated')) {
  $messageStack->add('header', SUCCESS_ORDER_UPDATED, 'success');
 }

 

Can you help?

 

 

Wolfgang

Share this post


Link to post
Share on other sites

I've just upgrade to latest version.

But when customers add comments to their order, no message show in the header, and redirect to account_history.php. Email send to admin, comments are stored in db (show only in admin section, it would better also for customer).

Share this post


Link to post
Share on other sites

All,

 

I'm sorry I've been out of action for quite a while. If any of these issues are still current, post here and I'll help sort them out.

 

A few notes:

- This has not been tested for MS1.

- If you read the instructions carefully, they show how to set the status to whatever you want

- This contribution assumes that the customer-side order number is the same as the admin-side order number. In other words, if you are randominzing the order number, you must expect that to cause potential grief with any other contribution that uses the order number

 

 

-jared

Share this post


Link to post
Share on other sites

hi there to all.. i am using your contribution.. i installed (1.2 update) and its working fine!!!! .. now..

 

MUST i do the "fix for bug report" ???????!!!!!!!

 

Also.. i have noticed when a customer leaves a comment.. though it works.. and as the customer i can see it updated and i as the seller get the email notification.. so all is working there..

 

i have noticed that the message as the customer was still left in the comments box.. and not cleared.. even though it was updated with what the customer has written..

 

Is this suppose to happen??? is there a ways to clear the comment box after the customer comments are updated/posted. Or does the fix bug report fix this..

 

I hope people are still around to support this..

 

thanks for your time!!!!!!

Share this post


Link to post
Share on other sites

i get this error after i appiled the fix bug report.. in the customer comments, order statue and i try to edit..

 

 

Fatal error: Call to undefined function: tep_cfg_pull_down_status_change_cancel_list() in /home/moderate/public_html/store/osc/admin/configuration.php(125) : eval()'d code on line 1

 

 

 

but it appears to be working fine cept for the above mentioned.

Share this post


Link to post
Share on other sites

I have just installed the latest version and the security fix. When I go in as a customer and add a comment to my order, it redirects me from a secure connection https to a unsecure connection http while still in the order details. What can be changed in the coding for the customer to remain within the secure connection?

 

Thank you in advance.

 

Melissa

Share this post


Link to post
Share on other sites

I have installed the latest version with the security fix. all is working well but the customer does not see the comment that he left. only the new status with no comments.

 

in the admin side i can see the comment normally .

. is that the normal contribution behavior ?

 

thank you

Share this post


Link to post
Share on other sites

I have installed the latest version with the security fix. all is working well but the customer does not see the comment that he left. only the new status with no comments.

 

in the admin side i can see the comment normally .

. is that the normal contribution behavior ?

 

thank you

 

I also have installed this contrib, works as it should. Customer can submit/add comments, it changes the status to "Customer Update" as I have it set up. Customer sees the status of their order change from whatever it was to "Customer Update", but the customer can NOT see the update they submitted because the Customer Notified Flag is set to not notify.

 

Going into the order as admin I see the customer's comments/updates and the order status is correctly changed to "Customer Update" and it's obvious why he customer can not see the comments they added, the Notify Customer has the red X.

 

I run an SQL statement :

mydbname_osc2`.`orders_status_history` SET `customer_notified` = '1' WHERE `orders_status_history`.`orders_status_id` =13;

 

Which changes all orders with the status 13, Customer Update, from the "0" it is created as to "1" so that customers can see the comments they added.

 

If customers don't see the update they submitted, they won't think the submitted updates actually worked. I know I wouldn't.

 

Is there a way to make the submission submit a customer notify=1 instead of 0? I have looked over the code and can't seem to find where it is sending a "0" customer notify flag so that I can change it to "1"

 

Share this post


Link to post
Share on other sites

@@NinjaPerformance

 

Change this

// BEGIN Customer Comments contrib section 1
    if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'update_order') ) {
       $oID = tep_db_prepare_input($HTTP_GET_VARS['order_id']);
       $comments = tep_db_prepare_input($HTTP_POST_VARS['comments']);

to this

// BEGIN Customer Comments contrib section 1
    if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'update_order') ) {
       $oID = tep_db_prepare_input($HTTP_GET_VARS['order_id']);
       $comments = tep_db_prepare_input($HTTP_POST_VARS['comments']);
       $customer_notified = '1';

Share this post


Link to post
Share on other sites

 

@@NinjaPerformance

 

Change this

// BEGIN Customer Comments contrib section 1
    if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'update_order') ) {
       $oID = tep_db_prepare_input($HTTP_GET_VARS['order_id']);
       $comments = tep_db_prepare_input($HTTP_POST_VARS['comments']);

to this

// BEGIN Customer Comments contrib section 1
    if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'update_order') ) {
       $oID = tep_db_prepare_input($HTTP_GET_VARS['order_id']);
       $comments = tep_db_prepare_input($HTTP_POST_VARS['comments']);
       $customer_notified = '1';

 

Wow, that did it, thank you,

 

I have a contrib that allows me to add comments to order history without customers seeing any of it which was causing this contrib to not update on customer side order history, I would see it on the admin side but customers would not unless I changed the history update status customer notified from from 0 to 1. This fix worked. It fixed the customer seeing their comment addition but my hide comments if I uncheck the notify/append boxes contrib also still works.

 

THANK YOU!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now