Jump to content

Archived

This topic is now archived and is closed to further replies.

Chemo

A Store Speed Optimization in Progress

Recommended Posts

Ok, seems that ctype_digit not works for this purpose so revert:

 

if (ctype_digit($char)) $rand_value .= $char;

 

to

 

if (preg_match('/^[0-9]$/i', $char)) $rand_value .= $char;

 

it should work now

Share this post


Link to post
Share on other sites

Ok, seems that ctype_digit not works for this purpose so revert:

 

if (ctype_digit($char)) $rand_value .= $char;

 

to

 

if (preg_match('/^[0-9]$/i', $char)) $rand_value .= $char;

 

it should work now

Works fine now

Share this post


Link to post
Share on other sites

I uploaded a new addon that integrate the PEAR cache lite file cache system with Oscommerce. This speeds up page load time and reduce the number of the queries

 

Check it out here: http://addons.oscommerce.com/info/8021

I cannot help with this one. I have USU5 pro which does the caching and when I tried this, it breaks the site

Share this post


Link to post
Share on other sites

I cannot help with this one. I have USU5 pro which does the caching and when I tried this, it breaks the site

 

I'm using USU5 pro, and it works for me.... strange...

 

I have usu5 pro caching enabled

Share this post


Link to post
Share on other sites

I'm using USU5 pro, and it works for me.... strange...

 

I have usu5 pro caching enabled

I will have another go, when I got some more spare time. I use KISSMT as well with caching. As a side note, I have changed all $HTTP_xx_VARS to their $_xx versions throughout my site

Share this post


Link to post
Share on other sites

I will have another go, when I got some more spare time. I use KISSMT as well with caching. As a side note, I have changed all $HTTP_xx_VARS to their $_xx versions throughout my site

 

 

the same also for me and it works.

 

Please send a thumbnail or error code. I cannot reproduce this.

Share this post


Link to post
Share on other sites

the same also for me and it works.

 

Please send a thumbnail or error code. I cannot reproduce this.

I have done the alterations to product_info.php. When completing the alteration to the top of the file everything is ok. The error occurs when I complete the alteration above require DIR_WS_INCLUDES . 'template_bottom.php';

 

This is the error that occurs

The web page at http://www.electricalcity.co.uk/mcbs-federal-electric-hca-c32-hca3p32-32a-mcb-p-826.html might be temporarily down or it may have moved permanently to a new web address.

Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.

 

Edit: It is producing a cache file in the tree directory

Share this post


Link to post
Share on other sites

I have done the alterations to product_info.php. When completing the alteration to the top of the file everything is ok. The error occurs when I complete the alteration above require DIR_WS_INCLUDES . 'template_bottom.php';

 

This is the error that occurs

The web page at http://www.electricalcity.co.uk/mcbs-federal-electric-hca-c32-hca3p32-32a-mcb-p-826.html might be temporarily down or it may have moved permanently to a new web address.

Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.

 

Edit: It is producing a cache file in the tree directory

 

 

Are you using Chrome browser?

 

http://www.google.com/support/forum/p/Chrome/thread?tid=3388bd392b939f43&hl=en

Share this post


Link to post
Share on other sites

Yes, I am using Chrome

 

Maybe updating it can resolve the issue. Also if your using gzip option inside oscommerce instead of gzip pages with .htaccess file can generate the problem on some environments.

Share this post


Link to post
Share on other sites

Maybe updating it can resolve the issue. Also if your using gzip option inside oscommerce instead of gzip pages with .htaccess file can generate the problem on some environments.

 

Turning off the gzip compression in osCommerce solves the problem

Share this post


Link to post
Share on other sites

Hello i've posted to github some php microimprovement to gain a little more speed you can check it on my github repository: https://github.com/a.../commits/master

 

Hi acidvertigo!

 

 

Great Work!

 

 

The $_GET supergobals not need to decode in some place, so much be faster. (IE in header.php)

 

From PHP manual:

Note:

 

The GET variables are passed through urldecode().

 

 

Regards,

Gergely


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

 

The $_GET supergobals not need to decode in some place, so much be faster. (IE in header.php)

 

From PHP manual:

 

 

 

Thank you for the tip! :lol:

Share this post


Link to post
Share on other sites

I tried other little changes on functions/general.php and functions/html_output.php changing the function tep_not_null in isset. Seems a little bit faster but i don't know if isset return the same bool results of the tep_not_null functions. Anyone can help?

Share this post


Link to post
Share on other sites

Hi,

 

Has somebody any experriencies in gzip? I think all web browsers support HTTP gzip at 2011.

 

 

I can reach Page Speed Score from 62/100 to 91/100 with some features.

css and js files gzip downloads

 

 

 

I add *.css and *.js files to *.css.php and *.js.php and rewrite template_top.php csss and js links

 

insert the top of the new php files

for *css.php

<?php
ob_start ("ob_gzhandler");
header("Content-type: text/css; charset: UTF-8");
header("Cache-Control: must-revalidate");
$offset = 60 * 60 * 24 * 7;
$ExpStr = "Expires: " .
gmdate("D, d M Y H:i:s",
time() + $offset) . " GMT";
header($ExpStr);
?>

 

for *css.php

<?php
ob_start ("ob_gzhandler");
header("Content-type: text/css; charset: UTF-8");
header("Cache-Control: must-revalidate");
$offset = 60 * 60 * 24 * 7;
$ExpStr = "Expires: " .
gmdate("D, d M Y H:i:s",
time() + $offset) . " GMT";
header($ExpStr);
?>

 

My main files for v2.3.1:

 

Perhaps this new files can be gziped static and after include them before the last ?> close tag. In this case not need ob_start. I think this feature can do in a new contribution.


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

You can do this putting this code in .htaccess file of your root directory:

 


# compress text, html, javascript, css, xml:
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript

Share this post


Link to post
Share on other sites

Oppss correct code is:

 

SetOutputFilter DEFLATE

# compress text, html, javascript, css, xml:
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript

Share this post


Link to post
Share on other sites

Hello all, I am feeling sorry to bloat even more this topic with my request.

I went thru some of the mods suggested here, from category enhancements to the various tep_get queries.

I also tweaked the .htaccess file adding deflating and duration timings.

 

Fact is that I am still getting no clue on where my OSC is running slow. The firs load of the catalog takes 23 secs! Specifically the queries that look like are getting things slow are again the categories query and the header_tags query.

 

I run a quite heavily modified shop including STS (disabling didn't give any performance improvement).

Can someone please help me understand where the problem lies?

 

www.schermaontc.com/ecom

 

thank you.

Francesco

Share this post


Link to post
Share on other sites

Seems something wrong with your hosting company and not with the script

 

You can check here the speed of your site: http://tools.pingdom.com/?url=www.schermaontc.com/ecom&treeview=0&column=objectID&order=1&type=0&save=true

 

The first time response is very long, then the site loads faster.

 

Check your apache configuration

Share this post


Link to post
Share on other sites

Hello

 

Can somebody maybe help me. i have oscommerce 2.3.1 but my webstore is very slow in the beginning. It take some 12 sec when the page open.

Please can watch my site http://www.merkkinderkleding.eu it starts in dutch but if you want you can change it to English :)

I hope that you give me some tips what i need to change..... and than I hope i can do it.

greetings Paul

Share this post


Link to post
Share on other sites

×