Jump to content
Sign in to follow this  
Vger

SID Killer

Recommended Posts

Hi,

I wouldn't like to post it, until I'm 100% certain it does work, and do what it is meant to do. The problem (spiders using old URL's) is important enough for it to be made a contrib, even though it's only about 10 lines of Apache mod_rewrite code.  :D

 

Sounds like you need it now though, drop me an email if you do, and I'll send it to you.

 

Peter

 

 

Hi,

 

Just wondering if there is an update on this yet as i could do with it.

 

Also will this get the spiders to have a frenzy on my site again as they seemed to have slowed down.

Share this post


Link to post
Share on other sites
Hi,

Yes, please see this announcement:

 

http://forums.oscommerce.com/index.php?showtopic=130698

 

Peter

 

 

From the contribution that has been released i guess you have had success with this then.

 

Top one mate, you are like the strongest painkiller in the world. You have just cured alot of headaches around the globe. HOW DO YOU FEEL.

Share this post


Link to post
Share on other sites

Hi,

 

Top one mate, you are like the strongest painkiller in the world. You have just cured alot of headaches around the globe. HOW DO YOU FEEL.

 

Well, just call me 'Asprin', or "Panadol' I guess. LOL

 

I couldn't have done the contrib. without the help of an Apache guru though.

 

Peter

Share this post


Link to post
Share on other sites

Can anyone help, firstly i know nothing about this 'sid' business, but i seem to be getting very high hits from USA in my stats and MSNBot - i think it relates to what you are all discussing.

 

I am in the UK - http://www.pleasurezone.uk.com

 

Just tried to install SID Killer v1.2 but ended up with completely blank page when re-loaded.

 

I tried the direct replacement of .htaccess file for the mod and when didn?t work I tried my existing htaccess contents WITH the mod contents of htaccess.

 

Whatever I tried, I got blank screen, when loading my site.

 

I take it that all you do is load the file - .htaccess, as it is, without altering it?

 

Here is what i put in .htaccess:

 

 

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

 

# Set some options

Options -Indexes

Options FollowSymLinks

 

RewriteEngine on

RewriteBase /

#

# Skip the next two rewriterules if NOT a spider

RewriteCond %{HTTP_USER_AGENT} !(msnbot|slurp|googlebot) [NC]

RewriteRule .* - [s=2]

#

# case: leading and trailing parameters

RewriteCond %{QUERY_STRING} ^(.+)&osCsid=[0-9a-z]+&(.+)$ [NC]

RewriteRule (.*) $1?%1&%2 [R=301,L]

#

# case: leading-only, trailing-only or no additional parameters

RewriteCond %{QUERY_STRING} ^(.+)&osCsid=[0-9a-z]+$|^osCsid=[0-9a-z]+&?(.*)$ [NC]

RewriteRule (.*) $1?%1 [R=301,L]

 

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

 

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

 

then i tried it WITH my original, which is this:

 

RewriteEngine on

RewriteCond %{HTTP_REFERER} !^http://pleasurezone.uk.com/.*$ [NC]

RewriteCond %{HTTP_REFERER} !^http://pleasurezone.uk.com$ [NC]

RewriteCond %{HTTP_REFERER} !^http://www.pleasurezone.uk.com/.*$ [NC]

RewriteCond %{HTTP_REFERER} !^http://www.pleasurezone.uk.com$ [NC]

RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ http://www.pleasurezone.uk.com [R,NC]

 

This alone, obviously works, but the mod screwed it up.

 

I have tried to enable Friendly URL's in admin/configuration, but when i do so, it screws up my site. It doesn't load my right boxes and some content, so i have to dis-regard this.

 

I really don't know if i have a spider/search engine problem or if someone is stealing bandwidth by linking to my pictures.

 

My bandwidth has tripled in the last 30 days, using about 350mb per month, now in January, up to 1200mb, and i had to upgrade via my hosting company.

 

I know somethings wrong as although i suddenly had 1000's more hits, i had zero sales!

 

I know its a stupid comment, but i thought the idea of search engine's spidering our sites was a good thing? Also, i have recently enabled 'Forced Cookie' usage - is that a good thing to do, or not.

 

Thank you for your time and patience.

 

Steve

http://www.pleasurezone.uk.com


Hope it helps...

PC Planet

Share this post


Link to post
Share on other sites

Steve,

 

This post was put in 3 different forums, and has been replied to.

 

Best not to ask questions about other contributions (i.e. the "Spider Session Remover" ) in a thread that is not relevant.

 

Peter

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×