Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
Guest

No Product listing w/ linkpoint

Recommended Posts

Guest

Hello,

I am using Linkpoint Connect payment module, and I am having trouble getting the products and customer information to show up in the order email. All i receive is a confirmation on the amount and the order number, but nothing else. So, i do not know who ordered what.

 

Help would be greatly appreciated.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

As far as I know, the linkpoint confirmation mail only contains the linkpoint order number and the "totals" sent (i.e. sub_total, shipping etc.). This is because the products ordered are not sent to linkpoint via the payment module.

 

Unfortunately, the osCommerce order does not contain the linkpoint order for easy cross reference. The only "link" you have is the customer's email logon name.

 

You need to add yourself to the order CC list in Oscommerce admin by adding your email address to

 

administration->Configuration->My Store->Send Extra Order Emails To

 

Then you'll get an email that contains all the ordered products for that customer at the same time that linkpoint sends you the credit card transaction totals.

 

HTH

Tom

Share this post


Link to post
Share on other sites
Guest

Thanks for the quick responce; however, the message sent to the "Send Extra Order Emails to" email address is the same. The order details are still not there.

[pulling out hair]

 

This is all i get:

-------------------------------------------------------------------------------

Company: Company Name

Reference Number: 000.00.00.00-1098734146-124895-7378-10

 

 

Subtotal: $357.90

Tax: $0.00

Shipping: $0.00

Total: $357.90

 

Company Name

 

-------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

That email is coming from Linkpoint not osCommerce and will not have the order details.

 

Are you receiving the order confirmation email from osCommerce?

 

If not then you have an email configuration problem on your site.

 

Tom

Share this post


Link to post
Share on other sites
Guest

No i guess i am not receiving anything from OsCommerce. I do not know what could be configured wrong, however. As far as I know, everthing is set correctly.

 

Here is the site if this helps: srlights

 

Any ideas on what could be configured wrong in OsCommerce?

 

-I've made it this far; this is the last step and i'll be smooth sailing.

 

Thanks for the help

Share this post


Link to post
Share on other sites
Guest

Also, here are screenshots of how i have this set up:

 

linkpointconfig.gif

 

mystoreconfig.gif

 

Here is how i set up linkpoint:

 

linkpointsetup.gif

Share this post


Link to post
Share on other sites

HAS ANYONE EVER FIGURED THIS OUT?

 

I am gettting the same thing and need to figure it out. I am not getting the order confirmation from oscommerce since installing linkpoint connect. Myself, and the customer gets a receipt from linkpoint, but it doesnt record the order info in the db. There is record of payment with no record of order.

 

How can we fix this?

 

I am using the linkpoint connect contribution. Should I be using the newer API? Does the API contrib work with linkpoint connect gateway?

 

Would be nice to make it work.

 

Any help will be most appreciated.

 

Thanks,

Jason@

Deeptronics.com

Share this post


Link to post
Share on other sites

Well this probably won't help, but I found that when the order goes through the authorization page from Linkpoint, there is an option at the bottom of that page that asks the customer to continue or (something else). If the customer does not click continue, then the order will not show up through oscommerce. I am having the same problem and still have not figured this thing out yet.

 

 

HAS ANYONE EVER FIGURED THIS OUT?

 

I am gettting the same thing and need to figure it out. I am not getting the order confirmation from oscommerce since installing linkpoint connect. Myself, and the customer gets a receipt from linkpoint, but it doesnt record the order info in the db. There is record of payment with no record of order.

 

How can we fix this?

 

I am using the linkpoint connect contribution. Should I be using the newer API? Does the API contrib work with linkpoint connect gateway?

 

Would be nice to make it work.

 

Any help will be most appreciated.

 

Thanks,

Jason@

Deeptronics.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×