Jump to content

Archived

This topic is now archived and is closed to further replies.

PandA.nl

ms2 and PHP5

Recommended Posts

I know ms2 does not work well on PHP5, so I just tried a search for php5 and ms2:

(it's possible I missed something of course)

 

Knowledge base => no results

 

Contributions => no results

 

Tips & Tricks => no reslults

 

Forums => lots of results, reporting some problems, and maybe some solutions

 

CVS => Aha :) At least one solution to one problem http://cvs.oscommerce.com/viewcvs.cgi/admi...f?r1=1.2&r2=1.3

 

 

Is anyone aware of other possible problems with osC2.2ms2 and PHP5 ? Is anyone running a live store on PHP5 succesfully already?


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

No wonder, I couldn't find much about the subject :rolleyes:

 

I just decided to do a test using Apache 2.0.51, MySQL 4.0.21 and PHP 5.0.1 and, after applying the (above mentioned) CVS fix, everything already seemed to work fine :thumbsup:

 

It was a quick test only (browsed around and did a test order, so of course there could be problems I haven't noticed yet). It still would be nice to hear if someone already has a live shop running on PHP5.x .


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

IMHO until osCommerce runs out of the box with PHP5 I would not put it onto a live store. not worth the headaches it could cause because of the unknowns.

but that is me . . .


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

Hi John,

 

you are right of course, but I am one of the poor people that can't afford to choose his PHP version :'(

 

I am using a shared host, as many others I suppose. And I am sure the hosting provider will update to PHP5 one day, and he might not even tell me about it :(

 

So I would like to be somewhat prepared for that day.


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

Can't edit my message... That single line fix, can that be applied right now to my heavily modded 2.2ms2 and then I likely won't have to worry if my host upgraded tomorrow?

Share this post


Link to post
Share on other sites

I'm also running on a box upgraded with php 5, but I don't seem to have uploading problems. Mine is logging off members. After logging off and returning to the homepage, they are still logged in. Is this a problem that has a known fix at all?

My store isn't live yet, but it is ready to go. Feel free to test around it with ordering or whatever.

Thanks for any help.

-Greg

Share this post


Link to post
Share on other sites
That single line fix, can that be applied right now to my heavily modded 2.2ms2 and then I likely won't have to worry if my host upgraded tomorrow?
It seems to me that you can apply the fix, and won't have problems on PHP 4.9x (I did, also on a very heavily modded 2.2ms2 live store, and it works fine).

 

But if you need to worry about upgrades is difficult to say. As far as I know the team doesn't tell much about it (except that they found some issues). And it might also depend on to which PHP5 version your host will upgrade. As far as I know it's possible (but not likely I hope) that someone is "inventing" a PHP5.x version at this very moment, that won't work for osC2.2ms2 :'(

 

@greg: you say "feel free to test", I am not sure if your post is moderated or something, but I don't see any url to test :huh:


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

×