Jump to content
Sign in to follow this  
smitty1

Current AUctions V2.0

Recommended Posts

Hi folks,

I'm getting the following error:

 

Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /home/v35163/public_html/catalog/includes/modules/current_auctions_module.php on line 54

 

It was working fine for me until recently. I've installed Ultimate_SEO_URLs - could that be the problem? Only other thing I can think of is that my ISP has changed their secuirty settings!

 

Anyone have any ideas?

 

Thanks in advance,

 

Di11on

 

Hi folks,

 

Anyone have any inspiration for this one?

 

Thanks,

 

Di11on

Share this post


Link to post
Share on other sites

the only part i'm having trouble with now is some sorta encoding/charset issue.. it seems to have a ? where the ? should be.. and also putting one on the end of the description for some reason!!

Share this post


Link to post
Share on other sites

I just installed version 2.1 and it works great. But, I have the same question as one of the posters above me.

 

How can I set it up that it only shows my eBay AUCTIONS and not STORE LISTINGS?

 

It's pulling up everything I have for sale...both store items in Buy It Now format AND Auctions. I'd only like auctions to appear. Thanks!

 

Andrea

My Website

Share this post


Link to post
Share on other sites

Hi All!

 

I have got this contribution up and running, it's very impressive!

Thank you all for being a part of creating it!

 

However, in Sweden we have our own version of ebay.

How do I connect to it?

 

Here's a link to their english pages...

Swedish Ebay

 

Any help would be much appreciated.

 

//Micke

Share this post


Link to post
Share on other sites

I have just installed the 2.1 version and I can change the settings fine. But on the site all i get is

 

Fatal error: Cannot redeclare tep_show_category() in /home/dscards/public_html/shop/includes/boxes/categories.php on line 13

 

http://www.ds-cards.com/shop/current_auctions.php

 

I have followed all the install intructions (even went over it a few times again to make sure)

Share this post


Link to post
Share on other sites
Hi folks,

 

Anyone have any inspiration for this one?

 

Thanks,

 

Di11on

 

 

Yes - this is a new issue that has arisen with PHP version 4.4.4

 

The CURLOPT_FOLLOWLOCATION option to curl has been disabled on servers running this version of PHP running in safe mode or having open_base dir in place (basically most shared server environments)

 

This prevents curl being redirected as is required by the eBay auction script (eBay redirects the search request to the listings page)

 

I don't have a fix for the vanilla script but I have modified the script to prefetch my listings every hour via a cron job then dump them into a MySQL table. A cron job calls the PHP executable on the server so bypasses the safe mode / open_base directives and thus the CURL redirect problem.

 

Other advantages of the database route is that you can have the listings sortable and split long listings over several pages. Also, you may have noticed that long listings can take a while to display as the data is pulled from eBay. Using this method results in very fast page displays.


Please use forum for support rather than PM - PMs unrelated to my contributions will be ignored.

Google Site Search is your friend

My contributions: Tracking Module | PDF Customer Invoice | Subcategory textboxes

Share this post


Link to post
Share on other sites

I keep getting this above my auctions box. How do I get rid of it?

 

Warning: mktime() expects parameter 2 to be long, string given in /home/brillian/public_html/includes/modules/current_auctions_module.php on line 116

 

Warning: mktime() expects parameter 4 to be long, string given in /home/brillian/public_html/includes/modules/current_auctions_module.php on line 116

Share this post


Link to post
Share on other sites

ooOH, i've also got a bug whereby if i have no current auctions, the module displays auctions from someone with a similar name! (the same characters @ the begining of the name, and a different number aftwewards!)

Share this post


Link to post
Share on other sites

Fritz i know this is an old post but did you ever find the cause and or a fix for this mktime error?

Share this post


Link to post
Share on other sites

Hello,

 

I have just installed this contrib and now my store is a white screen. What did I do wrong, I have checked all the instructions over and over again and for the life of me I can not see what I did wrong. This seems like a pretty easy contrib to install. Any help would be greatly appreciated.

 

Thanks

Cliff

Share this post


Link to post
Share on other sites
Hello,

 

I have just installed this contrib and now my store is a white screen. What did I do wrong, I have checked all the instructions over and over again and for the life of me I can not see what I did wrong. This seems like a pretty easy contrib to install. Any help would be greatly appreciated.

 

Thanks

Cliff

 

Ok, found what was wrong... seems that when i made the changes to one of the current pages and saved it, the save didn't save correctly. All is working now.

 

Cliff

Share this post


Link to post
Share on other sites
I keep getting this above my auctions box. How do I get rid of it?

 

Warning: mktime() expects parameter 2 to be long, string given in /home/brillian/public_html/includes/modules/current_auctions_module.php on line 116

 

Warning: mktime() expects parameter 4 to be long, string given in /home/brillian/public_html/includes/modules/current_auctions_module.php on line 116

 

I removed

 

// mktime is the marked time, and time() is the current time.

$target = mktime($hour,$minute,$second,$month,$day,$year);

$diff = $target - time();

 

From current_auctions_module.php and all seems to be working now.

Edited by NYS

Share this post


Link to post
Share on other sites

Hi everyone,

 

I have recently been looking to have some sort of ebay intergration with my oscommerce shop and I fond the above contribution (1443) which is perfect for this. I have installed everything as per the instructions but when I come to upload the query to my database I get the following error:

 

 

 

Error

SQL-query : [Edit]

 

INSERT INTO `configuration_group` (`configuration_group_id`, `configuration_group_title`, `configuration_group_description`, `sort_order`, `visible`) VALUES (30, 'Current Auctions', 'Current Auction configuration', 30, 1)

 

 

MySQL said:

 

 

Duplicate entry '30' for key 1

 

Any ideas?

 

Regards,

Daniel

Share this post


Link to post
Share on other sites
Hi everyone,

 

I have recently been looking to have some sort of ebay intergration with my oscommerce shop and I fond the above contribution (1443) which is perfect for this. I have installed everything as per the instructions but when I come to upload the query to my database I get the following error:

Error

SQL-query : [Edit]

 

INSERT INTO `configuration_group` (`configuration_group_id`, `configuration_group_title`, `configuration_group_description`, `sort_order`, `visible`) VALUES (30, 'Current Auctions', 'Current Auction configuration', 30, 1)

MySQL said:

Duplicate entry '30' for key 1

 

Any ideas?

 

Regards,

Daniel

Look with phpmysql in your configuration group table, and find an unused number, perhaps 31, or 32

then also use that number i.s.o. 30 in the next sql command to execute


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

Thanks for that, I got the script working fine after I changed the number...didn't realise it would be that easy. Now that I've uploaded the script and tried to use the current auctions page I get this error:-

 

 

Fatal error: Cannot redeclare tep_show_category() (previously declared

in /www/includes/header.php:203)

in /www/includes/boxes/categories.php on line 13

 

 

this is what my categories.php looks like:

 

<?php

/*

$Id: categories.php,v 1.25 2003/07/09 01:13:58 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

function tep_show_category($counter) {

global $tree, $categories_string, $cPath_array;

 

for ($i=0; $i<$tree[$counter]['level']; $i++) {

$categories_string .= "  ";

}

 

$categories_string .= '<a href="';

 

if ($tree[$counter]['parent'] == 0) {

$cPath_new = 'cPath=' . $counter;

} else {

$cPath_new = 'cPath=' . $tree[$counter]['path'];

}

 

$categories_string .= tep_href_link(FILENAME_DEFAULT, $cPath_new) . '">';

 

if (isset($cPath_array) && in_array($counter, $cPath_array)) {

$categories_string .= '<b>';

}

 

// display category name

$categories_string .= $tree[$counter]['name'];

 

if (isset($cPath_array) && in_array($counter, $cPath_array)) {

$categories_string .= '</b>';

}

 

if (tep_has_category_subcategories($counter)) {

$categories_string .= '->';

}

 

$categories_string .= '</a>';

 

if (SHOW_COUNTS == 'true') {

$products_in_category = tep_count_products_in_category($counter);

if ($products_in_category > 0) {

$categories_string .= ' (' . $products_in_category . ')';

}

}

 

$categories_string .= '<br>';

 

if ($tree[$counter]['next_id'] != false) {

tep_show_category($tree[$counter]['next_id']);

}

}

?>

<!-- categories //-->

<tr>

<td>

<?php

$info_box_contents = array();

$info_box_contents[] = array('text' => BOX_HEADING_CATEGORIES);

 

new infoBoxHeading($info_box_contents, true, false);

 

$categories_string = '';

$tree = array();

 

$categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.parent_id from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '0' and c.categories_id = cd.categories_id and cd.language_id='" . (int)$languages_id ."' order by sort_order, cd.categories_name");

while ($categories = tep_db_fetch_array($categories_query)) {

$tree[$categories['categories_id']] = array('name' => $categories['categories_name'],

'parent' => $categories['parent_id'],

'level' => 0,

'path' => $categories['categories_id'],

'next_id' => false);

 

if (isset($parent_id)) {

$tree[$parent_id]['next_id'] = $categories['categories_id'];

}

 

$parent_id = $categories['categories_id'];

 

if (!isset($first_element)) {

$first_element = $categories['categories_id'];

}

}

 

//------------------------

if (tep_not_null($cPath)) {

$new_path = '';

reset($cPath_array);

while (list($key, $value) = each($cPath_array)) {

unset($parent_id);

unset($first_id);

$categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.parent_id from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '" . (int)$value . "' and c.categories_id = cd.categories_id and cd.language_id='" . (int)$languages_id ."' order by sort_order, cd.categories_name");

if (tep_db_num_rows($categories_query)) {

$new_path .= $value;

while ($row = tep_db_fetch_array($categories_query)) {

$tree[$row['categories_id']] = array('name' => $row['categories_name'],

'parent' => $row['parent_id'],

'level' => $key+1,

'path' => $new_path . '_' . $row['categories_id'],

'next_id' => false);

 

if (isset($parent_id)) {

$tree[$parent_id]['next_id'] = $row['categories_id'];

}

 

$parent_id = $row['categories_id'];

 

if (!isset($first_id)) {

$first_id = $row['categories_id'];

}

 

$last_id = $row['categories_id'];

}

$tree[$last_id]['next_id'] = $tree[$value]['next_id'];

$tree[$value]['next_id'] = $first_id;

$new_path .= '_';

} else {

break;

}

}

}

tep_show_category($first_element);

 

$info_box_contents = array();

$info_box_contents[] = array('text' => $categories_string);

 

new infoBox($info_box_contents);

?>

</td>

</tr>

<!-- categories_eof //-->

 

 

 

 

Any ideas? Many thanks

Share this post


Link to post
Share on other sites
I removed

 

// mktime is the marked time, and time() is the current time.

$target = mktime($hour,$minute,$second,$month,$day,$year);

$diff = $target - time();

 

From current_auctions_module.php and all seems to be working now.

 

This worked for me too, thanks!

Share this post


Link to post
Share on other sites

I am getting the same warnings:

 

Warning: mktime() expects parameter 2 to be long, string given in /home/timeles3/public_html/includes/modules/current_auctions_module.php on line 116

 

Warning: mktime() expects parameter 4 to be long, string given in /home/timeles3/public_html/includes/modules/current_auctions_module.php on line 116

 

As several others suggested I deleted the mktime lines around 116... Yes the warnings went away but the end times for my auctions came in wrong... Current auction shows up as being ended...

 

Any other suggestions as what to fix?????

 

Would appreciate the help.

 

I installed version 2.1. Aside from this glich it is working wonderfully. I'd rather not have the warnings show at the top.

Share this post


Link to post
Share on other sites

For those of you who receive this error when thumbnails are enabled in current auctions 2.1 (english) :

 

2006 - MySQL server has gone away

select startdate, counter from counter

[TEP STOP]

2006 - MySQL server has gone away

select count(*) as total from sessions where sesskey = 'f27c5a5e0be7138cdfbf620cafd27968'

[TEP STOP]

 

REPLACE in includes/modules/current_auctions_module.php ::

 

echo '<tr>
						   <td class="' . $class . '" align="center" width="15%"><a href="' . AUCTION_URL . '/ws/eBayISAPI.dll?ViewItem&item=' . $Itemnum . '" target="_blank">' . tep_image('http://thumbs.ebaystatic.com/pict/' . $Itemnum . '6464_0.jpg') . '<br>' . $Itemnum . '</a></td>

 

WITH ::

 

echo '<tr>
						   <td class="' . $class . '" align="center" width="15%"><a href="' . AUCTION_URL . '/ws/eBayISAPI.dll?ViewItem&item=' . $Itemnum . '" target="_blank"><img src="http://thumbs.ebaystatic.com/pict/' . $Itemnum . '6464_0.jpg"><br />' . $Itemnum . '</a></td>

 

The osC image wrapper craps out the application for some reason. I don't know the true source of the problem as it may be a STS-based problem with this contrib. Anyway this change works wonderfully.

 

- Teitan Erim

Share this post


Link to post
Share on other sites
I am getting the same warnings:

 

Warning: mktime() expects parameter 2 to be long, string given in /home/timeles3/public_html/includes/modules/current_auctions_module.php on line 116

 

Warning: mktime() expects parameter 4 to be long, string given in /home/timeles3/public_html/includes/modules/current_auctions_module.php on line 116

 

As several others suggested I deleted the mktime lines around 116... Yes the warnings went away but the end times for my auctions came in wrong... Current auction shows up as being ended...

 

Any other suggestions as what to fix?????

 

Would appreciate the help.

 

I installed version 2.1. Aside from this glich it is working wonderfully. I'd rather not have the warnings show at the top.

 

Easy (temp) fix for this error: Go to line 118 in current_auctions_module.php

 

Change this:

 

$target = mktime($hour,$minute,$second,$month,$day,$year);

 

To this:

 

$target = @mktime($hour,$minute,$second,$month,$day,$year);

 

The @ sign forces php to not output error code. This is a lazy fix, but should work for now.

Edited by flywithsteve

FlyWithSteve Consulting

Share this post


Link to post
Share on other sites
Easy (temp) fix for this error: Go to line 118 in current_auctions_module.php

 

Change this:

 

$target = mktime($hour,$minute,$second,$month,$day,$year);

 

To this:

 

$target = @mktime($hour,$minute,$second,$month,$day,$year);

 

The @ sign forces php to not output error code. This is a lazy fix, but should work for now.

 

hello i have the same problem and tried this now no listings come up?

any other ideas/ thanks

Share this post


Link to post
Share on other sites

I've had this module installed for quite some time with no problems.

 

Just wanted to mention that I started receiving the same error after my webhost took me from PHP4 to PHP5 over the weekend. I don't know enough about the differences between the two to troubleshoot it, but...Thank You to Steve for the suggestion of placing that @ in the code. Works for me! Everything is accurate and looks great. Looks like normal...with no errors output onscreen.

 

Perhaps someone who is familiar with the difference between PHP4 and PHP5 could offer some assistance?

 

- Andrea

Share this post


Link to post
Share on other sites

Hey, This may be the wrong place to post this, but. I installed the current_actions.php, I don't have any errors, the current actions box comes up, but it doesn't have any of my current actions listed.

 

Can anyone help me with this?

Share this post


Link to post
Share on other sites

Does anyone know in PhP myAdmin if there is any special way to import the sql file i keep getting errors while trying to put in a fresh install or is there an alternate way of importing the database from the downloaded files

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×