Jump to content
Sign in to follow this  
cpthyland2

Star Products v1.4, table_... doesn't exist

Recommended Posts

I just installed the Star Products v1.4 and now I get a tep stop error on my main page.

 

 

1146 - Table 'clubhousegolf.table_star_product' doesn't exist

 

select substring(pd.products_description, 1, 598) as products_description, p.products_id, p.products_image, p.manufacturers_id, p.products_price, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price, p.products_tax_class_id, sp.product_id from products p, products_description pd, TABLE_STAR_PRODUCT sp left join specials s on p.products_id = s.products_id where p.products_id = pd.products_id and p.products_status = '1' and pd.products_description != '' and p.products_id=sp.product_id and pd.language_id = '1'

 

[TEP STOP]

 

 

I checked in the database, there is a table there called star_product, and from the admin screen when I change the star product, the record ID does get updated in the database, however from the catalog mainpage, i get the above database error.

 

Please help.

Share this post


Link to post
Share on other sites
I just installed the Star Products v1.4 and now I get a tep stop error on my main page.

1146 - Table 'clubhousegolf.table_star_product' doesn't exist

 

select substring(pd.products_description, 1, 598) as products_description, p.products_id, p.products_image, p.manufacturers_id, p.products_price, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price, p.products_tax_class_id, sp.product_id from products p, products_description pd, TABLE_STAR_PRODUCT sp left join specials s on p.products_id = s.products_id where p.products_id = pd.products_id and p.products_status = '1' and pd.products_description != '' and p.products_id=sp.product_id and pd.language_id = '1'

 

[TEP STOP]

I checked in the database, there is a table there called star_product, and from the admin screen when I change the star product, the record ID does get updated in the database,  however from the catalog mainpage, i get the above database error.

 

Please help.

 

 

I had a similar problem in that a database was not being found. I went through the install instructions again and found a line i had missed. As the error was different all i can suggest is that you carefully retrace the install instructions and hopefully find what you did wrong.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×