Jump to content
Jack_mcs

SEO Assistant

Recommended Posts

Great tool, very useful - only minor glitch is this:

 

Yahoo Position_Results 
The site www.niknakgroup.com is not in the top 100 for the term jewellery on Yahoo 
?
1 http://www.niknakgroup.com 

2 http://www.jewelry-jewellery.com 

3 http://www.jewellery-depo.com 

4 http://www.jlj-jewellery.co.uk 

5 http://www.jewellerycatalogue.co.uk 

6 http://www.shopsafe.co.uk

 

Ummmm. I hate to point out the obvious, but yes I am in the top 100 - I'm first! Why has the code not picked up my url position? I panicked when I thought I had dissappeared from Google just now - calmed down soemwhat when I found I had gone up from around 40th to 17th!

 

Like I say, just a minor glitch and one that nobody else seems to have reported...any ideas why I am getting this?

 

Anyway, great contrib, saves me lots of clicking around! Thx.

 

in

/admin/includes/modules/seo_google_position.php

/admin/includes/modules/seo_yahoo_position.php

 

find

if(strcmp('$searchurl,$url)==0)

 

replace with:

if(strcmp('http://'.$searchurl,$url)==0)

Share this post


Link to post
Share on other sites

I just checked mine and it worked. If yours was working before, then you just got a busy connection, so to speak. If it never worked before, then there might be an error in the installation.

 

Jack

Share this post


Link to post
Share on other sites
I just checked mine and it worked. If yours was working before, then you just got a busy connection, so to speak. If it never worked before, then there might be an error in the installation.

 

Jack

 

Jack,

Couldn't help but noticing that this contrib was your baby for most of the updates, according to the owners on the osc contribution site...and you seem to be doing most of the support on this thread.

 

This is not a slam to the others who have updated the contrib but have you reviewed the updates made to the contrib after your last upload? At what level or version of this contrib do you run yourself/support?

 

Thanks in advance!

 

Regards,

Siddall

Share this post


Link to post
Share on other sites

No, I haven't looked at the updates. One of them did not work according to the posts here. I use the last version I uploaded. If a question pops up on the contribution, I will try to answer it. I plan on releasing fixes for known problems and want to add some new features to it. But there is no time frame as to when that might happen. I generally don't spend a lot of time on uploads that are partial uploads. This is a terrible practice IMO. If the author couldn't be bothered to put together a full package, I don't feel to confident about the work that was done. This is no slam against anyone in particular. Unfortunately, it is an all too-common practice.

 

Jack

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Hi all,

 

I have big problem (Verified I've all the modifications needed done)...

When I attempt to see the ranking position, I have this errors :

 

Warning: fopen(http://www.google.com/search?as_q=gifts ideas&num=10&hl=en&ie=UTF-8&btnG=Google+Search&as_epq=&as_oq=&as_eq=&lr=&as_ft=i&as_filetype=&as_qdr=all&as_nlo=&as_nhi=&as_occt=any&as_dt=i&as_sitesearch=&safe=images&start=0): failed to open stream: Connexion terminated by waiting delay expired in /home/virtual/site156/fst/var/www/html/admin/includes/modules/seo_google_position.php on line 44

 

Unable to open remote file http://www.google.com/search?as_q=gifts ideas&num=10&hl=en&ie=UTF-8&btnG=Google+Search&as_epq=&as_oq=&as_eq=&lr=&as_ft=i&as_filetype=&as_qdr=all&as_nlo=&as_nhi=&as_occt=any&as_dt=i&as_sitesearch=&safe=images&start=0.

Warning: fclose(): supplied argument is not a valid stream resource in /home/virtual/site156/fst/var/www/html/admin/includes/modules/seo_google_position.php on line 98

 

Warning: fopen(http://search.yahoo.com/search?_adv_prop=web&x=op&ei=UTF-8&prev_vm=p&va=gifts ideas&va_vt=any&vp=&vp_vt=any&vo=&vo_vt=any&ve=&ve_vt=any&vd=all&vst=0&vs=&vf=all&vm=p&vc=&fl=0&n=100&b=1): failed to open stream: Connexion terminated by waiting delay expired in /home/virtual/site156/fst/var/www/html/pictures/includes/modules/seo_yahoo_position.php on line 44

 

 

Unable to open remote file http://search.yahoo.com/search?_adv_prop=w...v_vm=p&va=gifts ideas&va_vt=any&vp=&vp_vt=any&vo=&vo_vt=any&ve=&ve_vt=any&vd=all&vst=0&vs=&vf=all&vm=p&vc=&fl=0&n=100&b=1.

Warning: fclose(): supplied argument is not a valid stream resource in /home/virtual/site156/fst/var/www/html/admin/includes/modules/seo_yahoo_position.php on line 99

 

 

Any help ?

 

Best Regards

Share this post


Link to post
Share on other sites

Hi all,

 

I have big problem (Verified I've all the modifications needed done)...

When I attempt to see the ranking position, I have this errors :

 

Warning: fopen(http://www.google.com/search?as_q=gifts ideas&num=10&hl=en&ie=UTF-8&btnG=Google+Search&as_epq=&as_oq=&as_eq=&lr=&as_ft=i&as_filetype=&as_qdr=all&as_nlo=&as_nhi=&as_occt=any&as_dt=i&as_sitesearch=&safe=images&start=0): failed to open stream: Connexion terminated by waiting delay expired in /home/virtual/site156/fst/var/www/html/admin/includes/modules/seo_google_position.php on line 44

 

Unable to open remote file http://www.google.com/search?as_q=gifts ideas&num=10&hl=en&ie=UTF-8&btnG=Google+Search&as_epq=&as_oq=&as_eq=&lr=&as_ft=i&as_filetype=&as_qdr=all&as_nlo=&as_nhi=&as_occt=any&as_dt=i&as_sitesearch=&safe=images&start=0.

Warning: fclose(): supplied argument is not a valid stream resource in /home/virtual/site156/fst/var/www/html/admin/includes/modules/seo_google_position.php on line 98

 

Warning: fopen(http://search.yahoo.com/search?_adv_prop=web&x=op&ei=UTF-8&prev_vm=p&va=gifts ideas&va_vt=any&vp=&vp_vt=any&vo=&vo_vt=any&ve=&ve_vt=any&vd=all&vst=0&vs=&vf=all&vm=p&vc=&fl=0&n=100&b=1): failed to open stream: Connexion terminated by waiting delay expired in /home/virtual/site156/fst/var/www/html/admin/includes/modules/seo_yahoo_position.php on line 44

Unable to open remote file http://search.yahoo.com/search?_adv_prop=w...v_vm=p&va=gifts ideas&va_vt=any&vp=&vp_vt=any&vo=&vo_vt=any&ve=&ve_vt=any&vd=all&vst=0&vs=&vf=all&vm=p&vc=&fl=0&n=100&b=1.

Warning: fclose(): supplied argument is not a valid stream resource in /home/virtual/site156/fst/var/www/html/admin/includes/modules/seo_yahoo_position.php on line 99

Any help ?

 

1 precision : google_position contribution was working right, but I don't know why xactly, was no more working too...

 

Best Regards

Share this post


Link to post
Share on other sites
Hi all,

 

I have big problem (Verified I've all the modifications needed done)...

When I attempt to see the ranking position, I have this errors :

 

Warning: fopen(http://www.google.com/search?as_q=gifts ideas&num=10&hl=en&ie=UTF-8&btnG=Google+Search&as_epq=&as_oq=&as_eq=&lr=&as_ft=i&as_filetype=&as_qdr=all&as_nlo=&as_nhi=&as_occt=any&as_dt=i&as_sitesearch=&safe=images&start=0): failed to open stream: Connexion terminated by waiting delay expired in /home/virtual/site156/fst/var/www/html/admin/includes/modules/seo_google_position.php on line 44

 

Unable to open remote file http://www.google.com/search?as_q=gifts ideas&num=10&hl=en&ie=UTF-8&btnG=Google+Search&as_epq=&as_oq=&as_eq=&lr=&as_ft=i&as_filetype=&as_qdr=all&as_nlo=&as_nhi=&as_occt=any&as_dt=i&as_sitesearch=&safe=images&start=0.

Warning: fclose(): supplied argument is not a valid stream resource in /home/virtual/site156/fst/var/www/html/admin/includes/modules/seo_google_position.php on line 98

 

Warning: fopen(http://search.yahoo.com/search?_adv_prop=web&x=op&ei=UTF-8&prev_vm=p&va=gifts ideas&va_vt=any&vp=&vp_vt=any&vo=&vo_vt=any&ve=&ve_vt=any&vd=all&vst=0&vs=&vf=all&vm=p&vc=&fl=0&n=100&b=1): failed to open stream: Connexion terminated by waiting delay expired in /home/virtual/site156/fst/var/www/html/admin/includes/modules/seo_yahoo_position.php on line 44

Unable to open remote file http://search.yahoo.com/search?_adv_prop=w...v_vm=p&va=gifts ideas&va_vt=any&vp=&vp_vt=any&vo=&vo_vt=any&ve=&ve_vt=any&vd=all&vst=0&vs=&vf=all&vm=p&vc=&fl=0&n=100&b=1.

Warning: fclose(): supplied argument is not a valid stream resource in /home/virtual/site156/fst/var/www/html/admin/includes/modules/seo_yahoo_position.php on line 99

Any help ?

 

1 precision : google_position contribution was working right, but I don't know why xactly, was no more working too...

 

Best Regards

 

Same thing when I attemp to see page ranking :

 

Warning: file(http://www.google.com/search?client=navclient-auto&ch=6-847807023&ie=UTF-8&oe=UTF-8&features=Rank&q=info:www.onveut.com): failed to open stream: Connexion terminated by waiting delay expired in /home/virtual/site156/fst/var/www/html/admin/includes/functions/seo_assistant.php on line 96

 

Warning: implode(): Bad arguments. in /home/virtual/site156/fst/var/www/html/admin/includes/functions/seo_assistant.php on line 97

 

 

I BECOME CRAZY !!

Share this post


Link to post
Share on other sites

The fopen problem has been addressed many times. Please read back through the thread to find the solution (around page 3 or 4).

 

Jack

Share this post


Link to post
Share on other sites
The fopen problem has been addressed many times. Please read back through the thread to find the solution (around page 3 or 4).

 

Jack

 

I read the posts aboput it but :

I can't find anything related to " allow_url_fopen = on " in php tables ?

if it has to be in configuration table or something, can you guide me where ?

 

I can find a php.ini on the server in a dir named /etc/

in it I have :

;;;;;;;;;;;;;;;;;;

; Fopen wrappers ;

;;;;;;;;;;;;;;;;;;

 

; Whether to allow the treatment of URLs (like http:// or ftp://) as files.

allow_url_fopen = On

 

is it that ?

Share this post


Link to post
Share on other sites

Yes, that is the correct setting. If you are still having the problem I can't think of why it might be failing. Be sure teh url you are entering is valid. Try entering www.google.com as a test url and see if that works.

 

Jack

Share this post


Link to post
Share on other sites

Hi, I have just installed thsi contribution but am getting a number of errors,

I get this error when clicking on page ranking:

Warning: main(includes/functions/seo_assistant.php): failed to open stream: No such file or directory in /home/l*****/public_html/shop/admin/seo_assistant.php on line 59

Warning: main(includes/functions/seo_assistant.php): failed to open stream: No such file or directory in /home/l*****/public_html/shop/admin/seo_assistant.php on line 59

Fatal error: main(): Failed opening required 'includes/functions/seo_assistant.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/l*****/public_html/shop/admin/seo_assistant.php on line 59

 

I get this error when clicking on link popularity

Warning: main(includes/functions/seo_link_popularity.php): failed to open stream: No such file or directory in /home/l*****/public_html/shop/admin/seo_assistant.php on line 72

Warning: main(includes/functions/seo_link_popularity.php): failed to open stream: No such file or directory in /home/l*****/public_html/shop/admin/seo_assistant.php on line 72

Fatal error: main(): Failed opening required 'includes/functions/seo_link_popularity.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/l*****/public_html/shop/admin/seo_assistant.php on line 72

 

I get this error when I click on keyword density:

Warning: main(includes/functions/seo_density.php): failed to open stream: No such file or directory in /home/l*****/public_html/shop/admin/seo_assistant.php on line 108

Warning: main(includes/functions/seo_density.php): failed to open stream: No such file or directory in /home/l*****/public_html/shop/admin/seo_assistant.php on line 108

Fatal error: main(): Failed opening required 'includes/functions/seo_density.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/l*****/public_html/shop/admin/seo_assistant.php on line 108

 

And I get this error when clicking on link checker:

Warning: main(includes/functions/seo_assistant.php): failed to open stream: No such file or directory in /home/l*****/public_html/shop/admin/seo_assistant.php on line 118

Warning: main(includes/functions/seo_assistant.php): failed to open stream: No such file or directory in /home/l*****/public_html/shop/admin/seo_assistant.php on line 118

Fatal error: main(): Failed opening required 'includes/functions/seo_assistant.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/l*****/public_html/shop/admin/seo_assistant.php on line 118

 

Any ideas?

Edited by lee246

Share this post


Link to post
Share on other sites

You made a mistake on the installation. Please make sure you copied all of the files to their proper places.

 

Jack

Share this post


Link to post
Share on other sites

The errors are saying the files are not there. If they are, then something is wrong with your configure file would be my guess.

 

Jack

Share this post


Link to post
Share on other sites

I downloaded the v.1.3.3 and files were missing so I have since compiled the needed files and uploaded it as a full package.

Thanks for your help.

Share this post


Link to post
Share on other sites

Just installed the SEO Assistant contrib today, and I get the following error. Any ideas?

 

 

Warning: file(http://www.google.com/search?client=navclient-auto&ch=6-2147391108&ie=UTF-8&oe=UTF-8&features=Rank&q=info:www.burpsandbibs.com): failed to open stream: HTTP request failed! HTTP/1.0 403 Forbidden in /home/burpsan/public_html/store/admin/includes/functions/seo_assistant.php on line 96

 

Warning: implode(): Bad arguments. in /home/burpsan/public_html/store/admin/includes/functions/seo_assistant.php on line 97

Share this post


Link to post
Share on other sites

Hi I'm stumped,

 

I had installed version 1.2 of this contribution last year and it worked fine. I decided to update it last week to 1.3.3 full with the bug fix, but have been unable to get it running properly.

 

I've added the contribution and have double checked all the files and dropped the old sql tables and reloaded , I keep getting the same errors whaen I go to admin/seo assistant and try the tool:

 

Search Engine Ranking- when i run this with my URL or www.google.com , it runs, then I get a DNSerror/cannot find server

 

Page Rank - Seems to work (get a google page rank back)

 

Link Popularity - get DNSerror/cannot find server

 

Keyword Density - Returns blank page. Except once where I got a patial list of keywords from my site.

 

Link Checker - Returns blank page

 

What am I missing...

 

Anyone have any ideas why this isn't working...

 

Mark

Share this post


Link to post
Share on other sites

hi guys .. i've installed latest version and i receive following error

 

Warning: fopen(http://www.google.com/search?as_q=vstopnice&num=10&hl=en&ie=UTF-8&btnG=Google+Search&as_epq=&as_oq=&as_eq=&lr=&as_ft=i&as_filetype=&as_qdr=all&as_nlo=&as_nhi=&as_occt=any&as_dt=i&as_sitesearch=&safe=images&start=0): failed to open stream: HTTP request failed! HTTP/1.0 403 Forbidden in /home/web/xxxxxxx/www/admin/includes/modules/seo_google_position.php on line 44

 

Unable to open remote file http://www.google.com/search?as_q=vstopnic...=images&start=0.

Warning: fclose(): supplied argument is not a valid stream resource in /home/web/xxxxxxxxxxxx/www/admin/includes/modules/seo_google_position.php on line 98

 

when looking for page rank .. it also says i'm not among first 10 .. i am, at both engines .. :blush: :blink:

Share this post


Link to post
Share on other sites

The fopen problem is probably a server setting. See earlier in the thread for the fix.

 

Jack

Share this post


Link to post
Share on other sites

Ok...Add me to the list of fat fingered contrib customers....I have read thru the forum and re-installed the files, double checked the cut and paste mods and I still get a clean white page when I click the SEO assistant link on the side block from admin--->tools.

 

Here is the only output from my server logs:

 

PHP Warning:  Unknown(/path/to/osc/admin/seo_assistant.php): failed to open stream: Permission denied in Unknown on line 0, referer: http://www.mywebsite.com/admin/whos_online.php
[client xxx.xxx.xxx.xxx] PHP Warning:  (null)(): Failed opening '/path/to/osc/catalog/admin/seo_assistant.php' for inclusion (include_path='.:/usr/share/pear') in Unknown on line 0, referer: http://www.mywebsite.com/admin/whos_online.php

 

I posted the cut and paste changes with Quanta, which usually catches typos...Anyway, Does this PHP warning mean anything?? I think it may be an unrelated warning but I need someplace to start.

 

I tried replacing the entire seo_assistant.php file with a simple echo'hello'; line and still, I get the same result: blank page with same PHP warning.

 

Thanks for the great contribution!

 

Bill

Share this post


Link to post
Share on other sites

That's not a problem with the contribution. It looks like access is being blocked by your host. I would contact them and ask what the message means.

 

Jack

Share this post


Link to post
Share on other sites
That's not a problem with the contribution. It looks like access is being blocked by your host. I would contact them and ask what the message means.

 

Jack

 

 

I am my own host....What do you think is causing the server to block this script and not the rest of them??

Share this post


Link to post
Share on other sites

This contribution needs to access the web using fopen calls. There are settings in php.ini to block that. That might be your problem.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×