Jump to content
Jack_mcs

SEO Assistant

Recommended Posts

Hello Jack, I use google.es for my language spanish. If I search "carretes de pesca" in google.es my webpage is number 2:

 

http://www.google.es/search?hl=es&q=ca...oogle&meta=

 

 

but if I use this contribution and search the same words and the same web, the result: is not in the top 100 for the term carretes de pesca on Google, I must to changed everything to spanish google?? Thanks

Share this post


Link to post
Share on other sites

It only searches in English. The code needs to be changed to search in a difference language and I haven't had time to do that. Although, I think, it was posted in this thread if you want to amke the change.

 

Jack

Share this post


Link to post
Share on other sites

Yahoo works fine. MSN worked fine after changing conditions to <cite> </cite>. Google still does not work even with the new conditions...

 

???

 

Google

The site www.thesebweb.com is not in the top 10 for the term koonuki wear on Google

 

MSN

The site www.thesebweb.com is at position 1 ( 1 ) for the term koonuki wear on msn

 

1 www.thesebweb.com

Yahoo

The site www.thesebweb.com is at position 1 ( 1 ) for the term koonuki wear on Yahoo

 

1 www.thesebweb.com

 

Once again I have chekced the URL it uses to search Google, and it does appear in position 1, as expected...

 

I know there have been problems with this previously, but Google definitely use the <cite> </cite> thing, but using this doesn't work?????


osCommerce is GREAT. When it works...

Share this post


Link to post
Share on other sites

I test it here and it showed you to be in position 6 on google. I then checked google and you were at position 6. Google has many data centers and which one the code uses is determined by google. You may be getting a data center that doesn't have you listed, or at a low posiiton. It might also be that google was busy when you tried it. I've seen that happen a few times. Running it again will usually show the expected result.

 

Jack

Share this post


Link to post
Share on other sites
I test it here and it showed you to be in position 6 on google. I then checked google and you were at position 6. Google has many data centers and which one the code uses is determined by google. You may be getting a data center that doesn't have you listed, or at a low posiiton. It might also be that google was busy when you tried it. I've seen that happen a few times. Running it again will usually show the expected result.

 

Jack

 

 

That seems unlikely, given that the word "koonuki" only returns results related to my store, with the exception of one other website... and yet it won't even appear "in the top 1000"... but I'll take your word for it since you are using the same code and getting a result. Cheers.


osCommerce is GREAT. When it works...

Share this post


Link to post
Share on other sites

I have the same problem with Google & MSN results.

I get:

Google

The site www.magnet4less.com is not in the top 50 for the term ceramic magnets on Google

 

 

MSN

The site www.magnet4less.com is not in the top 50 for the term ceramic magnets on msn

 

Yahoo

The site www.magnet4less.com is at position 8 ( 5 ) for the term ceramic magnets on Yahoo

 

I am actually #1 page 1 on Google and #8 page1 on MSN.

 

Any ideas?

Share this post


Link to post
Share on other sites

Your sites are showing fine for me. Does it give the same results everytime? See my PM regarding this.

 

Jack

Share this post


Link to post
Share on other sites

Your PM said you could see your site in google when using my site to test so it must be a data center situation. You are probably connecting to a different data center than I am, thus the difference. The code can be setup to handle the different data centers but google has been known to change those IP's, which would make maintainig it a problem. Plus, as far as I know, not all of the data centers are known. So, if that is the problem, there's nothing to be done as far as the code is concerned. Eventually, in theory anyway, allof googles data centers will sync up with regards to a particular shop. Once that happens, you should get about the same results eash time.

 

Jack

Share this post


Link to post
Share on other sites
You are probably connecting to a different data center than I am, thus the difference.

Jack,

Can you tell me why I would be connecting to a different data center than you?

Seems a shame to not get results from google with your great script when they are the most important of the 3.

thanks,

Jon

Edited by Jon53

Share this post


Link to post
Share on other sites

Google maintains a number of data centers. Estimates to how many there are vary and google won't say. But the prevailing guess is that there are around 40 of them. Each data center is, roughly, in charge of handling specific areas, although that is not fixed and they will roam to other areas. Every once in a while, the databases of all of the data centers are merged, although I'm sure not at once. From all of that, google determines where your shop should rank. Now, if data center A visits your site, it will compare what it finds with all of the sites in its database and decide where you should rank, maybe at position 5. Then if data center B visits your site, it will do the same but it will compare your site against the sites in its databases and maybe come up with position 3. When you dial up google to search for your site, google determines which database to route your request to. They do that partially on where you are located, partially on how busy the data centers are and paritally on other things that no one knows of (except google). So if you go to google and check your position, the result will probably be consistent since google is controlling where you go. When you do it through a program like this one, the result is not always the same, possibly because of your servers IP. The code in SEO Assistant can be changed to dial a specific IP but I haven't had the time nor inclination to make that change. Eventually, all of the data centers will sync up and you'll get the same results.

 

Jack

Share this post


Link to post
Share on other sites

I tried

Enter total searches: 10

Enter search term: google

Enter URL to search for: www.google.com

 

and got

 

Google

The site www.google.com is not in the top 10 for the term google on Google

 

 

MSN

The site www.google.com is not in the top 10 for the term google on msn

 

Yahoo

The site www.google.com is at position 1 ( 1 ) for the term google on Yahoo

 

1 www.google.com


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

I tried it hear and got the expected results. It might be that you have an older version or they were busy at the time.

 

Jack

Share this post


Link to post
Share on other sites
I tried it hear and got the expected results. It might be that you have an older version or they were busy at the time.

 

Jack

SEO Assistant V 2.1

 

They must be very busy, I have tried 15 times and cannot get a response from google or MSN. Yahoo works.

 

Is possible that it is because I am in Australia?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
I tried

Enter total searches: 10

Enter search term: google

Enter URL to search for: www.google.com

 

and got

 

Google

The site www.google.com is not in the top 10 for the term google on Google

 

 

MSN

The site www.google.com is not in the top 10 for the term google on msn

 

Yahoo

The site www.google.com is at position 1 ( 1 ) for the term google on Yahoo

 

1 www.google.com

 

Yup...Seems this add-on does not work for most.....just for some like Jack... :angry:

Wish I knew of a way to connect to the same data center Jack is to actually get results for Google (the most important search engine).

Share this post


Link to post
Share on other sites

Thanks Jack.....

 

All is working except the msn index position.

 

 

 

For those of you with the fclose error.

 

"Unable to open remote file http://www.google.com/search?as_q=Yamaha+R...ges&start=0.

Warning: fclose(): supplied argument is not a valid stream resource in /home/xxxxxx/public_html/xxxx/admin/includes/modules/seo_position.php on line 110"

 

My server has this option turned off by default but can be allowed by adding this line to the .htaccess file.

 

php_flag allow_url_fopen on

 

It may be a fix for some of you...... hth

Share this post


Link to post
Share on other sites
For those of you with the fclose error.

 

"Unable to open remote file http://www.google.com/search?as_q=Yamaha+R...ges&start=0.

Warning: fclose(): supplied argument is not a valid stream resource in /home/xxxxxx/public_html/xxxx/admin/includes/modules/seo_position.php on line 110"

 

My server has this option turned off by default but can be allowed by adding this line to the .htaccess file.

 

php_flag allow_url_fopen on

 

It may be a fix for some of you...... hth

My webhost does not allow it to be over rided, so I test from wamp to the shop.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
I tried

Enter total searches: 10

Enter search term: google

Enter URL to search for: www.google.com

 

and got

 

Google

The site www.google.com is not in the top 10 for the term google on Google

 

 

MSN

The site www.google.com is not in the top 10 for the term google on msn

 

Yahoo

The site www.google.com is at position 1 ( 1 ) for the term google on Yahoo

 

1 www.google.com

 

 

I got this error when i tried the above search

 

Unable to open remote file http://www.google.com/search?as_q=google&a...ges&start=0.

 

Unable to open remote file http://search.msn.com/results.aspx?q=googl...=0&count=20.

 

Unable to open remote file http://search.yahoo.com/search?_adv_prop=w...mp;n=100&b=.

 

does anybody know how to fix this?

Share this post


Link to post
Share on other sites

Looks like your host is blocking the code that reads in the sites. Talking to them about it may find a solution.

 

Jack

Share this post


Link to post
Share on other sites
In admin/includes/modules/seo_msn_position.php file, change
$conditions = "<li class=\"dispUrl\">(.*)</li>";

to

$conditions = "<ul class=\"sb_meta\"><li><cite>(.*)</cite>";

 

I read back several pages and found the fix for msn.

 

Great contribution Jack.....Thanks

Edited by B-Hoff

Share this post


Link to post
Share on other sites

Any ideas what this means?

 

Warning: call_user_func(tep_reset_cache_data_seo_urls) [function.call-user-func]: First argument is expected to be a valid callback in /home/tiffany9/public_html/admin/includes/functions/general.php on line 1195

 

It doesn't seem to be affecting anything though!?

Share this post


Link to post
Share on other sites

That's not a function in this contribution. It is from Ultimate SEO so you will need to ask in that support thread.

 

Jack

Share this post


Link to post
Share on other sites

I have installed version 2.1 of this contribution, but it wont work for me. I get the following errors:

 

Unable to open remote file http://www.google.com/search?as_q=discount...ges&start=0.

 

Unable to open remote file http://search.msn.com/results.aspx?q=disco...=0&count=20.

 

Unable to open remote file http://search.yahoo.com/search?_adv_prop=w...mp;n=100&b=.

 

I tried the htaccess/fopen fix, but that didn't work, it just gave me a 500 internal server error. Any suggestions?

Share this post


Link to post
Share on other sites

Your host may not allow fopen calls. This question has come up many times and, as I recall, there is more than one fix/suggestion. So you may want to read through the whole thread, if you have not done so.

 

Jack

Share this post


Link to post
Share on other sites

I looked all the way back through, and it did remind me to check the allow_fopen status in OSC tools, but no other hints. fopen is allowed, so could there be another problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×