Jump to content
Jack_mcs

SEO Assistant

Recommended Posts

In admin/includes/modules/seo_msn_position.php file, change
$conditions = "<li class=\"dispUrl\">(.*)</li>";

to

$conditions = "<ul class=\"sb_meta\"><li><cite>(.*)</cite>";

 

Jack

 

Perfect. MSN works great now. Thanks Jack!

Share this post


Link to post
Share on other sites

hello,

 

Im stuck what does this mean =

 

Load the seo_assistant.sql file using phpmyadmin. You can alter the

file prior to uploading to start with your url and chosen search

word(s) if you like.

 

?

Share this post


Link to post
Share on other sites

Are you asking how to use phpmyadmin or how to alter the settings?

 

Jack

Share this post


Link to post
Share on other sites

how to use phpmyadmin.

 

i have downloaded it but theres so much in the folder and no install or anything like that, so im stuck with it.

Do i need phpmyadmin ?

 

paulie.

Share this post


Link to post
Share on other sites

There are other programs than phpmyadmin but the reason most people use it is because it is already installed on most servers. You should ask your host if it is installed and, if so, how to reach it. Once you have a working instalation, take a look at this post.

 

Jack

Share this post


Link to post
Share on other sites

hi jack

 

i found a phpmyadmin folder in my ftp catalog.

 

i did read the link you left for me but it ditn't help and im still not sure what i should do.

Share this post


Link to post
Share on other sites

Hi Jack.

 

Ok, i uploaded the seo assistant file to the phpmyadmin folder,

and then i followed all other instructions.

when i try to access the admin side of my site now i get these error messages =

 

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at d:\users\foxycardsuk\public_html\admin\includes\filenames.php:62) in d:\users\foxycardsuk\public_html\admin\includes\functions\sessions.php on line 102

 

Warning: Cannot modify header information - headers already sent by (output started at d:\users\foxycardsuk\public_html\admin\includes\filenames.php:62) in d:\users\foxycardsuk\public_html\admin\includes\functions\general.php on line 22

 

 

Obviously done something wrong.

I was gonna unload it all, but i think ill wait untill you read this.

 

Paulie.

Share this post


Link to post
Share on other sites

The sql file doesn't get uploaded to a folder so it sounds like that was not done correctly. Did you ask your host if they have phpmyadmin installed? For the error, it is most likely due to a space at the end of the filenames file. See the link in my signature for how to fix that.

 

Jack

Share this post


Link to post
Share on other sites

Ok thanks Jack,

 

The error was because of a space at the end of filenames.

So i got that sorted now.

I didnt contact my host company about the phpmyadmin, i just asumed the folder was what i needed.

I have however JUST contacted them now to ask if i have phpmyadmin, so ill wait and see what the say.

When i go into admin/tools/seo assistant i get this error =

 

1146 - Table 'foxycardsuk.seo_google' doesn't exist

 

select search_url, search_term, rank, sites_searched, date from seo_google

 

[TEP STOP]

 

 

So i guess its to do with the seo assistant file and phpmyadmin.

 

Paulie.

Share this post


Link to post
Share on other sites

i just had the email back from my host company they said =

 

PHP My Admin is not installed, but you can administer your database directly from your MyPANEL > Databases > MySQL, click on your database and there is a similar interface to edit your database.

 

 

 

What should i do ?

Share this post


Link to post
Share on other sites
i just had the email back from my host company they said =

 

PHP My Admin is not installed, but you can administer your database directly from your MyPANEL > Databases > MySQL, click on your database and there is a similar interface to edit your database.

 

What should i do ?

There's no way for me to explain how to use their program, not knowing what it is. But, in general, you need to open it so your database is displayed and import the sql file. Be sure to do a backup first since it is easy to ruin a database, espeically operating blindly that way.

 

Jack

Share this post


Link to post
Share on other sites

hi Jack,

 

i opened up my database and then clicked on SQL ;

this is a screen shot of what comes up :

 

 

do i need to click on browse and upload seo_assistant file there ?

Edited by paulieGB

Share this post


Link to post
Share on other sites

EDIT :i did post another picture but didnt come out well

 

hope this is a better picture :

 

 

69da61ea14.gif

Edited by paulieGB

Share this post


Link to post
Share on other sites

Copy all of the text the sql file and paste it into the sql window. Then click Go and it should add it for you.

 

Jack

Share this post


Link to post
Share on other sites

Ok,

I installed another great contribution (SEO Assistant v.2.1) and it seems to work fine.

Before running SQL I alter it to my domain name.

Well, most options work. It just gives me strange error when I try to do Page Rank:

On a top of a screen:

Failed to read url: www.mydomain.com (of course instead of mydomain it shows correctly my domain name)

That is strange, cause almost all other option works with no problems.

Sorry, I just checked again and noticed that it is known issue.

 

Another thing is Check Links gives me error page after some time. Same happening if I try to check my position in search engines and enter more than 100 or something like that in a box.

 

Thank you for help. It is really very helpful contribution indeed.


Computers777dotcom

Share this post


Link to post
Share on other sites
Without a url there's no way for me to check it.

 

Jack

 

Sorry, I didn't even know you can check it knowing url.

 

It is www.computers777.com

 

Thanks!


Computers777dotcom

Share this post


Link to post
Share on other sites

I'm seeing the same problems here. My guess is that, for the page rank code at least, the 777 in the url is causing the code problems. There's nothing you can do to get it to run since the code will have to be altered. I'll put that on the list of things to look at though, at this point, it will probably be months before I can get to it.

 

Jack

Share this post


Link to post
Share on other sites
I'm seeing the same problems here. My guess is that, for the page rank code at least, the 777 in the url is causing the code problems. There's nothing you can do to get it to run since the code will have to be altered. I'll put that on the list of things to look at though, at this point, it will probably be months before I can get to it.

 

Jack

 

Thanks Jack,

 

This is not the most important thing to me anyway, most options work fine and this is a great contribution.

I hope you will look at it just as some extra food for thinking, not as something realy important. I know, when you do something you want it to be perfect, so you polish it and polish it again. :lol: :lol: :lol:


Computers777dotcom

Share this post


Link to post
Share on other sites

Tonight I noticed that the get index position for yahoo failed to open the remote file (google and msn are ok).

 

Anyone else noticed this?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Hi

 

I have installed SEO Assistant, then click on SEO Assistant in admin/tools and received the following error.

 

----------------------------------------------------------------------------------------------

 

1146 - Table 'wi_osc3.seo_google' doesn't exist

 

select search_url, search_term, rank, sites_searched, date from seo_google

 

[TEP STOP]

 

----------------------------------------------------------------------------------------------

 

I installed database in phpadmin clicked on import,

selected: seo_assistant.sql

Character set of the file: utf8

Format of file:Sql Compatibility mode: None

 

I did not select a database to put it in because it did not say in the instructions.

 

Looking at tables in all of my databases looks like in wi.osc2 the following files may be part of the SEO Assistant.

 

seo_google

seo_msn

seo_yahoo

 

The contributions I have installed

 

Oscommerce rc2

Sts4 Latest version

Header Tags SEO Latest Version

 

 

My questions are:

 

Are these all the tables for SEO Assistant?

 

Should I move them from wi.osc2 to wi.osc3, since the error suggests it should have been imported in wi.osc3?

 

Or should I change some code somewhere to make SEO Assistant point to wi.osc2?

 

Please help

 

Thanks


I have installed:

Oscommerce version 2.2rc2a, STS version 4.5.8, Header Tags SEO version 3.1.5, SEO Assistant version 2.1

 

Thanks

Joey

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×