Jump to content
Sign in to follow this  
241

FAQDesk v1.01.0 Support

Recommended Posts

Dear 241,

 

Thanks for supporting this contribution. I have successfully installed it and it works well except when adding an URL and its name.

 

When I add extra URL and and give name, then when I go to detail of FAQ in the catalog side it says;

 

Warning: sprintf(): Too few arguments in (catalog folder)\faqdesk_info.php on line 232

 

Any help? :rolleyes:

 

Expert

Sorry it took so long to get back on this issue.

 

In catalog/includes/languages/english/faqdesk_info.php and other languages

 

change

define('TEXT_FAQDESK_LINK', 'For more information, please visit this related <a href="%s" target="_blank"><u>webpage</u></a>.');

to this

define('TEXT_FAQDESK_LINK', 'For more information, please visit this related link:  ');

obviously the wording will be different for each language.

 

The error is due to a duplication of part of the code in the language file which is now taken care of in the main faqdesk_info.php file thus the error states too few arguments.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Here are some other languages:

 

German:

define('TEXT_FAQDESK_LINK', 'Zu mehr Information besuchen Sie bitte diese in Verbindung stehende Verbindung:  ');

French:

define('TEXT_FAQDESK_LINK', 'Pour plus d\'information, visitez svp ce lien relatif:  ');

Spanish:

define('TEXT_FAQDESK_LINK', 'Para m?s informaci?n, visite por favor este acoplamiento relacionado:  ');

Dutch:

define('TEXT_FAQDESK_LINK', 'Voor meer informatie, te bezoeken gelieve deze verwante verbinding:  ');


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Hi to all.

 

Tnx for this very great contrib, it's much much much best than faqsystem :P

 

But I've a question:

 

I've also installed the dhtml menu (admin side) and I see only a part of the faqdesk box.

 

I am trying to create a mod version of oscommerce with only 2 languages but with many contrib installed, currently I have some more than 80, with some bug, but solvable. I'm not a php coder, I have only put together many contrib ;)

 

Here there is the administrative side, user and password are test@test.com

 

Sorry but I don't know how to resolve this problem, someone that knows the solution?

 

Tnx, jo.

Share this post


Link to post
Share on other sites
Hi to all.

 

Tnx for this very great contrib, it's much much much best than faqsystem :P

 

But I've a question:

 

I've also installed the dhtml menu (admin side) and I see only a part of the faqdesk box.

 

I am trying to create a mod version of oscommerce with only 2 languages but with many contrib installed, currently I have some more than 80, with some bug, but solvable. I'm not a php coder, I have only put together many contrib ;)

 

Here there is the administrative side, user and password are test@test.com

 

Sorry but I don't know how to resolve this problem, someone that knows the solution?

 

Tnx, jo.

I notice that you are missing other items from other boxes.

I also notice that you are using admin access with levels.

 

Have you given yourself permissions to see the files.

 

In Admin under Administrator and file access then faqdesk you need to have

 

faqdesk.php

faqdesk_configuration.php

faqdesk_reviews.php

 

this is the same for any of your other boxes.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Tnx for the fast reply.

 

Ops :P

 

Ok, I'm set the right file access at this file, but the problem ar not solved?

 

I've see the code, and I've noticed that:

 

in admin/includes/boxes/faqdesk.php If I've this

 

<?php
$heading = array();
$contents = array();

$heading[] = array(
?'text' ?=> BOX_HEADING_FAQDESK,
?'link' ?=> tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('selected_box')) . 'selected_box=faqdesk'));

if ($selected_box == 'faqdesk' || $menu_dhtml == true) {
$contents[] = array('text' ?=> 
//Admin begin
// ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? '<a href="' . tep_href_link(FILENAME_FAQDESK, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_FAQDESK . '</a><br>
// ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ?<a href="' . tep_href_link(FILENAME_FAQDESK_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_FAQDESK_REVIEWS . '</a><br>');
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? tep_admin_files_boxes(FILENAME_FAQDESK, BOX_FAQDESK) .
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? tep_admin_files_boxes(FILENAME_FAQDESK_REVIEWS, BOX_FAQDESK_REVIEWS));
//Admin end



$cfg_groups = '';
$configuration_groups_query = tep_db_query("
select configuration_group_id as cgID, configuration_group_title as cgTitle from " . TABLE_FAQDESK_CONFIGURATION_GROUP . " 
where visible = '1' order by sort_order
");

while ($configuration_groups = tep_db_fetch_array($configuration_groups_query)) {
$cfg_groups .= '
<a href="' . tep_href_link(FILENAME_FAQDESK_CONFIGURATION, 'gID=' . $configuration_groups['cgID'], 'NONSSL') . '" class="menuBoxContentLink">' . 
$configuration_groups['cgTitle'] . '</a><br>
';
}

$contents[] = array('text' ?=> $cfg_groups);


}

$box = new box;
echo $box->menuBox($heading, $contents);
?>

?</td>
</tr>

<!-- faqdesk_eof //-->


<?php

 

In this case only the 1 part works, until

 ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? tep_admin_files_boxes(FILENAME_FAQDESK_REVIEWS, BOX_FAQDESK_REVIEWS));

and the rest of the code will be ignored.

 

But if I invert the code this

$cfg_groups = '';
$configuration_groups_query = tep_db_query("
select configuration_group_id as cgID, configuration_group_title as cgTitle from " . TABLE_FAQDESK_CONFIGURATION_GROUP . " 
where visible = '1' order by sort_order
");

while ($configuration_groups = tep_db_fetch_array($configuration_groups_query)) {
$cfg_groups .= '
<a href="' . tep_href_link(FILENAME_FAQDESK_CONFIGURATION, 'gID=' . $configuration_groups['cgID'], 'NONSSL') . '" class="menuBoxContentLink">' . 
$configuration_groups['cgTitle'] . '</a><br>
';
}

$contents[] = array('text' ?=> $cfg_groups);

in place of this

$contents[] = array('text'? =>

//Admin begin

//? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ?  '<a href="' . tep_href_link(FILENAME_FAQDESK, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_FAQDESK . '</a><br>

//? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? <a href="' . tep_href_link(FILENAME_FAQDESK_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_FAQDESK_REVIEWS . '</a><br>');

? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ?  tep_admin_files_boxes(FILENAME_FAQDESK, BOX_FAQDESK) .

? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ?  tep_admin_files_boxes(FILENAME_FAQDESK_REVIEWS, BOX_FAQDESK_REVIEWS));

//Admin end

I see only the rest of the menu, but not all together!

 

If I leave the normal code I see only this a.jpg

If I invert the code I see only this b.jpg

 

Any Idea?

Edited by phobos

Share this post


Link to post
Share on other sites
Ok, I'm set the right file access at this file, but the problem ar not solved?

 

I've see the code, and I've noticed that:

 

Any Idea?

This seems that the dhtml is not taking the second array.

 

The way I have seen this overcome before is thus

 

admin/includes/boxes/faqdesk.php

 

<!-- faqdesk //-->

<tr>
 <td>

<?php
$heading = array();
$contents = array();
       $heading[] = array('text'  => BOX_HEADING_FAQDESK,
                   'link'  => tep_href_link(FILENAME_FAQDESK, 'selected_box=faqdesk'));

 if ($selected_box == 'faqdesk' || $menu_dhtml == true) {
$contents[] = array('text'  => 
 //Admin begin
 tep_admin_files_boxes(FILENAME_FAQDESK, BOX_FAQDESK) .
 //tep_admin_files_boxes(FILENAME_SUPPORT_STATUS, BOX_TICKET_STATUS) . 
 '<a href="' . tep_href_link(FILENAME_FAQDESK, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_FAQDESK . '</a><br>
 <a href="' . tep_href_link(FILENAME_FAQDESK_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_FAQDESK_REVIEWS   . '</a><br>'
);
 //Admin end
 }


$box = new box;
echo $box->menuBox($heading, $contents);
?>

 </td>
</tr>

<!-- faqdesk_eof //-->

then another file

 

admin/includes/boxes/faqdesk_configuration.php

 

<!-- newsdesk //-->

<tr>
 <td>

<?php
$heading = array();
$contents = array();
       $heading[] = array('text'  => BOX_HEADING_FAQDESK,
                   'link'  => tep_href_link(FILENAME_FAQDESK_CONFIGURATION,                                                       'gID=1&selected_box=faqdesk_configuration'));

 if ($selected_box == 'faqdesk_configuration' || $menu_dhtml == true) {
 $cfg_groups = '';
 $configuration_groups_query = tep_db_query("
 select configuration_group_id as cgID, configuration_group_title as cgTitle from " . TABLE_FAQDESK_CONFIGURATION_GROUP . "   where visible = '1' order by sort_order ");
while ($configuration_groups = tep_db_fetch_array($configuration_groups_query)) {
 $cfg_groups .= '<a href="' . tep_href_link(FILENAME_FAQDESK_CONFIGURATION, 'gID=' .   $configuration_groups['cgID'], 'NONSSL') . '
   " class="menuBoxContentLink">' . $configuration_groups['cgTitle'] . '</a><br>';
}
$contents[] = array('text'  => $cfg_groups);
 }

$box = new box;
echo $box->menuBox($heading, $contents);
?>

 </td>
</tr>

<!-- newsdesk_eof //-->


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Perfect :D

 

Now works, I've 2 menu named faqdesk, but works grat! B)

 

1 more little adjustment sorry :P

 

Now I've 2 menu named faqdesk, but if I set BOX_HEADING_FAQDESK_CONFIGURATION the heading of faqdesk_configuration file, in any language file define('BOX_HEADING_FAQDESK_CONFIGURATION', 'FAQDeskConf');

nothing change....the name of the second menu are identical at the frist!!!! :unsure:

 

 

Tnx, jo.

Share this post


Link to post
Share on other sites
Perfect :D

 

Now works, I've 2 menu named faqdesk, but works grat! B)

 

1 more little adjustment sorry :P

 

Now I've 2 menu named faqdesk, but if I set BOX_HEADING_FAQDESK_CONFIGURATION the heading of faqdesk_configuration file, in any language file define('BOX_HEADING_FAQDESK_CONFIGURATION', 'FAQDeskConf');

nothing change....the name of the second menu are identical at the frist!!!! :unsure:

 

 

Tnx, jo.

you need to also change admin/header_navigation.php

       array('faqdesk_configuration'      , 'faqdesk_configuration.php', BOX_HEADING_FAQDESK),

to

       array('faqdesk_configuration'      , 'faqdesk_configuration.php', BOX_HEADING_FAQDESK_CONFIGURATION),


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Hi,

 

I have a quick question about FAQdesk. First of all, I love it. There is one thing that I would like to be able to do, but I can't seem to figure it out, and I haven't been able to find any information in the forums, maybe I'm just having trouble finding it.

 

I want to be able to adjust the sort order for questions in their different categories. Are you able to do this?

 

Thank you for your time and help.

 

Sincerely,

Twinger

Share this post


Link to post
Share on other sites
Hi,

 

I have a quick question about FAQdesk. First of all, I love it. There is one thing that I would like to be able to do, but I can't seem to figure it out, and I haven't been able to find any information in the forums, maybe I'm just having trouble finding it.

 

I want to be able to adjust the sort order for questions in their different categories. Are you able to do this?

 

Thank you for your time and help.

 

Sincerely,

Twinger

Its just a case of adding a bit of code to the admin/faqdesk.php for the part that deals with the articles in a similar fashion to the sort order for the categories and adding a field to the database table then setting the code for order by to order by sort order.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Note that in faqdesk_index.php in catalog line @ 318

 

if (!tep_not_null($category['categories_image'])) {

 

must be

 

if (tep_not_null($category['categories_image'])) {

 

 

otherwise it doesn't show categories images...

 

Expert

Share this post


Link to post
Share on other sites
Note that in faqdesk_index.php in catalog line @ 318

 

if (!tep_not_null($category['categories_image'])) {

 

must be

 

if (tep_not_null($category['categories_image'])) {

 

 

otherwise it doesn't show categories images...

 

Expert

I have not found this to be so.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

but if it stay as it is, categories images don't displayed...

 

whats wrong?

Share this post


Link to post
Share on other sites
but if it stay as it is, categories images don't displayed...

 

whats wrong?

you are correct, I am wrong, I was working on the wrong set of codes.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Hi Steve:

 

Thanks for your efforts on this useful contribution. Once I got rid of Admin Access with Levels, installation was smooth and FAQDesk is working well. The only minor snag I've hit is that Extra URL is not showing. It's in the database (as instructed, no http://), but on the page the space under "For more information, please visit this related link:" is blank.

 

Oh, and since you're also the author of the brilliant "Categories Box Bullet and Line", did you ever consider adding bullets to FAQ boxes? B)


"Buy the ticket, take the ride..." -HST

Share this post


Link to post
Share on other sites
Hi Steve:

 

Thanks for your efforts on this useful contribution. Once I got rid of Admin Access with Levels, installation was smooth and FAQDesk is working well. The only minor snag I've hit is that Extra URL is not showing. It's in the database (as instructed, no http://), but on the page the space under "For more information, please visit this related link:" is blank.

 

Oh, and since you're also the author of the brilliant "Categories Box Bullet and Line", did you ever consider adding bullets to FAQ boxes? B)

I have this working with admin access with levels without any issues.

I have the faqdesk boxes and newsdesk boxes with bullets and lines in my own setup, very easy to do.

 

the url question has already been resolved in this support

 

URL naming and the post below it.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Hi Steve:

 

the url question has already been resolved in this support

 

URL naming and the post below it.

 

As instructed, I'd already changed the line to

 

define('TEXT_FAQDESK_LINK', 'For more information, please visit this related link:  ');

 

My problem is not a WARNING as in the earlier post, it is that no link appears.

 

I have this working with admin access with levels without any issues.

 

I've read that, but it appears that I was using a different Admin Access with Levels--the one I had isn't even available as a contribution any more.

 

http://forums.oscommerce.com/index.php?sho...20entry399143

 

Thanks.


"Buy the ticket, take the ride..." -HST

Share this post


Link to post
Share on other sites

what do you have for lines 231 and 232 of catalog/faqdesk_info.php

 

<?php $faqlink = ($product_info_values['faqdesk_extra_url_name']); ?>
<?php echo sprintf(TEXT_FAQDESK_LINK . '<a href="%s" target="_blank"><u>' . $faqlink . '</u></a>.', tep_href_link(FILENAME_REDIRECT, 'action=url&goto=' . urlencode($product_info_values['faqdesk_extra_url']), 'NONSSL', true, false)); ?>


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

What I had was v1.1 instead of v1.01. That would explain a number of things. Sheesh, must be dyslexic or something. :blink:


"Buy the ticket, take the ride..." -HST

Share this post


Link to post
Share on other sites
What I had was v1.1 instead of v1.01

That is why I have been having some difficulties with helping you. :lol:

Sheesh, must be dyslexic or something

The same as me then, makes coding a bit harder to deal with. ;)

 

I am sorry to inform you but v1.1 is not supported here this is the support thread for v1.01 which uses different codes. :P


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites
I am sorry to inform you but v1.1 is not supported here this is the support thread for v1.01 which uses different codes. :P

No need for v1.1 any more, v1.01 is superior! :D

 

btw, I've found that the class cat_description in faqdesk_index.php was not defined in my stylesheet.css file. Don't know if anybody else will bump into that, but for my preferences adding this did the job

 

TD.cat_description {

font-family: Verdana, Arial, sans-serif;

font-size: 12px;

font-weight: bold;

color: #000000;

}


"Buy the ticket, take the ride..." -HST

Share this post


Link to post
Share on other sites
I am sorry to inform you but v1.1 is not supported here this is the support thread for v1.01 which uses different codes. :P

No need for v1.1 any more, v1.01 is superior! :D

 

btw, I've found that the class cat_description in faqdesk_index.php was not defined in my stylesheet.css file. Don't know if anybody else will bump into that, but for my preferences adding this did the job

 

TD.cat_description {

font-family: Verdana, Arial, sans-serif;

font-size: 12px;

font-weight: bold;

color: #000000;

}

Thank you for bringing this to my attention and others.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Seems like a cool contribution. Does anyone have a working demo onlin? I would like to see what it looks like before installing.

Share this post


Link to post
Share on other sites

Hi there,

 

I had uploaded v.1.1 after changing some admin IE crach issues and lightened some codes to make it working properly.

 

Therefore 1.01 much better. Lets support this one and continue working on it. (I wish to see this one as v1.11)

 

You can see it working in my shop: Actually I've posted this before ... Lets browse all the pages before requesting something..

 

http://www.hepsikamera.com

 

But it is in Turkish. I didn't use any infobox to show up FAQs. Instead I've used information box to access FAQ section. Click "Sık?a Sorulan Sorular" in info box at left bottom.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×