Jump to content
Sign in to follow this  
241

FAQDesk v1.01.0 Support

Recommended Posts

The contribution can be downloaded from here.

 

*** FAQDesk v1.01.0 ***

 

This is the complete package.

 

This is based on the original Carsten contribution.

I have this working to a similar level to the NewsDesk contribution.

 

- added functionality to the WYSIWYG editor in admin.

- updated code and fixed a lot of bugs (I do mean a lot of bugs).

- fixed the I.E.6 crash issue.

- added support for more languages (upto 9 at the last count).

- added url naming


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

When I enable (via setting 1) the FaQ box on mainpage, I do not see the box on the mainpage, I can enable (via setting 1) the latest FaQ box, and that works fine.

 

I am using a native installion of MS2.2

 

Any ideas?

 

Thanks

Share this post


Link to post
Share on other sites

which version are you using


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites
When I enable (via setting 1) the FaQ box on mainpage, I do not see the box on the mainpage, I can enable (via setting 1) the latest FaQ box, and that works fine.

 

I am using a native installion of MS2.2

 

Any ideas?

 

Thanks

I do not understand what you mean by enabling setting 1 this woulf infer that you are using something like infobox admin to control display of boxes from admin.

 

What is the code you have used for the right_column.php and do you have faq categories


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

ok, I have figured out the problem, but of course that displays a new problem.

 

A) you need to create a category and faq, then the box becomes visable on the right hand side as expected. However, now for a title for the box, I have "BOX_HEADING_FAQDESK_CATEGORIES", I would prefer if this only said "FAQ Categories". Any idea on how I can change the title?

 

Thanks

Share this post


Link to post
Share on other sites
ok, I have figured out the problem, but of course that displays a new problem.

 

A) you need to create a category and faq, then the box becomes visable on the right hand side as expected.  However, now for a title for the box, I have "BOX_HEADING_FAQDESK_CATEGORIES",  I would prefer if this only said "FAQ Categories".  Any idea on how I can change the title?

 

Thanks

Hey I know the answer to that one as well B)

 

Some Idiot forgot to put this in the install instructions :D

 

open catalog/includes/languages/english.php

 

add code

// BEGIN -- faqdesk
define('TABLE_HEADING_FAQDESK', 'FAQ Information');
define('TEXT_NO_FAQDESK_NEWS', 'Sorry but there are no FAQs');
define('TEXT_FAQDESK_READMORE', 'Read More');
define('TEXT_FAQDESK_VIEWED', 'Viewed:');

define('BOX_HEADING_FAQDESK_CATEGORIES', 'FAQs Catagories');
define('BOX_HEADING_FAQDESK_LATEST', 'Latest FAQs');

define('TEXT_DISPLAY_NUMBER_OF_ARTICLES', 'Displaying <b>%d</b> to <b>%d</b> (of <b>%d</b> FAQs)');
//END -- faqdesk

close and save file catalog/includes/languages/english.php
If I were you I would get hold of the Idiot that posted that contribution and slap them hard :lol:

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

After more testing, I am unable to get the following 2 functions to work:

 

1) Copy to

2) Move

 

Are these tested and working features, and I have done something wrong?

 

here is the error message I recieve:

 

Fatal error: Call to undefined function: tep_array_reverse() in c:\inetpub\wwwroot\whitemountainpro\admin\includes\functions\faqdesk_general.php on line 206

 

here is my code for that line:

 

$categories_array[$index] = tep_array_reverse($categories_array[$index]);

 

I'm hoping I have provided enough info, if not, please let me know

 

Thanks

Share this post


Link to post
Share on other sites
After more testing, I am unable to get the following 2 functions to work:

 

1) Copy to

2) Move

 

Are these tested and working features, and I have done something wrong?

 

here is the error message I recieve:

 

Fatal error: Call to undefined function: tep_array_reverse() in c:\inetpub\wwwroot\whitemountainpro\admin\includes\functions\faqdesk_general.php on line 206

 

here is my code for that line:

 

$categories_array[$index] = tep_array_reverse($categories_array[$index]);

 

I'm hoping I have provided enough info, if not, please let me know

 

Thanks

In admin/includes/functions/faqdesk_general.php line# 206 change tep_array_reverse to array_reverse

Edited by 241

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Awsome Steve :D

 

That also worked great, and now it appears fully functional and I can migrate my changes to production.

 

I just want to say thanks again

 

Mike

Share this post


Link to post
Share on other sites

For future reference faqdesk 1.01.0 support is here

 

FAQDesk v1.01.0 Support


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Is this right in Install-Doc (admin/index.php)?

 

open file admin/index.php *

* *

*****************************

 

************

* *

* add code *

* *

************

 

array('title' => BOX_HEADING_FAQDESK,
	 // 'access' => tep_admin_check_boxes('configuration.php'),
                 'image' => 'catalog.gif',
                 'href' => tep_href_link(FILENAME_FAQDESK, 'selected_box=faqdesk'),
                 'children' => array(array('title' => FAQDESK_ARTICLES, 'link' => tep_href_link(FILENAME_FAQDESK, 'selected_box=faqdesk')),
                              array('title' => FAQDESK_REVIEWS, 'link' => tep_href_link(FILENAME_FAQDESK_REVIEWS, 'selected_box=faqdesk')))),

 

 

regards

rainer

Share this post


Link to post
Share on other sites

Yes,

 

the commented out line is refered to in the notes

 

NOTE:: If using admin access with levels contribution uncomment line

? ? ? ? // 'access' => tep_admin_check_boxes('configuration.php'),? ?

? ? ? ? so as to be? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? 

? ? ? ? 'access' => tep_admin_check_boxes('configuration.php'),

Edited by 241

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Hello,

 

my /admin/faqdesk_configuration.php is empty - see here:

 

admin_faqdesk_config.gif

 

regards

rainer :angry:

Share this post


Link to post
Share on other sites

*******************************
*                             *
* open file catalog/index.php *
*                             *
*******************************

************
*          *
* add code *
*          *
************

<!-- BEGIN faqdesk -->
<tr><td><?php include(FILENAME_FAQDESK_STICKY); ?></td></tr>
<!-- //END faqdesk -->
<!-- BEGIN faqdesk -->
<tr><td><?php include(FILENAME_FAQDESK); ?></td></tr>
<!-- //END faqdesk -->

*****************************************
*                                       *
* save file and close catalog/index.php *
*                                       *
*****************************************

All of the instructions up until this point were quite clear. Where are the above lines supposed to be added within catalog/index.php? It's not clear to me where these lines should be placed within that file. Any pointers would be greatly appreciated.

 

Sincere thanks in advance,

 

Justin

Share this post


Link to post
Share on other sites
All of the instructions up until this point were quite clear. Where are the above lines supposed to be added within catalog/index.php? It's not clear to me where these lines should be placed within that file. Any pointers would be greatly appreciated.

Where you want to have the areas, do you want the areas just below the greeting, in the middle of the page, below the new products, just above the new products, at the very bottom. The choice has been left to you as to where you want the areas, and to what best fits your site layout.

Edited by 241

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

To everyone that posted information to help get this contribution working right I salute you!

:mellow:

 

It's 3:00am and I'm falling asleep and you guys just made my night end on a great note, especially after installin 60 contributions in one whole day!!!!

 

If this was MSN you would have a couple of 24's of Beer mugs..heh.

 

 

Tip: I didn't like the newest questions showing so I commented out

//include(DIR_WS_BOXES . 'faqdesk_latest.php');

 

 

Thanks,

 

BGT

Share this post


Link to post
Share on other sites
To everyone that posted information to help get this contribution working right I salute you!

:mellow:

 

It's 3:00am and I'm falling asleep and you guys just made my night end on a great note, especially after installin 60 contributions in one whole day!!!!

 

If this was MSN you would have a couple of 24's of Beer mugs..heh.

 

 

Tip: I didn't like the newest questions showing so I commented out

//include(DIR_WS_BOXES . 'faqdesk_latest.php');

 

 

Thanks,

 

BGT

Thank you for that, I am glad that someone appreciates the time and effort that I have put into getting this contibution working to the level that it is. It is just a shame that no-one was willing to help with this, but plenty want it working. ;)


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

i am having two problems with the faq desk the first one is on the main page I get this error even after the database's have been added

 

1146 - Table 'localhost.TABLE_FAQDESK' doesn't exist

 

select p.faqdesk_id, pd.language_id, pd.faqdesk_question, pd.faqdesk_answer_long, pd.faqdesk_answer_short, pd.faqdesk_extra_url, p.faqdesk_image, p.faqdesk_date_added, p.faqdesk_last_modified, p.faqdesk_date_available, p.faqdesk_status from TABLE_FAQDESK p, faqdesk_description pd WHERE pd.faqdesk_id = p.faqdesk_id and pd.language_id = "1" and faqdesk_status = 1 ORDER BY faqdesk_date_added DESC LIMIT 3

 

[TEP STOP]

 

 

Second one is in the admin panel when I click on FAQ management i get 404 error and i get this line in the address bar admin/FILENAME_FAQDESK instead of accessing the right file any suggestions? everything else in the admin works just fine

Share this post


Link to post
Share on other sites
i am having two problems with the faq desk the first one is on the main page I get this error even after the database's have been added

 

1146 - Table 'localhost.TABLE_FAQDESK' doesn't exist

 

select p.faqdesk_id, pd.language_id, pd.faqdesk_question, pd.faqdesk_answer_long, pd.faqdesk_answer_short, pd.faqdesk_extra_url, p.faqdesk_image, p.faqdesk_date_added, p.faqdesk_last_modified, p.faqdesk_date_available, p.faqdesk_status from TABLE_FAQDESK p, faqdesk_description pd WHERE pd.faqdesk_id = p.faqdesk_id and pd.language_id = "1" and faqdesk_status = 1 ORDER BY faqdesk_date_added DESC LIMIT 3

 

[TEP STOP]

 

 

Second one is in the admin panel when I click on FAQ management i get 404 error and i get this line in the address bar admin/FILENAME_FAQDESK instead of accessing the right file any suggestions? everything else in the admin works just fine

You are missing defines the first error would be a missing table define from database_tables.php that is clear by the fact that the error states

Table 'localhost.TABLE_FAQDESK'
when it should read
Table 'localhost.faqdesk'

 

It is similar with your admin error in that you are missing a define filename in filenames.php this is evident from the error you post

admin/FILENAME_FAQDESK

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

thanks I guess when I put the defines in I forgot a line....I guess that's what I get for working late into the night lol

Share this post


Link to post
Share on other sites

Dear 241,

 

Thanks for supporting this contribution. I have successfully installed it and it works well except when adding an URL and its name.

 

When I add extra URL and and give name, then when I go to detail of FAQ in the catalog side it says;

 

Warning: sprintf(): Too few arguments in (catalog folder)\faqdesk_info.php on line 232

 

Any help? :rolleyes:

 

Expert

Edited by expert

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×