Jump to content
Sign in to follow this  
franco

Horrible, horrible Payflow Link problem. Help!

Recommended Posts

Please help me. We are running OS Commere (the latest build), and have the Verisign Payflow Link payment module (downloaded from the contributions section, dated 10-Feb-2003). Everything was working fine for a while and transactions were going through, but starting sometime in the middle of June, the following started happening every time: let's say a customer wants to buy a $69 product. Everything seems fine in the database, but Verisign attempts to process a credit card transaction for $6900 instead of $69. Every time the value is multiplied by 100. So this person tried to buy a $199 product and his credit car was charged $19900! Can you image the hell he raised when he found out? Thanks in advance for any help.

 

Franco

Share this post


Link to post
Share on other sites

Update:

 

I found the problem: the web server had PHP 4.3.7 and the function number_format was not adding the decimal point to the numbers. I'm waiting to see if PHP 4.3.8 will solve this bug.

Share this post


Link to post
Share on other sites

Hi Franco,

 

I had just experience this problem today. I still didn't have any idea to fix the problem. I had just have to uninstall the verisign credit card module, and using the regular credit card module to process offline.

 

Do anyone have idea to fix this problem?

Share this post


Link to post
Share on other sites

Ok, I was having this problem as well. Here is the solution:

 

Open payflowlink.php in catalog>includes>modules>payment and change the following lines:

 

                               tep_draw_hidden_field('AMOUNT', number_format($order->info['total'], 2, '', '')).
                              tep_draw_hidden_field('SHIPAMOUNT', number_format($order->info['shipping_cost'], 2, '', '')).
                              tep_draw_hidden_field('TAX', number_format($order->info['tax'], 2, '', '')).

 

to

 

                               tep_draw_hidden_field('AMOUNT', number_format($order->info['total'], 2, '.', '')).
                              tep_draw_hidden_field('SHIPAMOUNT', number_format($order->info['shipping_cost'], 2, '.', '')).
                              tep_draw_hidden_field('TAX', number_format($order->info['tax'], 2, '.', '')).

 

The problem is the missing decimal points.

Share this post


Link to post
Share on other sites
Ok, I was having this problem as well.  Here is the solution:

 

Open payflowlink.php in catalog>includes>modules>payment and change the following lines:

 

 ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? tep_draw_hidden_field('AMOUNT', number_format($order->info['total'], 2, '', '')).
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? tep_draw_hidden_field('SHIPAMOUNT', number_format($order->info['shipping_cost'], 2, '', '')).
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? tep_draw_hidden_field('TAX', number_format($order->info['tax'], 2, '', '')).

 

to

 

 ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? tep_draw_hidden_field('AMOUNT', number_format($order->info['total'], 2, '.', '')).
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? tep_draw_hidden_field('SHIPAMOUNT', number_format($order->info['shipping_cost'], 2, '.', '')).
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? tep_draw_hidden_field('TAX', number_format($order->info['tax'], 2, '.', '')).

 

The problem is the missing decimal points.

 

I want to thank you for pointing this out. I was on the right track, (knew it was a decimal issue), but wasn't too familiar with the coding, on where I needed to modify. I tried that and it's now back to normal. You're the best!! Thanks!!! :D


RuKuS

Share this post


Link to post
Share on other sites

Wow, this is a serious problem with the VeriSign payment module. For some reason it kicked in today for me. I don't know why it would work correctly until today but I lost a few orders and got some mean phone calls because of it. Thanks for the quick fix.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×